Jump to content
TrinityCore
  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Valufa
      Hello, would anyone know if there is an XML OR JSON file with all the class spells from section 3.3.5a?
      If not, would you know how to inform the procedure on how to extract this information from the game client, or some way faster than Web Scraping?
       
    • By Dipdill
      So I got a new Trinity Core server up and running.  For the life of me I can not get my client to connect.  I have edited the Data\enUS\realmlist.wtf to point to my server.  I have confirmed that the firewalls are open to both 8085 and 3724.  When I open the wow.exe client I use my credentials and it immediately goes to Downloading Update screen and sits at 0%.  I have also added set patchlist to my server thinking that might help and still no go.  I downloaded the client from warmane as mentioned in this thread:  
      Did I miss a step on patching the wow.exe file?  I know on the new master branch there is a patching process... but I didn't see one for the 3.3.5 branch.  
      Thanks
    • By Hesione
      I'm having a problem with a number of factions not getting the flag "at war" in the reputation tab, and this is unable to be selected by the player. Currently, this is with The Oracles, as my character has their reputation with Frenzyheart. The problem occurs when one of two opposing factions is chosen as the positive reputation one. That said, Bloodsail Buccaneers seems to work fine.
      I did a search on how to fix this, and found this on the TrinityCore issues tracker: https://github.com/TrinityCore/TrinityCore/issues/9469 (specifically https://github.com/TrinityCore/TrinityCore/issues/9469#issuecomment-78925130)
      Do I just go into the ReputationManager.cpp file and edit it directly? I don't understand how the dbc/cpp files are used. Are they called by the client each time the client is started up?
      I found the code for ReputationManager.cpp here: https://github.com/TrinityCore/TrinityCore/blob/master/src/server/game/Reputation/ReputationMgr.cpp
      I don't understand how the fix goes into this code. I can see a Git pull (push?) whereas I thought I could just edit ReputationManager.cpp directly. If so, which lines do I replace (if any)? Otherwise, where should I insert the fix?
       
    • By Katria
      I am currently trying to add another realm to my server.
      I have set up 2 new world and characters DB and copied SQL tables over from the first realm. I copied the first realm files (/server) and made a new folder called (/server2). I changed the worldserver.conf to new ports 8086 and added the new dbs to it. I've also tried to change the SOAP port from 7878 to 7879 and turning it off. When I turn on the worldserver for the second realm, it crashes and tells me it can't bind to port 7878 since it's in use from the first realm.
      I run auth and worldserver from the first server folder. I then try to run worldserver for the second realm and the error persists. I am running TC on latest SSL/TC core on Ubuntu 18
      ----------------------------------------------------------------------------------------------------------------------------------------------------------------
      I have also tried to cmake into the second realm folder (/server2) and I get greeted with this error:
      [email protected]:~/TrinityCore/build# make
      [  4%] Built target g3dlib
      [  4%] Built target Detour
      [  5%] Built target Recast
      [  6%] Built target fmt
      [  9%] Built target jemalloc
      [  9%] Built target gsoap
      [ 10%] Built target mpq
      [ 10%] Built target revision_data.h
      [ 14%] Built target common
      [ 14%] Building CXX object src/server/database/CMakeFiles/database.dir/Database/Implementation/CharacterDatabase.cpp.o
      fatal error: file '/usr/include/linux/limits.h' has been modified since the
            precompiled header
            '/root/TrinityCore/build/src/server/database/cotire/database_CXX_prefix.hxx.pch'
            was built
      note: please rebuild precompiled header
            '/root/TrinityCore/build/src/server/database/cotire/database_CXX_prefix.hxx.pch'
      1 error generated.
      src/server/database/CMakeFiles/database.dir/build.make:427: recipe for target 'src/server/database/CMakeFiles/database.dir/Database/Implementation/CharacterDatabase.cpp.o' failed
      make[2]: *** [src/server/database/CMakeFiles/database.dir/Database/Implementation/CharacterDatabase.cpp.o] Error 1
      CMakeFiles/Makefile2:1124: recipe for target 'src/server/database/CMakeFiles/database.dir/all' failed
      make[1]: *** [src/server/database/CMakeFiles/database.dir/all] Error 2
      Makefile:129: recipe for target 'all' failed
      make: *** [all] Error 2
      [email protected]:~/TrinityCore/build#
    • By Darkh62100
      Hello,

      Sorry if my question is not in the right category.

      Since a few days I started in TrinityCore v3.3.5, I currently encounter a small problem of which I still have a solution.

      I realized there was almost no titanium vein in icecrown.

      How can I implement them?


      Thanks for your help
×
×
  • Create New...