Jump to content
TrinityCore
Sign in to follow this  
reyne

Error extracting maps

Recommended Posts

Hey there!

I've followed a few threads here about map extraction, and am still having issues. Originally, I was having the issue described here.
After following the advice given in that thread (creating characters of both BC races and running around for a bit), I am no longer getting that error, however now I get the following error while trying to extract maps:

`Error loading World\Maps\Expansion01\Expansion01_42_6.adt`

This repeats for every line in Expansion01, and then the extractor crashes.

I'm not sure where else to go from here.

Thanks for your help

Edit: I've created an 85 on an i85 server and flown all around Outland now, same issue.

Edited by reyne

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Uee
      I recently found the Trinity Cataclsym Preservation Project and thought I will try it out.
      I am already running 3.3.5a and Master - both server run great
      Pulled 4.3.4 down using Git and built it same way as others:
      boost_1_73_0 cmake 3.17.2 Mysql 5.7.30 VS Community 2019 Built fine - no issue. Used 'Extractor.bat' to run all the map extractors - worked great!
      Noticed there was extra file 'connection_patcher.exe`, ran that - worked great! Now have "wow_patched" and use this to launch client
      MySQL runs in standalone mode, -initialize, added base sql files, imported, auth and character sql files
      Configured both the .conf files and passwords, IPs etc are all in place.
      Note: When loading the exe and built conf file, bnetserver complain about these items missing, so I add them:
      Updates.AutoSetup = 1 Updates.EnableDatabases = 0 LoginDatabase.SynchThreads = 1 Load up Mysql - loads fine
      Load up bnetserver and appears to load ok - last few lines look like this:
      Connected to MySQL database at 127.0.0.1
      DatabasePool 'auth' opened successfully. 2 total connections running.
      Started auth database connection pool.
      Listening on connections from worldservers on port 1118...
      Load up worldserver and it adds the FULL world and hotfixes, then applied all updates (confirmed archived in SQL) - last few lines look like this:
      Calculate next monthly quest reset time...
      Calculate random battleground reset time...
      Calculate guild limitation(s) reset time...
      Calculate next currency reset time...
      World initialized in 0 minutes 13 seconds
      TrinityCore rev. d0c7bbab40bc 2020-05-06 00:01:21 +0200 (master branch) (Win64, RelWithDebInfo, Static) (worldserver-daemon) ready...
       
      There are no db errors in logs.
      Config.wtf contain portal, realmlist as remote server and patchlist as localhost.
      When I try to connecting using "[email protected]" and password I get immediately disconnected.
      What I did noticed different is that the bnetserver doesnt add "Added realm "Battle for Azeroth" at 192.168.10.213:8085." (From my Master log) 
      3.3.5a also have this line as last line in authserver - but 4.3.4 is not giving me this one.
      Realmlist table is accurate with right information.
      Anyone know why bnetserver is not starting me realm?
       
    • By Ithylis
      =====[ English ]=====
      Hello,
      First of all I'm sorry if my english is not good, it's the use of Mr Google translation
      That's after years I restart in a WoW private server.
      I thank everyone who gives their time to help TrinityCore evolve.
      I appeal to the community because I can not find the dbc-cameras-vmaps-maps-mmaps-gt files of master 8.2.0.31478.
      I have the official version of the game in 8.2.5 and going through Arctium I do not have the data to extract all that, or else I get it wrong.
      Would anyone be kind enough to share all these extracted files please?
      Thank you very much and have a good day / night
      Regards,
      Ithylis
      =====[ Français ]=====
      Bonjour,

      Avant tout je suis désolé si mon anglais n'est pas bon, c'est l'utilisation de Monsieur Google traduction

      Voilà après des années je me relance dans un serveur privé WoW.
      Je remercie tout ceux qui donnent de leur temps pour faire évoluer TrinityCore.
      Je fais appel à la communauté, car je n'arrive pas à trouver les fichiers dbc-cameras-vmaps-maps-mmaps-gt de la version master 8.2.0.31478.
      J'ai la version officielle du jeu en 8.2.5 et en passant par Arctium je n'ai pas les données pour extraire tout cela, ou alors je m'y prends mal.

      Est-ce que quelqu'un aurait la bonté de partager tous ces fichiers extraits s'il vous plait ?

      Merci beaucoup et bonne journée/nuit
      Cordialement,
      Ithylis
    • By Hydra_Btforce
      Just finished download & compile fresh trinitycore 4.3.4  From : https://gitlab.com/trinitycore/TrinityCore_434/tree/4.3.4
       
      Creating World database from : https://github.com/TrinityCoreLegacy/TrinityCore/releases
      Downloading the lasted one & create new database named World
      Navigate to my repo applying sql/updates/world/4.3.4
      Trying to apply all updates but an error occurred while applying updates
      And if i don't apply all updates the world is totally bugged and items/creature are missing.
       
      Please help
    • By Cantte
      Well ... today I was about to compile the trinity core version for WoW 4.3.4 of this repository "https://gitlab.com/trinitycore/TrinityCore_434". Download them and when you use the cmake, I generate the solution correctly. When I began to compile this went well until I got to the last step, when I was 90% practically.
      This was the error:
      Main.obj: error LNK2019: external symbol SSLeay_version unresolved referred to in the function "public: void __cdecl <lambda_4a2d53ce610f18dba0b4b4d6532c13a7> :: operator () (void) const" (?? R <lambda_4a2d53ce610f18dba0b4b4d6532c13a7> @@ QEBAXXZ)
      25> scripts.lib (cs_server.obj): error LNK2001: external symbol SSLeay_version unresolved
      25> gsoap.lib (stdsoap2.obj): error LNK2019: unresolved sk_num external symbol referenced in the tcp_connect function
      25> gsoap.lib (stdsoap2.obj): error LNK2019: unresolved sk_value external symbol referenced in the tcp_connect function
      25> gsoap.lib (stdsoap2.obj): error LNK2019: unresolved sk_pop_free external symbol referenced in the tcp_connect function
      25> gsoap.lib (stdsoap2.obj): error LNK2019: outer symbol OPENSSL_add_all_algorithms_noconf unresolved referenced in the soap_ssl_init function
      25> gsoap.lib (stdsoap2.obj): error LNK2019: external symbol SSL_load_error_strings unresolved referenced in the soap_ssl_init function
      25> gsoap.lib (stdsoap2.obj): error LNK2019: unresolved external SSLv23_method symbol referenced in the ssl_auth_init function
      25> gsoap.lib (stdsoap2.obj): error LNK2019: external symbol SSL_library_init unresolved referenced in the soap_ssl_init function
      25> gsoap.lib (stdsoap2.obj): error LNK2019: external symbol SSL_state unresolved referenced in the tcp_connect function
      25> common.lib (OpenSSLCrypto.obj): error LNK2019: external symbol CRYPTO_num_locks unresolved referred to in the function "void __cdecl OpenSSLCrypto :: threadsCleanup (void)" (? ThreadsCleanup @ OpenSSLCrypto @@ YAXXZ)
      25> common.lib (OpenSSLCrypto.obj): error LNK2019: external symbol CRYPTO_set_locking_callback unresolved referred to in the function "void __cdecl OpenSSLCrypto :: threadsCleanup (void)" (? ThreadsCleanup @ OpenSSLCrypto @@ YAXXZ)
      25> common.lib (OpenSSLCrypto.obj): error LNK2019: external symbol CRYPTO_THREADID_set_numeric unresolved referred to in the function "void __cdecl threadIdCallback (struct crypto_threadid_st *)" (? ThreadIdCallback @@ YAXPEAUcrypto_threadid_st @@@ Z)
      25> common.lib (OpenSSLCrypto.obj): error LNK2019: external symbol CRYPTO_THREADID_set_callback unresolved referenced in the function "void __cdecl OpenSSLCrypto :: threadsCleanup (void)" (? ThreadsCleanup @ OpenSSLCrypto @@ YAXXZ)
      25> common.lib (ARC4.obj): error LNK2019: external symbol EVP_CIPHER_CTX_init unresolved referred to in the function "public: __cdecl ARC4 :: ARC4 (unsigned int)" (?? 0ARC4 @@ QEAA @ I @ Z)
      25> common.lib (HmacHash.obj): error LNK2019: unresolved HMAC_CTX_init external symbol referenced in the "struct hmac_ctx_st * __cdecl HMAC_CTX_new (void)" function (? HMAC_CTX_new @@ YAPEAUhmac_ctx_st @@ XZ)
      25> common.lib (HmacHash.obj): error LNK2019: unresolved HMAC_CTX_cleanup external symbol referenced in the "void __cdecl HMAC_CTX_free (struct hmac_ctx_st *)" function (? HMAC_CTX_free @@ YAXPEAUhmac_ctx_st @@@ Z)
      25> E: \ Server-Wow \ TrinityCore_434-4.3.4 \ Build \ bin \ RelWithDebInfo \ worldserver.exe: fatal error LNK1120: 16 external unresolved
      25> Compilation of the "worldserver.vcxproj" project completed - ERROR.
      26> ------ Compile operation started: project: ALL_BUILD, configuration: RelWithDebInfo x64 ------
      26> Building Custom Rule E: /Server-Wow/TrinityCore_434-4.3.4/CMakeLists.txt
      26> CMake does not need to re-run because E: /Server-Wow/TrinityCore_434-4.3.4/Build/CMakeFiles/generate.stamp is up-to-date.
      ========== Compile: 23 correct, 3 incorrect, 0 updated, 0 omitted ==========
       
      And this is the original error in Spanish (since I use the compiler in Spanish)
       
      Main.obj : error LNK2019: símbolo externo SSLeay_version sin resolver al que se hace referencia en la función "public: void __cdecl <lambda_4a2d53ce610f18dba0b4b4d6532c13a7>::operator()(void)const " (??R<lambda_4a2d53ce610f18dba0b4b4d6532c13a7>@@QEBAXXZ)
      25>scripts.lib(cs_server.obj) : error LNK2001: símbolo externo SSLeay_version sin resolver
      25>gsoap.lib(stdsoap2.obj) : error LNK2019: símbolo externo sk_num sin resolver al que se hace referencia en la función tcp_connect
      25>gsoap.lib(stdsoap2.obj) : error LNK2019: símbolo externo sk_value sin resolver al que se hace referencia en la función tcp_connect
      25>gsoap.lib(stdsoap2.obj) : error LNK2019: símbolo externo sk_pop_free sin resolver al que se hace referencia en la función tcp_connect
      25>gsoap.lib(stdsoap2.obj) : error LNK2019: símbolo externo OPENSSL_add_all_algorithms_noconf sin resolver al que se hace referencia en la función soap_ssl_init
      25>gsoap.lib(stdsoap2.obj) : error LNK2019: símbolo externo SSL_load_error_strings sin resolver al que se hace referencia en la función soap_ssl_init
      25>gsoap.lib(stdsoap2.obj) : error LNK2019: símbolo externo SSLv23_method sin resolver al que se hace referencia en la función ssl_auth_init
      25>gsoap.lib(stdsoap2.obj) : error LNK2019: símbolo externo SSL_library_init sin resolver al que se hace referencia en la función soap_ssl_init
      25>gsoap.lib(stdsoap2.obj) : error LNK2019: símbolo externo SSL_state sin resolver al que se hace referencia en la función tcp_connect
      25>common.lib(OpenSSLCrypto.obj) : error LNK2019: símbolo externo CRYPTO_num_locks sin resolver al que se hace referencia en la función "void __cdecl OpenSSLCrypto::threadsCleanup(void)" ([email protected]@@YAXXZ)
      25>common.lib(OpenSSLCrypto.obj) : error LNK2019: símbolo externo CRYPTO_set_locking_callback sin resolver al que se hace referencia en la función "void __cdecl OpenSSLCrypto::threadsCleanup(void)" ([email protected]@@YAXXZ)
      25>common.lib(OpenSSLCrypto.obj) : error LNK2019: símbolo externo CRYPTO_THREADID_set_numeric sin resolver al que se hace referencia en la función "void __cdecl threadIdCallback(struct crypto_threadid_st *)" ([email protected]@[email protected]@@Z)
      25>common.lib(OpenSSLCrypto.obj) : error LNK2019: símbolo externo CRYPTO_THREADID_set_callback sin resolver al que se hace referencia en la función "void __cdecl OpenSSLCrypto::threadsCleanup(void)" ([email protected]@@YAXXZ)
      25>common.lib(ARC4.obj) : error LNK2019: símbolo externo EVP_CIPHER_CTX_init sin resolver al que se hace referencia en la función "public: __cdecl ARC4::ARC4(unsigned int)" ([email protected]@[email protected]@Z)
      25>common.lib(HmacHash.obj) : error LNK2019: símbolo externo HMAC_CTX_init sin resolver al que se hace referencia en la función "struct hmac_ctx_st * __cdecl HMAC_CTX_new(void)" ([email protected]@[email protected]@XZ)
      25>common.lib(HmacHash.obj) : error LNK2019: símbolo externo HMAC_CTX_cleanup sin resolver al que se hace referencia en la función "void __cdecl HMAC_CTX_free(struct hmac_ctx_st *)" ([email protected]@[email protected]@@Z)
      25>E:\Server-Wow\TrinityCore_434-4.3.4\Build\bin\RelWithDebInfo\worldserver.exe : fatal error LNK1120: 16 externos sin resolver
      25>Compilación del proyecto "worldserver.vcxproj" terminada -- ERROR.
      26>------ Operación Compilar iniciada: proyecto: ALL_BUILD, configuración: RelWithDebInfo x64 ------
      26>Building Custom Rule E:/Server-Wow/TrinityCore_434-4.3.4/CMakeLists.txt
      26>CMake does not need to re-run because E:/Server-Wow/TrinityCore_434-4.3.4/Build/CMakeFiles/generate.stamp is up-to-date.
      ========== Compilar: 23 correctos, 3 incorrectos, 0 actualizados, 0 omitidos ==========
       
       
      Thanks.
    • By Szone
      Hello,
       
      I have a TrinityCore 3.3.5 realm and i want to make a second realm (4.3.4), but the question is : can I run/install on the same server (Ubuntu 16.04 server) ACE and BOOST ?    
       
      Thank you!
       
       
×
×
  • Create New...