Jump to content
TrinityCore
Sign in to follow this  
technic88

SQL Salt Error with authserver

Recommended Posts

After a recent update in the 3.3.5 branch I get the following error when launching authserver:

https://pastebin.com/EuHb2EY6

I think it may be related to getting rid of sha_pass_hash being replaced with salt.

 

Share this post


Link to post
Share on other sites
13 hours ago, technic88 said:

After a recent update in the 3.3.5 branch I get the following error when launching authserver:

https://pastebin.com/EuHb2EY6

I think it may be related to getting rid of sha_pass_hash being replaced with salt.

 

you forgot to update database.

Share this post


Link to post
Share on other sites

I've run into this same problem. only i am a little fuzzy on how to properly update my database.  ( new to Databases ) usually when i update my core i compare the databases on the workstation i use to assemble the core with the database on my virtual server, Create an SQL file to update the database on my Virtual server then move everything over. Up until now that seems to have worked just fine.  however with the removal of the the sha_pass_hash i'm not sure how ( or if it can be done ) to keep / convert the passwords for all the accounts to the new format.  any info or advice would be greatly appreciated!

Share this post


Link to post
Share on other sites
On 10/8/2020 at 4:43 PM, Frayre said:

I've run into this same problem. only i am a little fuzzy on how to properly update my database.  ( new to Databases ) usually when i update my core i compare the databases on the workstation i use to assemble the core with the database on my virtual server, Create an SQL file to update the database on my Virtual server then move everything over. Up until now that seems to have worked just fine.  however with the removal of the the sha_pass_hash i'm not sure how ( or if it can be done ) to keep / convert the passwords for all the accounts to the new format.  any info or advice would be greatly appreciated!

Ignore this... i figured it out

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...