Jump to content


  • Content Count

  • Joined

  • Last visited

Community Reputation

0 Neutral

About Nikno

  • Rank
  1. Did you use a generic linux bundle or the Debian Deb bundle for MySQL 5.6? You might want to check if you did also update the client lib and check its path. If you know where your 5.6 client lib is, you can link to it directly while configuring with '-DMYSQL_LIBRARY=/usr/lib/x86_64-linux-gnu/libmysqlclient.so'. Change the path if your library is not in the standard path.
  2. It seems that MySQL changes something in the most recent 5.6 updates. While Trinity was working fine on 5.6.15, after updating to 5.6.19 I can't apply auth_database.sql, getting weird errors. I didn't change the sql_mode, it's still "NO_ENGINE_SUBSTITUTION,STRICT_TRANS_TABLES". I'll potter around a bit, hoping that I get it working and that I don't need to rollback the update. Edit: The issue actually wasn't related to the update. It was fixed by this commit.
  3. Import has worked fine, thank you very much for your help! That changed my view of phpmyadmin...
  4. Oki doki, I'll report possible errors. And, could you tell me what I have to do when I've imported the code? Because it's deprecated, do I have to execute every single file in /sql/updates/world?
  5. That code is out of the TrinityCore TDB_full_335.52_2013_07_17.sql. I'm not that much into SQL but when they create a code with a procedure then I think they want a procedure, not just a table.
  6. Hello, I'm setting up the TrinityCore 3.3.5 for the first time. I'm using Debian 7 and MySQL 5.6.15. According to this topic I need to change the sql_mode when using 5.6. But when I'm using SELECT @@GLOBAL.sql_mode; to determine which modes are set, only STRICT_TRANS_TABLES and NO_ENGINE_SUBSTITION is listed. The ONLY_FULL_GROUP_BY flag mentioned by Machiavelli is not listed. So I thought everything is fine and I ran the create and base .sql files. So now, auth and character db is up to date. But when I want to execute TDB_full_335.52_2013_07_17.sql to create the world db (db itself already created) then I receive the following error: DELIMITER ;; /*!50003 CREATE*/ /*!50003 PROCEDURE `sp_dev_reguid_alter_tables`() BEGIN CREATE TABLE `creature_temp` ( `guid` INT(10) UNSIGNED NOT NULL AUTO_INCREMENT COMMENT 'Global Unique Identifier', `id` MEDIUMINT(8) UNSIGNED NOT NULL DEFAULT '0' COMMENT 'Creature Identifier', `map` SMALLINT(5) UNSIGNED NOT NULL DEFAULT '0' COMMENT 'Map Identifier', `spawnMask` TINYINT(3) UNSIGNED NOT NULL DEFAULT '1', `phaseMask` SMALLINT(5) UNSIGNED NOT NULL DEFAULT '1', `modelid` MEDIUMINT(8) UNSIGNED NOT NULL DEFAULT '0', `equipment_id` MEDIUMINT(9) NOT NULL DEFAULT '0', `position_x` FLOAT NOT NULL DEFAULT '0', `position_y` FLOAT NOT NULL DEFAULT '0', `position_z` FLOAT NOT NULL DEFAULT '0', `orientation` FLOAT NOT NULL DEFAULT '0', `spawntimesecs` INT(10) UNSIGNED NOT NULL DEFAULT '120', `spawndist` FLOAT NOT NULL DEFAULT '5', `currentwaypoint` MEDIUMINT(8) UNSIGNED NOT NULL DEFAULT '0', `curhealth` INT(10) UNSIGNED NOT NULL DEFAULT[...] #1064 - You have an error in your SQL syntax; check the manual that corresponds to yo-- ur MySQL server version for the right syntax to use near 'CREATE*/ /*!50003 PROCEDURE `sp_dev_reguid_alter_tables`() BEGIN ' at line 1 What is this error caused by? Still wrong sql_mode although the flag isn't listed? And another short question: If this import works fine, do I have to run every single .sql update file since 335.52 in /sql/updates/world until it's up to date? Thanks in advance!
  • Create New...