Jump to content
TrinityCore

ravensnow

Plebs
  • Content Count

    10
  • Joined

  • Last visited

Community Reputation

1 Neutral

About ravensnow

  • Rank
    Member

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. hi, non-monolitic error link:http://git.661346.n2.nabble.com/Error-non-monotonic-index-after-failed-recursive-quot-sed-quot-command-td7575014.html (no need to read if you dont want to go through the entire thread) TL;DR: you remove the non-monolotic index and then reindex it. In linux it would be: > rm .git/objects/pack/pack-*.idx (del in windows unless you have git with linux tools installed on your windows) > git index-pack .git/objects/pack/pack-*.pack After this git gc --prune=now and git remote prune origin back up the repo first before you attempt anything. should be easy to fix.
  2. Maybe dumb question but before running cmake did you run "make clean" ?
  3. yes unfortunately ...:) mac here. but thank you. Hoping its soon party :). Saw so many good commits pass by.
  4. Hi, Didn't know where else to post but wanted to thank the team for all the updates of yesterday and today (stormshield, casting etc..), like many i too have a page open at github checking for updates and changed opcodes :). Really great work. Could i ask not to forget the connection patcher for windows latest version if at all please possible the mac ? Would love to get in-world . Just asking. Thank you again
  5. Hi, I dont understand that your post. You say 6.2.0.20216 works. You can not patch the client as the connection patcher does not work for that version , care to tell me how you made it work ? Curious as i want to play.
  6. Hi, You are apparently missing some libs. ( or your compiler cannot find them, apparently at least zmq and mysql libararies) Are you sure you installed all dependencies as mentioned in the guide ? Look at the steps how to resolve them and go through that for zmq also. (even gives mysql as example). ( the link D3vil is pointing you to).
  7. Unfortunately i have no old client. @Aokromes unfortunately my mac (on 10.7) to old xcode offered cant install and so on (and it all compiled beautyfull on the linux server,map extraction went perfect also, just need the patcher/patched client ). i'll buy something new soon i promise. @Brian , thank so much hope soon. @carbenium hope you find it soon and thank you again for all the hard work. Though saw the issue is low-priority could it maybe get a bump ? Totally cant connect without, just asking. Kinda funny got a server but no client. And totally not relevant but thought should mention it : the automatic sql updater is just fantastic.
  8. hi,. oh so I cant play yet then untill the connection_patcher is fixed ? (cries..) Hope the devteam releases a new patcher very soon then, and thank you already that would help allot.,
  9. Hi all, I have compiled on linux everything from trinitycore and worldserver launches. However i am unable to patch with connection_patcher on linux my mac client. (and i cant compile on my mac , it is an old one and the gcc is outdated. osx 10.7 not allowed by apple to upgrade but wow runs still perfect with a newer gfx card). Now the issue is i need a connection_patcher compiled on osx (hopefully it can launch on 10.7) or the patched client. Would anyone be so kind to email or make it somewhere available either the connection patcher or the patched client ? It really would help so much. I got so close just need the client patched. Any help greatly appreciated. thank you all (pm m for email)
  10. Update : Resolved issue by building new system and reinstalling all tools, one by one carefully. :). thanks to trinity-team for a great system. now extracting..lets hope.... ----- Hi, i would appreciate any help. First time compile. Using centos 7 using git pull 10 minutes ago. (* TrinityCore revision : 9a9706cc5f02 2015-07-12 05:05:49 +0200 (6.x branch)) I might have maybe overlooked something ? cmake passes. then when running make i get the following error : [ 7%] Building CXX object dep/cppformat/CMakeFiles/format.dir/posix.cc.o In file included from /root/builds/TrinityCore/dep/cppformat/posix.cc:33:0: /root/builds/TrinityCore/dep/cppformat/posix.cc: In member function ‘fmt::LongLong fmt::File::size() const’: /root/builds/TrinityCore/dep/cppformat/posix.h:74:70: error: ‘static_assert’ was not declared in this scope # define FMT_STATIC_ASSERT(cond, message) static_assert(cond, message) ^ /root/builds/TrinityCore/dep/cppformat/posix.cc:162:3: note: in expansion of macro ‘FMT_STATIC_ASSERT’ FMT_STATIC_ASSERT(sizeof(fmt::LongLong) >= sizeof(file_stat.st_size), ^ dep/cppformat/CMakeFiles/format.dir/build.make:77: recipe for target 'dep/cppformat/CMakeFiles/format.dir/posix.cc.o' failed make[2]: *** [dep/cppformat/CMakeFiles/format.dir/posix.cc.o] Error 1 CMakeFiles/Makefile2:357: recipe for target 'dep/cppformat/CMakeFiles/format.dir/all' failed make[1]: *** [dep/cppformat/CMakeFiles/format.dir/all] Error 2 Makefile:116: recipe for target 'all' failed make: *** [all] Error 2 Can anyone point me out how to correct/fix ? Apologies if i forgot a library, would appreciate the help. Regards,
×
×
  • Create New...