Jump to content
TrinityCore

[SOLVED]Clarification(Install Prerequisites)


Recommended Posts

Page here: http://collab.kpsn.org/display/tc/Requirements

​Object 2: Install the compiler/IDE Visual Studio Community 2013 with Update 4

This page does not include acceptable install options when reaching portions of the installer which allow you to add and remove various elements. Can this be clarified, as the 10GB size is significant to me. (If I can cut a gig or two...)

Also, since 2015 Community is on the same page and free, I would preferably use that version. Can that be clarified as well. I'm not sure of its compatibility or what options must be installed. Can someone update this page with that information? 

Link to post
Share on other sites

Thanks for the info. What about boost. It has a new version (59), will that break the setup?

P.S. I installed the 2013 Community, including all packages, but that entailed installing a bulky add-on for windows 8.1 phone emulation. I'm assuming I could have unchecked that to save some space. ;)

Link to post
Share on other sites

Just to make it clear, VS 2015 works fine with TC (however you'll need to compile your own Boost libs since they don't yet ship installers for msvc-14)

And yes, you could have unchecked all the options in the VS install screen, including the emulators.

  • Upvote 1
Link to post
Share on other sites

Just to make it clear, VS 2015 works fine with TC (however you'll need to compile your own Boost libs since they don't yet ship installers for msvc-14)

And yes, you could have unchecked all the options in the VS install screen, including the emulators.

​​An excellent response, exactly what I was looking for. I have TB of space but you never know when I'll need a few gigs.

 

Is there a page with a checklist of things that haven't been done?

 

I would like to know, when I walk into an area of something, that its lack of "whatever" is known to the developers.

Link to post
Share on other sites

Is there a page with a checklist of things that haven't been done

 

I'm afraid such page would be nearly impossible to maintain.

You can check some stuff that is happening in issues like https://github.com/TrinityCore/TrinityCore/issues/15079 (changelog), https://github.com/TrinityCore/TrinityCore/issues/15127 (SAI for Catalysm creatures), https://github.com/TrinityCore/TrinityCore/issues/15181 (Cataclysm Zones - Movement) or https://github.com/TrinityCore/TrinityCore/issues/15182 (Cataclysm Zones - Quests + Phasing)

  • Upvote 1
Link to post
Share on other sites
  • 1 year later...
Guest
This topic is now closed to further replies.
  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Ajaxhore
      As title says:
      Is the 3.3.5a branch fully VS 2015 compatible, or should I stay with VS 2013 for a while longer?
    • By JourneyJay
      So far, it appears to be irrelevant, since extraction continued, and I'm assuming the client will load. If not, I'll update this post.
       
      Map Extractor fails to find a series of files, but continues onward. A jpeg is linked via google drive below.
      https://drive.google.com/file/d/0By4quSN6E7RvTFhvdjZSS3JSZjQ/view

×
×
  • Create New...