Jump to content
TrinityCore

[SOLVED]-DPREFIX deprecated?


DoxramosPS
 Share

Recommended Posts

So I went to install a second server onto my Ubuntu Server and I ran 

sudo cmake ../ -DPREFIX=/opt/TestServer -DTOOLS=0

This is what I used to use when I used to install to a directory, but it's no longer supported and it seems there's no option anywhere to install to another path. Am I missing something here or is TrinityCore bound to one server now?

TrinityCore revision   : 747a3f1d38ab 2015-09-26 23:40:13 +0200 (3.3.5 branch)
TrinityCore buildtype  : Release

 

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Sandra Kaimraptor
      Dear Community,
      currently I am using screen to manage the daily restart of that server to prevent overloads. But screen is not a clean solution for that. I want to integrate the worldserver and authserver as services to my system. Unfortunately I do not know how I can write into the running daemon any command via Bash shell? sighup shutdown via killall is no option because I need to shutdown the server with 5 minutes delay and informing all players about the shutdown.
      Has anyone any idea how to resolve that issue?
      Kind Regards
      Sandra Kaimraptor
    • By blackmetalz
      Hi guys, I'm going to buy new hardware for reducing compile time in Trinity core. I have heard about Ryzen, it had more core and threads but haven't tested its performance. I just want to ask anyone have Ryzen CPU can share compile time?
       
    • By Chuck
      https://pastebin.com/WxBuZkFH
      Windows 10 Computer, following the TrinityCore guide for 7.3.
      CMake always seems to be the trickiest part for me, but this time I can't find any useful info about the CheckPlatform file it can't find. I don't even know if that is the important error or if just fixing the MYSQL error is my problem. Unfortunately the instructions "Note: If MySQL is not found by CMake it is required to set MYSQL_INCLUDE_DIR = C:/mysql_libs/include and MYSQL_LIBRARY= C:/mysql_libs/lib_XX/libmysql.lib." don't seem to apply as I can't find anyplace in cmake asking for MYSQL_LIBRARY or MYSQL_INCLUDE_DIR, so I assume I need to fix the CheckPlatform problem first.
       
      Thanks in advance. 
    • By grandmst20
      So I'm trying to do something and I'm sure there is a more effective way since I'm not very familiar with Git or CMake. I can compile my own binaries from sources, etc, but that's about the extent of my knowledge.
      I have about 10 different sources (git repos) that I use to compile binaries. Ultimately what I'm trying to do is pull all of these repos and update them, have CMake make new project files with the updated repos, and then build them and output into a directory structure like this:
      X:\Builds\repo 1\<git commit number>
      X:\Builds\repo 2\<git commit number>
      etc...
      Most of this I can do manually, with the exception of building to a new directory with the name being the git commit. I have the git pulls covered, I use a batch file to update all of the repos. But automating the process past this is beyond my knowledge.
      Can anyone help shed some light on what I'm trying to accomplish?
    • By Atréalis
      When taking quests, NPC text is in French (witch is what I want) but when checking or completing, text become in English.
      screens: quest proposal - quest validation
      Does anyone have a clue how to change it to French only? (and what in the world have I done for it to be like this?)
      Thanks.
×
×
  • Create New...