Jump to content
TrinityCore
Sign in to follow this  
KevinC.

Compile Error Debian TrinityCore 6.x

Recommended Posts

Hey guys,

I've got the following errors during compiling TrinityCore 6.x on a debian 8.4 machine.

 

[ 24%] Building CXX object src/server/scripts/CMakeFiles/scripts.dir/Commands/cs_list.cpp.o
In file included from /root/wow-source/trinitycore_6.x/TrinityCore/src/server/game/Achievements/AchievementMgr.h:22:0,
                 from /root/wow-source/trinitycore_6.x/TrinityCore/src/server/scripts/Commands/cs_guild.cpp:25:
/root/wow-source/trinitycore_6.x/TrinityCore/src/server/game/Achievements/CriteriaHandler.h:65:32: error: declaration of ‘const Criteria* CriteriaTree::Criteria’ [-fpermissive]
     Criteria const* Criteria = nullptr;
                                ^
compilation terminated due to -Wfatal-errors.
src/server/scripts/CMakeFiles/scripts.dir/build.make:468: recipe for target 'src/server/scripts/CMakeFiles/scripts.dir/Commands/cs_guild.cpp.o' failed
make[2]: *** [src/server/scripts/CMakeFiles/scripts.dir/Commands/cs_guild.cpp.o] Error 1
make[2]: *** Waiting for unfinished jobs....
 error: declaration of ‘const Criteria* CriteriaTree::Criteria’ [-fpermissive] error: declaration of ‘const Criteria* CriteriaTree::Criteria’ [-fpermissive]CMakeFiles/Makefile2:1246: recipe for target 'src/server/scripts/CMakeFiles/scripts.dir/all' failed
make[1]: *** [src/server/scripts/CMakeFiles/scripts.dir/all] Error 2
Makefile:117: recipe for target 'all' failed
make: *** [all] Error 2

 

Installed compiler:

ii  g++                               4:4.9.2-2                            amd64        GNU C++ compiler
ii  g++-4.9                           4.9.2-10                             amd64        GNU C++ compiler
ii  gcc                               4:4.9.2-2                            amd64        GNU C compiler
ii  gcc-4.9                           4.9.2-10                             amd64        GNU C compiler

using the following cmake command:
cmake ../ -DTOOLS=1 -DUSE_COREPCH=0 -DUSE_SCRIPTPCH=0 -DSERVERS=1 -DSCRIPTS="static" -DCMAKE_INSTALL_PREFIX=/root/wow-build/trinitycore_6.x_latest -DWITH_WARNINGS=1

surely using make -j 4

 

Edited by KevinC.
-

Share this post


Link to post
Share on other sites

--- Canned message start --- This thread does not belong in this section in its current form, and should be reposted in the tracker. Please read this thread to make your future help requests more effective. Read This too Search on tracker before posting any bug report. --- Canned message end ---

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Atréalis
      When taking quests, NPC text is in French (witch is what I want) but when checking or completing, text become in English.
      screens: quest proposal - quest validation
      Does anyone have a clue how to change it to French only? (and what in the world have I done for it to be like this?)
      Thanks.
    • By darki73
      So i guess it is pretty obvious about what am i going to ask =)
      Problem is, previousle we could just sha1 username and password separated by colon and here is the sha_pass_hash.
      The problem i am facing right now, is that according to https://github.com/TrinityCore/TrinityCore/blob/86b98686a95e23247ecb774fb23ecd5b8d94b97b/src/server/game/Accounts/BattlenetAccountMgr.cpp#L177 Trinity now uses SHA256, so the hashes do not match anymore. The thing is, password length in database is 40 symbols (exactly as many as in sha1 hash), but sha256 hash length is 64 characters long. I am confused...
      I've tried to recreate whole "Cryptography" thing on PHP but, guess what, failed.
      Can somebody explain me how the password is generated nowadays?
      Thank you for your attention. 
    • By HolyNitzan
      Hey Guys,
      I'm  using the last build of TrinityCore for WoD, currently using latest TDB release, I noticed that there are no spawns in Draenor, I would like to konw how could I solve it? is the TDB not populated with Draenor mobs/npc spawns?
    • By Shinzon
      I have searched all over the forums and can't find anything that exactly matches this. 
      I can connect fine to the server using my windows client, but when I try to connect using my mac client it immediately bounces back stating "You have been disconnected from the server". 
      I have the correct IP address in the config.wtf (And realmlist in the DB) but still can't connect. 
      I of course can't apply the connection patcher, because the EXE isn't mac compatible. 
      Is there something else I need to do to connect with mac?
      Here is my connection.log if it helps (NOTE that the ".logon.battle.net" I can't get rid of... there is no where config.wtf that has that).
       
      3/14 13:10:21.966  Login program=WoW platform=Mc64 locale=enUS 3/14 13:10:22.097  Component WoW.Mc64.20886 3/14 13:10:22.097  Component WoW.base.20726 3/14 13:10:22.099  Battle.net is Component Bnet.Mc64.37165 3/14 13:10:22.099  LOGIN: state: LOGIN_STATE_CONNECTING result: LOGIN_OK  3/14 13:10:22.145  Failed to resolve “108.26.241.19”.logon.battle.net 3/14 13:10:22.145  LOGIN: state: LOGIN_STATE_FAILED result: DISCONNECTED  3/14 13:10:22.145  Login program=WoW platform=Mc64 locale=enUS 3/14 13:10:22.145  Component WoW.Mc64.20886 3/14 13:10:22.145  Component WoW.base.20726 3/14 13:10:22.154  Battle.net is Component Bnet.Mc64.37165 3/14 13:10:23.298  Client Disconnect due to reason:8 3/14 13:12:54.053  LOGIN: state: LOGIN_STATE_CONNECTING result: LOGIN_OK  3/14 13:12:54.073  Failed to resolve “192.168.1.130”.logon.battle.net 3/14 13:12:54.151  LOGIN: state: LOGIN_STATE_FAILED result: DISCONNECTED  3/14 13:12:54.151  Login program=WoW platform=Mc64 locale=enUS 3/14 13:12:54.173  Component WoW.Mc64.20886 3/14 13:12:54.173  Component WoW.base.20726 3/14 13:12:54.308  Battle.net is Component Bnet.Mc64.37165 3/14 13:12:54.309  Client Disconnect due to reason:8  
       
       
    • By skeezix
      Hello -
      Does anyone mess with this particular flavor? I installed a new Debian 8.5 server, nothing but the basics. I installed the needed packages, setup a git clone for brand trinity-wotlk-ai (3.3.5), and tried to compile. I can compile this on Windows, but not linux. I can, though, compile the normal trinity build. I tried this a few days ago but not sure which commit/build as I deleted it once I knew I could at least compile it. (sorry!)
      I didn't really look through the build logs on Windows since it compiled fine, but I assume the issues below are existent there as well, but just don't stop it from finishing. In linux, I'll see warnings from compiling some of it, but then it gets all the way to 100% progress then dumps the whole thing.
      Here's the output of cmake - http://pastebin.com/c96LMDBE
      Here's the output of make (errors/warnings only) - http://pastebin.com/tUH1L0bn
      This server is a virtual machine, 22 cores and 32GB memory. The commit I'm grabbing for mangosbot is 9fefd30dabd9d5e8be82651e288feeb9b5025c22 and I also tried the previous, which is 55b583d1726fe70d55c4b9efab476d3fa0710ae4 and got the same errors.
      The directions for mangosbot were to clone whatever branch you want for it, then follow the same directions for compiling/installing TrinityCore. I went through these step-by-step and cannot find anything else I could do. Anyone have any ideas? I'm with limited coding knowledge.
      Note - I also tried Ubuntu 16.04, as well as Fedora (23 I think? whatever is the latest at this point) and got the same compile errors on those as well.
      Thanks!
×