Jump to content
TrinityCore
TULOA

AHBot Issues

Recommended Posts

Looks like for whatever reason the bot is using items that are no longer available to the players.

Any idea what would be causing this? See attached screenshot.

Its using this ItemID: 35420 for `Enchant Bracer - Brawn` when it should be using ItemID: 38897

 

This apparently isnt the only one doing this. Most all enchants are this way that are scrolls except Enchant Weapon - Major Spirit. My version was pulled on July 18th.

 

I thought it was a migration issue from Mangos but its not. Its the bot sadly somehow.

AHBot Enchant Issues.png

Share this post


Link to post
Share on other sites

Ok so for clarity maybe its the:
AuctionHouseBot.Items.Misc = 0
Setting?

They no longer seem to show up but also there is no other enchants so far. Ill keep an eye but could use some input on this.

Also fixed a few issues and did an init on git to fix the revision stuff so heres mine:
TrinityCore revision : 331e463de83e 2017-07-21 23:00:14 +0200 (3.3.5 branch)

Share this post


Link to post
Share on other sites

Ok well based on testing for the last hour I have to conclude that was indeed it. 

 

I have also made a change to AuctionHouseBotSeller.cpp to add a query line to a customer database with my enchants I want shown in found from a search for scrolls on the item_template in world passed it all into a table and added a select line matching the others.

If this goes well I will be all set. I am not versed enough in git to try to make an upload for a fix for this but it should be fairly simple.

Edit: Well so far no good lol. Im sure not giving up on this but I guess I need to keep checking the code to see how it checks items. I assumed with the extra select and items in there it would be fine but those are loot tables. Back to the drawing board it seems lol.

Edited by TULOA

Share this post


Link to post
Share on other sites
40 minutes ago, Aokromes said:

Not a bug, simply user forced to put no longer used items on ah. he can block undesired items at https://github.com/TrinityCore/TrinityCore/blob/3.3.5/src/server/worldserver/worldserver.conf.dist#L3476

Yup didnt see that setting enabled and for the life of me I was stumped for the time there.

Now im just trying to get enchant scrolls in the AH. If I cant ill just have to make a tool to add auctions. Which will likely at this point be the easiest way to do it. 

Share this post


Link to post
Share on other sites
1 hour ago, codeman8214 said:

Why true it is not a bug but still should be noted to be added to default in trinitycore config file so it is not a problem in the future. 

We can always add them and submit a PR ;)

Not sure how many items that may need to be excluded.

  • Upvote 1

Share this post


Link to post
Share on other sites

That maybe but just cause the mission is bigger than normal doesn't mean we can just give in and stop trying, we have to push forward no matter the cost. There will be deaths though lol

  • Upvote 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...