Jump to content
TrinityCore
Sign in to follow this  
LewisPotato

TrinityCore 4.3.4 Map Issues

Recommended Posts

Hey!

I finally learnt how to compile TrinityCore for 3.3.5a!

I've now compiled TrinityCore 4.3.4 and it was successful, however when I extract the maps from a 4.3.4 enGB (full) client it extracts but when I load the maps on the server I get this error: 

Using DataDir ./
WORLD: MMap data directory is: ./mmaps
VMap support included. LineOfSight: 1, getHeight: 1, indoorCheck: 1
VMap data directory is: ./vmaps
Map file './maps/5301243.map' does not exist!
Please place MAP-files (*.map) in the appropriate directory (./maps/), or correct the DataDir setting in your worldserver.conf file.
Unable to load critical files - server shutting down !!!

I have downloaded multiple full 4.3.4 enGB clients but with no luck I get the same error... Am I doing something wrong? Also I don't want to use enUS so I will only try enGB if that's okay.

Share this post


Link to post
Share on other sites
3 minutes ago, LewisPotato said:

Hey!

I finally learnt how to compile TrinityCore for 3.3.5a!

I've now compiled TrinityCore 4.3.4 and it was successful, however when I extract the maps from a 4.3.4 enGB (full) client it extracts but when I load the maps on the server I get this error: 

Using DataDir ./
WORLD: MMap data directory is: ./mmaps
VMap support included. LineOfSight: 1, getHeight: 1, indoorCheck: 1
VMap data directory is: ./vmaps
Map file './maps/5301243.map' does not exist!
Please place MAP-files (*.map) in the appropriate directory (./maps/), or correct the DataDir setting in your worldserver.conf file.
Unable to load critical files - server shutting down !!!

I have downloaded multiple full 4.3.4 enGB clients but with no luck I get the same error... Am I doing something wrong? Also I don't want to use enUS so I will only try enGB if that's okay.

you have put maps directory inside the directory where worldserver binary is?

Share this post


Link to post
Share on other sites
36 minutes ago, Aokromes said:

you have put maps directory inside the directory where worldserver binary is?

Yeah.

For some reason it keeps telling me that it is missing that particular map file. It detects the vmap and mmaps fine.

Share this post


Link to post
Share on other sites
2 hours ago, LewisPotato said:

Yeah.

For some reason it keeps telling me that it is missing that particular map file. It detects the vmap and mmaps fine.

that specific file exists?

Share this post


Link to post
Share on other sites
20 minutes ago, Aokromes said:

that specific file exists?

No, it is missing that one file. I'm not sure if I am using the wrong client to extract the maps, if you can mind linking me to a full 4.3.4 enGB client that you use to extact the maps? It must be an issue with the client.

Share this post


Link to post
Share on other sites
12 minutes ago, LewisPotato said:

No, it is missing that one file. I'm not sure if I am using the wrong client to extract the maps, if you can mind linking me to a full 4.3.4 enGB client that you use to extact the maps? It must be an issue with the client.

Then it's obviously a client issue, search one really complete 4.3.4 client OR connect to a wow 4.3.4 server create one draenei and blood elf characters and run around to see if that fixes your issue.

Share this post


Link to post
Share on other sites
12 hours ago, Aokromes said:

Then it's obviously a client issue, search one really complete 4.3.4 client OR connect to a wow 4.3.4 server create one draenei and blood elf characters and run around to see if that fixes your issue.

I've tried all the enGB clients I can find and doing the other way would just take days to download everything..

Share this post


Link to post
Share on other sites
2 hours ago, LewisPotato said:

I've tried all the enGB clients I can find and doing the other way would just take days to download everything..

You only need to connect with one of the clients you are trying to use the one with the larger % of downloaded content.

Share this post


Link to post
Share on other sites
51 minutes ago, LewisPotato said:

Does the client download the whole game if it is open or do you have to go everywhere for it to download?

you must to travel.

Share this post


Link to post
Share on other sites
5 hours ago, Aokromes said:

you must to travel.

Unfortunately I'm not going to be able to do that. It'd take me way too long to get around everywhere.

Do the map extractors only work on certain versions of the 4.3.4 client?

Share this post


Link to post
Share on other sites
1 minute ago, LewisPotato said:

Unfortunately I'm not going to be able to do that. It'd take me way too long to get around everywhere.

Do the map extractors only work on certain versions of the 4.3.4 client?

Not everywhere, try only draenei and blood elf start zones, if instant server also outland (map 530)

Share this post


Link to post
Share on other sites
On ‎02‎/‎02‎/‎2018 at 10:04 PM, Aokromes said:

Not everywhere, try only draenei and blood elf start zones, if instant server also outland (map 530)

Back again, It downloaded all content 100%, attempted again and it has done the same thing... Starting to think it's something wrong with the map extractors.

I also tried to recompile everything.

Share this post


Link to post
Share on other sites
12 minutes ago, LewisPotato said:

Back again, It downloaded all content 100%, attempted again and it has done the same thing... Starting to think it's something wrong with the map extractors.

I also tried to recompile everything.

they work for me (TM).

ls ../../../misc/share/434/maps/5301243*
../../../misc/share/434/maps/5301243.map
 

Share this post


Link to post
Share on other sites

Hi @LewisPotato,

I'm having the exact same issue: /maps/5301243.map missing.

My Client now is showing 86% of downloaded content and i guess some maps are missing.

I have 11.992 files on my vmaps folder and 6.030 on maps folder.

Were you able to find any feaseable solution that does not involve waking around the entire map?

Edited by Rickgaara

Share this post


Link to post
Share on other sites


I did what was suggested and create a char on a instant lvl 85 server and did some walking.

After that i got my client with 100% download and the extraction was sucessful.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...