Jump to content
TrinityCore
Sign in to follow this  
Kruel

[SOLVED]Change .Conf location

Recommended Posts

Hello i been trying to figure out how to change all my .dist and .conf file locations to lets say /server/conf how would one do this?

Share this post


Link to post
Share on other sites

Yeah don't seem to be in there also possibly needs to be configured in the source with windows? Unsure where it would be in there not much of a coder but can edit 

Share this post


Link to post
Share on other sites
3 hours ago, Kruel said:

And how would i be able to do this? only know the basics of cmake for compiling 

Presumably, it works a lot like the linux version of the install. However, for more general information on using cmake in windows, you might look at this tutorial, which was the clearest answer I could find. (I haven't used windows in over a decade, so it seems very confusing to me.)

Share this post


Link to post
Share on other sites
2 hours ago, Kruel said:

Yeah still confused my self on how i would change the directories for config / data files

Look at oXL0C0Xo's post above. That flag changes the config directory. You'll also see it in the drop-down under the linux core installation. The cmake command ought to be roughly the same, so something like

cmake .. -G "Visual Studio 15 2017" -DCMAKE_INSTALL_PREFIX=[install dir] -DCONF_DIR=[config dir] -DTOOLS=1

should get you a visual studio solution file which you use to compile (according to the tutorial). I

Share this post


Link to post
Share on other sites

I have added those strings and fully compiled but World server and Auth Server are still unable to read config files from folder of choice.

Says Error: invalid or missing default configuration file 

 

cmake .. -G "Visual Studio 15 2017 Win64" -DCMAKE_INSTALL_PREFIX=C:\trinitycore -DCONF_DIR=/conf -DLIBSDIR=/lib -DMYSQL_LIBRARY=C:/MySQL/lib_64/libmysql.lib -DSERVERS=1

Is the line i came up and it fully compiles world and auth files.

Share this post


Link to post
Share on other sites

Had some help tracking it down. It's under MAIN.CPP files for both world and realm

Before Main.CPP

image.png.7cdabf0f22e9433a659808014c268091.png

 

After MAIN.CPP

image.png.f543df6d66530b1151ef86b1e18666c2.png

Removed the cfg_def_file due to it was not finding the normal conf paths.

Share this post


Link to post
Share on other sites
16 hours ago, Kruel said:

Had some help tracking it down. It's under MAIN.CPP files for both world and realm

Before Main.CPP

 

 

After MAIN.CPP

 

Removed the cfg_def_file due to it was not finding the normal conf paths.

has workaround you can use worldserver -c pathtoconfig.

Share this post


Link to post
Share on other sites

Yep that would more than likely be easier the method i found seems to be working well tho with no issues other than having to add it every time compiling is done.

Share this post


Link to post
Share on other sites

--- Canned message start --- It appears the issue in the original post was solved, so this thread shall be closed. Should you encounter any other difficulties, please open a new thread. --- Canned message end ---

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×