Jump to content
TrinityCore
Sign in to follow this  
darkseid4nk

Wrong GCC version, but I have the correct GCC version...

Recommended Posts

How do I get the make files to use the correct version. According to my OS 6.3.0 is what I have configured, as you can see with gcc and g++ version output.

 

[email protected]:~/wow/TrinityCore/build# sudo update-alternatives --config gcc
There are 2 choices for the alternative gcc (providing /usr/bin/gcc).

  Selection    Path              Priority   Status
------------------------------------------------------------
* 0            /usr/bin/gcc-6     60        auto mode
  1            /usr/bin/gcc-4.8   60        manual mode
  2            /usr/bin/gcc-6     60        manual mode

Press enter to keep the current choice[*], or type selection number: 2
[email protected]:~/wow/TrinityCore/build# gcc -v
Using built-in specs.
COLLECT_GCC=gcc
COLLECT_LTO_WRAPPER=/usr/local/libexec/gcc/x86_64-pc-linux-gnu/6.3.0/lto-wrapper
Target: x86_64-pc-linux-gnu
Configured with: ./configure --disable-multilib
Thread model: posix
gcc version 6.3.0 (GCC)
[email protected]:~/wow/TrinityCore/build# g++ -v
Using built-in specs.
COLLECT_GCC=g++
COLLECT_LTO_WRAPPER=/usr/local/libexec/gcc/x86_64-pc-linux-gnu/6.3.0/lto-wrapper
Target: x86_64-pc-linux-gnu
Configured with: ./configure --disable-multilib
Thread model: posix
gcc version 6.3.0 (GCC)
[email protected]:~/wow/TrinityCore/build# cmake ../ -DCMAKE_INSTALL_PREFIX=/home/darkseid/server
-- Detected 64-bit platform
-- UNIX: Using default configuration directory
-- UNIX: Using default library directory
-- UNIX: Configuring uninstall target
-- UNIX: Created uninstall target
-- UNIX: Detected compiler: /usr/bin/cc
CMake Error at cmake/compiler/gcc/settings.cmake:9 (message):
  GCC: TrinityCore requires version 6.3.0 to build but found 4.8.4
Call Stack (most recent call first):
  cmake/platform/unix/settings.cmake:29 (include)
  cmake/macros/CheckPlatform.cmake:13 (include)
  CMakeLists.txt:61 (include)


-- Configuring incomplete, errors occurred!
See also "/home/darkseid/wow/TrinityCore/build/CMakeFiles/CMakeOutput.log".
 

Share this post


Link to post
Share on other sites

You should also run sudo update-alternatives --config g++

And check if you dont have CC/CXX environment variables defined pointing to 4.8

Share this post


Link to post
Share on other sites

if you compil with centos you can export the gcc you want before run cmake

export CC=path_to_your_gcc

export CXX=path_to_your_gcc++

Always with Centos if you have installed devtoolset 7 for centos7  only run before cmake

scl enable devtoolset-7 bash

Edited by elixcyr

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...