Jump to content
TrinityCore

Recommended Posts

Hello,

I have been using TC for a few weeks now and have noticed a few issues. I am using TDB_full_735.00_2018_02_19 and loading the updates from the src folder ( As suggested from the database setup)

1. Cooking window shows 0/0 and will not allow me to update the skills
2. Unable to learn any cooking skills 
3. After purchasing the fishing skill, logging out and coming back in. The Skill is removed from my professions and I cannot purchase it again
4. While fishing, the fishing bobber never plays the animation that a fish has landed.

Any suggestions on what could be causing these issue?

I have been digging around in the code looking into possible ways to fix it but am not sure where to start. I have read the documentation about contributing but still, there is a lot there. Also, is there any write up on how the database is setup or an explanation as to how the tables are structured? I would love to start contributing to this project. Seems like a fun/challenging process.

Thank you,
Chaz

cooking.png

Share this post


Link to post
Share on other sites

--- Canned message start --- This thread does not belong in this section in its current form, and should be reposted in the tracker. Please read this thread to make your future help requests more effective. Read This too Search on tracker before posting any bug report. --- Canned message end ---

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Levcsu
      Where can I edit the quest rewards?
      PS: Quest_template not contains those items, what the quest offers, and I want to remove them.
    • By Levcsu
      Hello,
      I'd like to know, how to add a new item to the server, or edit an existed one. Since theres no longer an item_template table at the DB, I need to add it trough DBC files?
      For example: items.dbc or items.db2?
    • By Levcsu
      Hello!
      When I'm done with the cmake and the compile, I try to extract the dbc, maps, mmps, vmaps folders by the extractors, but theres an issue.
      All files moved to the 7.3.5 folder, start the extractors, and they only create the folders (gt, mmaps, vmaps, dbc), but nothing happens. I tried with System administrator mode, and the issue is still presist.
      The only extractor what do something, is only the vmaps extractor, but only: UNABLE TO OBTAIN error message (and its says frFR language, but the client is set to enUS - and tried with enGB but the issue is the same).
       
      PS: I tried to get the files from the 7.3.5 client (downloaded from a running 7.3.5 server). Or I need to download the client form battle.net, and use the extractors at bnets wow?
      I ask this, becouse for 3.3.5a its get every folders and files form privateserver client.
      Thanks for your help!
    • By spudmasher
      I have looked through forums, and can't find a straight answer. Have followed the guide, but not working.
      ISSUE: Starter areas for the Pandaren, Worgen, and Goblins are either broken, or non-exsistent. I have followed the guide to git current commits, but it continues to say 'up-to-date'. The only topics I have seen on any of these are old, or links that go to dead pages. My question, and I do apologize if it is here somewhere (and i missed it), is how do I make these starter areas act 'normal', with working quests?
      If I did miss it, a simple link is fine. Else an in-depth step-by-step to get these working would be appreciative. If it is not possible at this time, that as an answer would suffice.
    • By Cantte
      Hello everyone! It is my first publication so I will try to make it as understandable as possible.
      I was working on an instant server in version 4.3.4 with the ArkCore source code, everything was fine until I got into the professions. I found and fixed a script that taught you instantly the professions, this will be executed perfectly. The problem arises when I observe in the graphical interface of WoW, the learned profession was duplicated and, when trying to learn another, it was not learned; In addition to trying to forget this profession the game was hanging. I thought that only by disconnecting and reconnecting myself when I learned this profession would it return to "normal", but no.
      Then try to upload the profession myself to see if the error was from the script that taught you or a mistake of the game, check that erro came from the game since I raised a profession only up to 150 skill points and it already presented the mentioned errors previously; I added that when I was disconnected and connected this profession was returned to a single skill point but with all the recipes learned.
      I attached this link to a video where the error is shown.
      Link: 
       
      and sorry if I write something wrong in English, I do not speak it so well.
       
      Thanks!
×
×
  • Create New...