Jump to content
TrinityCore

[HowTo] Patch from 3.3.5.12340 to 4.3.4.15595 (UPDATED 2014-01-24)


MrSmite
 Share

Recommended Posts

Yes, well, from links you provided, 13287 to 13329, and 13329 to 13596 archives do not have win-final mpqs. Doubt they are in some other archives so Ive just dled them from some random place.

So you didn't read the whole guide either? It was right at the top, you couldn't miss it.

wow_cata_win-final_collection-enUS - A collection of "wow-0-xxxxx-Win-final.MPQ" in case a 3rd

party patch is missing them. These are needed to apply patches using commands or scripts.

Only download this if you find a patch doesn't meet any of the following criteria:

Link to comment
Share on other sites

btw, fast provider without restrictions:

http://webshare.cz/3h9pFZH2mj-wow3_2_2.zip.001

http://webshare.cz/EVLP145jkA-wow3_2_2.zip.002

http://webshare.cz/Q6uRmq0DGf-wow3_2_2.zip.003

http://webshare.cz/SZEQ15axLT-wow3_2_2.zip.004

http://webshare.cz/o3Jk0937AT-wow3_2_2.zip.005

http://webshare.cz/eWNNYQ4vJd-wow3_2_2.zip.006

http://webshare.cz/3K6HXU1Oo3-wow3_2_2.zip.007

http://webshare.cz/0ma0cY5FuI-wow3_2_2.zip.008

http://webshare.cz/r7uA6k3D7W-wow3_2_2.zip.009

http://webshare.cz/npFq2HYvqz-wow3_2_2.zip.010

http://webshare.cz/16Pwzh59t6-wow3_2_2.zip.011

http://webshare.cz/gF46Rnvzh5-wow3_2_2.zip.012

http://webshare.cz/26oc5096We-wow3_2_2.zip.013

http://webshare.cz/2270zQ682c-wow3_2_2.zip.014

http://webshare.cz/0DPX388c5S-wow3_2_2.zip.015

http://webshare.cz/3W7TMXte38-wow3_2_2.zip.016

http://webshare.cz/pp2KwOmHHX-wow3_2_2.zip.017

http://webshare.cz/05xd15O501-wow3_2_2.zip.018

http://webshare.cz/QWM40Deuv8-wow3_2_2.zip.019

http://webshare.cz/8295U78rE9-wow3_2_2.zip.020

http://webshare.cz/gxY55CnzT5-wow3_2_2.zip.021

http://webshare.cz/JiUed2U9U3-wow3_2_2.zip.022

http://webshare.cz/4gTqF7kD1i-wow3_2_2.zip.023

http://webshare.cz/8tRwg4lehS-wow3_2_2.zip.024

http://webshare.cz/7qDD9j01eq-wow3_2_2.zip.025

http://webshare.cz/CEYHH9Z41p-wow3_2_2.zip.026

http://webshare.cz/fi01Z5Ks35-wow3_2_2.zip.027

http://webshare.cz/16XYw3G043-wow3_2_2.zip.028

http://webshare.cz/g56YQtR3X5-wow3_2_2.zip.029

(filename is wrong, it is a cata client... but I am not sure what version)

Link to comment
Share on other sites

  • 2 weeks later...

hello,

 

i have done all the instructions and doing fine,

 

but starting from wow-4.3.0.15050-to-4.3.2.15211-enUS, when i'm running Background Downloader.exe (because that patch including a "WoW.tfil" file), the Background Downloader.exe appears to be downloading something starting from about 397MB of 10.6GB.

 

is it suppose to be like that, or am i do something wrong somewhere?

Link to comment
Share on other sites

hello,

 

i have done all the instructions and doing fine,

 

but starting from wow-4.3.0.15050-to-4.3.2.15211-enUS, when i'm running Background Downloader.exe (because that patch including a "WoW.tfil" file), the Background Downloader.exe appears to be downloading something starting from about 397MB of 10.6GB.

 

is it suppose to be like that, or am i do something wrong somewhere?

There are a couple of patches that will do that. The only thing I'd caution you about is there seems to be mixed results with this whole process. I've personally done it 7 times and 3 of those times I ended up with a client that wouldn't even start.

 

I've been working with two other members trying to nail down something reliable but we keep getting different results. One method that Oiler2112 used was to grab a 3.3.5 installation and then take the TFIL from 4.3.4 and run backgrounddownloader.exe. The final product was a 14 GB client which based on forum posting is too small - although he can log in with it.

 

To illustrate the problem, Gixxer_j did the same and ended up with a 30 GB client and I did it and my client was 17 GB.

Link to comment
Share on other sites

after my last post a few days ago, the download is surprisingly complete in only 4 days. i have done all the patch and my client now is 4.3.4.15595.

 

the problem is, when i start wow.exe, it launches the launcher instead of the wow itself. it said "downloading updated tools", but i didn't finish that download and force the launcher to close.

 

what should i do now, you said that "NEVER launch the launcher.exe", but the Wow.exe itself launch the launcher.

 

i hope i'm not screwed up yet.

Link to comment
Share on other sites

  • 2 weeks later...

Ok so now i have just patched my wow client to 4.3.4 and its size is 20.3gb. I just started wow.exe and it says " World of warcraft is performing initial setup for data files." and then it crashes halfway. Then i checked my wow size is about 16.5gb and i already changed the realmlist to a private server. Is ther anyway to prevent this crash?

Link to comment
Share on other sites

  • 5 weeks later...

 The patch "pc-game-hdfilesWow.exe" could not be applied. (MD5 mismatch: expected 0x0D3995E75EF62D7317D68FC92615DAA5, actual 0x3D4965F5549AE3017BA6CBD6E04C9CAA.)(PTCApply_BSDiff failed.) If this problem persists, you may be able to solve it by uninstalling and then reinstalling the game. If you are unable to correct this problem, please contact Blizzard Technical Support. (BNUpdate::PTCApply)
 

-.-^^

 

Anyone can Fix it / Help me ?

Link to comment
Share on other sites

  • 1 month later...

@MrSmite

 

First of all, AWESOME guide bro... been trying to fix these asinine patch problems for two days now.  Long story short, I think it's finally going okay... so far, anyway.  I didn't run the background downloader until the 4.2-4.3 patch, so I might have to start over at some point (luckily, I learned the hard way with WotLK to ALWAYS backup my client before doing this stuff).  If I do have to start over, at least now I don't have to dance around between 20 different mirrors trying to find all the patches I need - thanks again.

 

@Dr.Core

 

I ran into that same problem last night / today... re-copy the "base-Win.MPQ" into your wow/data folder then start the patch again - that should fix the problem.

Link to comment
Share on other sites

  • 5 months later...

im having a bit of an issue with the background downloader.... after using a cata install dvd to upgrade my wrath install, i follow your guide to start installing patches, and when i run the background downloader it gives me an error window with "this download is not authorized" and will close the downloader shortly there after. if i get the connection info window up before the error window pops up the download continues.

 

any one know how else to bypass the error window?

 

Never mind.......it might help if i read the entire guide properly....

Link to comment
Share on other sites

+alysher take your time

Rule number 1. Don't EVER run the Launcher (You probably have seen that infested all over the forums that talk about client patching)

If it opens and starts to run, just close it.. and continue with patching, backgroundownloader, etc...

 

EDIT: Almost forgot to mention, If you ever install the TFIL/MFIL and the launcher runs by accident (dont know how), you HAVE to remove the tfiland mfil files. Then start over with the version you left off.

Link to comment
Share on other sites

actually there was one part that i DID let the launcher run...immeadeatly after the install of the dvd....it downloaded upadted tools and such...but as soon as i got the popup saying it wanted to optimize, i closed it(was afraid at that point that it would try to download 5.x. indeed it started to, but i was able to start the regular patching process).....the only issue ive had was my earlier post. one last question....i assume that the scripts that i ran of MrSmites are safe to delete after they have been run, is there any thing else that is safe to delete in the base folder, such as the .mpq files i copied there earlier in the patching process(or are these still necessary?)

Link to comment
Share on other sites

If you aren't sure, then move them to another directory named "old", It's basically just a waiting game now. After applying each patch, you should check that the backgrounddownloader didn't need to update anything before the next patch you apply. Also in MrSmites doc shows the tfil_collection, might as well grab that just in case something gets borked. Anything in the root directory of wow can be removed after it's installed to the full version 15595. But, during the patch process might as well just leave the mpq files alone.

Link to comment
Share on other sites

ya, leaving them during the patch process was what i figured id do. 

 

 

now i have the age old "cannot stream required data" issue.....ho hum

 

How far did you get applying the patches?

If you are at the latest, there is still hope, but a tedious process...

Use the tfil_collection and start with the first patch. Just copy the tfil/mfil in the root directory of wow, run backgrounddownloader, than move on to the next if it gives you an error/warning or doesn't download/stream.

 

I guarantee you, it still has data to stream.

Link to comment
Share on other sites

ya, leaving them during the patch process was what i figured id do. 

 

 

now i have the age old "cannot stream required data" issue.....ho hum

 

That's because you downloaded the 5.x updated tools from the Launcher. These tools are not compatible with old patches because they want to connect and download MoP content, not Cata content.

 

I don't know why, after being told NOT to, you decided to let the Launcher run. Hell the guide even says in bold, red letters not to let it run. You'll most likely need to start over.

Link to comment
Share on other sites

That's because you downloaded the 5.x updated tools from the Launcher. These tools are not compatible with old patches because they want to connect and download MoP content, not Cata content.

 

I don't know why, after being told NOT to, you decided to let the Launcher run. Hell the guide even says in bold, red letters not to let it run. You'll most likely need to start over.

im not so sure i did that for the tools for the dvd. i checked the version info for wow and it said 4.0.0, not 5x.

 

and i got all the way to 4.3.4 and applied the client patch you provided CDawg then started wow. and that was when i got the "cannot stream required arcive data" error. i already started re copying the .tfil and .mfil files and running the background downloader again. we shall see what happens after its all done

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...