Jump to content
TrinityCore

Recommended Posts

Hello,

 

When i try to build the core i recive this error (i use ubuntu 16.4.3 and last rev of Trinitycore 335):

 

/home/szone/TrinityCore/TrinityCore/src/common/Collision/Maps/TileAssembler.cpp: In member function ‘bool VMAP::TileAssembler::readMapSpawns()’:
/home/szone/TrinityCore/TrinityCore/src/common/Collision/Maps/TileAssembler.cpp:227:51: warning: ignoring return value of ‘size_t fread(void*, size_t, size_t, FILE*)’, declared with attribute warn_unused_result [-Wunused-result]
             fread(&tileX, sizeof(uint32), 1, dirf);
                                                   ^
/home/szone/TrinityCore/TrinityCore/src/common/Collision/Maps/TileAssembler.cpp:228:51: warning: ignoring return value of ‘size_t fread(void*, size_t, size_t, FILE*)’, declared with attribute warn_unused_result [-Wunused-result]
             fread(&tileY, sizeof(uint32), 1, dirf);
 

 

Thank you!

 

 

 

Link to comment
Share on other sites

20 hours ago, Szone said:

Hello,

 

When i try to build the core i recive this error (i use ubuntu 16.4.3 and last rev of Trinitycore 335):

 

/home/szone/TrinityCore/TrinityCore/src/common/Collision/Maps/TileAssembler.cpp: In member function ‘bool VMAP::TileAssembler::readMapSpawns()’:
/home/szone/TrinityCore/TrinityCore/src/common/Collision/Maps/TileAssembler.cpp:227:51: warning: ignoring return value of ‘size_t fread(void*, size_t, size_t, FILE*)’, declared with attribute warn_unused_result [-Wunused-result]
             fread(&tileX, sizeof(uint32), 1, dirf);
                                                   ^
/home/szone/TrinityCore/TrinityCore/src/common/Collision/Maps/TileAssembler.cpp:228:51: warning: ignoring return value of ‘size_t fread(void*, size_t, size_t, FILE*)’, declared with attribute warn_unused_result [-Wunused-result]
             fread(&tileY, sizeof(uint32), 1, dirf);
 

 

Thank you!

 

 

 

Are you cancelling out the compile? It should continue. It will say "build failed". Otherwise, just let continue.

  • Upvote 1
Link to comment
Share on other sites

On 6/28/2017 at 7:31 PM, Aokromes said:

Or you can simply:
 

apt-get install git cmake make gcc g++ libmariadbclient-dev libssl1.0-dev libbz2-dev libreadline-dev libncurses-dev libboost-all-dev mysql-server p7zip

Doesn't appear to be the solutions for me.  Please help.

I had to switch things up a bit since I'm not using maria, but I also found that on Ubuntu 16.04 libssl1.0-dev and libncurses-dev do not exist.  

sudo apt-get install git cmake make gcc g++ libmysqlclient-dev libssl-dev libbz2-dev libreadline-dev libncurses5-dev libboost-all-dev mysql-server p7zip
Reading package lists... Done
Building dependency tree
Reading state information... Done
g++ is already the newest version (4:5.3.1-1ubuntu1).
gcc is already the newest version (4:5.3.1-1ubuntu1).
libbz2-dev is already the newest version (1.0.6-8).
libncurses5-dev is already the newest version (6.0+20160213-1ubuntu1).
libreadline-dev is already the newest version (6.3-8ubuntu2).
make is already the newest version (4.1-6).
libboost-all-dev is already the newest version (1.58.0.1ubuntu1).
p7zip is already the newest version (9.20.1~dfsg.1-4.2).
cmake is already the newest version (3.5.1-1ubuntu3).
git is already the newest version (1:2.7.4-0ubuntu1.2).
libmysqlclient-dev is already the newest version (5.7.19-0ubuntu0.16.04.1).
mysql-server is already the newest version (5.7.19-0ubuntu0.16.04.1).
libssl-dev is already the newest version (1.1.0f-2~ubuntu16.04.1+deb.sury.org+1).
The following packages were automatically installed and are no longer required:
  linux-headers-4.4.0-75 linux-headers-4.4.0-75-generic
  linux-image-4.4.0-75-generic linux-image-extra-4.4.0-75-generic
Use 'sudo apt autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Link to comment
Share on other sites

5 hours ago, jempson said:

Doesn't appear to be the solutions for me.  Please help.

I had to switch things up a bit since I'm not using maria, but I also found that on Ubuntu 16.04 libssl1.0-dev and libncurses-dev do not exist.  

sudo apt-get install git cmake make gcc g++ libmysqlclient-dev libssl-dev libbz2-dev libreadline-dev libncurses5-dev libboost-all-dev mysql-server p7zip
Reading package lists... Done
Building dependency tree
Reading state information... Done
g++ is already the newest version (4:5.3.1-1ubuntu1).
gcc is already the newest version (4:5.3.1-1ubuntu1).
libbz2-dev is already the newest version (1.0.6-8).
libncurses5-dev is already the newest version (6.0+20160213-1ubuntu1).
libreadline-dev is already the newest version (6.3-8ubuntu2).
make is already the newest version (4.1-6).
libboost-all-dev is already the newest version (1.58.0.1ubuntu1).
p7zip is already the newest version (9.20.1~dfsg.1-4.2).
cmake is already the newest version (3.5.1-1ubuntu3).
git is already the newest version (1:2.7.4-0ubuntu1.2).
libmysqlclient-dev is already the newest version (5.7.19-0ubuntu0.16.04.1).
mysql-server is already the newest version (5.7.19-0ubuntu0.16.04.1).
libssl-dev is already the newest version (1.1.0f-2~ubuntu16.04.1+deb.sury.org+1).
The following packages were automatically installed and are no longer required:
  linux-headers-4.4.0-75 linux-headers-4.4.0-75-generic
  linux-image-4.4.0-75-generic linux-image-extra-4.4.0-75-generic
Use 'sudo apt autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Ubuntu expert here :P
What error are you receiving? What version are you looking for?
MariaDB is just an option and your version of libssl (openssl) is just fine.
However, you will need to use a newer version of boost for Ubuntu 16.04+

Are you trying to compile 3.3.5 or master?

Link to comment
Share on other sites

  • 2 weeks later...

Hey There,

I am trying to build master branch. I am running Ubuntu Headless Server 16.04.

It is old and solved problem with build directory but I can't get past it. I have made directory build inside and outside TrinityCore with cmake ../ -DCMAKE_INSTALL_PREFIX=/home/trinity/server. What am I doing wrong?

By the way, if you want to be sure what error message is:

configure_file attempted to configure a file:

bla bla bla cmake_uninstall.cmake into a source directory.

 

Link to comment
Share on other sites

First of all, my language is not English, it's Portuguese.

I have partially looked at the topic about core compilation errors, I have not found anything that can help me. I do not use MySQL the intalalled version, I use the ".zip" version and start it from the command line. What I pointed out the missing mysql paths to folders of my mysql ".zip"
MYSQL_EXECUTABLE = C:/Users/Henrrique/Desktop/SERVER/mysql/bin/mysqlX.exe
MYSQL_INCLUDE_DIR = C:/Users/Henrrique/Desktop/SERVER/mysql/include
MYSQL_LIBRARY = C:/Users/Henrrique/Desktop/SERVER/mysql/lib
NOTE: I also had problems with the paths to boost, pointed the missing paths and did not get any more errors, however I had to point out LINK paths in the vmap4assembler and mmaps_generator project.

The error that points to the output is:

Error    LNK1181    cannot open input file 'C:\Users\Henrrique\Desktop\SERVER\mysql\lib.obj'    authserver    C:\Users\Henrrique\Desktop\PROJECTWOW\BUILD\src\server\authserver\LINK    1
Error    LNK1181    cannot open input file 'C:\Users\Henrrique\Desktop\SERVER\mysql\lib.obj'    worldserver    C:\Users\Henrrique\Desktop\PROJECTWOW\BUILD\src\server\worldserver\LINK    1

The strange thing is this obj file: "lib.obj" it is part of mysql, I did not find this file in mysql nor in the debug_test version.

Edited by gldssgames
Add information and remove
Link to comment
Share on other sites

  • 2 weeks later...
  • 3 weeks later...

Dear Users!

I followed all of the steps, but heres an error named:

~/TrinityCore/build# cmake ../
CMake Error at cmake/compiler/gcc/settings.cmake:7 (message):
  GCC: TrinityCore requires version 4.9.0 to build but found 4.8.4
Call Stack (most recent call first):
  cmake/platform/unix/settings.cmake:29 (include)
  cmake/macros/CheckPlatform.cmake:13 (include)
  CMakeLists.txt:58 (include)


-- Configuring incomplete, errors occurred!
See also "/root/TrinityCore/build/CMakeFiles/CMakeOutput.log".
See also "/root/TrinityCore/build/CMakeFiles/CMakeError.log".

 

Plus, I tried to do following these steps:

http://www.ac-web.org/forums/showthread.php?175234-How-to-compile-Trinity-Core-on-Ubuntu&p=2286499#post2286499

But theres an error aswell, named: 

[email protected]:~/TrinityCore/build# make
make: *** No targets specified and no makefile found.  Stop.
[email protected]:~/TrinityCore/build# make install
make: *** No rule to make target `install'.  Stop.
 

 

Anyone have any ideas? OR anyone have a compiled linux files from master (7.1.5).

Id like to do this to work, please help me out! :(

Link to comment
Share on other sites

  • 2 weeks later...

After a fierce and lengthy battle in which CMake for Windows won by refusing to find the BOOST folders no matter what I did,  I decided to switch to Mac where I was successful in getting past compiling with Xcode, so I have everything compiled. Unfortunately, I don't have the original 7.2.5 client and I am unable to extract maps, vmaps, etc. Not a huge problem since I already have them anyway downloaded from DevApex. And everything works.

Is it possible to run cmake in Mac but have the results made for Visual Studio? the command line has an "xcode" argument in it and given that there was no SLN file made, I gather the cmake command will have to have something like "visualstudio" or something similar. In the Trinity server for Windows tutorial, there is no reference to running cmake from the command line, I thought that if I knew what the command line looked like, I would be able to interpolate/translate for Mac, then run it on a Mac and then compile from Visual Studio.

Thanks

Link to comment
Share on other sites

Hey,

its been a while that i worked with a trinitycore but after playing some time on retail i wanted to start working with a TC 3.3.5

I installed visual 2015 and all programms i need for compilie

i installed git like the tutorial said, and also checked if the path is in

but i am getinng this cmake error:

CMake Error at cmake/macros/EnsureVersion.cmake:95 (NORMALIZE_VERSION):
NORMALIZE_VERSION Macro invoked with incorrect arguments for macro named:
NORMALIZE_VERSION
Call Stack (most recent call first):
cmake/macros/FindGit.cmake:37 (ensure_version)
CMakeLists.txt:67 (find_package)

 

Git version too old :

CMake Error at cmake/macros/FindGit.cmake:42 (message):


Git was found but is OUTDATED - did you forget to install a recent version, or setting the path to it?
Observe that for revision hash/date to work you need at least version 1.7
Call Stack (most recent call first):
CMakeLists.txt:67 (find_package)

Unbenannt.png

Link to comment
Share on other sites

CMAKE fails in FindGit.cmake:

 # make sure we're using minimum the required version of git, so the "dirty-testing" will work properly
  ensure_version( "${_REQUIRED_GIT_VERSION}" "${_GIT_VERSION}" _GIT_VERSION_OK)

  # throw an error if we don't have a recent enough version of git...
  if(NOT _GIT_VERSION_OK)
    message(STATUS "Git version too old : ${_GIT_VERSION}")
    message(FATAL_ERROR "
      Git was found but is OUTDATED - did you forget to install a recent version, or setting the path to it?
      Observe that for revision hash/date to work you need at least version ${_REQUIRED_GIT_VERSION}")
  endif()
endif()

CMAKE can't find a value for ${_GIT_VERSION}. Seems to by empty in your case. Don't know why.

May it helps to reinstall Git Extensions and/or CMake following exactly the guide in TC Wiki.

BTW: Can you show the full message log of CMake before the error message ?

Link to comment
Share on other sites

Before the error there should be a line like:

Found git binary : C:/Program Files (x86)/Git/cmd/git.exe

 

You can test it in a windows console with :

"C:/Program Files (x86)/Git/cmd/git.exe" --version

 

That's more or less what the CMake script is checking to determine the version.

 

Link to comment
Share on other sites

Found git binary : E:/Daniel/Programme/Git/cmd/git.exe

CMake Error at cmake/macros/EnsureVersion.cmake:95 (NORMALIZE_VERSION):
NORMALIZE_VERSION Macro invoked with incorrect arguments for macro named:
NORMALIZE_VERSION
Call Stack (most recent call first):
cmake/macros/FindGit.cmake:37 (ensure_version)
CMakeLists.txt:67 (find_package)

 

Git version too old :

CMake Error at cmake/macros/FindGit.cmake:42 (message):


Git was found but is OUTDATED - did you forget to install a recent version, or setting the path to it?
Observe that for revision hash/date to work you need at least version 1.7
Call Stack (most recent call first):
CMakeLists.txt:67 (find_package)

 

Configuring incomplete, errors occurred!

See also "E:/Daniel/Developing/TrinityCore-Cmake/CMakeFiles/CMakeOutput.log".

 

 

 

 

Unbenannt.png

Link to comment
Share on other sites

Looks for me like a bug. In your case the variable ${_GIT_VERSION} in FindGit.cmake is empty. That why there is nothing written behind "Git version too old : "

May you can wait till somebody else knows something or open a bug in the issue tracker with a link to this forum.

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.


  • Similar Content

    • By xgamerninjax
      Hello all, first time posting here and it's really got me scratching my head.
      I've compiled everything on my own computer, and then transferred everything to a host computer so the server can stay live. The server was running fine for a month or so and then suddenly it just crashes when it hits "Loading C++ scripts", exiting saying "caught signal 22"
      I tried setting up the host computer from scratch and transferred everything over fresh and it's still happening for some reason. (Note, I can run the server perfectly on my personal pc where I compiled it.)
      Any help would be greatly appreciated, thanks!
      3d7e3a40e2b3+_worldserver.exe_[1-4_15-19-45].dmp 3d7e3a40e2b3+_worldserver.exe_[1-4_15-19-45].txt
    • By Deer_Hunter
      Hello all,
      I just updated from the latest Git 
      Trinity Core REV. ac6baa547376 + 2020-02-21  3.3.5 Branch.
      I'm getting this error after crash.
      Problem signature:
        Problem Event Name:    APPCRASH
        Application Name:    worldserver.exe
        Application Version:    0.0.0.0
        Application Timestamp:    5e50a462
        Fault Module Name:    StackHash_f12f
        Fault Module Version:    6.3.9600.19629
        Fault Module Timestamp:    5e2fdc0d
        Exception Code:    c0000374
        Exception Offset:    PCH_9E_FROM_ntdll+0x0000000000090D0A
        OS Version:    6.3.9600.2.0.0.272.7
        Locale ID:    1033
        Additional Information 1:    f12f
        Additional Information 2:    f12f0934d3e965f73c68e60f20f2cd40
        Additional Information 3:    7595
        Additional Information 4:    7595e4d8d703db9dcd3d2f6ea540e357
      the exception code says its a Heap error,  I'm not sure how to troubleshoot this.
      Thanks
    • By 939h
      Hi,

      The chat channel Lookup for group is not available when a player isn't in a city. I tried to modify the worldserver.conf file with:
      #
      #    Channel.RestrictedLfg
      #        Description: Restrict LookupForGroup channel to characters registered in the LFG tool.
      #        Default:     1 - (Enabled, Allow join to channel only if registered in LFG)
      #                     0 - (Disabled, Allow join to channel in any time)
      Channel.RestrictedLfg = 0

      I restarted the server but it didn't help.

      Thanks
    • By meeek
      Hey, I've been trying to compile from github the core from 6.2.3/6.2.4, I'm well aware its stopped developing. I cannot get it to configure properly in CMake, nor can I obviously build it.
       
      I'd be willing to pay for help and get this working and running. I want to develop my own server on my freetime as a learning project and for entertainment. I can't find any core for WoD, sadly.. Very hard, would appreciate any quick help
       
    • By Probie_Wan_Kenobi
      I believe everything I have done up to this point has been correct. When I go to launch worldserver.exe a console window opens up for a second and closes right away and nothing else seems to have happened. I skipped a head a little in the instructions to see what is left and step 5 seems skippable since I am running this only for this computer and step 6 has me launch to a log in screen which I can not get to. I tried going to the faq but the page was not loading properly so I am forced to post here.
×
×
  • Create New...