Jump to content

Recommended Posts

Hello there, i am new here and i hope some one can help me to understand this error. I am a little noob at compiling but in debian i can do alot.

So i have a Debian 10 VM that run Trinitycore. I want Compile the new Version of 3.3.5a on it but its stuck. I dont know its a Error at my Server or not?

Can some on Explain whats going wrong?

-- Detected 64-bit platform
-- UNIX: Using default configuration directory
-- UNIX: Using default library directory
-- UNIX: Configuring uninstall target
-- UNIX: Created uninstall target
-- UNIX: Detected compiler: /usr/bin/cc
-- Clang: All warnings enabled
-- cotire 1.7.10 loaded.
-- Using mysql-config: /usr/bin/mysql_config
-- Found MySQL library: /usr/lib/x86_64-linux-gnu/libmariadb.so
-- Found MySQL headers: /usr/include/mariadb
-- Found MySQL executable: /usr/bin/mysql
-- Found git binary : /usr/bin/git

* TrinityCore revision   : 7450be4cfd3f 2020-02-10 22:33:38 +0100 (3.3.5 branch)
* TrinityCore buildtype  : RelWithDebInfo

* Install core to        : /home/t2k/server
* Install libraries to   : /home/t2k/server/lib
* Install configs to     : /home/t2k/server/etc

* Build world/auth       : Yes (default)
* Build with scripts     : Yes (static)
* Build map/vmap tools   : Yes (default)
* Build core w/PCH       : Yes (default)
* Build scripts w/PCH    : Yes (default)
* Show all warnings      : Yes
* Use coreside debug     : No  (default)
* Show source tree       : Yes (hierarchical)
* Use GIT revision hash  : Yes (default)

-- Boost version: 1.67.0
-- Found the following Boost libraries:
--   system
--   filesystem
--   thread
--   program_options
--   iostreams
--   regex
-- Found OpenSSL library: /usr/lib/x86_64-linux-gnu/libssl.so;/usr/lib/x86_64-linux-gnu/libcrypto.so
-- Found OpenSSL headers: /usr/include
-- Found Readline library: /usr/lib/x86_64-linux-gnu/libreadline.so
-- Include dir is: /usr/include

* Script configuration (static):
    +- worldserver
    |   +- Commands
    |   +- Custom
    |   +- EasternKingdoms
    |   +- Events
    |   +- Kalimdor
    |   +- Northrend
    |   +- OutdoorPvP
    |   +- Outland
    |   +- Pet
    |   +- Spells
    |   +- World

-- Configuring done
-- Generating done
-- Build files have been written to: /home/t2k/TrinityCore/build
[  0%] Built target Detour
[  0%] Built target fmt
[  1%] Built target Recast
[  5%] Built target g3dlib
[  5%] Built target sfmt
[  6%] Built target argon2
[  6%] Built target gsoap
[  7%] Built target mpq
[ 10%] Built target jemalloc
[ 10%] Built target revision_data.h
[ 10%] Building CXX object src/common/CMakeFiles/common.dir/Common.cpp.o
[ 10%] Building CXX object src/common/CMakeFiles/common.dir/Collision/BoundingIntervalHierarchy.cpp.o
[ 10%] Building CXX object src/common/CMakeFiles/common.dir/GitRevision.cpp.o
[ 10%] Building CXX object src/common/CMakeFiles/common.dir/Banner.cpp.o
fatal error: C++17 was disabled in PCH file but is currently enabled
fatal error: 1 error generated.
C++17 was disabled in PCH file but is currently enabled
1 error generated.
make[2]: *** [src/common/CMakeFiles/common.dir/build.make:120: src/common/CMakeFiles/common.dir/Collision/BoundingIntervalHierarchy.cpp.o] Fehler 1
make[2]: *** Es wird auf noch nicht beendete Prozesse gewartet....
make[2]: *** [src/common/CMakeFiles/common.dir/build.make:106: src/common/CMakeFiles/common.dir/GitRevision.cpp.o] Fehler 1
fatal error: C++17 was disabled infatal error:  PCHC++17  filewas  butdisabled  isin  currently enabled
PCH file but is currently enabled
1 error generated.
1 error generated.
make[2]: *** [src/common/CMakeFiles/common.dir/build.make:78: src/common/CMakeFiles/common.dir/Banner.cpp.o] Fehler 1
make[2]: *** [src/common/CMakeFiles/common.dir/build.make:92: src/common/CMakeFiles/common.dir/Common.cpp.o] Fehler 1
make[1]: *** [CMakeFiles/Makefile2:1032: src/common/CMakeFiles/common.dir/all] Fehler 2
make: *** [Makefile:130: all] Fehler 2


Edited by t2k
Link to comment
Share on other sites

try to set cmake prefixes manually, as me:

cmake ../ \
 -DMYSQL_EXECUTABLE="/usr/bin/mysql" \
 -DMYSQL_INCLUDE_DIR="/usr/include/mariadb" \
 -DMYSQL_LIBRARY="/usr/lib/x86_64-linux-gnu/libmariadbclient.so" \
 -DSCRIPTS=static \
 -DTOOLS=1 \
&> $LOG_FILE \
&& make -j $CPU

It also seems that you have lost ZLIB1g-DEV



Link to comment
Share on other sites

  • 3 weeks later...

Im tring to use cmake and I keep encountering this error after resting up al the programs to do the core installation. ive been trying to find solutions online and im completely lost. as a note im trying to set up 3.3.5


Determining if the include file pthread.h exists failed with the following output:
Change Dir: C:/Wow server/build/CMakeFiles/CMakeTmp

Run Build Command(s):C:/Program Files (x86)/Microsoft Visual Studio/2017/Community/MSBuild/15.0/Bin/MSBuild.exe cmTC_bcfc6.vcxproj /p:Configuration=Debug /p:Platform=Win32 /p:VisualStudioVersion=15.0 /v:m && Microsoft (R) Build Engine version 15.9.21+g9802d43bc3 for .NET Framework
Copyright (C) Microsoft Corporation. All rights reserved.

  Microsoft (R) C/C++ Optimizing Compiler Version 19.16.27035 for x86
  Copyright (C) Microsoft Corporation.  All rights reserved.
  cl /c /Zi /W1 /WX- /diagnostics:classic /Od /Ob0 /Oy- /D WIN32 /D _WINDOWS /D "CMAKE_INTDIR=\"Debug\"" /D _MBCS /Gm- /RTC1 /MDd /GS /fp:precise /Zc:wchar_t /Zc:forScope /Zc:inline /Fo"cmTC_bcfc6.dir\Debug\\" /Fd"cmTC_bcfc6.dir\Debug\vc141.pdb" /Gd /TC /analyze- /errorReport:queue "C:\Wow server\build\CMakeFiles\CMakeTmp\CheckIncludeFile.c"
C:\Wow server\build\CMakeFiles\CMakeTmp\CheckIncludeFile.c(1): fatal error C1083: Cannot open include file: 'pthread.h': No such file or directory [C:\Wow server\build\CMakeFiles\CMakeTmp\cmTC_bcfc6.vcxproj]


full log: https://pastebin.com/hWCwwnsT


discord: kylezzz101#3942

Edited by Kylezzz101
Link to comment
Share on other sites

  • 3 months later...

Hello guys, 

I have an issue with recompiling my old TC core (2015) on Windows 10, like in the attached screenshot.

Steps I took:

1. Install Git Extensions (2.27.0) 64-bit

2. Install Visual Studio 2019

3. Install Win64 OpenSSL v1.0.2u to the /bin directory

4. Install and add to Windows path boost_1_73_0-msvc-14.2-64.exe

5. Install CMake-3.17.3-win64-x64.msi

6. Install and configure MySQL

7. Pulled the Core Source to a folder

8. Created a Build folder

9. Run CMake and got the error.


I've tried changing the compiler to Visual Studio 2013 - same error

I've tried changing CMake to v2.8.12.2 - same error

I've tried changing Win64 OpenSSL v1.1.1g 64bit/32/bit - same error


This is driving me crazy... :(

Any help would be greatly appreciated.


Thanks a lot!


Link to comment
Share on other sites

  • 4 months later...

Hello guys, 

I have an issue with recompiling Trinitycore 3.3.5 on Server 2019 with Bots, like in the attached.

Steps I took:

1. Install Git-2.28.0-64-bit

2. Install Visual Studio 2019

3. Install Win64OpenSSL-1_1_1h to the /bin directory

4. Install and add to Windows path boost_1_72_0-msvc-14.2-64.exe

5. Install cmake-3.18.4-win32-x86.msi

6. Install and configure MySQL

7. Pulled the Core Source to a folder

8. Pulled the bots Source to the same folder ( https://github.com/trickerer/Trinity-Bots )

9. Run bot Patch  -> patch -p1 < NPCBots.patch (no Error)

8. Created a Build folder

9. Run CMake (no error)

10. Run Visual Studio 2019 get errors see attach.

If i compile without bots it works fine.

Please Help!


Link to comment
Share on other sites

  • 2 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By xgamerninjax
      Hello all, first time posting here and it's really got me scratching my head.
      I've compiled everything on my own computer, and then transferred everything to a host computer so the server can stay live. The server was running fine for a month or so and then suddenly it just crashes when it hits "Loading C++ scripts", exiting saying "caught signal 22"
      I tried setting up the host computer from scratch and transferred everything over fresh and it's still happening for some reason. (Note, I can run the server perfectly on my personal pc where I compiled it.)
      Any help would be greatly appreciated, thanks!
      3d7e3a40e2b3+_worldserver.exe_[1-4_15-19-45].dmp 3d7e3a40e2b3+_worldserver.exe_[1-4_15-19-45].txt
    • By Deer_Hunter
      Hello all,
      I just updated from the latest Git 
      Trinity Core REV. ac6baa547376 + 2020-02-21  3.3.5 Branch.
      I'm getting this error after crash.
      Problem signature:
        Problem Event Name:    APPCRASH
        Application Name:    worldserver.exe
        Application Version:
        Application Timestamp:    5e50a462
        Fault Module Name:    StackHash_f12f
        Fault Module Version:    6.3.9600.19629
        Fault Module Timestamp:    5e2fdc0d
        Exception Code:    c0000374
        Exception Offset:    PCH_9E_FROM_ntdll+0x0000000000090D0A
        OS Version:    6.3.9600.
        Locale ID:    1033
        Additional Information 1:    f12f
        Additional Information 2:    f12f0934d3e965f73c68e60f20f2cd40
        Additional Information 3:    7595
        Additional Information 4:    7595e4d8d703db9dcd3d2f6ea540e357
      the exception code says its a Heap error,  I'm not sure how to troubleshoot this.
    • By 939h

      The chat channel Lookup for group is not available when a player isn't in a city. I tried to modify the worldserver.conf file with:
      #    Channel.RestrictedLfg
      #        Description: Restrict LookupForGroup channel to characters registered in the LFG tool.
      #        Default:     1 - (Enabled, Allow join to channel only if registered in LFG)
      #                     0 - (Disabled, Allow join to channel in any time)
      Channel.RestrictedLfg = 0

      I restarted the server but it didn't help.

    • By meeek
      Hey, I've been trying to compile from github the core from 6.2.3/6.2.4, I'm well aware its stopped developing. I cannot get it to configure properly in CMake, nor can I obviously build it.
      I'd be willing to pay for help and get this working and running. I want to develop my own server on my freetime as a learning project and for entertainment. I can't find any core for WoD, sadly.. Very hard, would appreciate any quick help
    • By Probie_Wan_Kenobi
      I believe everything I have done up to this point has been correct. When I go to launch worldserver.exe a console window opens up for a second and closes right away and nothing else seems to have happened. I skipped a head a little in the instructions to see what is left and step 5 seems skippable since I am running this only for this computer and step 6 has me launch to a log in screen which I can not get to. I tried going to the faq but the page was not loading properly so I am forced to post here.
  • Create New...