Jump to content

Recommended Posts

You are either using an old revision or using a non-supported custom patch

If you had looked at the information provided:

* TrinityCore rev. hash  : 26ff19dbf82a

* TrinityCore rev. date  : 2012-04-11 13:40:17 +0200

* TrinityCore buildtype  : Release

And I am not using any custom patches. I've removed the local copy of the sourcecode and redownloaded it with git and now it is compiling.
* TrinityCore rev. hash  : e88e0f08d199

* TrinityCore rev. date  : 2012-04-12 13:29:51 -0400

* TrinityCore buildtype  : Release

Edited by Luniz2k1
Link to comment
Share on other sites

And I am not using any custom patches. I've removed the local copy of the sourcecode and redownloaded it with git and now it is compiling.

I want to believe you but there is no "UNIT_STAT_FOLLOW" used anywhere on the code (not on 6400c13fcb342fff7e2d8, at least)

Edited by Nay
Link to comment
Share on other sites

Each of the two computer windows 7 operating system is installed.

The server is required to create programs I downloaded from here.


The translations of the bodies in accordance with the Visual C + + 2010 Express was performed, which ran without error.

I have no idea what's wrong.

Link to comment
Share on other sites

I vote the 2nd computer don't supports SFMT.

The SFMT what?

These data processor:

EVEREST Corporate Edition

Version EVEREST v5.50.2100

Benchmark Module

Homepage http://www.lavalys.com/

Report Type Report Wizard


Generator pegasus

Operating System Microsoft Windows 7 Ultimate 6.1.7601

Date 2012-04-15

Time 17:04


CPU Properties:

CPU Type AMD Athlon XP, 1800 MHz (13.5 x 133) 2200+

CPU Alias Thoroughbred-B

CPU Stepping B0

Instruction Set x86, MMX, 3DNow!, SSE

L1 Code Cache 64 KB

L1 Data Cache 64 KB

L2 Cache 256 KB (On-Die, Full-Speed)

CPU Physical Info:

Package Type 453 Pin PGA

Package Size 4.95 cm x 4.95 cm

Transistors 37.6 million

Process Technology 6Mi, 0.13 um, CMOS, Cu

Die Size 84 mm2

Core Voltage 1.50 - 1.65 V

I/O Voltage 1.6 V

Typical Power 44.0 - 64.0 W (depending on clock speed)

Maximum Power 48.5 - 74.3 W (depending on clock speed)

CPU Manufacturer:

Company Name Advanced Micro Devices, Inc.

Product Information http://www.amd.com/us-en/Processors/ProductInformation/0,,30_118,00.html

CPU Utilization:

CPU #1 33 %


CPUID Properties:

CPUID Manufacturer AuthenticAMD

CPUID CPU Name AMD Athlon XP 2200+

CPUID Revision 00000681h

Extended CPUID Revision 00000781h

Platform ID D1h (Socket A)

HTT / CMP Units 0 / 0

Instruction Set:

64-bit x86 Extension (AMD64, Intel64) Not Supported

AMD 3DNow! Supported

AMD 3DNow! Professional Supported

AMD 3DNowPrefetch Not Supported

AMD Enhanced 3DNow! Supported

AMD Extended MMX Supported

AMD MisAligned SSE Not Supported

AMD SSE4A Not Supported

AMD SSE5 Not Supported

Cyrix Extended MMX Not Supported

IA-64 Not Supported

IA MMX Supported

IA SSE Supported

IA SSE 2 Not Supported

IA SSE 3 Not Supported

IA Supplemental SSE 3 Not Supported

IA SSE 4.1 Not Supported

IA SSE 4.2 Not Supported

IA AVX Not Supported

IA FMA Not Supported

IA AES Extensions Not Supported

VIA Alternate Instruction Set Not Supported

CLFLUSH Instruction Not Supported

CMPXCHG8B Instruction Supported

CMPXCHG16B Instruction Not Supported

Conditional Move Instruction Supported

LZCNT Instruction Not Supported

MONITOR / MWAIT Instruction Not Supported

MOVBE Instruction Not Supported

PCLMULQDQ Instruction Not Supported

POPCNT Instruction Not Supported

RDTSCP Instruction Not Supported

SYSCALL / SYSRET Instruction Supported

SYSENTER / SYSEXIT Instruction Supported

VIA FEMMS Instruction Not Supported

Security Features:

Advanced Cryptography Engine (ACE) Not Supported

Advanced Cryptography Engine 2 (ACE2) Not Supported

Data Execution Prevention (DEP, NX, EDB) Not Supported

Hardware Random Number Generator (RNG) Not Supported

PadLock Hash Engine (PHE) Not Supported

PadLock Montgomery Multiplier (PMM) Not Supported

Processor Serial Number (PSN) Not Supported

Power Management Features:

Automatic Clock Control Not Supported

Digital Thermometer Not Supported

Dynamic FSB Frequency Switching Not Supported

Enhanced Halt State (C1E) Not Supported

Enhanced SpeedStep Technology (EIST, ESS) Not Supported

Frequency ID Control Not Supported

Hardware P-State Control Not Supported

LongRun Not Supported

LongRun Table Interface Not Supported

PowerSaver 1.0 Not Supported

PowerSaver 2.0 Not Supported

PowerSaver 3.0 Not Supported

Processor Duty Cycle Control Not Supported

Software Thermal Control Not Supported

Temperature Sensing Diode Supported

Thermal Monitor 1 Not Supported

Thermal Monitor 2 Not Supported

Thermal Monitoring Not Supported

Thermal Trip Not Supported

Voltage ID Control Not Supported

CPUID Features:

1 GB Page Size Not Supported

36-bit Page Size Extension Supported

Address Region Registers (ARR) Not Supported

Core Power Boost Not Supported

CPL Qualified Debug Store Not Supported

Debug Trace Store Not Supported

Debugging Extension Supported

Direct Cache Access Not Supported

Dynamic Acceleration Technology (IDA) Not Supported

Fast Save & Restore Supported

Hyper-Threading Technology (HTT) Not Supported

Invariant Time Stamp Counter Not Supported

L1 Context ID Not Supported

Local APIC On Chip Supported

Machine Check Architecture (MCA) Supported

Machine Check Exception (MCE) Supported

Memory Configuration Registers (MCR) Not Supported

Memory Type Range Registers (MTRR) Supported

Model Specific Registers (MSR) Supported

Nested Paging Not Supported

Page Attribute Table (PAT) Supported

Page Global Extension Supported

Page Size Extension (PSE) Supported

Pending Break Event Not Supported

Physical Address Extension (PAE) Supported

Safer Mode Extensions (SMX) Not Supported

Secure Virtual Machine Extensions (Pacifica) Not Supported

Self-Snoop Not Supported

Time Stamp Counter (TSC) Supported

Turbo Boost Not Supported

Virtual Machine Extensions (Vanderpool) Not Supported

Virtual Mode Extension Supported

x2APIC Not Supported

XSAVE / XRSTOR Extended States Not Supported

Edited by kestom83
Link to comment
Share on other sites

Well, I have managed to get and compile the source code twice. only to get "Illegal instruction" when running worldserver. authserver works fine.

I am running Debian linux. The version of the code I am using: whatever version git gave me. As far as what database version, I don't know that either, but it doesn't matter at this point because it isn't even getting that far.

Link to comment
Share on other sites

Well, I have managed to get and compile the source code twice. only to get "Illegal instruction" when running worldserver. authserver works fine.

Need a proper crash dump to even begin helping

The version of the code I am using: whatever version git gave me. As far as what database version, I don't know that either

Not to sound rude but if you can't be bothered to supply simple revision info, how can you expect people to be bothered to help?

but it doesn't matter at this point because it isn't even getting that far.

Actually it matters a lot, that's why there are guidelines for submitting support issues

Link to comment
Share on other sites

I can't compile with new sources, on windows it's work.

I have ubuntu 10.04 x32, with the old sourcecode it's work.

[email protected]:~/wow/buildfun$ make -j 4

[  1%] [  1%] Built target gsoap

Built target mpq

[  1%] Building C object dep/jemalloc/CMakeFiles/jemalloc.dir/src/rtree.c.o

Scanning dependencies of target revision.h

Scanning dependencies of target shared_pch_dephelp

[  1%] Built target g3dlib

Scanning dependencies of target game_pch_dephelp

In file included from /home/desktop/wow/trinitycorefun/dep/jemalloc/include/jemalloc/internal/jemalloc_internal.h:388,

				 from /home/desktop/wow/trinitycorefun/dep/jemalloc/src/rtree.c:2:

/home/desktop/wow/trinitycorefun/dep/jemalloc/include/jemalloc/internal/atomic.h:102:6: error: #error "Missing implementation for 64-bit atomic operations"

make[2]: *** [dep/jemalloc/CMakeFiles/jemalloc.dir/src/rtree.c.o] Erreur 1

make[1]: *** [dep/jemalloc/CMakeFiles/jemalloc.dir/all] Erreur 2

make[1]: *** Attente des tâches non terminées....

[  1%] Building CXX object src/server/shared/CMakeFiles/shared_pch_dephelp.dir/shared_pch_dephelp.cxx.o

[  1%] Building CXX object src/server/game/CMakeFiles/game_pch_dephelp.dir/game_pch_dephelp.cxx.o

Linking CXX static library libshared_pch_dephelp.a

[  1%] Built target shared_pch_dephelp

[  1%] Built target revision.h

Linking CXX static library libgame_pch_dephelp.a

[  1%] Built target game_pch_dephelp

make: *** [all] Erreur 2

[email protected]:~/wow/buildfun$

how can i fix this?

(sorry for my bad english)

Link to comment
Share on other sites

This isn't a "compile" problem, this is a cmake error.

Click configure when you make a selection, or click configure before making any changes. IMO click configure a couple of times, before clicking generate. Also check permissions when using CMake.

Link to comment
Share on other sites

  • 3 weeks later...

11>D:\Trinity Core\AHModCore\src\server\scripts\Northrend\Ulduar\Ulduar\boss_yoggsaron.cpp(32): error C2365: 'SPELL_SARAS_ANGER' : redefinition; previous definition was 'enumerator'

11> D:\Trinity Core\AHModCore\src\server\scripts\Northrend\Ulduar\Ulduar\boss_yoggsaron.cpp(31) : see declaration of 'SPELL_SARAS_ANGER'

11>D:\Trinity Core\AHModCore\src\server\scripts\Northrend\Ulduar\Ulduar\boss_yoggsaron.cpp(34): error C2365: 'SPELL_SARAS_FEVOR' : redefinition; previous definition was 'enumerator'

11> D:\Trinity Core\AHModCore\src\server\scripts\Northrend\Ulduar\Ulduar\boss_yoggsaron.cpp(33) : see declaration of 'SPELL_SARAS_FEVOR'

11>D:\Trinity Core\AHModCore\src\server\scripts\Northrend\Ulduar\Ulduar\boss_yoggsaron.cpp(35): error C2365: 'SPELL_SARAS_BLESSING' : redefinition; previous definition was 'enumerator'

11> D:\Trinity Core\AHModCore\src\server\scripts\Northrend\Ulduar\Ulduar\boss_yoggsaron.cpp(30) : see declaration of 'SPELL_SARAS_BLESSING'

This happened after pulling the most recent files on Sunday May 13th at 11:30pm PST


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By xgamerninjax
      Hello all, first time posting here and it's really got me scratching my head.
      I've compiled everything on my own computer, and then transferred everything to a host computer so the server can stay live. The server was running fine for a month or so and then suddenly it just crashes when it hits "Loading C++ scripts", exiting saying "caught signal 22"
      I tried setting up the host computer from scratch and transferred everything over fresh and it's still happening for some reason. (Note, I can run the server perfectly on my personal pc where I compiled it.)
      Any help would be greatly appreciated, thanks!
      3d7e3a40e2b3+_worldserver.exe_[1-4_15-19-45].dmp 3d7e3a40e2b3+_worldserver.exe_[1-4_15-19-45].txt
    • By Deer_Hunter
      Hello all,
      I just updated from the latest Git 
      Trinity Core REV. ac6baa547376 + 2020-02-21  3.3.5 Branch.
      I'm getting this error after crash.
      Problem signature:
        Problem Event Name:    APPCRASH
        Application Name:    worldserver.exe
        Application Version:
        Application Timestamp:    5e50a462
        Fault Module Name:    StackHash_f12f
        Fault Module Version:    6.3.9600.19629
        Fault Module Timestamp:    5e2fdc0d
        Exception Code:    c0000374
        Exception Offset:    PCH_9E_FROM_ntdll+0x0000000000090D0A
        OS Version:    6.3.9600.
        Locale ID:    1033
        Additional Information 1:    f12f
        Additional Information 2:    f12f0934d3e965f73c68e60f20f2cd40
        Additional Information 3:    7595
        Additional Information 4:    7595e4d8d703db9dcd3d2f6ea540e357
      the exception code says its a Heap error,  I'm not sure how to troubleshoot this.
    • By 939h

      The chat channel Lookup for group is not available when a player isn't in a city. I tried to modify the worldserver.conf file with:
      #    Channel.RestrictedLfg
      #        Description: Restrict LookupForGroup channel to characters registered in the LFG tool.
      #        Default:     1 - (Enabled, Allow join to channel only if registered in LFG)
      #                     0 - (Disabled, Allow join to channel in any time)
      Channel.RestrictedLfg = 0

      I restarted the server but it didn't help.

    • By meeek
      Hey, I've been trying to compile from github the core from 6.2.3/6.2.4, I'm well aware its stopped developing. I cannot get it to configure properly in CMake, nor can I obviously build it.
      I'd be willing to pay for help and get this working and running. I want to develop my own server on my freetime as a learning project and for entertainment. I can't find any core for WoD, sadly.. Very hard, would appreciate any quick help
    • By Probie_Wan_Kenobi
      I believe everything I have done up to this point has been correct. When I go to launch worldserver.exe a console window opens up for a second and closes right away and nothing else seems to have happened. I skipped a head a little in the instructions to see what is left and step 5 seems skippable since I am running this only for this computer and step 6 has me launch to a log in screen which I can not get to. I tried going to the faq but the page was not loading properly so I am forced to post here.
  • Create New...