Jump to content
TrinityCore

Recommended Posts

Hello all,

i have the following error when compiling TC on Linux by the step "make"

# /home/wowserver/trinitycore/dep/jemalloc/src/huge.c: In function 'huge_ralloc':

# /home/wowserver/trinitycore/dep/jemalloc/src/huge.c:235: error: 'MREMAP_FIXED' undeclared (first use in this function)

# /home/wowserver/trinitycore/dep/jemalloc/src/huge.c:235: error: (Each undeclared identifier is reported only once

# /home/wowserver/trinitycore/dep/jemalloc/src/huge.c:235: error: for each function it appears in.)

# /home/wowserver/trinitycore/dep/jemalloc/src/huge.c:236: error: too many arguments to function 'mremap'

# make[2]: *** [dep/jemalloc/CMakeFiles/jemalloc.dir/src/huge.c.o] Error 1

# make[1]: *** [dep/jemalloc/CMakeFiles/jemalloc.dir/all] Error 2

# make: *** [all] Error 2

What can i do to correct this error?

MfG

excitus

Edited by excitus
Link to comment
Share on other sites

--- Canned message start ---

I would love to be able to just say: "Look in upper right hand corner of the forum, there is a button labeled SEARCH, please use it", but I don't think that will be enough therefore I present to you:

searchbuttonfordummieslsq1.jpg

Please read it cover to cover, and don't bother posting again until you do!

--- Canned message end ---

Link to comment
Share on other sites

Rev. https://github.com/TrinityCore/TrinityCore/commit/de56044b13d76b0461b820f12918029fa6d86015

When I try to compile on my dedicated get this error.

Is the dedicated x32 and x64.

errorcompilar.png

I have:

Visual Studio 10 Ultimate

Microsoft Visual C++ 2010 Redistributable Package

Cmake

GitExtensions

MySQL 5.x

OpenSSL 1.0.0c

Edit: In my personal computer also happens to me, and always there to run.

Thanks for your attention

Edited by Fantasy
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.


  • Similar Content

    • By xgamerninjax
      Hello all, first time posting here and it's really got me scratching my head.
      I've compiled everything on my own computer, and then transferred everything to a host computer so the server can stay live. The server was running fine for a month or so and then suddenly it just crashes when it hits "Loading C++ scripts", exiting saying "caught signal 22"
      I tried setting up the host computer from scratch and transferred everything over fresh and it's still happening for some reason. (Note, I can run the server perfectly on my personal pc where I compiled it.)
      Any help would be greatly appreciated, thanks!
      3d7e3a40e2b3+_worldserver.exe_[1-4_15-19-45].dmp 3d7e3a40e2b3+_worldserver.exe_[1-4_15-19-45].txt
    • By Deer_Hunter
      Hello all,
      I just updated from the latest Git 
      Trinity Core REV. ac6baa547376 + 2020-02-21  3.3.5 Branch.
      I'm getting this error after crash.
      Problem signature:
        Problem Event Name:    APPCRASH
        Application Name:    worldserver.exe
        Application Version:    0.0.0.0
        Application Timestamp:    5e50a462
        Fault Module Name:    StackHash_f12f
        Fault Module Version:    6.3.9600.19629
        Fault Module Timestamp:    5e2fdc0d
        Exception Code:    c0000374
        Exception Offset:    PCH_9E_FROM_ntdll+0x0000000000090D0A
        OS Version:    6.3.9600.2.0.0.272.7
        Locale ID:    1033
        Additional Information 1:    f12f
        Additional Information 2:    f12f0934d3e965f73c68e60f20f2cd40
        Additional Information 3:    7595
        Additional Information 4:    7595e4d8d703db9dcd3d2f6ea540e357
      the exception code says its a Heap error,  I'm not sure how to troubleshoot this.
      Thanks
    • By 939h
      Hi,

      The chat channel Lookup for group is not available when a player isn't in a city. I tried to modify the worldserver.conf file with:
      #
      #    Channel.RestrictedLfg
      #        Description: Restrict LookupForGroup channel to characters registered in the LFG tool.
      #        Default:     1 - (Enabled, Allow join to channel only if registered in LFG)
      #                     0 - (Disabled, Allow join to channel in any time)
      Channel.RestrictedLfg = 0

      I restarted the server but it didn't help.

      Thanks
    • By meeek
      Hey, I've been trying to compile from github the core from 6.2.3/6.2.4, I'm well aware its stopped developing. I cannot get it to configure properly in CMake, nor can I obviously build it.
       
      I'd be willing to pay for help and get this working and running. I want to develop my own server on my freetime as a learning project and for entertainment. I can't find any core for WoD, sadly.. Very hard, would appreciate any quick help
       
    • By Probie_Wan_Kenobi
      I believe everything I have done up to this point has been correct. When I go to launch worldserver.exe a console window opens up for a second and closes right away and nothing else seems to have happened. I skipped a head a little in the instructions to see what is left and step 5 seems skippable since I am running this only for this computer and step 6 has me launch to a log in screen which I can not get to. I tried going to the faq but the page was not loading properly so I am forced to post here.
×
×
  • Create New...