Jump to content

Recommended Posts

Ok. I followed your directions I also followed the directions posted on the Wiki

As for an error log there is none it will not create one because the Executable will not launch


I have been compiling cores for well over 6 years now I also work with C++ on a daily basis

this is the first time I have come into this issue I also utilized google before approaching anyone with this issue

Only when I could not come up with a solution or locate one that works in the forum or google did i bring this to your attention as I Know theres many other things to focus on 

Link to comment
Share on other sites

Aokromes I thank you for the link its quite intuitive but it does not cover this issue at all.

I did use the search function of the forums and I did use google and I did come to that link before i even posted

I guess I will look at different avenues since i am getting a canned support message

Link to comment
Share on other sites

Hey Trinity-Forums,


in the latest rev (fb997c5) I'm unable to compile the TrinityCore on my Linux machine. It exits with the following output:



-- Detected 64-bit platform

-- UNIX: Using jemalloc
-- UNIX: Using default configuration directory
-- UNIX: Using default library directory
CMake Error at cmake/platform/unix/settings.cmake:22 (configure_file):
  configure_file attempted to configure a file:
  /home/trinity/TrinityCore/cmake_uninstall.cmake into a source directory.
Call Stack (most recent call first):
  cmake/macros/CheckPlatform.cmake:15 (include)
  CMakeLists.txt:48 (include)
-- Configuring incomplete, errors occurred!


I tried do configure the CMake-Files into TrinityCore/build and TrinityCore/../build with another user like root.


Thanks for any help in advance.



Link to comment
Share on other sites

Hi there,

I've got a problem with my 4.3.4 compile and I would really appreciate it if someone could help me
Everytime I try to open my Authserver or Worldserver it tells me Trinitycore does not support versions below 5.1 even though I run above that version


I don't know what to do, could anyone please help?


Thanks in advance, and kind regards,

Edited by Rebirth
Link to comment
Share on other sites

I think alot of people use repacks just to get up and running easy. I've never really liked them. Was always going and downloading all 3, PHP, MySQL, and Apache then installing them. Something as complicated as a wow server, I can understand getting a re-pack for a starter-outter, just to get your fingers dirty with, if you know what I mean. That's what I done, but soon found out that there was a better way.

Link to comment
Share on other sites

Your top screen shot states twice, once in both terminals, "Trinity does not support MySQL below 5.1". Did you download MySQL server from their site, or is it a package thing like XAMP or something? Sometimes those packages claim to be latest and are not. I have ran across that before.

Yes i did download mysql from the mysql website, so I have no idea what could be wrong.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By xgamerninjax
      Hello all, first time posting here and it's really got me scratching my head.
      I've compiled everything on my own computer, and then transferred everything to a host computer so the server can stay live. The server was running fine for a month or so and then suddenly it just crashes when it hits "Loading C++ scripts", exiting saying "caught signal 22"
      I tried setting up the host computer from scratch and transferred everything over fresh and it's still happening for some reason. (Note, I can run the server perfectly on my personal pc where I compiled it.)
      Any help would be greatly appreciated, thanks!
      3d7e3a40e2b3+_worldserver.exe_[1-4_15-19-45].dmp 3d7e3a40e2b3+_worldserver.exe_[1-4_15-19-45].txt
    • By Deer_Hunter
      Hello all,
      I just updated from the latest Git 
      Trinity Core REV. ac6baa547376 + 2020-02-21  3.3.5 Branch.
      I'm getting this error after crash.
      Problem signature:
        Problem Event Name:    APPCRASH
        Application Name:    worldserver.exe
        Application Version:
        Application Timestamp:    5e50a462
        Fault Module Name:    StackHash_f12f
        Fault Module Version:    6.3.9600.19629
        Fault Module Timestamp:    5e2fdc0d
        Exception Code:    c0000374
        Exception Offset:    PCH_9E_FROM_ntdll+0x0000000000090D0A
        OS Version:    6.3.9600.
        Locale ID:    1033
        Additional Information 1:    f12f
        Additional Information 2:    f12f0934d3e965f73c68e60f20f2cd40
        Additional Information 3:    7595
        Additional Information 4:    7595e4d8d703db9dcd3d2f6ea540e357
      the exception code says its a Heap error,  I'm not sure how to troubleshoot this.
    • By 939h

      The chat channel Lookup for group is not available when a player isn't in a city. I tried to modify the worldserver.conf file with:
      #    Channel.RestrictedLfg
      #        Description: Restrict LookupForGroup channel to characters registered in the LFG tool.
      #        Default:     1 - (Enabled, Allow join to channel only if registered in LFG)
      #                     0 - (Disabled, Allow join to channel in any time)
      Channel.RestrictedLfg = 0

      I restarted the server but it didn't help.

    • By meeek
      Hey, I've been trying to compile from github the core from 6.2.3/6.2.4, I'm well aware its stopped developing. I cannot get it to configure properly in CMake, nor can I obviously build it.
      I'd be willing to pay for help and get this working and running. I want to develop my own server on my freetime as a learning project and for entertainment. I can't find any core for WoD, sadly.. Very hard, would appreciate any quick help
    • By Probie_Wan_Kenobi
      I believe everything I have done up to this point has been correct. When I go to launch worldserver.exe a console window opens up for a second and closes right away and nothing else seems to have happened. I skipped a head a little in the instructions to see what is left and step 5 seems skippable since I am running this only for this computer and step 6 has me launch to a log in screen which I can not get to. I tried going to the faq but the page was not loading properly so I am forced to post here.
  • Create New...