Jump to content
TrinityCore

Recommended Posts

clang: warning: argument unused during compilation: '-pthread'
0  0x1001e1724  __assert_rtn + 144
1  0x10021625e  archive::File<x86_64>::makeObjectFileForMember(archive::File<x86_64>::Entry const*) const + 1118
2  0x100215c3b  archive::File<x86_64>::justInTimeforEachAtom(char const*, ld::File::AtomHandler&) const + 139
3  0x10022a3fe  ld::tool::InputFiles::searchLibraries(char const*, bool, bool, bool, ld::File::AtomHandler&) const + 210
4  0x100231181  ld::tool::Resolver::resolveUndefines() + 189
5  0x1002331a5  ld::tool::Resolver::resolve() + 79
6  0x1001e1b17  main + 669
A linker snapshot was created at:
	/tmp/worldserver-2013-09-27-195633.ld-snapshot
ld: Assertion failed: (memberIndex != 0), function makeObjectFileForMember, file /SourceCache/ld64/ld64-224.1/src/ld/parsers/archive_file.cpp, line 355.
clang: error: linker command failed with exit code 1 (use -v to see invocation)

So you think using SDK 10.8 works? Hm, I'll try.

Edit: FUCK YOU APPLE! Thanks Jeremy, it works with SDK 10.8

Link to comment
Share on other sites

hi i tried to compile in 64 bit after the 32 bit

i got Microsoft Visual studio 2010 Ultimate Valid

 

and i get this issue all the time i tried to clean the project and downloaded the openssl 64bit is there any thing that i missed?

 

found the problem forgot to change the settings in cmake :)

libmysql.dirReleaseget_password.obj : fatal error LNK1112: module machine type 'x64' conflicts with target machine type 'X86'
Edited by Gunzmo
Link to comment
Share on other sites

  • 2 weeks later...

@CDawg

first, thank you for help  :)

 

i hope i've got the right thing here ...

 

i really don't know what i made wrong.

 

 

 

@Aokromes

yeah i have read that thread before, but i'm just a beginner and i didn't really understand what to do there.

 

"You have to remove ONLY_FULL_GROUP_BY flag from MySQL's sql_mode variable in the MySQL config file so that all queries can be prepared correctly. (Certain queries used in the core are not compliant to this restriction and need to be rewritten in order to work. Hint: pull request   :rolleyes:)"

 

that sounds to be the souloution but (i'm so sorry, my english is not the best) i don't understand where i can find the required files :/

 

may you can help me?

post-16036-0-59887500-1384110311_thumb.j

Link to comment
Share on other sites

One problem (which I thought was fixed a while back with a PR I made, but, may have been reverted or somehow broken in the many months since) is, if the search paths are not listed properly in the cmake files, cmake will report that it found 5.6 and actually use the headers for 5.0 instead, if you have both installed...

Link to comment
Share on other sites

oww. i remembered that,it was like this back in 3.3.5 ,we had to copy paste these files, but as far as i recall i didnt done this for  a long time,

but there is another problem , "libeay32.dll" i cannot find this in my mysql directory, there is one in sqlyog folder ,but my sqlyog is for 64bit,and when i copy that file to the core folder ,i get an error that i assume is because that core needs the 32bit version (im just guessing , cause when i pasted the ssleay32.dll from the 64 bit openssl folder i got the same error and the error fixed when i pasted the 32 bit version)

im trying to search trough forums for a guide , Btw thank you for your reply

Link to comment
Share on other sites

Hello everyone so I have small problem compiling Trinity source on linux ubuntu machine. 
I have installed openssl 0.9.8 by default on my machine and cant get rid of it because everytime i install cmake it installs also and openssl 0.9.8 so i made new user named it 'wow' and installed openssl 1.0.0 only for that user. Now this is command i used to compile core:

cmake ../ -DPREFIX=/home/wow/server -DWITH_WARNINGS=1 -DOPENSSL_LIBRARIES=/home/wow/openssl-1.0.0 -DOPENSSL_INCLUDE_DIR=/home/wow/openssl-1.0.0/include

Please let me know if all OPENSSL urls are correct for include folder and libraries?

This is error im getting at end of compiling:
http://screencast.com/t/S9oxa0Z6Mjg3
 
Those errors
 
Regards, uDev
Edited by uDev
Link to comment
Share on other sites

As I said already it has installed openssl 0.9.8 and i cant upgrade it to 1.0.0 if i remove 0.9.8 i get removed and cmake, if i install cmake it installs openssl 0.9.8 not 1.0.0 :)


can someone tell me proper way for using -DOPENSSL_LIBRARIES= -DOPENSSL_INCLUDE_DIR= commands?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.


  • Similar Content

    • By xgamerninjax
      Hello all, first time posting here and it's really got me scratching my head.
      I've compiled everything on my own computer, and then transferred everything to a host computer so the server can stay live. The server was running fine for a month or so and then suddenly it just crashes when it hits "Loading C++ scripts", exiting saying "caught signal 22"
      I tried setting up the host computer from scratch and transferred everything over fresh and it's still happening for some reason. (Note, I can run the server perfectly on my personal pc where I compiled it.)
      Any help would be greatly appreciated, thanks!
      3d7e3a40e2b3+_worldserver.exe_[1-4_15-19-45].dmp 3d7e3a40e2b3+_worldserver.exe_[1-4_15-19-45].txt
    • By Deer_Hunter
      Hello all,
      I just updated from the latest Git 
      Trinity Core REV. ac6baa547376 + 2020-02-21  3.3.5 Branch.
      I'm getting this error after crash.
      Problem signature:
        Problem Event Name:    APPCRASH
        Application Name:    worldserver.exe
        Application Version:    0.0.0.0
        Application Timestamp:    5e50a462
        Fault Module Name:    StackHash_f12f
        Fault Module Version:    6.3.9600.19629
        Fault Module Timestamp:    5e2fdc0d
        Exception Code:    c0000374
        Exception Offset:    PCH_9E_FROM_ntdll+0x0000000000090D0A
        OS Version:    6.3.9600.2.0.0.272.7
        Locale ID:    1033
        Additional Information 1:    f12f
        Additional Information 2:    f12f0934d3e965f73c68e60f20f2cd40
        Additional Information 3:    7595
        Additional Information 4:    7595e4d8d703db9dcd3d2f6ea540e357
      the exception code says its a Heap error,  I'm not sure how to troubleshoot this.
      Thanks
    • By 939h
      Hi,

      The chat channel Lookup for group is not available when a player isn't in a city. I tried to modify the worldserver.conf file with:
      #
      #    Channel.RestrictedLfg
      #        Description: Restrict LookupForGroup channel to characters registered in the LFG tool.
      #        Default:     1 - (Enabled, Allow join to channel only if registered in LFG)
      #                     0 - (Disabled, Allow join to channel in any time)
      Channel.RestrictedLfg = 0

      I restarted the server but it didn't help.

      Thanks
    • By meeek
      Hey, I've been trying to compile from github the core from 6.2.3/6.2.4, I'm well aware its stopped developing. I cannot get it to configure properly in CMake, nor can I obviously build it.
       
      I'd be willing to pay for help and get this working and running. I want to develop my own server on my freetime as a learning project and for entertainment. I can't find any core for WoD, sadly.. Very hard, would appreciate any quick help
       
    • By Probie_Wan_Kenobi
      I believe everything I have done up to this point has been correct. When I go to launch worldserver.exe a console window opens up for a second and closes right away and nothing else seems to have happened. I skipped a head a little in the instructions to see what is left and step 5 seems skippable since I am running this only for this computer and step 6 has me launch to a log in screen which I can not get to. I tried going to the faq but the page was not loading properly so I am forced to post here.
×
×
  • Create New...