Jump to content
TrinityCore

Recommended Posts

VIRTUAL, do you not know what that means? also, did you even read the error messages you posted at all?

 

 

Nice dick move, by the way, removing the posting of errors that I'm talking about. Fuck you, go help yourself.

Share this post


Link to post
Share on other sites

I need help with :
If you are using one linux with system wide openssl 0.9.8 instalation you need to update to openssl 1.0.0 or install openssl 1.0.0 into your home directory and set cmake to that path with:

-DOPENSSL_LIBRARIES
-DOPENSSL_SSL_LIBRARIES
-DOPENSSL_INCLUDE_DIR
-DOPENSSL_CRYPTO_LIBRARIES
-DOpenSSL_ROOT_DIR

Share this post


Link to post
Share on other sites

I need help with :

If you are using one linux with system wide openssl 0.9.8 instalation you need to update to openssl 1.0.0 or install openssl 1.0.0 into your home directory and set cmake to that path with:

-DOPENSSL_LIBRARIES

-DOPENSSL_SSL_LIBRARIES

-DOPENSSL_INCLUDE_DIR

-DOPENSSL_CRYPTO_LIBRARIES

-DOpenSSL_ROOT_DIR

 

Little confused are you stating what to do? or asking for help?

Bcuz that is the wrong way to do it.

Also, if you have a problem loading openssl on Ubuntu, google it. It's like 4 steps.

Share this post


Link to post
Share on other sites

Good day,

my problem has the very same symptoms as these two persons described "case 1" and "case 2" but I can assure you that I'm not using any repack, I downloaded your master_branch using GIT. We have empty consoles, I'm sure that config is correctly set (I did it many times in my life already), servers are not creating even logs.

 

I have checked your FAQ and did the compilation with help of your wiki. My server computer used to run TC releases regularly about 1,5 years ago when I was compiling new and new versions like every week. From that time I had all the needed programs so I realized I will have to update.

I updated all the programs with help of your wiki via method full uninstal of old versions, restart and clean instal of the new ones (because I know what old rogue libraries can be capable of).

 

With CMake we are getting message that we can find something in cmake error log but when I look into it, there is like 0 warnings 0 errors, everything just succes. We have tried to compile with visual 2008, 2010 and even 2013 in 32 and 64bits, release and debug, always with the same result.

 

We run on Win7 x64, mysql, apache and everything up-to-date because we are providing other server/hosting services that require these things always up-to-date. 

 

I expect it to be some stupid mistake that we missed something quite obvious, but after several days of trying, I'm trying it here that maybe you can tell me what can cause such symptoms.

 

Thanks in advance for any advice you can provide where to look or what have we missed.

Edited by Civic

Share this post


Link to post
Share on other sites

If you mean like configs for authserver and worldserver then I used the new ones that come with revision. The only thing I changed in them was connection into DB just to be sure that I'm not creating unnecessary mistakes via configs. Or do you mean any other configs ?

Share this post


Link to post
Share on other sites

no, if you missed to update the configs, the server will display some kind of message like "Unknown Log Type" or somethink like meaning this.

so that isnt the reason for this issue

Share this post


Link to post
Share on other sites

Ok, so i just got a new Computer and i try to Compile Trinity and then this happens

 

17>C:Program Files (x86)MSBuildMicrosoft.Cppv4.0Microsoft.CppCommon.targets(113,5): error MSB3073: The command "setlocal
17>C:Program Files (x86)MSBuildMicrosoft.Cppv4.0Microsoft.CppCommon.targets(113,5): error MSB3073: "C:Program Files (x86)CMake 2.8bincmake.exe" -DBUILD_TYPE=Debug -P cmake_install.cmake
17>C:Program Files (x86)MSBuildMicrosoft.Cppv4.0Microsoft.CppCommon.targets(113,5): error MSB3073: if %errorlevel% neq 0 goto :cmEnd
17>C:Program Files (x86)MSBuildMicrosoft.Cppv4.0Microsoft.CppCommon.targets(113,5): error MSB3073: :cmEnd
17>C:Program Files (x86)MSBuildMicrosoft.Cppv4.0Microsoft.CppCommon.targets(113,5): error MSB3073: endlocal & call :cmErrorLevel %errorlevel% & goto :cmDone
17>C:Program Files (x86)MSBuildMicrosoft.Cppv4.0Microsoft.CppCommon.targets(113,5): error MSB3073: :cmErrorLevel
17>C:Program Files (x86)MSBuildMicrosoft.Cppv4.0Microsoft.CppCommon.targets(113,5): error MSB3073: exit /b %1
17>C:Program Files (x86)MSBuildMicrosoft.Cppv4.0Microsoft.CppCommon.targets(113,5): error MSB3073: :cmDone
17>C:Program Files (x86)MSBuildMicrosoft.Cppv4.0Microsoft.CppCommon.targets(113,5): error MSB3073: if %errorlevel% neq 0 goto :VCEnd
17>C:Program Files (x86)MSBuildMicrosoft.Cppv4.0Microsoft.CppCommon.targets(113,5): error MSB3073: :VCEnd" exited with code 1.
 
Anyone Got a Clue What this means and how to fix it?

Share this post


Link to post
Share on other sites

Hello, I'm trying to compile. I've followed How_to_Win section carefully but stuck again and again at the same point, I've tried deleting everything clean using revo and redownload all components again but no prevail yet. Feeling very frustated. Please give me direction what to do, I got this error messages when configuring with Cmake :

 

The C compiler identification is MSVC 16.0.30319.1

The CXX compiler identification is MSVC 16.0.30319.1

Check for working C compiler using: Visual Studio 10

Check for working C compiler using: Visual Studio 10 -- broken

CMake Error at C:/Program Files/CMake 2.8/share/cmake-2.8/Modules/CMakeTestCCompiler.cmake:61 (message):
The C compiler "C:/Program Files/Microsoft Visual Studio
10.0/VC/bin/cl.exe" is not able to compile a simple test program.

It fails with the following output:

Change Dir: D:/BUILD/CMakeFiles/CMakeTmp



Run Build Command:C:WindowsMicrosoft.NETFrameworkv4.0.30319MSBuild.exe
cmTryCompileExec1940773719.vcxproj /p:Configuration=Debug
/p:VisualStudioVersion=10.0

Microsoft ® Build Engine version 4.0.30319.18408


[Microsoft .NET Framework, version 4.0.30319.18408]


Copyright © Microsoft Corporation. All rights reserved.

 


Build started 11/28/2013 11:47:18 AM.


Project "D:BUILDCMakeFilesCMakeTmpcmTryCompileExec1940773719.vcxproj"
on node 1 (default targets).


PrepareForBuild:


Creating directory "cmTryCompileExec1940773719.dirDebug".

Creating directory "D:BUILDCMakeFilesCMakeTmpDebug".


InitializeBuildStatus:


Creating "cmTryCompileExec1940773719.dirDebugcmTryCompileExec1940773719.unsuccessfulbuild" because "AlwaysCreate" was specified.


ClCompile:


C:Program FilesMicrosoft Visual Studio 10.0VCbinCL.exe /c /Zi /W3 /WX- /Od /Ob0 /Oy- /D WIN32 /D _WINDOWS /D _DEBUG /D "CMAKE_INTDIR="Debug"" /D _MBCS /Gm- /RTC1 /MDd /GS /fp:precise /Zc:wchar_t /Zc:forScope /Fo"cmTryCompileExec1940773719.dirDebug" /Fd"cmTryCompileExec1940773719.dirDebugvc100.pdb" /Gd /TC /analyze- /errorReport:queue testCCompiler.c

Microsoft ® 32-bit C/C++ Optimizing Compiler Version 16.00.30319.01 for 80x86

Copyright © Microsoft Corporation. All rights reserved.

 

cl /c /Zi /W3 /WX- /Od /Ob0 /Oy- /D WIN32 /D _WINDOWS /D _DEBUG /D "CMAKE_INTDIR="Debug"" /D _MBCS /Gm- /RTC1 /MDd /GS /fp:precise /Zc:wchar_t /Zc:forScope /Fo"cmTryCompileExec1940773719.dirDebug" /Fd"cmTryCompileExec1940773719.dirDebugvc100.pdb" /Gd /TC /analyze- /errorReport:queue testCCompiler.c

 

testCCompiler.c


ManifestResourceCompile:


C:Program FilesMicrosoft SDKsWindowsv7.0Abinrc.exe /nologo /fo"cmTryCompileExec1940773719.dirDebugcmTryCompileExec1940773719.exe.embed.manifest.res" cmTryCompileExec1940773719.dirDebugcmTryCompileExec1940773719_manifest.rc


Link:


C:Program FilesMicrosoft Visual Studio 10.0VCbinlink.exe /ERRORREPORT:QUEUE /OUT:"D:BUILDCMakeFilesCMakeTmpDebugcmTryCompileExec1940773719.exe" /INCREMENTAL /NOLOGO kernel32.lib user32.lib gdi32.lib winspool.lib shell32.lib ole32.lib oleaut32.lib uuid.lib comdlg32.lib advapi32.lib /MANIFEST /ManifestFile:"cmTryCompileExec1940773719.dirDebugcmTryCompileExec1940773719.exe.intermediate.manifest" /MANIFESTUAC:"level='asInvoker' uiAccess='false'" /DEBUG /PDB:"D:/BUILD/CMakeFiles/CMakeTmp/Debug/cmTryCompileExec1940773719.pdb" /SUBSYSTEM:CONSOLE /TLBID:1 /DYNAMICBASE /NXCOMPAT /IMPLIB:"D:/BUILD/CMakeFiles/CMakeTmp/Debug/cmTryCompileExec1940773719.lib" /MACHINE:X86 cmTryCompileExec1940773719.dirDebugcmTryCompileExec1940773719.exe.embed.manifest.res

cmTryCompileExec1940773719.dirDebugtestCCompiler.obj /machine:X86 /debug


LINK : fatal error LNK1123: failure during conversion to COFF: file invalid
or corrupt
[D:BUILDCMakeFilesCMakeTmpcmTryCompileExec1940773719.vcxproj]


Done Building Project
"D:BUILDCMakeFilesCMakeTmpcmTryCompileExec1940773719.vcxproj" (default
targets) -- FAILED.

 


Build FAILED.

 


"D:BUILDCMakeFilesCMakeTmpcmTryCompileExec1940773719.vcxproj" (default
target) (1) ->


(Link target) ->


LINK : fatal error LNK1123: failure during conversion to COFF: file invalid or corrupt [D:BUILDCMakeFilesCMakeTmpcmTryCompileExec1940773719.vcxproj]

 


0 Warning(s)

1 Error(s)

 


Time Elapsed 00:00:00.88






CMake will not be able to correctly generate this project.
Call Stack (most recent call first):
CMakeLists.txt:12 (project)

 

Configuring incomplete, errors occurred!

See also "D:/BUILD/CMakeFiles/CMakeOutput.log".

See also "D:/BUILD/CMakeFiles/CMakeError.log".

 


I found this thread, he had more or less same problem with mine.

Share this post


Link to post
Share on other sites

Thanks for the link Paradox, I really appreciate it. I'am very green, it took me some effort to understand and digest. Please bear with me.

Next time I will do better, for now I will accept my punishment

So from the link and the link inside the link there are two possible solution:

1. Uninstall .net 4.5 and replace it with .net 4.0

2. disable incremental linking (I totally can't understand it)

 

I will try solution one first and report it.

Share this post


Link to post
Share on other sites

Problem above solved, thank ye.

 

Now I encounter error in this step : Right-click ALL_BUILD in the Solution Explorer on the left sidebar and select Clean.

 

The result is an error message : ms. VC express has stopped working

Problem details:

Problem signature:
  Problem Event Name: CLR20r3
  Problem Signature 01: vcexpress.exe
  Problem Signature 02: 10.0.30319.1
  Problem Signature 03: 4ba1faa9
  Problem Signature 04: Microsoft.VisualStudio.Shell.10.0
  Problem Signature 05: 10.0.0.0
  Problem Signature 06: 4ba1e1f5
  Problem Signature 07: 50b
  Problem Signature 08: 4b
  Problem Signature 09: System.InvalidCastException
  OS Version: 6.1.7601.2.1.0.256.1
  Locale ID: 1033
 
Additional information about the problem:
  LCID: 1033

 

 

 
I've tried google, no solution yet, maybe I am not using correct keywords. Please lend me a hand again.
edit: I have a severe headache, sleepless last two nights trying to figure out how to set up the trinity, I must prevail.
Edited by dutamulia

Share this post


Link to post
Share on other sites

Hello,

 

i am trying to install the trinity core on an ubuntu 12.04 x86 server and i am getting the following error on each time i try to compile it.

 

[ 35%] Building CXX object src/server/authserver/CMakeFiles/authserver.dir/PrecompiledHeaders/authPCH.cpp.o
make[2]: *** No rule to make target `/usr/lib/libmysqlclient_r.so', needed by `src/server/authserver/authserver'.  Stop.
make[1]: *** [src/server/authserver/CMakeFiles/authserver.dir/all] Error 2
make: *** [all] Error 2
 
I have searched for a solution on google but the only one i fund was to "make clean" and to remake.
 
What i have done
Installed Packages:
build-essential autoconf libtool gcc g++ make cmake git-core patch wget links zip unzip unrar
openssl libssl-dev percona-mysql-server56 percona-mysql-client56 libmysqlclient-dev libmysql++-dev libreadline6-dev zlib1g-dev libbz2-dev libncurses5-dev
libace-dev
And the libSSL package was a part of openssl.
 
Everything else i have done like in the tutorial here.
My cmake is "cmake $HOME/TrinityCore -DPREFIX=/wowsvr/core  -DWITH_WARNINGS=1"
 
I have also checked if the file really exists in /usr/lib and it "does". There is a symbolik link with this name.
 
How can i solve this problem? What is important to me, that i use Percona MySQL 5.6, because i want to run the server on my public server and there is this MySQL kind of server running, so it's really really difficult to me to replace it, there are many other processes using it. A nice way would be, if i don't need to compile any other things except the core, but this is not really important.
Edited by Pyrdacor

Share this post


Link to post
Share on other sites


...because i want to run the server on my public server and...

 

Wrong thing to say bro...

TC community does not support public servers

Share this post


Link to post
Share on other sites

I've tried google, no solution yet, maybe I am not using correct keywords. Please lend me a hand again.

edit: I have a severe headache, sleepless last two nights trying to figure out how to set up the trinity, I must prevail.

 

Signature errors usually mean, re-installing. Your VC executables are crashing

http://social.msdn.microsoft.com/Forums/en-US/7301455d-e567-4468-aa0a-2dbaef532d9b/error-installing-vc-or-vc-express-editions

 

...and Paradox is right, this really isn't a TC problem.

Share this post


Link to post
Share on other sites

I have tried reinstalling VC express, but upon installing mySQL I met this problem (i googled it, he had the exact same problem with me)

I might have missed this error before and just continued on and I guess this is the root of my problem.

I don't really want to download 2GB of full Visual Studio from piratebay, it will take some while for me finish the download. Any idea?

I know this is not on trinity scope but who knows you happen to know the solution. 

Edited by dutamulia

Share this post


Link to post
Share on other sites

Sry i just sayed it wrong, it is my own and private server, this server ist just accessible from the internet by a hand full of people over vpn.

Edited by Pyrdacor

Share this post


Link to post
Share on other sites

Hey guys,

I was previously using a Trinity repack and now am in the process of compiling a Trinity Server for the first time... on a mac.

I have managed to get around most of the issues such as deprecated tempnam and so forth.

 

I am now however at an impass.

 

I'm following the How to for Mac on Mavericks, with the mavericks releases of ACE, CMake, Mysql, git and so on.

 

I have updated the mavericks Openssl to 1.0.1e through terminal and macports as this appears to be the issue.

However, when I try to compile it using the "xcode solution", the following errors occur:
 

CMake Error at cmake/macros/FindOpenSSL.cmake:200 (list):
  list GET given empty list
Call Stack (most recent call first):
  CMakeLists.txt:56 (find_package)

 


-- Found OpenSSL headers: /usr/include
CMake Error at cmake/macros/FindOpenSSL.cmake:188 (file):
  file STRINGS file "/usr/include/openssl/opensslv.h" cannot be read.
Call Stack (most recent call first):
  CMakeLists.txt:56 (find_package)

(Repeated several times on different lines, then:)

 


CMake Error at cmake/macros/EnsureVersion.cmake:76 (MATH):
  math cannot parse the expression: "..*10000 + ..*100 + 0": syntax error,
  unexpected exp_TIMES, expecting exp_OPENPARENT or exp_NUMBER (3)

 

CMake Error at cmake/macros/FindOpenSSL.cmake:223 (message):
  TrinityCore needs OpenSSL version 1.0.0 but found version ..

 

 

From what I can tell, the FindOpenSSL.cmake file is part of the issue. I have clean installed cmake twice now, both in macports and throught the .pkg options, with the same issue. Further to that, it doesn't appear to see any of the openssl files, which I just did a repair install of the OS on just incase.

When I version check openssl in terminal, it confirms the correct version is there, but when you do the lib scan, it will only show the 0.9.7 and 0.9.8 dylibs there, ignoring 1.0.

 

I realise this may be a rather noobish set of errors, but I figured that at least you guys can point me in the right direction.

Gotta love apples openssl /sigh.

 

If anyone can help or point me in the right direction, that would be great hahaha >.<

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Deer_Hunter
      Hello all,
      I just updated from the latest Git 
      Trinity Core REV. ac6baa547376 + 2020-02-21  3.3.5 Branch.
      I'm getting this error after crash.
      Problem signature:
        Problem Event Name:    APPCRASH
        Application Name:    worldserver.exe
        Application Version:    0.0.0.0
        Application Timestamp:    5e50a462
        Fault Module Name:    StackHash_f12f
        Fault Module Version:    6.3.9600.19629
        Fault Module Timestamp:    5e2fdc0d
        Exception Code:    c0000374
        Exception Offset:    PCH_9E_FROM_ntdll+0x0000000000090D0A
        OS Version:    6.3.9600.2.0.0.272.7
        Locale ID:    1033
        Additional Information 1:    f12f
        Additional Information 2:    f12f0934d3e965f73c68e60f20f2cd40
        Additional Information 3:    7595
        Additional Information 4:    7595e4d8d703db9dcd3d2f6ea540e357
      the exception code says its a Heap error,  I'm not sure how to troubleshoot this.
      Thanks
    • By 939h
      Hi,

      The chat channel Lookup for group is not available when a player isn't in a city. I tried to modify the worldserver.conf file with:
      #
      #    Channel.RestrictedLfg
      #        Description: Restrict LookupForGroup channel to characters registered in the LFG tool.
      #        Default:     1 - (Enabled, Allow join to channel only if registered in LFG)
      #                     0 - (Disabled, Allow join to channel in any time)
      Channel.RestrictedLfg = 0

      I restarted the server but it didn't help.

      Thanks
    • By meeek
      Hey, I've been trying to compile from github the core from 6.2.3/6.2.4, I'm well aware its stopped developing. I cannot get it to configure properly in CMake, nor can I obviously build it.
       
      I'd be willing to pay for help and get this working and running. I want to develop my own server on my freetime as a learning project and for entertainment. I can't find any core for WoD, sadly.. Very hard, would appreciate any quick help
       
    • By Probie_Wan_Kenobi
      I believe everything I have done up to this point has been correct. When I go to launch worldserver.exe a console window opens up for a second and closes right away and nothing else seems to have happened. I skipped a head a little in the instructions to see what is left and step 5 seems skippable since I am running this only for this computer and step 6 has me launch to a log in screen which I can not get to. I tried going to the faq but the page was not loading properly so I am forced to post here.
    • By Wark
      I'd just like to get a little insight to why so much of the current Trinitycore code doesn't match up to a few years ago.
      Now I know I'm not a pro at coding on Trinitycore and I understand that the core is open sourced but these just seem so significant and doesn't seem right to remove this stuff.
       
      Let me give an example. Lets say I'm watching this tutorial to get a little information about classes and methods that I can use when making a script. (I've also been using the Trinitycore Code Documentation as reference as well but it also seems to show the same issues)
      Although the tutorial is a little out of date, I don't see why OnGossipSelect doesn't exist anywhere in CreatureScript and that when I try to link the script to the core code it spits out this error.
      object of abstract class type "GossipTeleporter" is not allowed:
      pure virtual function "CreatureScript::GetAI" has no overrider
      The DEFINES of "ADD_GOSSIP_ITEM" and many more don't exist either.
       
      Am I missing something? All I want to know is if the core is mean't to be this way and if not should I download an older version of the core before I put to much working into my current core.
      (I downloaded my core right from the Trinitycore website tutorial)
       
      I'm currently trying to write a simple gossipteleporter that will let you talk to an npc and teleport to the given location. It's very hard to do this when so many things just don't exist within my core.
       
      EXTRA: I pasted this into a new custom script just to see if I would get errors and I got a lot of different errors: http://pastebin.com/raw/G62e0t49
      This was obtained from here: http://www.ac-web.org/forums/showthread.php?129885-Request-Teleporter-NPC-for-TrinityCore
      By no means am I looking to copy the code from the two links above, I was using them as a test to see if my core accepted them.
       
      Thanks,
      Wark
×
×
  • Create New...