Jump to content
TrinityCore

Recommended Posts

Even requierements have changed, TC still compiles with wiki, you only need to be sure of use gcc 6.0.3, also, the error message comes from gcc not from TC, the problem very likely comes from the kernel your VPS uses.

 

You mean ACE 6.0.3, since gcc isn't even to the 5.x series (yet).

Link to comment
Share on other sites

Ok, i tried to update to gcc 4.7.3, i done this:

1. I reinstalled my vps to Ubuntu 12.04 x64

2. Installed all needed apps with

sudo apt-get install build-essential autoconf libtool gcc g++ make cmake git-core patch wget links zip unzip unrar
sudo apt-get install openssl libssl-dev mysql-server mysql-client libmysqlclient15-dev libmysql++-dev libreadline6-dev zlib1g-dev libbz2-dev

and also updated libncurses5-dev

sudo apt-get install libncurses5-dev

...and libace-dev

sudo apt-get install libace-dev 

3. Downloaded test build of gcc4.7

sudo add-apt-repository ppa:ubuntu-toolchain-r/test
sudo apt-get update
sudo apt-get install gcc-4.7 g++-4.7

first the command "sudo add-apt-repository" didnt work, but i find somewhere, that this

sudo apt-get install python-software-properties

fixes it, so i downloaded it and it worked...

4. Then i updated alternatives of gcc ane set gcc4.7 as default compiler

sudo update-alternatives --install /usr/bin/gcc gcc /usr/bin/gcc-4.6 60 --slave /usr/bin/g++ g++ /usr/bin/g++-4.6 
sudo update-alternatives --install /usr/bin/gcc gcc /usr/bin/gcc-4.7 40 --slave /usr/bin/g++ g++ /usr/bin/g++-4.7 
sudo update-alternatives --config gcc

(in that little interface i selected gcc4.7)

5. Now, when i type "gcc -v" it returns this: "gcc version 4.7.3 (Ubuntu/Linaro 4.7.3-2ubuntu1~12.04)", so i think the update was successful.

But when i download ACE 6.0.3 (as it is in wiki), configure it and use command "make", mysterious errors show again... it is compiling +/- 25 minutes and then error shows up... I tried it also with "make -j 4" (i have 4 cores) or "make -j4" but again that same problem...

I would be very grateful if someone with linux knowledge updated the linux tutorial on wiki or posted it on forum...

P.S: Sorry for mistakes :D

Edited by LaBlazer
Link to comment
Share on other sites

What version of openssl?

 1.0.1f

Ensure that you installed a version of OpenSSL that isn't a light version and matches 32-bit or 64-bit (for your computer.) After that, retry.

no it's not the light version, I installed it earlier today.

The most strange part is that I have an older compile in a different folder that starts perfectly fine (however it's running without libeay32.dll)

 

 

EDIT: It appears as though I forgot about the ssleay32.dll, sorry for wasting your time.

Link to comment
Share on other sites

http://puu.sh/6hZ1E.png

CMakeFiles/worldserver.dir/CommandLine/CliRunnable.cpp.o: In function `CliRunnable::run()':
CliRunnable.cpp:(.text+0x185): undefined reference to `readline'
CliRunnable.cpp:(.text+0x18d): undefined reference to `rl_complete'
CliRunnable.cpp:(.text+0x19b): undefined reference to `rl_bind_key'
CliRunnable.cpp:(.text+0x35e): undefined reference to `add_history'
collect2: ld returned 1 exit status
make[2]: *** [src/server/worldserver/worldserver] Error 1
make[1]: *** [src/server/worldserver/CMakeFiles/worldserver.dir/all] Error 2
Edited by Axl Gois
Link to comment
Share on other sites

  • 2 weeks later...

Hello,

(excuse my bad English)

I did all steps with installation and when click on authserver.conf or worldserver.conf I get  0x000007b - I reinstalled core and used MySQL 5.6 - again this error, after this I used 5.5 and same this error.

I'm use:

Windows 8 Pro

machine with 6gb RAM  1TB HDD 1gb video card

installed VIsual studio 2012, get GetExtension, Heidisql ( showed in http://collab.kpsn.org/display/tc/How-to_Win Cmake 2.8.12

 OpenSSL v1.0.1f , and another thing when I installed MySQL I didn't see Launch the MySQL Instance Configuration Wizard, re-isntaled it around 5-6 times and again didn't see it.

Link to comment
Share on other sites

I compile and I get this strange error.

 

Help?

Error    1    error MSB6006: "cmd.exe" exited with code 1.    C:Program Files (x86)MSBuildMicrosoft.Cppv4.0V110Microsoft.CppCommon.targets    172    5    ZERO_CHECK
Error    5    error MSB6006: "cmd.exe" exited with code 1.    C:Program Files (x86)MSBuildMicrosoft.Cppv4.0V110Microsoft.CppCommon.targets    172    5    ALL_BUILD
Error    6    error MSB3073: The command "setlocal
"CMake 2.8bincmake.exe" -DBUILD_TYPE=Release -P cmake_install.cmake
if %errorlevel% neq 0 goto :cmEnd
:cmEnd
endlocal & call :cmErrorLevel %errorlevel% & goto :cmDone
:cmErrorLevel
exit /b %1
:cmDone
if %errorlevel% neq 0 goto :VCEnd
:VCEnd" exited with code 1.    C:Program Files (x86)MSBuildMicrosoft.Cppv4.0V110Microsoft.CppCommon.targets    134    5    INSTALL
Error    2    error LNK1107: invalid or corrupt file: cannot read at 0x2B0    D:filenameBuildOpenSSL-Win32ssleay32.dll    1    1    libmysql
Error    3    error LNK1107: invalid or corrupt file: cannot read at 0x2B0    D:filenameBuildOpenSSL-Win32ssleay32.dll    1    1    authserver
Error    4    error LNK1107: invalid or corrupt file: cannot read at 0x2B0    D:filenameBuildOpenSSL-Win32ssleay32.dll    1    1    worldserver
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.


  • Similar Content

    • By xgamerninjax
      Hello all, first time posting here and it's really got me scratching my head.
      I've compiled everything on my own computer, and then transferred everything to a host computer so the server can stay live. The server was running fine for a month or so and then suddenly it just crashes when it hits "Loading C++ scripts", exiting saying "caught signal 22"
      I tried setting up the host computer from scratch and transferred everything over fresh and it's still happening for some reason. (Note, I can run the server perfectly on my personal pc where I compiled it.)
      Any help would be greatly appreciated, thanks!
      3d7e3a40e2b3+_worldserver.exe_[1-4_15-19-45].dmp 3d7e3a40e2b3+_worldserver.exe_[1-4_15-19-45].txt
    • By Deer_Hunter
      Hello all,
      I just updated from the latest Git 
      Trinity Core REV. ac6baa547376 + 2020-02-21  3.3.5 Branch.
      I'm getting this error after crash.
      Problem signature:
        Problem Event Name:    APPCRASH
        Application Name:    worldserver.exe
        Application Version:    0.0.0.0
        Application Timestamp:    5e50a462
        Fault Module Name:    StackHash_f12f
        Fault Module Version:    6.3.9600.19629
        Fault Module Timestamp:    5e2fdc0d
        Exception Code:    c0000374
        Exception Offset:    PCH_9E_FROM_ntdll+0x0000000000090D0A
        OS Version:    6.3.9600.2.0.0.272.7
        Locale ID:    1033
        Additional Information 1:    f12f
        Additional Information 2:    f12f0934d3e965f73c68e60f20f2cd40
        Additional Information 3:    7595
        Additional Information 4:    7595e4d8d703db9dcd3d2f6ea540e357
      the exception code says its a Heap error,  I'm not sure how to troubleshoot this.
      Thanks
    • By 939h
      Hi,

      The chat channel Lookup for group is not available when a player isn't in a city. I tried to modify the worldserver.conf file with:
      #
      #    Channel.RestrictedLfg
      #        Description: Restrict LookupForGroup channel to characters registered in the LFG tool.
      #        Default:     1 - (Enabled, Allow join to channel only if registered in LFG)
      #                     0 - (Disabled, Allow join to channel in any time)
      Channel.RestrictedLfg = 0

      I restarted the server but it didn't help.

      Thanks
    • By meeek
      Hey, I've been trying to compile from github the core from 6.2.3/6.2.4, I'm well aware its stopped developing. I cannot get it to configure properly in CMake, nor can I obviously build it.
       
      I'd be willing to pay for help and get this working and running. I want to develop my own server on my freetime as a learning project and for entertainment. I can't find any core for WoD, sadly.. Very hard, would appreciate any quick help
       
    • By Probie_Wan_Kenobi
      I believe everything I have done up to this point has been correct. When I go to launch worldserver.exe a console window opens up for a second and closes right away and nothing else seems to have happened. I skipped a head a little in the instructions to see what is left and step 5 seems skippable since I am running this only for this computer and step 6 has me launch to a log in screen which I can not get to. I tried going to the faq but the page was not loading properly so I am forced to post here.
×
×
  • Create New...