Jump to content
TrinityCore

Recommended Posts

Hello again!

 

I setup everything following your wiki guide, and apparently everything works without problems.

 

I setup EVERYTHING on my laptop, and i'm trying to play on my desktop computer. The realmlist in the db (on my laptop) is set as 127.0.0.1, and in my realmlist.wtf (on my desktop computer) is set as the local ip of my laptop (192.168.x.xx).

 

I created an account as test/test, and gave it gm level 3.

 

When I try to connect it it says: Correct, and it lets me choose the kingdom (named by default trinity) and when I click accept it says "accessing a game server" and it returns to the kingdom choosing. Its like I can't enter the kingdom.

 

Should I do everything else with the realmlist? I didnt receive any error while the server setup (compile, db, etc), and I extracted maps, dbc, vmaps and mmaps. Followed all steps one by one.

 

Thanks!

 

Edit: Ok, in my laptop works properly... dont know why it doesnt work in my desktop pc ¬¬

Edited by bury
Link to comment
Share on other sites

Did you remember to change the field in the auth.realmlist table?

 

Hello, that table was in 127.0.0.1, thought that changing my realmlist to the local net of my laptop, it would run properly but nope, I couldnt enter the kingdom. 

 

 

What I did is put the public ip in the normal adress of tha table, and then the local ip of my laptop in the local adress and open the ports. Now it seems it works properly.

 

Your guide in the wiki is really well explained.

 

Thanks you!

Link to comment
Share on other sites

Hi,i just wasted whole day to try all solution that i found at google (and i still failed) so please can some one tell me how to fix Cmake generate problem with following information:
OS: Windows7 Ultimate SP1 x64
Cmake Version:3.0.2 (I just tried with 2.8.x before that and its the same)
Visual Studio Express 2013 with update 3 for Windows Desctop
Everything was fine until that lame .netflamework 4.5.1 update from windows that i reverted but the problem still exist and i have done too much changed to my OS to go to restore point.


Error that i get:
from CMake: http://pastebin.com/xTpGqBJv
Cmake Output: http://pastebin.com/kyvmeTQs
Cmake ErrorLog: http://pastebin.com/Wy2PZhZb

 

Steps i tried:
I tried Repair,Uninstalled and Installed again VS12,reinstalled .netflamework,reinstalledcmake,reinstalledgitextensions.
Nothing helped or made any change so far =[

Link to comment
Share on other sites

hello guys i am trying to run cmake but i recieve this error hopefully somone can help me 

 

i compiled with the latest rev version from trinitycore 

Determining if files pthread.h exist failed with the following output:
Change Dir: C:/TrinityCore/Build/CMakeFiles/CMakeTmp

Run Build Command:"C:/Program Files (x86)/MSBuild/12.0/bin/MSBuild.exe" "cmTryCompileExec2558042386.vcxproj" "/p:Configuration=Debug" "/p:VisualStudioVersion=12.0"
Microsoft (R) Build Engine version 12.0.21005.1

[Microsoft .NET Framework, version 4.0.30319.18444]

Copyright (C) Microsoft Corporation. All rights reserved.



Build started 9/9/2014 12:38:42 PM.

Project "C:TrinityCoreBuildCMakeFilesCMakeTmpcmTryCompileExec2558042386.vcxproj" on node 1 (default targets).

PrepareForBuild:

  Creating directory "cmTryCompileExec2558042386.dirDebug".

  Creating directory "C:TrinityCoreBuildCMakeFilesCMakeTmpDebug".

  Creating directory "cmTryCompileExec2558042386.dirDebugcmTryCom.82BE167A.tlog".

InitializeBuildStatus:

  Creating "cmTryCompileExec2558042386.dirDebugcmTryCom.82BE167A.tlogunsuccessfulbuild" because "AlwaysCreate" was specified.

ClCompile:

  C:Program Files (x86)Microsoft Visual Studio 12.0VCbinCL.exe /c /Zi /W3 /WX- /Od /Ob0 /Oy- /D WIN32 /D _WINDOWS /D _DEBUG /D "CMAKE_INTDIR="Debug"" /D _MBCS /Gm- /RTC1 /MDd /GS /fp:precise /Zc:wchar_t /Zc:forScope /Fo"cmTryCompileExec2558042386.dirDebug" /Fd"cmTryCompileExec2558042386.dirDebugvc120.pdb" /Gd /TC /wd4996 /wd4355 /wd4244 /wd4985 /wd4267 /wd4619 /wd4512 /analyze- /errorReport:queue CheckIncludeFiles.c

  Microsoft (R) C/C++ Optimizing Compiler Version 18.00.21005.1 for x86

  Copyright (C) Microsoft Corporation.  All rights reserved.

  

  cl /c /Zi /W3 /WX- /Od /Ob0 /Oy- /D WIN32 /D _WINDOWS /D _DEBUG /D "CMAKE_INTDIR="Debug"" /D _MBCS /Gm- /RTC1 /MDd /GS /fp:precise /Zc:wchar_t /Zc:forScope /Fo"cmTryCompileExec2558042386.dirDebug" /Fd"cmTryCompileExec2558042386.dirDebugvc120.pdb" /Gd /TC /wd4996 /wd4355 /wd4244 /wd4985 /wd4267 /wd4619 /wd4512 /analyze- /errorReport:queue CheckIncludeFiles.c

  

  CheckIncludeFiles.c

CheckIncludeFiles.c(2): fatal error C1083: Cannot open include file: 'pthread.h': No such file or directory [C:TrinityCoreBuildCMakeFilesCMakeTmpcmTryCompileExec2558042386.vcxproj]

Done Building Project "C:TrinityCoreBuildCMakeFilesCMakeTmpcmTryCompileExec2558042386.vcxproj" (default targets) -- FAILED.



Build FAILED.



"C:TrinityCoreBuildCMakeFilesCMakeTmpcmTryCompileExec2558042386.vcxproj" (default target) (1) ->

(ClCompile target) -> 

  CheckIncludeFiles.c(2): fatal error C1083: Cannot open include file: 'pthread.h': No such file or directory [C:TrinityCoreBuildCMakeFilesCMakeTmpcmTryCompileExec2558042386.vcxproj]



    0 Warning(s)

    1 Error(s)



Time Elapsed 00:00:00.88


Source:
/* */
#include <pthread.h>


int main(){return 0;}

Link to comment
Share on other sites

Google said it could be a path too long, exceeding a certain amount of characters. I do not think it's that.

Can you link the entire path, maybe remove the ' within path. Worth a try, seems like the only actual characer out of place

I just want to cut my veins right now >_< I cant believe that whole sunday is wasted i tried most of the solutions over google and finally it was just this...

Thank you!!! :3

Link to comment
Share on other sites

hi! im getting problems with the make command.

 

[  9%] Building CXX object src/server/shared/CMakeFiles/shared.dir/Configuration/Config.cpp.o

c++: internal compiler error: Segmentation fault (program cc1plus)
Please submit a full bug report,
with preprocessed source if appropriate.

make[2]: *** [src/server/shared/CMakeFiles/shared.dir/Configuration/Config.cpp.o] Error 4
make[1]: *** [src/server/shared/CMakeFiles/shared.dir/all] Error 2
make: *** [all] Error 2

 

Lastest revision.

Debian 7.6

OVH kernel with grsec.

Rev  38200f83606c

Edited by elraro
Link to comment
Share on other sites

Hi guys. I am compiling 4.3.4 brach from trinitycore on debian. I have installed everythings that are needed to perform a compiling. When I use command "make" everything is fine but when the compiling arrive at "Linking CXX static library libscripts.a" or "Linking CXX executable worldserver" it takes like 2-3 hours to finish this steps. Same thing when I use "make install" . 

 

It is not the first time when I compile. It used to compile fast and not stuck 2 hours on that Linking things .. but now I don't know why this problem" and when I use cmake I use just DWITH_COREDEBUG=1 and DWITH_WARNINGS=1

Link to comment
Share on other sites

You likely do not need DWITH_COREDEBUG=1 and DWITH_WARNINGS=1, those two will likely slow down the compilation.

 

Linking needs a lot of I/O, are you sure that nothing bad happened with your hard drive?

 

Are you compiling with PCH enabled? You should.

Link to comment
Share on other sites

Greetins everyone,

today, im trying to compile fresh 4.3.4 core, but i have found one big problem in Compiling.

Look at this

-- Detected 64-bit platform
-- UNIX: Using jemalloc
-- UNIX: Using default configuration directory
-- UNIX: Using default library directory
-- UNIX: Configuring uninstall target
-- UNIX: Created uninstall target
-- UNIX: Detected compiler: /usr/bin/cc
CMake Error at cmake/compiler/gcc/settings.cmake:7 (message):
  GCC: TrinityCore requires version 4.7.2 to build but found 4.4.5
Call Stack (most recent call first):
  cmake/platform/unix/settings.cmake:37 (include)
  cmake/macros/CheckPlatform.cmake:15 (include)
  CMakeLists.txt:51 (include)


-- Configuring incomplete, errors occurred!
[email protected]:/home/development/TrinityCore/build#

Core revision

c695c084b8

I have this gcc version

gcc version 4.4.5 (Debian 4.4.5-8)

Some next informations

[email protected]:/home/development/TrinityCore/build# uname -a
Linux DarkDream 2.6.32-wvg-hosting #1 SMP Fri May 24 10:05:54 CEST 2013 x86_64 GNU/Linux

 

 

I must have 4.7.2 version,but i cant update/upgrade it! Someone can please help me? I dont know how to fix this problem and a lot of links on Google doesnt help me. Thanks anybody for help or idea how to upgrade GCC. 

Have a good rest of the day :)

Link to comment
Share on other sites

This afternoon, CMake showed this Warning:

WARNING: Target "authserver" requests linking to directory "C:/mysql_lib/include".  Targets may link only to libraries.  CMake is dropping the item.
WARNING: Target "authserver" requests linking to directory "C:/mysql_lib/include".  Targets may link only to libraries.  CMake is dropping the item.
WARNING: Target "authserver" requests linking to directory "C:/mysql_lib/include".  Targets may link only to libraries.  CMake is dropping the item.
WARNING: Target "authserver" requests linking to directory "C:/mysql_lib/include".  Targets may link only to libraries.  CMake is dropping the item.
WARNING: Target "worldserver" requests linking to directory "C:/mysql_lib/include".  Targets may link only to libraries.  CMake is dropping the item.
WARNING: Target "worldserver" requests linking to directory "C:/mysql_lib/include".  Targets may link only to libraries.  CMake is dropping the item.
WARNING: Target "worldserver" requests linking to directory "C:/mysql_lib/include".  Targets may link only to libraries.  CMake is dropping the item.
WARNING: Target "worldserver" requests linking to directory "C:/mysql_lib/include".  Targets may link only to libraries.  CMake is dropping the item.

I follow step by step all. I asked my friends, etc. 

Later of this warnings, on Visual studio 12 x64 (latest version) show me 106 errors about this line: include <mysql.h>

 

What could I do?

 

Thanks for all  :)

Edited by Dnel
Link to comment
Share on other sites

+Dnel: these are my values: MYSQL_INCLUDE_DIR=C:Program FilesMySQLMySQL Server 5.5/include

and MYSQL_LIBRARY=C:Program FilesMySQLMySQL Server 5.5liblibmysqld.lib (64 bits)

 

Generating done

 

Fix with this values: 

  • MYSQL_INCLUDE_DIR = C:/mysql_lib/include
  • MYSQL_LIBRARY          = C:/mysql_lib/lib_64/mysqld.lib

 

Thanks you Nay  :wub:

Edited by Dnel
Link to comment
Share on other sites

Like you said, you need gcc 4.7, update your ancient linux to debian 7 or similar modern linux, because for sure you will lack other requirements.

Hello, I'm having same issue but i'm using latest libraries. Here's error :

cmake -DCMAKE_BUILD_TYPE=release -DCMAKE_INSTALL_PREFIX=../build && make && make install
-- The C compiler identification is GNU 4.7.2
-- The CXX compiler identification is GNU 4.7.2
-- Check for working C compiler: /usr/bin/gcc
-- Check for working C compiler: /usr/bin/gcc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Detected 64-bit platform
-- UNIX: Using jemalloc
-- UNIX: Using default configuration directory
-- UNIX: Using default library directory
CMake Error at cmake/platform/unix/settings.cmake:22 (configure_file):
  configure_file attempted to configure a file:
  /home/wow/server_core/cmake_uninstall.cmake into a source directory.
Call Stack (most recent call first):
  cmake/macros/CheckPlatform.cmake:15 (include)
  CMakeLists.txt:51 (include)


-- Configuring incomplete, errors occurred!

I did what instructions said for those who are doing this first time but as you see i failed :S 

Help?

Link to comment
Share on other sites

No you don't have do, and it's not same error, you are trying to compile into souces directory. You must create a directory, for example build, enter there and run cmake from there.

Still getting same/similar error :

[email protected]:~/build$  cmake ../server_core -DCMAKE_BUILD_TYPE=release -DCMAKE_INSTALL_PREFIX=../build && make && make install
-- Detected 64-bit platform
-- UNIX: Using jemalloc
-- UNIX: Using default configuration directory
-- UNIX: Using default library directory
CMake Error at cmake/platform/unix/settings.cmake:22 (configure_file):
  configure_file attempted to configure a file:
  /home/wow/server_core/cmake_uninstall.cmake into a source directory.
Call Stack (most recent call first):
  cmake/macros/CheckPlatform.cmake:15 (include)
  CMakeLists.txt:51 (include)


-- Configuring incomplete, errors occurred!

I'm using " cmake -DCMAKE_BUILD_TYPE=release -DCMAKE_INSTALL_PREFIX=../build && make && make install " line to compile, source files are located in server_core folder and as u said i made build folder.

Link to comment
Share on other sites

Hello

 

guys can some 1 plz try to help me with this problem i have 

i get  Use MySQL sourcetree : No   this is why i get lot of mysql error when compiling i think this need to be on Use MySQL sourcetree: Yes (default) something like this i have latest MySQL 5.6.21 installed do i need to download TDB or something?

 

under task manager MYSQL56 Runing

 

ty 

 

 

The C compiler identification is MSVC 18.0.30723.0

The CXX compiler identification is MSVC 18.0.30723.0

Check for working C compiler using: Visual Studio 12

Check for working C compiler using: Visual Studio 12 -- works

Detecting C compiler ABI info

Detecting C compiler ABI info - done

Check for working CXX compiler using: Visual Studio 12

Check for working CXX compiler using: Visual Studio 12 -- works

Detecting CXX compiler ABI info

Detecting CXX compiler ABI info - done

Detected 32-bit platform

MSVC: Enabled large address awareness

MSVC: Enabled SSE2 support

MSVC: Disabled Safe Exception Handlers for debug builds

MSVC: Overloaded standard names

MSVC: Disabled NON-SECURE warnings

MSVC: Disabled POSIX warnings

MSVC: Disabled generic compiletime warnings

Found OpenSSL library: optimized;C:/OpenSSL-Win32/lib/VC/ssleay32MD.lib;C:/OpenSSL-Win32/lib/VC/libeay32MD.lib;debug;C:/OpenSSL-Win32/lib/VC/ssleay32MDd.lib;C:/OpenSSL-Win32/lib/VC/libeay32MDd.lib

Found OpenSSL headers: C:/OpenSSL-Win32/include

Looking for include file pthread.h

Looking for include file pthread.h - not found

Found Threads: TRUE

Boost version: 1.55.0

Found the following Boost libraries:

system

thread

program_options

Found MySQL library: C:/Program Files (x86)/MySQL/MySQL Server 5.5/lib/libmysql.lib

Found MySQL headers: C:/Program Files (x86)/MySQL/MySQL Server 5.5/include

Found git binary : C:/Program Files (x86)/Git/cmd/git.exe

 

* TrinityCore revision : 4ed3254aa84a 2014-09-29 20:12:03 +0200 (master branch)

 

* Install core to : C:/Program Files (x86)/TrinityCore

 

* Build world/auth : Yes (default)

* Build with scripts : Yes (default)

* Build map/vmap tools : No (default)

* Build core w/PCH : Yes (default)

* Build scripts w/PCH : Yes (default)

* Show compile-warnings : No (default)

* Use coreside debug : No (default)

* Use MySQL sourcetree : No

* Use GIT revision hash : Yes

 

SCRIPT PREPARATIONS

-> Prepared: Spells

-> Prepared: Commands

-> Prepared: Custom

-> Prepared: World

-> Prepared: Outdoor PVP Zones

-> Prepared: Eastern Kingdoms

-> Prepared: Kalimdor

-> Prepared: Outland

-> Prepared: Northrend

-> Prepared: Events

-> Prepared: Pet

SCRIPT PREPARATION COMPLETE

 

Configuring done

Edited by narnak
Link to comment
Share on other sites

@narnak read:

I can't compile TC under Windows. i get:

Could not find the MySQL libraries! Please install the development

libraries and headers

MySQL sources have been removed from the repository.

Like OpenSSL, you need to set MYSQL_LIBRARY and MYSQL_INCLUDE_DIR to where you have mysql installed.

In my case, it's LIB=C:mysqlliblibmysqld.lib and INCLUDE_DIR=C:mysqlinclude

or http://collab.kpsn.org/display/tc/TrinityCore+Requirements#TrinityCoreRequirements-Windows

Link to comment
Share on other sites

This is the command I use:

cmake ../ -DPREFIX=/home/`echo $USER`/server -DTOOLS=1
This is the output:

-- Found Threads: TRUE
CMake Error at cmake/macros/FindBoost.cmake:1115 (message):
  Unable to find the requested Boost libraries.

  Unable to find the Boost header files.  Please set BOOST_ROOT to the root
 directory containing Boost or BOOST_INCLUDEDIR to the directory containing
  Boost's headers.
Call Stack (most recent call first):
  cmake/macros/ConfigureBoost.cmake:28 (find_package)
  CMakeLists.txt:60 (include)
I am using Ubuntu 14 x64 on VPS. I don't think this becuase of 64bit systems, I also tried on 32bit version as well. So, what should I do?
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.


  • Similar Content

    • By xgamerninjax
      Hello all, first time posting here and it's really got me scratching my head.
      I've compiled everything on my own computer, and then transferred everything to a host computer so the server can stay live. The server was running fine for a month or so and then suddenly it just crashes when it hits "Loading C++ scripts", exiting saying "caught signal 22"
      I tried setting up the host computer from scratch and transferred everything over fresh and it's still happening for some reason. (Note, I can run the server perfectly on my personal pc where I compiled it.)
      Any help would be greatly appreciated, thanks!
      3d7e3a40e2b3+_worldserver.exe_[1-4_15-19-45].dmp 3d7e3a40e2b3+_worldserver.exe_[1-4_15-19-45].txt
    • By Deer_Hunter
      Hello all,
      I just updated from the latest Git 
      Trinity Core REV. ac6baa547376 + 2020-02-21  3.3.5 Branch.
      I'm getting this error after crash.
      Problem signature:
        Problem Event Name:    APPCRASH
        Application Name:    worldserver.exe
        Application Version:    0.0.0.0
        Application Timestamp:    5e50a462
        Fault Module Name:    StackHash_f12f
        Fault Module Version:    6.3.9600.19629
        Fault Module Timestamp:    5e2fdc0d
        Exception Code:    c0000374
        Exception Offset:    PCH_9E_FROM_ntdll+0x0000000000090D0A
        OS Version:    6.3.9600.2.0.0.272.7
        Locale ID:    1033
        Additional Information 1:    f12f
        Additional Information 2:    f12f0934d3e965f73c68e60f20f2cd40
        Additional Information 3:    7595
        Additional Information 4:    7595e4d8d703db9dcd3d2f6ea540e357
      the exception code says its a Heap error,  I'm not sure how to troubleshoot this.
      Thanks
    • By 939h
      Hi,

      The chat channel Lookup for group is not available when a player isn't in a city. I tried to modify the worldserver.conf file with:
      #
      #    Channel.RestrictedLfg
      #        Description: Restrict LookupForGroup channel to characters registered in the LFG tool.
      #        Default:     1 - (Enabled, Allow join to channel only if registered in LFG)
      #                     0 - (Disabled, Allow join to channel in any time)
      Channel.RestrictedLfg = 0

      I restarted the server but it didn't help.

      Thanks
    • By meeek
      Hey, I've been trying to compile from github the core from 6.2.3/6.2.4, I'm well aware its stopped developing. I cannot get it to configure properly in CMake, nor can I obviously build it.
       
      I'd be willing to pay for help and get this working and running. I want to develop my own server on my freetime as a learning project and for entertainment. I can't find any core for WoD, sadly.. Very hard, would appreciate any quick help
       
    • By Probie_Wan_Kenobi
      I believe everything I have done up to this point has been correct. When I go to launch worldserver.exe a console window opens up for a second and closes right away and nothing else seems to have happened. I skipped a head a little in the instructions to see what is left and step 5 seems skippable since I am running this only for this computer and step 6 has me launch to a log in screen which I can not get to. I tried going to the faq but the page was not loading properly so I am forced to post here.
×
×
  • Create New...