Jump to content
TrinityCore

Recommended Posts

  • Replies 2.9k
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Let's stick to the facts here. OP is oblivious on how to proceed in order to get his server working because he either a) doesn't understand a word of English and could not understand the error message

Who ever this gregarious person is, I don't know what it is you think I have done to you, since you are too cowardly to confront me directly, but, stop negative repping me for no reason.

So if it found everything now then can you post the errors you are getting so I can see what issue it is causing.

Posted Images

I can't compile latest branch 3.3.5 on FreeBSD 10.2. Got an error

Quote

In file included from /home/leader/source/wotlk/dep/process/boost/process/posix/initializers.hpp:24:

/home/leader/source/wotlk/dep/process/boost/process/posix/initializers/inherit_env.hpp:30:17: error:

      use of undeclared identifier 'environ'

        e.env = environ;

                ^

1 error generated.

*** Error code 1

Boost version - 1.55 (installed from ports)

Could, please, someone, help me?

 

 

Edited by ZPS
Link to post
Share on other sites

Greetings.

I have the same problem after updating Linux. I recompiled the server but he always say:
____
.../src/server/database/Database/DatabaseWorkerPool.h:71 in DatabaseWorkerPool FATAL ERROR:
  Used MySQL library version (5.5.47) does not match the version used to compile TrinityCore (5.5.46).
Speicherzugriffsfehler
____

I have looking at the mysql status, and yeah he use 5.5.47. But wich way i have to downgrade it again or say trinity at compiling, that he also can use this version? Sorry i am not a Linuxbro..

And sorry for necromance this thread =) 

Greets

Link to post
Share on other sites

I use

  1. Debian 8.3 stable (Jessie) (stable) (64bits)
  2. Core™ i5-2300 4Cores 2,8GHZ and 16GB
  3. Gcc Verison 4.9.2-10
  4. SSE2 capable processor -> fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf eagerfpu pni pclmulqdq dtes64 monitor ds_cpl vmx smx est tm2 ssse3 cx16 xtpr pdcm pcid sse4_1 sse4_2 x2apic popcnt tsc_deadline_timer aes xsave avx lahf_lm ida arat epb xsaveopt pln pts dtherm tpr_shadow vnmi flexpriority ept vpid

Cmake Command and Log -> Pastebin

If you are need more Information, /w me

Edit: and now the compile error
 -> Pastebin

     
Edited by Inten
Link to post
Share on other sites

Now again Compile

Here the Log -> Pastebin

and here only the Error

 

c++: internal compiler error: Segmentation fault (program cc1plus)

Please submit a full bug report,

with preprocessed source if appropriate.

See <file:///usr/share/doc/gcc-4.9/README.Bugs> for instructions.

src/common/CMakeFiles/common.dir/build.make:54: recipe for target 'src/common/CMakeFiles/common.dir/Common.cpp.o' failed

make[2]: *** [src/common/CMakeFiles/common.dir/Common.cpp.o] Error 4

CMakeFiles/Makefile2:526: recipe for target 'src/common/CMakeFiles/common.dir/all' failed

make[1]: *** [src/common/CMakeFiles/common.dir/all] Error 2

make[1]: *** Waiting for unfinished jobs....

Link to post
Share on other sites

I can not do anything with it. Because I think the server has enough power . Ram = 16GB for swap ( when the RAM is full stores Linux on the hard drive ) würdem nearly enough 2TB .For this purpose, it is a dedicated server as a Quad Core i5 with 2.8 GHz . In my eyes, it all fits and if I'm honest is her answer not very helpful because they do not in my exzessiver Solution provides help and much too general . Please be a little more concrete UBD say clearly the most and so you effect that, and that .

Link to post
Share on other sites

OS : Windows 10 x64

Visual Studio 2013 with update 5

MySQL 5.7.10

Boost 1.59 ,openssl 1.0.2,cmake 3.4.3

Fresh Trinitycore.

full output : 

http://pastebin.com/yMafKwU1

error list :

Error    1    error C1001: An internal error has occurred in the compiler.    C:\TrinityCore\src\server\game\Server\WorldSocket.cpp    215    1    game
Error    2    error C1060: compiler is out of heap space    F:\build3\src\server\game\c1xx    game
Error    3    error D8040: error creating or communicating with child process    F:\build3\src\server\game\cl    game
Error    4    error LNK1181: cannot open input file '..\game\Release\game.lib'    F:\build3\src\server\worldserver\LINK    worldserver

 

Edited by benmich
Link to post
Share on other sites

@alfal: see if any of these conditions apply:

I can't compile Trinitycore under Linux i get  internal compiler error:

This can be because multiple reasons:

1) Selinux stronged kernels, workaround change to one standard kernel or compile with clang instead gcc or compile without pch.

2) Low ram/swap memory, increase ram/swap amount.

 

From https://community.trinitycore.org/topic/1518-trouble-with-your-trinity-install-readme-1st-faqs/?do=findComment&comment=47670
Link to post
Share on other sites

Immediately apologize, I'm Russian and I use Google translation.

 

When I compile the server it was on 97% and gives me the error:

/usr/bin/ld: cannot find -lg3dlib
collect2: error: ld returned 1 exit status
make[2]: *** [src/server/worldserver/worldserver] Error 1
make[1]: *** [src/server/worldserver/CMakeFiles/worldserver.dir/all] Error 2
make: *** [all] Error 2

 

Tell me where do I find her? Since I already searched the Google.

Link to post
Share on other sites


In file included from /home/wow/TrinityCore/src/server/game/Server/WorldSocketMgr.cpp:20:0:
/home/wow/TrinityCore/src/server/shared/Networking/NetworkThread.h: In lambda function:
/home/wow/TrinityCore/src/server/shared/Networking/NetworkThread.h:152:19: error: no match for ‘operator--’ in ‘--this->NetworkThread<SocketType>::_connections’
/home/wow/TrinityCore/src/server/shared/Networking/NetworkThread.h:152:19: note: candidates are:
In file included from /usr/include/c++/4.7/atomic:41:0,

               from PrecompiledHeaders/gamePCH.h:4:
/usr/include/c++/4.7/bits/atomic_base.h:360:7: note: std::__atomic_base<_IntTp>::__int_type std::__atomic_base<_IntTp>::operator--(int) [with _ITp = int; std::__atomic_base<_IntTp>::__int_type = int]
/usr/include/c++/4.7/bits/atomic_base.h:360:7: note:   candidate expects 1 argument, 0 provided
/usr/include/c++/4.7/bits/atomic_base.h:364:7: note: std::__atomic_base<_IntTp>::__int_type std::__atomic_base<_IntTp>::operator--(int) volatile [with _ITp = int; std::__atomic_base<_IntTp>::__int_type = int]
/usr/include/c++/4.7/bits/atomic_base.h:364:7: note:   candidate expects 1 argument, 0 provided
/usr/include/c++/4.7/bits/atomic_base.h:376:7: note: std::__atomic_base<_IntTp>::__int_type std::__atomic_base<_IntTp>::operator--() [with _ITp = int; std::__atomic_base<_IntTp>::__int_type = int] <near match>
/usr/include/c++/4.7/bits/atomic_base.h:376:7: note:   no known conversion for implicit ‘this’ parameter from ‘const std::atomic<int>*’ to ‘std::__atomic_base<int>*’
/usr/include/c++/4.7/bits/atomic_base.h:380:7: note: std::__atomic_base<_IntTp>::__int_type std::__atomic_base<_IntTp>::operator--() volatile [with _ITp = int; std::__atomic_base<_IntTp>::__int_type = int] <near match>
/usr/include/c++/4.7/bits/atomic_base.h:380:7: note:   no known conversion for implicit ‘this’ parameter from ‘const std::atomic<int>*’ to ‘volatile std::__atomic_base<int>*’
[ 42%] Building CXX object src/server/game/CMakeFiles/game.dir/Server/Protocol/Opcodes.cpp.o
[ 42%] Building CXX object src/server/scripts/CMakeFiles/scripts.dir/OutdoorPvP/OutdoorPvPZM.cpp.o
[ 42%] Building CXX object src/server/game/CMakeFiles/game.dir/Server/Protocol/PacketLog.cpp.o
make[2]: *** [src/server/game/CMakeFiles/game.dir/Server/WorldSocketMgr.cpp.o] Error 1
 

I have the Current Source loaded, it may be that this is currently broken?

Edited by Inten
Link to post
Share on other sites

/usr/local/include/boost/utility/result_of.hpp:189:8: error: no class template named ‘result’ in ‘const struct TaxiPathGraph::GetCompleteNodeRoute(const TaxiNodesEntry*, const TaxiNodesEntry*, const Player*, std::vector<unsigned int>&)::<lambda(const struct TaxiPathGraph::EdgeCost&)>’
compilation terminated due to -Wfatal-errors.
make[2]: *** [src/server/game/CMakeFiles/game.dir/Entities/Taxi/TaxiPathGraph.cpp.o] Error 1
make[1]: *** [src/server/game/CMakeFiles/game.dir/all] Error 2
make: *** [all] Error 2
 

Link to post
Share on other sites

Ubuntu 14, clean install, all setup exactly as per https://trinitycore.atlassian.net/wiki/display/tc/Linux+Requirements

Error building  3.3.5 branch:

[  2%]Built target jemalloc
[  7%] Built target g3dlib
[  7%] Built target Detour
[  8%] Built target Recast
[  8%] Built target format
[  9%] Built target gsoap
[  9%] Built target mpq
[  9%] Built target revision_data.h
[  9%] Built target commonPCH.cpp_dephelp
[ 10%] Built target generate_commonPCH.cpp
[ 13%] Built target common
[ 13%] Built target databasePCH.cpp_dephelp
[ 13%] Built target generate_databasePCH.cpp
[ 13%] Building CXX object src/server/database/CMakeFiles/database.dir/Database/Implementation/LoginDatabase.cpp.o
In file included from <command-line>:0:0:
/usr/include/stdc-predef.h:59:1: error: one or more PCH files were found, but they were invalid
 #endif
 ^
/usr/include/stdc-predef.h:59:1: error: use -Winvalid-pch for more information
/usr/include/stdc-predef.h:59:1: fatal error: /home/vagrant/TrinityCore/build/src/server/database/databasePCH.h: No such file or directory
compilation terminated.
make[2]: *** [src/server/database/CMakeFiles/database.dir/Database/Implementation/LoginDatabase.cpp.o] Error 1
make[1]: *** [src/server/database/CMakeFiles/database.dir/all] Error 2
make: *** [all] Error 2
 

Please help.

 

 

 

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.


  • Similar Content

    • By xgamerninjax
      Hello all, first time posting here and it's really got me scratching my head.
      I've compiled everything on my own computer, and then transferred everything to a host computer so the server can stay live. The server was running fine for a month or so and then suddenly it just crashes when it hits "Loading C++ scripts", exiting saying "caught signal 22"
      I tried setting up the host computer from scratch and transferred everything over fresh and it's still happening for some reason. (Note, I can run the server perfectly on my personal pc where I compiled it.)
      Any help would be greatly appreciated, thanks!
      3d7e3a40e2b3+_worldserver.exe_[1-4_15-19-45].dmp 3d7e3a40e2b3+_worldserver.exe_[1-4_15-19-45].txt
    • By Deer_Hunter
      Hello all,
      I just updated from the latest Git 
      Trinity Core REV. ac6baa547376 + 2020-02-21  3.3.5 Branch.
      I'm getting this error after crash.
      Problem signature:
        Problem Event Name:    APPCRASH
        Application Name:    worldserver.exe
        Application Version:    0.0.0.0
        Application Timestamp:    5e50a462
        Fault Module Name:    StackHash_f12f
        Fault Module Version:    6.3.9600.19629
        Fault Module Timestamp:    5e2fdc0d
        Exception Code:    c0000374
        Exception Offset:    PCH_9E_FROM_ntdll+0x0000000000090D0A
        OS Version:    6.3.9600.2.0.0.272.7
        Locale ID:    1033
        Additional Information 1:    f12f
        Additional Information 2:    f12f0934d3e965f73c68e60f20f2cd40
        Additional Information 3:    7595
        Additional Information 4:    7595e4d8d703db9dcd3d2f6ea540e357
      the exception code says its a Heap error,  I'm not sure how to troubleshoot this.
      Thanks
    • By 939h
      Hi,

      The chat channel Lookup for group is not available when a player isn't in a city. I tried to modify the worldserver.conf file with:
      #
      #    Channel.RestrictedLfg
      #        Description: Restrict LookupForGroup channel to characters registered in the LFG tool.
      #        Default:     1 - (Enabled, Allow join to channel only if registered in LFG)
      #                     0 - (Disabled, Allow join to channel in any time)
      Channel.RestrictedLfg = 0

      I restarted the server but it didn't help.

      Thanks
    • By meeek
      Hey, I've been trying to compile from github the core from 6.2.3/6.2.4, I'm well aware its stopped developing. I cannot get it to configure properly in CMake, nor can I obviously build it.
       
      I'd be willing to pay for help and get this working and running. I want to develop my own server on my freetime as a learning project and for entertainment. I can't find any core for WoD, sadly.. Very hard, would appreciate any quick help
       
    • By Probie_Wan_Kenobi
      I believe everything I have done up to this point has been correct. When I go to launch worldserver.exe a console window opens up for a second and closes right away and nothing else seems to have happened. I skipped a head a little in the instructions to see what is left and step 5 seems skippable since I am running this only for this computer and step 6 has me launch to a log in screen which I can not get to. I tried going to the faq but the page was not loading properly so I am forced to post here.
×
×
  • Create New...