Jump to content

3.3.5a Connection Issues From Outside Networks


Recommended Posts

My server is up and running and everything is gold. However, my friend that asked me to host the server in the first place (we want to just experience classic wow again) cannot seem to stay connected.

Half of the time, he gets stuck at the loading screen after selecting his character, but h ALWAYS gets past the character select with no issues. Once in a while he can connect, but things are buggy and laggy for him and he gets disconnected. 

I have tested the connection remotely from another computer (at work) and everything ran fine. I logged in under his account and there was absolutely nothing wrong).  So the problem lies somewhere within his network / computer obviously. (Also, I shared my client with him, so they are all the same).

I have tried the following:

-opened 3724 and 8085 in his firewall (though he owns wow legitimately so I'd imagine the correct ports should be open already)

-deleted the wtf and cache

-did a dns flush

Can anyone think of anything else to do that might solve this? I can play with no issues even running teamviewer, connecting to the computer at work, and logging in from there!

Server is running on Ubuntu 16.4 and is magical. 

Edited by iDuggitz
Link to comment
Share on other sites

17 hours ago, iDuggitz said:

Just had him try it. Same thing. Sometimes npcs aren't aknowledging him and he can't hand in quests sometimes. 

that sounds like lag to me, how's your friend bandwidth? is it saturated? how much Latency does the client shows?


best regards

Link to comment
Share on other sites

tell him to delete the Cache, Logs and WTF folder, even the Interface(maybe is an addon that is causing this), then if he's running Windows 8+ right click on Wow.exe and click on Troubleshoot Compatibility, let that run and then test the application, all the settings will be reset to default, even addons, but that's ok, you can always add them later.


best regards

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Voarsh
      I suppose this is two questions in one.
      I ".reset spells", etc and now when I login to WowTLK 3.3.5A I get "can't speak that language"
      I have a macro that selects a language and then I can talk normally.... or I can just choose a language. What language is my char/client trying to use?
      I cleared my account/cache in my client. Only new chars work.
      I then thought, I can't solve this, all I can do is "select" a language every login... I can't even use GM commands until i do.
      So, perhaps make a new char and "copy" the quests over.... I've no idea how I might do this.
      Any help?
    • By ChiefMcClane
      Hello folks
      I once updated my Trinity Server (3.3.5a) to the latest version (30.09.2020), unfortunately my Draenei Warlock is now broken.  I once created one in an older version by simply changing the breed in the database. After the update I couldn't select it at first, because the combination is invalid. This message came in the console. 
      I did some research and found out that the playercreateinfo_ tables have to be filled. I did that.
      I can log in now, but it seems that I have no language. The error message "you can not speak this language" appears in the chat. I cannot select a language either. I have already tried many things, including adding the skills, but the error remains. 
      I can't remember that it was so difficult in the past, has anything been changed?
    • By shroom
      Following one recent commit officially adding MariaDB 10.4 support, I took this opportunity to update my database server (from MariaDB 10.1 to MariaDB 10.4) and compiled the game server with the corresponding libraries instead of MySQL 5.7.
      Everything went fine and the server runs properly.
      I had one tiny little issue though: I had to fill the MySQLExecutable variable in the conf file otherwise the worldserver executable wouldn't launch:
      Didn't find any executable MySQL binary at '/Server/Release/bin/Release' or in path, correct the path in the *.conf ("MySQLExecutable").
      I never had to fill this variable before and it was still working fine with this commit: https://github.com/TrinityCore/TrinityCore/commit/48c700347c91b1748427a8c5b09b8d4099c9a105
      I'm running with this commit at the moment: https://github.com/TrinityCore/TrinityCore/commit/43d9ffd1bc127768882711a47d5e2bae92845d04
      It's not that big of deal obviously, but the worldserver conf file states for this variable:
      If the path is left empty, built-in path from cmake is used.
      Alas, while being properly set in CMake, the path isn't used anymore.
      Is this the new expected behavior or is this a bug?
    • By leandrod
      Hello guys,
      I was wondering that would be nice if i can active the flying mounts in Azeroth allowing the players to use it in Orgrimmar for example.
      So, here's my question: is there any way to do that in the server core side? I know that the game doesnt support flying mounts in Azeroth in the retail but i would like to do it (if its possible).
      I've serched in the forum for it and didn't find anything about it.
      Thanks for the help!
    • By Billy
      Placed several items in the AH today with the 24 hour setting to check with, restarted both world and auth servers, and the items placed in AH were no longer there, nor was there any mail for items sold or returned.
      TrinityCore rev. 59682bbd9b33 2019-02-09 21:06:09 +0100 (3.3.5 branch) (Unix, RelWithDebInfo, Static) (worldserver-daemon)
  • Create New...