Jump to content
TrinityCore
Fyury

Need help with worldserver

Recommended Posts

When I run "worldserver.exe" it just crashes and I get this:

TrinityCore rev. 084da48ba15a 2018-05-26 18:48:09 +0200 (master branch) (Win64, RelWithDebInfo, Static) (worldserver-daemon)
<Ctrl-C> to stop.

 ______                       __
/\__  _\       __          __/\ \__
\/_/\ \/ _ __ /\_\    ___ /\_\ \, _\  __  __
   \ \ \/\`'__\/\ \ /' _ `\/\ \ \ \/ /\ \/\ \
    \ \ \ \ \/ \ \ \/\ \/\ \ \ \ \ \_\ \ \_\ \
     \ \_\ \_\  \ \_\ \_\ \_\ \_\ \__\\/`____ \
      \/_/\/_/   \/_/\/_/\/_/\/_/\/__/ `/___/> \
                                 C O R E  /\___/
http://TrinityCore.org                    \/__/

Using configuration file C:/WoW-Server/bin/RelWithDebInfo/worldserver.conf.
Using SSL version: OpenSSL 1.0.1e 11 Feb 2013 (library: OpenSSL 1.0.1e 11 Feb 2013)
Using Boost version: 1.65.1
Updating Auth database...
>> Auth database is up-to-date! Containing 6 new and 115 archived updates.
Updating Character database...
>> Character database is up-to-date! Containing 3 new and 77 archived updates.
Updating World database...
>> World database is up-to-date! Containing 193 new and 2262 archived updates.
Updating Hotfixes database...
>> Hotfixes database is up-to-date! Containing 18 new and 130 archived updates.
Realm running as realm ID 1
Using World DB: TDB 735.00
Using enUS DBC Locale
Will clear `logs` table of entries older than 1209600 seconds every 10 minutes.
Using DataDir ./
WORLD: MMap data directory is: ./mmaps
VMap support included. LineOfSight: 1, getHeight: 1, indoorCheck: 1
VMap data directory is: ./vmaps
Missing name Guild.SaveInterval in config file C:/WoW-Server/bin/RelWithDebInfo/worldserver.conf, add "Guild.SaveInterval = 15" to this file
Initialize PlayerDump...
>> Initialized 370 PlayerDump ColumnDefinitions in 551 ms.
Loading Trinity strings...
>> Loaded 965 trinity strings in 32 ms
Initialize data stores...

Some required *.db2 files (2 from 230) not found or not compatible:
ItemSearchName.db2
WorldSafeLocs.db2
 

 

ItemSearName.db2 & WorldSafeLocs.db2 dont exist but how can I get them

When I start "mapextractor.exe" this happens:

 

Unable to open file DBFilesClient\ItemSearchName.db2 in the archive for locale enUS: FILE_NOT_FOUND

Unable to open file DBFilesClient\Unittest.db2 in the archive for locale enUS: FILE_NOT_FOUND

Unable to open file DBFilesClient\WorldSafeLocs.db2 in the archive for locale enUS: FILE_NOT_FOUND

 

Share this post


Link to post
Share on other sites
13 minutes ago, Fyury said:

When I run "worldserver.exe" it just crashes and I get this:

TrinityCore rev. 084da48ba15a 2018-05-26 18:48:09 +0200 (master branch) (Win64, RelWithDebInfo, Static) (worldserver-daemon)
Initialize data stores...

Some required *.db2 files (2 from 230) not found or not compatible:
ItemSearchName.db2
WorldSafeLocs.db2
 

 

ItemSearName.db2 & WorldSafeLocs.db2 dont exist but how can I get them

When I start "mapextractor.exe" this happens:

 

Unable to open file DBFilesClient\ItemSearchName.db2 in the archive for locale enUS: FILE_NOT_FOUND

Unable to open file DBFilesClient\Unittest.db2 in the archive for locale enUS: FILE_NOT_FOUND

Unable to open file DBFilesClient\WorldSafeLocs.db2 in the archive for locale enUS: FILE_NOT_FOUND

 

change wow client language to en us and run extractor again.

Share this post


Link to post
Share on other sites
On 1.6.2018 at 1:23 PM, Aokromes said:

change wow client language to en us and run extractor again.

Thanks that fixed it.

 

Now I have another problem. My Realm "Trintiy" (default realm) is incompatible ?! help pls

Share this post


Link to post
Share on other sites
31 minutes ago, Fyury said:

Thanks that fixed it.

 

Now I have another problem. My Realm "Trintiy" (default realm) is incompatible ?! help pls

you need to update client.

Share this post


Link to post
Share on other sites
2 hours ago, Aokromes said:

you need to update client.

I deletet the WoW_Patched.exe and repatched it and now its working. (I think I patched the worng wow.exe before)

Now the Realm is not anymore incompatible, but I cant join it. I am stuck in a "Logging in to game server " loop. Help again pls

P.S: Thanks for all the help!

 

EDIT: worldserver.exe is giving this error, when I try to connect.

WorldSocket::HandleAuthSession: Authentication failed for account: 2 ('1#1') address: 127.0.0.1

Edited by Fyury

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Probie_Wan_Kenobi
      I believe everything I have done up to this point has been correct. When I go to launch worldserver.exe a console window opens up for a second and closes right away and nothing else seems to have happened. I skipped a head a little in the instructions to see what is left and step 5 seems skippable since I am running this only for this computer and step 6 has me launch to a log in screen which I can not get to. I tried going to the faq but the page was not loading properly so I am forced to post here.
    • By spudmasher
      I have looked through forums, and can't find a straight answer. Have followed the guide, but not working.
      ISSUE: Starter areas for the Pandaren, Worgen, and Goblins are either broken, or non-exsistent. I have followed the guide to git current commits, but it continues to say 'up-to-date'. The only topics I have seen on any of these are old, or links that go to dead pages. My question, and I do apologize if it is here somewhere (and i missed it), is how do I make these starter areas act 'normal', with working quests?
      If I did miss it, a simple link is fine. Else an in-depth step-by-step to get these working would be appreciative. If it is not possible at this time, that as an answer would suffice.
    • By Смердокрыл
      Hi!
      How come a whole bunch of spells, for example rogue's Pistol Shot and Saber Slash, while obviously producing some sort of visual effect, are nowhere to be found in SpellXSpellVisual.db2? Is there another table responsible for them?
    • By Xzter
      Hello, before i was using trinity fine, everything working perfect. But now, im always getting the worldserver.exe crash.
      Here is log, if someone  can help me to fix it, please. Thanks

      Screenshoot where error always appear

      And, Error Log 
      b19413aaf21d_worldserver.exe_[22-4_11-51-42].txt
    • By cloudfox
      hi there
      i've met a strange problem on linux running TC worldserver.
      everything is ok when i direct type ./worldserver and don't close ssh window. the worldserver session only take 1% less cpu use.
      but when i try to use nohup or setsid to put worldserver backgroud.
      this world server instantly taking 100% cpu percent .no matter how long i wait,%cpu will not come down.
      i even try to use systemctl's service to made server run background,and i found server and systemctl still got 100% cpu use.
      i'm asking for help about how to run server background on ubuntu16.04,and not with 100%cpu use.
       
      thanks!!
×