Jump to content
TrinityCore

Connection Patcher 6.2.4a (build 21742)


Frik24
 Share

Recommended Posts

Hello TrinityCore members,

I wanted to mess around with 6.2.4a build 21742,
I've downloaded/compiled the trinitycore TrinityCore-6.2.4-21742 from github

I've got connection_patcher.exe among other files in my release build

I've got client with same patch TrinityCore-6.2.4-21742

I patched the client(all successful) with patcher i've got from compiling source.

When i run WoW_Patched.exe i get error message https://imgur.com/a/ZZQI3J9

 

can anyone help me i'd appreciate it a lot!

Edited by Frik24
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By belziere
      Hi guys, i compiled my server under linux and i saw the thing about needing a connection patcher for my client (that needs to be compiled under windows) so i compiled my project on windows too but i can't find the connection patcher, it is nowhere to be seen !
    • By darki73
      So i guess it is pretty obvious about what am i going to ask =)
      Problem is, previousle we could just sha1 username and password separated by colon and here is the sha_pass_hash.
      The problem i am facing right now, is that according to https://github.com/TrinityCore/TrinityCore/blob/86b98686a95e23247ecb774fb23ecd5b8d94b97b/src/server/game/Accounts/BattlenetAccountMgr.cpp#L177 Trinity now uses SHA256, so the hashes do not match anymore. The thing is, password length in database is 40 symbols (exactly as many as in sha1 hash), but sha256 hash length is 64 characters long. I am confused...
      I've tried to recreate whole "Cryptography" thing on PHP but, guess what, failed.
      Can somebody explain me how the password is generated nowadays?
      Thank you for your attention. 
    • By HolyNitzan
      Hey Guys,
      I'm  using the last build of TrinityCore for WoD, currently using latest TDB release, I noticed that there are no spawns in Draenor, I would like to konw how could I solve it? is the TDB not populated with Draenor mobs/npc spawns?
    • By raidriar
      So I have gotten everything working for my trinitycore server until now. My problem is that when I open wow_Patched it won't start. I have tried opening wow-64_Patched but the realm is incompatible. When I try to start wow_ Patched it gives me the error
      The CAS system was unable to initialize: ClientHandler: initialization error: failed fetching the CDN configuration file
      tact::ClientHandler::Create failed: E_NOT_AVAILABLE
      [20160922T17:33:09] {199c}INF:Got bade content response : id=5, path= /tpr/wow/config/e0/27/e02762b486f1611bded7ad275c6e7457 length = 175  [20160922T17:33:09] {199c} WRN: [HzCj:5] Req hndl error (COMP
      So then I looked up the issue and couldn't find anything so then I tried patching it again but instead of working it says this
      Creating patched binary...
      Determined build number: 22624
      Win32 client...
      patching Portal
      Found offset 10990640
      patching redirect RSA Modulus
      Found offset 10505944
      patching BNet certificate file location
      Found offset 10955784 
      patching BNet certificate file to load from local path instead of CASC
      EX: unable to find pattern
      An error occurred. Press ENTER to continue
       
      Anyone know how to fix this? 
       
    • By Shinzon
      I have searched all over the forums and can't find anything that exactly matches this. 
      I can connect fine to the server using my windows client, but when I try to connect using my mac client it immediately bounces back stating "You have been disconnected from the server". 
      I have the correct IP address in the config.wtf (And realmlist in the DB) but still can't connect. 
      I of course can't apply the connection patcher, because the EXE isn't mac compatible. 
      Is there something else I need to do to connect with mac?
      Here is my connection.log if it helps (NOTE that the ".logon.battle.net" I can't get rid of... there is no where config.wtf that has that).
       
      3/14 13:10:21.966  Login program=WoW platform=Mc64 locale=enUS 3/14 13:10:22.097  Component WoW.Mc64.20886 3/14 13:10:22.097  Component WoW.base.20726 3/14 13:10:22.099  Battle.net is Component Bnet.Mc64.37165 3/14 13:10:22.099  LOGIN: state: LOGIN_STATE_CONNECTING result: LOGIN_OK  3/14 13:10:22.145  Failed to resolve “108.26.241.19”.logon.battle.net 3/14 13:10:22.145  LOGIN: state: LOGIN_STATE_FAILED result: DISCONNECTED  3/14 13:10:22.145  Login program=WoW platform=Mc64 locale=enUS 3/14 13:10:22.145  Component WoW.Mc64.20886 3/14 13:10:22.145  Component WoW.base.20726 3/14 13:10:22.154  Battle.net is Component Bnet.Mc64.37165 3/14 13:10:23.298  Client Disconnect due to reason:8 3/14 13:12:54.053  LOGIN: state: LOGIN_STATE_CONNECTING result: LOGIN_OK  3/14 13:12:54.073  Failed to resolve “192.168.1.130”.logon.battle.net 3/14 13:12:54.151  LOGIN: state: LOGIN_STATE_FAILED result: DISCONNECTED  3/14 13:12:54.151  Login program=WoW platform=Mc64 locale=enUS 3/14 13:12:54.173  Component WoW.Mc64.20886 3/14 13:12:54.173  Component WoW.base.20726 3/14 13:12:54.308  Battle.net is Component Bnet.Mc64.37165 3/14 13:12:54.309  Client Disconnect due to reason:8  
       
       
×
×
  • Create New...