Jump to content
TrinityCore
Billy

Glyphs in Auction House

Recommended Posts

I've searched through the Wiki concerning this and the only thing I found was a post that states it is outdated. Is there another guide for setting up the built-in ahbot to offer glyphs?

TrinityCore rev. 50146b22296a 2016-06-23 22:25:55 +0200 (3.3.5 branch) (Win64, Release, Static) (worldserver-daemon)

Share this post


Link to post
Share on other sites

There are multiple configs named AuctionHouseBot.Class.Glyph.* in worldserver.conf. Have you looked at those?

Share this post


Link to post
Share on other sites

Yes, below are the settings that I have been adjusting to see if the glyphs will show in AH, but no luck yet. That's why I was wondering if there might be a new write up on how to get it running.

# AUCTION HOUSE BOT SETTINGS
AuctionHouseBot.Class.Glyph = 10

# AUCTION HOUSE BOT ITEM FINE TUNING
#    AuctionHouseBot.Class.Glyph.ReqLevel.*
#       Description: Prevent seller from listing glyphs below/above this required level
#       Default:     0

AuctionHouseBot.Class.Glyph.ReqLevel.Min = 0
AuctionHouseBot.Class.Glyph.ReqLevel.Max = 0

#
#    AuctionHouseBot.Class.Glyph.ItemLevel.*
#       Description: Prevent seller from listing glyphs below/above this item level
#       Default:     0

AuctionHouseBot.Class.Glyph.ItemLevel.Min = 0
AuctionHouseBot.Class.Glyph.ItemLevel.Max = 0

#    AuctionHouseBot.Class.RandomStackRatio.
AuctionHouseBot.Class.RandomStackRatio.Glyph = 50

 

Share this post


Link to post
Share on other sites
On 6/30/2016 at 1:14 PM, Nay said:

There are multiple configs named AuctionHouseBot.Class.Glyph.* in worldserver.conf. Have you looked at those?

Figured it out, but the description within the worldserver.conf file for this section is a bit misleading " Prevent seller from listing ". In this case it should mention that you need to set the Max to the max level of the server.

I changed up the:

#
#    AuctionHouseBot.Class.Glyph.ReqLevel.*
#       Description: Prevent seller from listing glyphs below/above this required level
#       Default:     0

AuctionHouseBot.Class.Glyph.ReqLevel.Min = 0
AuctionHouseBot.Class.Glyph.ReqLevel.Max = 80

#
#    AuctionHouseBot.Class.Glyph.ItemLevel.*
#       Description: Prevent seller from listing glyphs below/above this item level
#       Default:     0

AuctionHouseBot.Class.Glyph.ItemLevel.Min = 0
AuctionHouseBot.Class.Glyph.ItemLevel.Max = 80

  • Upvote 1

Share this post


Link to post
Share on other sites
On 7/12/2016 at 1:09 PM, Billy said:

Figured it out, but the description within the worldserver.conf file for this section is a bit misleading " Prevent seller from listing ". In this case it should mention that you need to set the Max to the max level of the server.

I changed up the:

#
#    AuctionHouseBot.Class.Glyph.ReqLevel.*
#       Description: Prevent seller from listing glyphs below/above this required level
#       Default:     0

AuctionHouseBot.Class.Glyph.ReqLevel.Min = 0
AuctionHouseBot.Class.Glyph.ReqLevel.Max = 80

#
#    AuctionHouseBot.Class.Glyph.ItemLevel.*
#       Description: Prevent seller from listing glyphs below/above this item level
#       Default:     0

AuctionHouseBot.Class.Glyph.ItemLevel.Min = 0
AuctionHouseBot.Class.Glyph.ItemLevel.Max = 80

I have recently come back and started doing all this again.

I noticed on the glyph part of AH you also need to set this line in the worldserver.conf for glyphs.

#    AuctionHouseBot.Items.Misc
#       Description: Include misc. items.
#       Default:     0 - (Disabled)
#                    1 - (Enabled)

AuctionHouseBot.Items.Misc = 1

I had set all my other settings like I wrote before, but AH was still not showing glyphs. After setting the line above, glyphs started coming in once again. So I'm guessing glyphs are listed as Misc items now.

  • Like 1

Share this post


Link to post
Share on other sites

Enabling the Misc items in the cfg will post many undesired items onto the auctionhouse.

The best way (so far) to get glyphs to show up seems to be the following - all credit goes to Mightylink @ cmangos.

(Haven't verified all id's one by one, but assuming they are correct for wotlk)

 

 

All you need to do is add all the glyphs to the force include line, this
will ignore any settings and make them start appearing at random times.

Here are all the glyphs sorted by class:

Code:
|Death Knight:
43533,43534,43535,43536,43537,43538,43539,43541,43542,43543,43544,43545,43546,43547,43548,43549,43550,43551,43552,43553,43554,43671,43672,43673,43825,43826,43827,45799,45800,45803,45804,45805,45806

Warrior:    
43395,43396,43397,43398,43399,43400,43412,43413,43414,43415,43416,43417,43418,43419,43420,43421,43422,43423,43424,43425,43426,43427,43428,43429,43430,43431,43432,45790,45792,45793,45794,45795,45797,49084

Paladin:    
41092,41094,41095,41096,41097,41098,41099,41100,41101,41102,41103,41104,41105,41106,41107,41108,41109,41110,43340,43365,43366,43367,43368,43369,43867,43868,43869,45741,45742,45743,45744,45745,45746,45747

Shaman:      
41517,41518,41524,41526,41527,41529,41530,41531,41532,41533,41534,41535,41536,41537,41538,41539,41540,41541,41542,41547,41552,43344,43381,43385,43386,43388,43725,44923,45770,45771,45772,45775,45776,45777,45778

Hunter:      
42897,42898,42899,42900,42901,42902,42903,42904,42905,42906,42907,42908,42909,42910,42911,42912,42913,42914,42915,42916,42917,43338,43350,43351,43354,43355,43356,45625,45731,45732,45733,45734,45735

Rogue:      
42954,42955,42956,42957,42958,42959,42960,42961,42962,42963,42964,42965,42966,42967,42968,42969,42970,42971,42972,42973,42974,43343,43376,43377,43378,43379,43380,45761,45762,45764,45766,45767,45768,45769

Druid:      
40896,40897,40899,40900,40901,40902,40903,40906,40908,40909,40912,40913,40914,40915,40916,40919,40920,40921,40922,40923,40924,43316,43331,43332,43334,43335,43674,44928,44922,45601,45602,45603,45604,45622,45623,46372,48720,50125

Mage:        
42734,42735,42736,42737,42738,42739,42740,42741,42742,42743,42744,42745,42746,42747,42748,42749,42750,42751,42752,42753,42754,43339,43357,43359,43360,43361,43364,44684,44955,44920,45736,45737,45738,45740,50045

Warlock:    
42453,42454,42455,42456,42457,42458,42459,42460,42461,42462,42463,42464,42465,42466,42467,42468,42469,42470,42471,42472,42473,43389,43390,43391,43392,43393,43394,45779,45780,45781,45782,45783,45785,45789,50077

Priest:      
42396,42397,42398,42399,42400,42401,42402,42403,42404,42405,42406,42407,42408,42409,42410,42411,42412,42414,42415,42416,42417,43341,43370,43371,43372,43373,43374,45753,45755,45756,45757,45758,45760

|

And here are all the glyphs together you can just copy and paste into
the config:

Code:
|43533,43534,43535,43536,43537,43538,43539,43541,43542,43543,43544,43545,43546,43547,43548,43549,43550,43551,43552,43553,43554,43671,43672,43673,43825,43826,43827,45799,45800,45803,45804,45805,45806,43395,43396,43397,43398,43399,43400,43412,43413,43414,43415,43416,43417,43418,43419,43420,43421,43422,43423,43424,43425,43426,43427,43428,43429,43430,43431,43432,45790,45792,45793,45794,45795,45797,49084,41092,41094,41095,41096,41097,41098,41099,41100,41101,41102,41103,41104,41105,41106,41107,41108,41109,41110,43340,43365,43366,43367,43368,43369,43867,43868,43869,45741,45742,45743,45744,45745,45746,45747,41517,41518,41524,41526,41527,41529,41530,41531,41532,41533,41534,41535,41536,41537,41538,41539,41540,41541,41542,41547,41552,43344,43381,43385,43386,43388,43725,44923,45770,45771,45772,45775,45776,45777,45778,42897,42898,42899,42900,42901,42902,42903,42904,42905,42906,42907,42908,42909,42910,42911,42912,42913,42914,42915,42916,42917,43338,43350,43351,43354,43355,43356,45625,45731,45732,45733,45734,45735,42954,42955,42956,42957,42958,42959,42960,42961,42962,42963,42964,42965,42966,42967,42968,42969,42970,42971,42972,42973,42974,43343,43376,43377,43378,43379,43380,45761,45762,45764,45766,45767,45768,45769,40896,40897,40899,40900,40901,40902,40903,40906,40908,40909,40912,40913,40914,40915,40916,40919,40920,40921,40922,40923,40924,43316,43331,43332,43334,43335,43674,44928,44922,45601,45602,45603,45604,45622,45623,46372,48720,50125,42734,42735,42736,42737,42738,42739,42740,42741,42742,42743,42744,42745,42746,42747,42748,42749,42750,42751,42752,42753,42754,43339,43357,43359,43360,43361,43364,44684,44955,44920,45736,45737,45738,45740,50045,42453,42454,42455,42456,42457,42458,42459,42460,42461,42462,42463,42464,42465,42466,42467,42468,42469,42470,42471,42472,42473,43389,43390,43391,43392,43393,43394,45779,45780,45781,45782,45783,45785,45789,50077,42396,42397,42398,42399,42400,42401,42402,42403,42404,42405,42406,42407,42408,42409,42410,42411,42412,42414,42415,42416,42417,43341,43370,43371,43372,43373,43374,45753,45755,45756,45757,45758,45760

 

  • Like 1

Share this post


Link to post
Share on other sites

Right now it seems like all items are put into 3 categories:

  • Vendor items
  • Loot item
  • Misc, neither vendor or loot

This means that all items that exclusively come from crafting will be in the Misc category.
https://github.com/TrinityCore/TrinityCore/blob/d7c53c30fb45f6da015e126aeb8a4a1901f72e58/src/server/game/AuctionHouseBot/AuctionHouseBotSeller.cpp#L245

What if a fourth Craftable category was introduced? Then there would be a way to to get craftable items for sale without having to enable Misc or add them all to forceInclude.

This should include Glyphs among other things, without all the other junk in Misc. This should also include other missing items like the specialty bags.

So the question is, is there an good way to find a list of all craftable items?

Edited by splinecl

Share this post


Link to post
Share on other sites

You could iterate spells linked to profession skills in SkillLineAbility.dbc (and check the created item id) but that will also include craftable materials (example: https://www.wowhead.com/spell=32454/knothide-leather) as well as items that are not supposed to be obtained (they are placeholders to display in profession UI, discovery spells use that)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Billy
      Placed several items in the AH today with the 24 hour setting to check with, restarted both world and auth servers, and the items placed in AH were no longer there, nor was there any mail for items sold or returned.
      TrinityCore rev. 59682bbd9b33 2019-02-09 21:06:09 +0100 (3.3.5 branch) (Unix, RelWithDebInfo, Static) (worldserver-daemon)
       
    • By kepo
      I made 2 realms, one for 2.4.3, one for 3.3.5 but for some reason when I try to connect to the 3.3.5 realm I'm getting this error in the cosole: 
      WorldSocket::HandleAuthSession: Client *my home pc's ip is here* requested connecting with realm id 22 but this realm has id 2 set in config. I also get this in-game: 
      The game server you have chosen is currently down. Use the Change Realm button to choose another Realm. The Auth.exe that I use is by OregonCore 2.4.3 for both, but Oregon is 50-60% TrinityCore. When I use the auth.exe by TrinityCore the same problem occurs in the 2.4.3 realm but the 3.3.5 starts working. I don't have any other errors like DB & etc. That's the only problem. 
      I checked the DB auth > realmist and everything looks fine. Here's a picture: http://prntscr.com/mhpbmr
      I have also opened all the needed ports.
      Also - worldconfig for 3.3.5:
      LoginDatabaseInfo     = "127.0.0.1;3306;mysql user;mysql pass;auth" WorldDatabaseInfo     = "127.0.0.1;3306;mysql user;mysql pass;world2" CharacterDatabaseInfo = "127.0.0.1;3306;mysql user;mysql pass;characters2" RealmID = 2 WorldServerPort = 8086 and for 2.4.3
      LoginDatabaseInfo     = "127.0.0.1;3306;mysql user;mysql pass;auth" WorldDatabaseInfo     = "127.0.0.1;3306;mysql user;mysql pass;world" CharacterDatabaseInfo = "127.0.0.1;3306;mysql user;mysql pass;characters" RealmID = 1 WorldServerPort = 8085 Also I checked the AuthSocket.cpp and realmlist.cpp, it looks like there is a code or whatever is called for 3.3.5:
      AuthSocket.cpp
          case 8606:                                          // 2.4.3     case 10505:                                         // 3.2.2a     case 11159:                                         // 3.3.0a     case 11403:                                         // 3.3.2     case 11723:                                         // 3.3.3a     case 12340:                                         // 3.3.5a realmlist.cpp
      static RealmBuildInfo ExpectedRealmdClientBuilds[] = {     {12340, 3, 3, 5, 'a'},                                  // highest supported build, also auto accept all above for simplify future supported builds testing     {11723, 3, 3, 3, 'a'},     {11403, 3, 3, 2, ' '},     {11159, 3, 3, 0, 'a'},     {10505, 3, 2, 2, 'a'},     {8606,  2, 4, 3, ' '},     {6005,  1,12, 2, ' '},     {5875,  1,12, 1, ' '},     {0,     0, 0, 0, ' '}                                   // terminator }; My account's gmlevel in account_access is set to '3' and 'RealmID: is 2', since the max rank level in 2.4.3 (RealmID: 1) is '5'.
      Oh, almost forgot... I modified accounts table, also fusioncms recognize the realm: http://prntscr.com/mhpf3f // trinity is fresh-compiled soo... it's latest version, oregon is 2017 rev since we did tons of custom changes (it's fun server) but hey.. oregon is ded - latest rev is 1 year ago. ;c
    • By Billy
      I just pulled an update this morning and done the compile works, but when I started the worldserver up I got these messages immediately after the server booted up.
      Anybody know what this might mean?

    • By Billy
      Players are logging off while at one location, but when they re-login their character is not where it was when they log off.
      Has happened to me as well. Was in the rest area in Astranaar, went to log back in and was at the Flight master at Astranaar instead.
      When this happens, the rest state does not properly shutdown. Have to go back into the rest area then leave before it shuts down the rest state. In other words, I can run all over the place, go into combat and finish, and still be gaining rest state.
      Edit:
      Forgot to add rev of core...sry.
      TrinityCore rev. 41982aa30026 2018-08-12 14:17:26 +0200 (3.3.5 branch) (Win64, RelWithDebInfo, Static) (worldserver-daemon)
    • By Fyury
      I followed every step from the wiki site and created an own 3.3.5a WoW Server. After that I downloadet the 3.3.5a version of World of Warcraft from Warmane. Now when I want to create a character it look like this:
      Character: https://www.pic-upload.de/view-35767483/help1.png.html
      Npc: https://www.pic-upload.de/view-35767486/help2.png.html
       
      Is this a fail from my server or world of warcraft files? 
×
×
  • Create New...