Jump to content
TrinityCore
Ajaxhore

Is 7.3.5 (25928) not supported with extractors?

Recommended Posts

Hi

Im trying to extract maps with a 7.3.5 (25928) client.

Is this not yet supported?

Im getting all kind of errors.

Share this post


Link to post
Share on other sites

Is there a way to still get the dbc, maps, mmaps and vmaps for 7.3.2 if your retail WoW upgraded to 7.3.5 already? Or do I simply have to wait for TC 7.3.5?

Share this post


Link to post
Share on other sites
13 hours ago, RocketWings said:

Is there another link available for this, or is someone with the client able to rehost it somehow? I keep getting redirect errors when I try to visit this page.

At this precise moment it works perfectly for me.

Share this post


Link to post
Share on other sites
On 11.02.2018 at 8:56 AM, HannibalRoG said:

At this precise moment it works perfectly for me.

But it's not works for others. Moreover, registration on the main site does not work either.;)

Share this post


Link to post
Share on other sites
On 08.02.2018 at 5:07 PM, Selia said:

Is there a way to still get the dbc, maps, mmaps and vmaps for 7.3.2 if your retail WoW upgraded to 7.3.5 already? Or do I simply have to wait for TC 7.3.5?

I already have updated retail version 7.3.5 25996. And i've found solution how to extract the DBC, maps and vmaps for 7.3.2 25549.

First of all, I found the reason why it is impossible to extract data from an empty client version 7.3.2 25549, downloaded from link below:

On 06.02.2018 at 5:23 PM, vatoqwerty said:

https://nofile.io/f/ujVQpPSZErb/Wow-64_732MS.exe  use this launcher. 7.3.2 can be started via the client 7.3.5

 

 The reason is that after a full download of the client, there is no .build.info file in the folder. Without it, the extractor can not determine the locale.

I opened that file from my 7.3.5 client. It consist of trhree strings, beginnigs "Branch", "eu|0|", "us|1|"

Branch!STRING:0|Active!DEC:1|Build Key!HEX:16|CDN Key!HEX:16|Install Key!HEX:16|IM Size!DEC:4|CDN Path!STRING:0|CDN Hosts!STRING:0|Tags!STRING:0|Armadillo!STRING:0|Last Activated!STRING:0|Version!STRING:0|CDN Servers!STRING:0
eu|0|0dcd27adeb73b039302160d07f6c3402|3085234dd989d2d1d8fb565becd85ba5|7b0a274098b14855fc34911a0bd748b9||tpr/wow|edgecast.blizzard.com blzddist1-a.akamaihd.net level3.blizzard.com|Windows x86_32 x86_64 EU? ruRU speech?:Windows x86_32 x86_64 EU? ruRU text?||2017-11-25T16:59:15Z|7.3.2.25549|http://edgecast.blizzard.com http://blzddist1-a.akamaihd.net http://level3.blizzard.com
us|1|c23a2f39506457c036d70547b805a3e7|a02d1d31f80ce2550aaa193dec8c7988|19b6d18b4a1f5b1adf0743a41579458f||tpr/wow|edgecast.blizzard.com blzddist1-a.akamaihd.net level3.blizzard.com|Windows x86_32 x86_64 US? ruRU speech?:Windows x86_32 x86_64 US? ruRU text?||2018-02-09T21:35:31Z|7.3.5.25996|http://edgecast.blizzard.com http://blzddist1-a.akamaihd.net http://level3.blizzard.com

If you see, two past string contains patch data from 7.3.2 and 7.3.5

I renamed it and created a new .build.info file.
Then inserted the first two lines of the old one into it . Then I changed eu|0| -> eu|1| because it still not worked and after that all works.

Branch!STRING:0|Active!DEC:1|Build Key!HEX:16|CDN Key!HEX:16|Install Key!HEX:16|IM Size!DEC:4|CDN Path!STRING:0|CDN Hosts!STRING:0|Tags!STRING:0|Armadillo!STRING:0|Last Activated!STRING:0|Version!STRING:0|CDN Servers!STRING:0
eu|1|0dcd27adeb73b039302160d07f6c3402|3085234dd989d2d1d8fb565becd85ba5|7b0a274098b14855fc34911a0bd748b9||tpr/wow|edgecast.blizzard.com blzddist1-a.akamaihd.net level3.blizzard.com|Windows x86_32 x86_64 EU? ruRU speech?:Windows x86_32 x86_64 EU? ruRU text?||2017-11-25T16:59:15Z|7.3.2.25549|http://edgecast.blizzard.com http://blzddist1-a.akamaihd.net http://level3.blizzard.com

Also i tried to add its file into full downloaded 7.3.2 client folder and copied /data/config directory of 7.3.5 without replacing existed files into it, changed data to US enUS. This also worked.

Branch!STRING:0|Active!DEC:1|Build Key!HEX:16|CDN Key!HEX:16|Install Key!HEX:16|IM Size!DEC:4|CDN Path!STRING:0|CDN Hosts!STRING:0|Tags!STRING:0|Armadillo!STRING:0|Last Activated!STRING:0|Version!STRING:0|CDN Servers!STRING:0
us|1|0dcd27adeb73b039302160d07f6c3402|3085234dd989d2d1d8fb565becd85ba5|7b0a274098b14855fc34911a0bd748b9||tpr/wow|edgecast.blizzard.com blzddist1-a.akamaihd.net level3.blizzard.com|Windows x86_32 x86_64 US? enUS speech?:Windows x86_32 x86_64 US? enUS text?||2017-11-25T16:59:15Z|7.3.2.25549|http://edgecast.blizzard.com http://blzddist1-a.akamaihd.net http://level3.blizzard.com

Have a nice day

 

Edited by saurelius
  • Upvote 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By spudmasher
      I have looked through forums, and can't find a straight answer. Have followed the guide, but not working.
      ISSUE: Starter areas for the Pandaren, Worgen, and Goblins are either broken, or non-exsistent. I have followed the guide to git current commits, but it continues to say 'up-to-date'. The only topics I have seen on any of these are old, or links that go to dead pages. My question, and I do apologize if it is here somewhere (and i missed it), is how do I make these starter areas act 'normal', with working quests?
      If I did miss it, a simple link is fine. Else an in-depth step-by-step to get these working would be appreciative. If it is not possible at this time, that as an answer would suffice.
    • By Fyury
      When I run "worldserver.exe" it just crashes and I get this:
      TrinityCore rev. 084da48ba15a 2018-05-26 18:48:09 +0200 (master branch) (Win64, RelWithDebInfo, Static) (worldserver-daemon)
      <Ctrl-C> to stop.
       ______                       __
      /\__  _\       __          __/\ \__
      \/_/\ \/ _ __ /\_\    ___ /\_\ \, _\  __  __
         \ \ \/\`'__\/\ \ /' _ `\/\ \ \ \/ /\ \/\ \
          \ \ \ \ \/ \ \ \/\ \/\ \ \ \ \ \_\ \ \_\ \
           \ \_\ \_\  \ \_\ \_\ \_\ \_\ \__\\/`____ \
            \/_/\/_/   \/_/\/_/\/_/\/_/\/__/ `/___/> \
                                       C O R E  /\___/
      http://TrinityCore.org                    \/__/
      Using configuration file C:/WoW-Server/bin/RelWithDebInfo/worldserver.conf.
      Using SSL version: OpenSSL 1.0.1e 11 Feb 2013 (library: OpenSSL 1.0.1e 11 Feb 2013)
      Using Boost version: 1.65.1
      Updating Auth database...
      >> Auth database is up-to-date! Containing 6 new and 115 archived updates.
      Updating Character database...
      >> Character database is up-to-date! Containing 3 new and 77 archived updates.
      Updating World database...
      >> World database is up-to-date! Containing 193 new and 2262 archived updates.
      Updating Hotfixes database...
      >> Hotfixes database is up-to-date! Containing 18 new and 130 archived updates.
      Realm running as realm ID 1
      Using World DB: TDB 735.00
      Using enUS DBC Locale
      Will clear `logs` table of entries older than 1209600 seconds every 10 minutes.
      Using DataDir ./
      WORLD: MMap data directory is: ./mmaps
      VMap support included. LineOfSight: 1, getHeight: 1, indoorCheck: 1
      VMap data directory is: ./vmaps
      Missing name Guild.SaveInterval in config file C:/WoW-Server/bin/RelWithDebInfo/worldserver.conf, add "Guild.SaveInterval = 15" to this file
      Initialize PlayerDump...
      >> Initialized 370 PlayerDump ColumnDefinitions in 551 ms.
      Loading Trinity strings...
      >> Loaded 965 trinity strings in 32 ms
      Initialize data stores...
      Some required *.db2 files (2 from 230) not found or not compatible:
      ItemSearchName.db2
      WorldSafeLocs.db2
       
       
      ItemSearName.db2 & WorldSafeLocs.db2 dont exist but how can I get them
      When I start "mapextractor.exe" this happens:
       
      Unable to open file DBFilesClient\ItemSearchName.db2 in the archive for locale enUS: FILE_NOT_FOUND
      Unable to open file DBFilesClient\Unittest.db2 in the archive for locale enUS: FILE_NOT_FOUND
      Unable to open file DBFilesClient\WorldSafeLocs.db2 in the archive for locale enUS: FILE_NOT_FOUND
       
    • By Смердокрыл
      Hi!
      How come a whole bunch of spells, for example rogue's Pistol Shot and Saber Slash, while obviously producing some sort of visual effect, are nowhere to be found in SpellXSpellVisual.db2? Is there another table responsible for them?
    • By silviu2008
      Hello. I have a question related to the state of artifacts in master repo. I can add using additem command the artifacts, but when I right click them I get the interface showing the I have not yet discovered the true power of the artifact. is there anything I can do to unlock the interface? Thank you.
×