Jump to content
TrinityCore

Dbc, Maps, mmaps, Vmaps problems


Munga
 Share

Recommended Posts

Well if he is talking about 3.3.5a then mine is enGB but if you are talking about 7.2.5 I know there is no enGB anymore but for the other client I have enGB on mine or 4.3.4 but have you tried moving that to another directory because I had to before mine worked. Is that in the main directory? I know you said it worked on 7.2.0, mine works for both too.

  • Upvote 1
Link to comment
Share on other sites

Hello everyone,

 

It has been a long time since I last compiled a core and start working on a project. I am at the part where I need to extract all the maps and vmaps and so on. The only issue I am running into is when using the extractors to launch all the map extractors it opens the .exe files but immediately closes them. There is no folder created and it says hit any key to continue without and error message or anything. I tried to run the mapsextractor.exe independently and it wouldn't even load. It kept crashing right away. I have no problems when compiling so any help would be wonderful.

Link to comment
Share on other sites

Same problem here. I run it manualy and get the following error:

Opened casc storage 'C:/World of Warcraft\Data'
Extracting maps...
Read Map.db2 file...
Failed to open 'DBFilesClient\Map.db2' in CASC storage: FILE_NOT_FOUND
Fatal error: Invalid Map.db2 file format! FILE_NOT_FOUND

I found the file "Map.db2" in C:/WOW/dbc/deDE/

common.dll was new build befor i run it again.

Edited by mxvampi
additional informations
Link to comment
Share on other sites

Hi all at first, im triying tom extract the maps with the extractor, but the mapextractror.exe only extract the dbc and gt, maybe is cause is not yet updated to version 7.2.5 (24415) ?

Can i use maps or vmaps from a lower version while waiting for the update? thanks a lot.

Edited by DanielHyM
Link to comment
Share on other sites

36 minutes ago, DanielHyM said:

Hi all at first, im triying tom extract the maps with the extractor, but the mapextractror.exe only extract the dbc and gt, maybe is cause is not yet updated to version 7.2.5 (24415) ?

Can i use maps or vmaps from a lower version while waiting for the update? thanks a lot.

core was updated to   7.2.5 (24415) yesterday.

Link to comment
Share on other sites

18 minutes ago, DanielHyM said:

so maybe i have a problem with the extractors..., the map extractor only extracts for me the dbc and the gt without any exit error, maybe im doing something wrong? thanks.

what client language are you trying to use? for me worked with enus.

Link to comment
Share on other sites

Hello all, I have a problem with the extractor, when I launch the first step (dbc/map extractor), the dbc folder appear and is succesfully filled by the extractor, but the map folder isn't created and maps aren't extracted in the folder, this makes the third step (vmaps) can't work because "maps folder didn't exist or is empty".

Can you help me with this issue ? ( i have already download WoW and launch it on my PC and tried to re-install it) 

Thank you 

N.B : Sorry for my bad English, i'm french :P

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.


  • Similar Content

    • By WalkerSh
      Friends,
      I am going through a big problem.
      all maps in "BFa" are completely empty. (without "mobs", without "Npc's".
      how can I enable world missions and all the content in "BFa".  ??????????????????????
      I looked everywhere on this subject, but I was unsuccessful.
      I apologize, I am a beginner in the projects.

      ====================================================================
      I am currently using this project. 8.3.0 (33369)
      http://www.ac-web.org/forums/showthread.php?237071-World
       
      updated to 8.3.7 (35662)
      https://mega.nz/file/0dpmla4Q#4tKwrc-G9uhyxCkJozNwZp8Pr0ArgZmwO-ay7OCMvGw
      Source project
      https://github.com/TrinityCore/TrinityCore

      ====================================================================
      My WorldServ.conf
      #    Expansion
      #        Description: Allow server to use content from expansions. Checks for expansion-related
      #                     map files, client compatibility and class/race character creation.
      #        Default:     7 - (Expansion 7)
      #                     6 - (Expansion 6)
      #                     5 - (Expansion 5)
      #                     4 - (Expansion 4)
      #                     3 - (Expansion 3)
      #                     2 - (Expansion 2)
      #                     1 - (Expansion 1)
      #                     0 - (Disabled, Ignore and disable expansion content (maps, races, classes)
      Expansion = 8
      #
    • By reyne
      Hey there!

      I've followed a few threads here about map extraction, and am still having issues. Originally, I was having the issue described here.
      After following the advice given in that thread (creating characters of both BC races and running around for a bit), I am no longer getting that error, however now I get the following error while trying to extract maps:

      `Error loading World\Maps\Expansion01\Expansion01_42_6.adt`

      This repeats for every line in Expansion01, and then the extractor crashes.

      I'm not sure where else to go from here.

      Thanks for your help

      Edit: I've created an 85 on an i85 server and flown all around Outland now, same issue.
    • By Ithylis
      =====[ English ]=====
      Hello,
      First of all I'm sorry if my english is not good, it's the use of Mr Google translation
      That's after years I restart in a WoW private server.
      I thank everyone who gives their time to help TrinityCore evolve.
      I appeal to the community because I can not find the dbc-cameras-vmaps-maps-mmaps-gt files of master 8.2.0.31478.
      I have the official version of the game in 8.2.5 and going through Arctium I do not have the data to extract all that, or else I get it wrong.
      Would anyone be kind enough to share all these extracted files please?
      Thank you very much and have a good day / night
      Regards,
      Ithylis
      =====[ Français ]=====
      Bonjour,

      Avant tout je suis désolé si mon anglais n'est pas bon, c'est l'utilisation de Monsieur Google traduction

      Voilà après des années je me relance dans un serveur privé WoW.
      Je remercie tout ceux qui donnent de leur temps pour faire évoluer TrinityCore.
      Je fais appel à la communauté, car je n'arrive pas à trouver les fichiers dbc-cameras-vmaps-maps-mmaps-gt de la version master 8.2.0.31478.
      J'ai la version officielle du jeu en 8.2.5 et en passant par Arctium je n'ai pas les données pour extraire tout cela, ou alors je m'y prends mal.

      Est-ce que quelqu'un aurait la bonté de partager tous ces fichiers extraits s'il vous plait ?

      Merci beaucoup et bonne journée/nuit
      Cordialement,
      Ithylis
    • By roweqharoji
      Hi guys, this is my first post for help. I think this may be a really noob problem, but I just can't...... Sorry first if there's any mistakes.
      I tried to host 4.3.4 from https://gitlab.com/trinitycore/TrinityCore_434, but with no luck I keep recieving error like The `spell_proc` table entry for spellIdXXX has Attribute PROC_ATTR_REQ_SPELLMOD, but spell has no spell mods. Proc will not be triggered. Detailed log is attached below.
      I have host 3.3.5 without error, but when it comes to 4.3.4, I just can't figure out how to solve this situation. I've tried searching for similar problem, but they said it's client side issue. like this https://gitlab.com/trinitycore/TrinityCore_434/issues/165. I tried download different client data such as wowmortal, atlantiss, mangos wowregeneration...and other two client. But no luck with those...
      If anyone can show me any hint, I would really appreciate
      DBErrors.log
    • By omgdior
      Hello user!  Help me please. How to extract the client DBC, Maps, VMaps & VMaps. I for some reason after 3.3.5 can not understand what to do in the new version. I hope for you.
×
×
  • Create New...