Jump to content

Compile or cmake problems


Recommended Posts

  • Replies 2.9k
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Posted Images

1 hour ago, Revolution said:

Did you use a default system account for the service or did you specify details like your own account? If its your own, does it have fulll administrative privileges? (or at least the required privs)

It's my own account and yes,it has full privileges.

P.S.I think I resolved the problem: SQL Windows support.It seems that Windows 10 users cannot install other version than 5.7.I am installing it right now even that it says it's not recommended to install 5.7 but whatever,I don't lose anything :).

Edited by rothmans92
Link to comment
Share on other sites

Did you try running installer with admin rights?

I personally used http://dev.mysql.com/downloads/windows/installer/5.6.html                  and the offline installer
it should already be set for 5.6.32
install.jpg advconf.jpg service.jpg success.jpg
As you can see 5.6.32 does run on windows 10 anniversary  edition
Just use the offline installer and you "should" be fine

Edited by Lorac
Added Link and Screenshots and added thoughts
Link to comment
Share on other sites

I have had this on both  Win10 32 bit and 64 bit systems.

It is a bug in the installer or more to the point the configuration. 


Even if you select "Standard System Account" it wants to use the "Network Service" account which cannot start the service. Switching it to use "Local System" worked for me in both cases.


Credit to answer to this link: http://stackoverflow.com/questions/26970454/mysql-configuration-stops-at-starting-server

Link to comment
Share on other sites

Hello every one, I have problem about compilation TrinityCore 6.x Opcodes.cpp and DB2Stores.cpp

My develop environment:

   Visual Studio 2015, OpenSSL win64 1.0.1t 3 May 2016, boost_1_59_0 lib64-msvc-14.0

Now I am stuck on game.lib compilation. I have some log message about my Question list below.

------ Build started: Project: game, Configuration: Debug x64 ------
D:\TrinityCore-6.x\src\server\game\Server\Protocol\Opcodes.cpp(256): error C2672: 'OpcodeTable::ValidateAndSetClientOpcode': no matching overloaded function found
D:\TrinityCore-6.x\src\server\game\Server\Protocol\Opcodes.cpp(256): error C2893: Failed to specialize function template 'void OpcodeTable::ValidateAndSetClientOpcode(OpcodeClient,const char *,SessionStatus,PacketProcessing)'
D:\TrinityCore-6.x\src\server\game\Server\Protocol\Opcodes.cpp(256): note: With the following template arguments:
D:\TrinityCore-6.x\src\server\game\Server\Protocol\Opcodes.cpp(256): note: 'Handler=void (WorldPackets::Channel::ChannelPlayerCommand &)'
D:\TrinityCore-6.x\src\server\game\Server\Protocol\Opcodes.cpp(256): note: 'HandlerFunction=void WorldSession::HandleChannelCommand<void Channel::Announce(const Player *)>(WorldPackets::Channel::ChannelPlayerCommand &)'
D:\TrinityCore-6.x\src\server\game\Server\Protocol\Opcodes.cpp(257): error C2672: 'OpcodeTable::ValidateAndSetClientOpcode': no matching overloaded function found
D:\TrinityCore-6.x\src\server\game\Server\Protocol\Opcodes.cpp(257): error C2893: Failed to specialize function template 'void OpcodeTable::ValidateAndSetClientOpcode(OpcodeClient,const char *,SessionStatus,PacketProcessing)'
D:\TrinityCore-6.x\src\server\game\Server\Protocol\Opcodes.cpp(257): note: With the following template arguments:
D:\TrinityCore-6.x\src\server\game\Server\Protocol\Opcodes.cpp(257): note: 'Handler=void (WorldPackets::Channel::ChannelPlayerCommand &)'
D:\TrinityCore-6.x\src\server\game\Server\Protocol\Opcodes.cpp(257): note: 'HandlerFunction=void WorldSession::HandleChannelPlayerCommand<void Channel::Ban(const Player *,const std::string &)>(WorldPackets::Channel::ChannelPlayerCommand &)'
D:\TrinityCore-6.x\src\server\game\DataStores\DB2Stores.cpp(512): error C2958: the left bracket '[' found at 'd:\trinitycore-6.x\src\server\game\datastores\db2stores.cpp(512)' was not matched correctly
D:\TrinityCore-6.x\src\server\game\DataStores\DB2Stores.cpp(512): error C2059: syntax error: '}'
D:\TrinityCore-6.x\src\server\game\DataStores\DB2Stores.cpp(512): error C2059: syntax error: ']'

------ Build started: Project: worldserver, Configuration: Debug x64 ------
LINK : fatal error LNK1181: cannot open input file '..\game\Debug\game.lib'


Does anyone have some suggestion for me?






Link to comment
Share on other sites

Description: "No Boost libraries were found" - Error 
I have the path set, and boost 1.5.9 is installed with the libraries

Current behaviour: Can't use cmake

Branch(es): 3.3.5

TC hash/commit: 3f9cf3f+

TDB version: 335.61

Operating system: Windows 10 64-bit


Edit: Solved


Directory Renamed to "lib" and it solved it.

Edited by SkyLiner
Link to comment
Share on other sites



Since the announcement of the new Visual Studio change, from 2013 to 2015, I've had pleanty of errors while trying to use Cmake,

Or trying to compile.


Firstly, I tried to uninstall everything I had for compiling, because of the errors, after uninstalling I searched for the folders and if they were there I deleted them,

then I reinstalled everything and when I installed Visual Studio 2015 it gives me a "Package failed" or "Package error" of some sort. But it still let's me use it to compile.

Then I try to compile it and it doesn't work and gives me a bunch of errors, I believe its due to the installation error, but I don't know how to fix this..


Any help?

Link to comment
Share on other sites

So I'm gonna rephrase everything..


A few days ago now I tried to install the C++ packages for my VS2015 installation, but it wouldn't install them so I uninstalled the entirety of VS2015 and then reinstalled, but since then I've been getting tons of errors when I start the software, they are like this:

The 'Visual Studio Component Enumerator Package' package did not load correctly. The problem may have been caused by a configuration change or by the installation of another extension. You can get more information by examining the file: 'C:Users\\AppData\Roaming\Microsoft\VisualStudio\14.0\ActivityLog.xml'.

I get around 10 of these Package errors before I can finally load into the software, but then when I try to either open an existing C# project it says "Unavailable" or if I try to start a new C++ project it says

'C:\Program Files (x86)\Microsoft Visual Studio 14.0\VC\VCWizards\default.vcxproj' cannot be opened because its project type (.vcxproj) is not supported by this version of the application. To open it, please use a version that support this type

I have tried the following to fix these issues, and every possible combination of these:

  • Uninstalling and reinstalling
  • Deleting my %appdata% in both Local and Roaming for VS 14.0
  • Deleting Program Files (x86)\Visual Studio 14.0
  • Repairing the installation
  • Uninstalling, cleaning registry, deleting everything I can find RE: Visual Studio and then reinstalling
  • devenv /setup, devenv /clearcache, devenv /uninstall /force and then reinstalling, every command line I've found anywhere.

I've been dealing with this issue for a few days and it has completely halted my development process and I'm unable to do anything with VS and it's gotten to the point where I'm extremely frustrated and not sure what to do next.

As far as I can tell there are a lot of packages missing from my installation, but Repairing my installation does not fix this. Is there a way to restore the packages?


"Coppied" From THIS POST which has the same error.

Edited by SkyLiner
Link to comment
Share on other sites

I've run into some issues during the compilation of the 3.3.5 core which seems to be linked to OpenSSL.

I'll list a few of the fatal errors logged by VC2015 during build.

C:\TrinityCore\src\common\Cryptography\HMACSHA1.cpp(54): error C2664: 'int HMAC_Update(HMAC_CTX *,const unsigned char *,std::size_t)': cannot convert argument 1 from 'int *' to 'HMAC_CTX *'

C:\TrinityCore\src\common\Cryptography\HMACSHA1.cpp(54): note: Types pointed to are unrelated; conversion requires reinterpret_cast, C-style cast or function-style cast

C:\TrinityCore\src\common\Cryptography/HMACSHA1.h(43): error C2079: 'HmacHash::m_ctx' uses undefined struct 'hmac_ctx_st' (compiling source file C:\TrinityCore\src\common\Cryptography\Authentication\AuthCrypt.cpp)

C:\TrinityCore\src\common\Cryptography/ARC4.h(34): error C2079: 'ARC4::m_ctx' uses undefined struct 'evp_cipher_ctx_st' (compiling source file C:\TrinityCore\src\common\Cryptography\Authentication\AuthCrypt.cpp)

They all seem to be related to OpenSSL but I can't pinpoint what the problem is, I have gone through the requirements list and ensured that everything is matching, and cMake doesn't report any issues during configuration.

I couldn't seem to find any information relating to this elsewhere, so hopefully you guys can give me some insight on this one.

Link to comment
Share on other sites

40 minutes ago, b.desconocido said:

Downgrade to OpenSSL-1_0_2h solved those issues for me.

Worked perfectly, thanks!

Are these isolated cases, or is the 1.1.0 version of OpenSSL not compatible with the current compilation process? As in, should it be noted in the compile guide?

Link to comment
Share on other sites

I don`t know what to do seriously.

Last year when i tryed to compile, everything compiled from 1st try without errors.. nothing.

Now, im doing the same things again and again and again and again 1000 times maybe for 2 days, and all the time I get errors like this.

I tryed with Microsoft Visual Studio 2013, got error`s from this kind again, reinstalled and updated all the programs, that are required for compilation (openssl, cmake, gits and all others.)

After 1 day of trying with Visual Studio 2013 I downloaded Visual Studio 2015 and same thing, I`m about to reinstall my computer and try it again really .. :D So if someone can help me... all help is welcome. Thanks! 

Checkout the attached file its picture with the errors in Visual Studio.

Без име.png

Link to comment
Share on other sites

  • Aokromes changed the title to Compile or cmake problems
  • Aokromes pinned this topic

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Create New...