Jump to content
TrinityCore
Sign in to follow this  
palooka

[Help] Problems with the login protocol [6.x]

Recommended Posts

I'd been running the x64 version of the 6.2.3 client and previous Trinity server compilation successfully for the past month or 2.

But, after March 24th I was unable to log in to my 64-bit client (although I in no way used or attempted their launcher - all client runs were executed via the "wow-64_patched.exe" file).  I suspect that somehow Blz somehow could see that there was a patch difference in my client version vs their latest patch.

So after numerous unsuccessful attempts at logging in to client, I updated the client patchwise from client source, waited for Trinity Server update, and built, recompiled 64-bit version  (successfully), as of a few days ago. I ran server, installed "bnetaccount create [email protected] test", modified the client's config.wtf file, then pasted the new patcher file into the client folder, and dragged wow-64.exe over the patcher, then ran the "wow-64_patched.exe" executable - which resulted in bringing up the latest 6.2.4 21355 client. 

But, I have not been able to successfully log in to the client with the new configuration.  The client response continues to be:

"Unable to connect. Please try again later. If this problem, please contact technical support at: ....
.... index.xml?gameld=11&rootCategoryld=2316]       (BLZ51901002)"

I've uninstalled the client and BNet accounts, reinstalled same and gone through pretty much the same process again with exactly the same result.

I'm really at a standstill at this point - please help!

Share this post


Link to post
Share on other sites

is portal patchlist and realm list set to the correct ip in config wtf. also is your realmlist table pointed to the correct ip and build version in your db?

Share this post


Link to post
Share on other sites

Compiled 6.x tonight but i have the same issue, i was using 3.3.5 before but this is a fresh DB. Any hint?

Share this post


Link to post
Share on other sites

@Dabloon I want to connect on my computer (localhost) settins are:

config.wtf : SET portal "localhost"

bnetserver.conf :

LoginREST.Port = 8081
LoginREST.ExternalAddress=127.0.0.1
LoginREST.LocalAddress=127.0.0.1

 

everything on default settings (auth.realmlist is from fresh auth db - nothing changed), runned connection_patcher succesfully like on 6.2.3...fresh auth/char/hotfix/world database till revision https://github.com/TrinityCore/TrinityCore/commit/c1c02535605710cf42e748c76d3aa7184551bab4

and I cant still log in...stil persist problem BLZ51901002 like client cant connect so bnetserver.exe

 

I want fix starting zones like this https://github.com/TrinityCore/TrinityCore/commit/7de5842f08645f24f20e24baf2a57cc4291db37e

but I cant...if anybody not help me, I will stop patching starting zones...

Edited by Soky

Share this post


Link to post
Share on other sites

Do not use "localhost" in portal - type in the ip address directly "127.0.0.1".

Since the new patch client can translate "localhost" to IPv6 representation instead, "::1" which will not work.

Share this post


Link to post
Share on other sites

Thank you very much Shauren by this: https://github.com/TrinityCore/TrinityCore/commit/fa74fa1f4db379b24dfd3366860e15dd6ed28e5a

I set 192.168.0.100 (my local IP adress) in bnetserver.conf and config.wtf too:

config.wtf : SET portal "192.168.0.100"

bnetserver.conf :

LoginREST.Port = 8081
LoginREST.ExternalAddress=127.0.0.1
LoginREST.LocalAddress=192.168.0.100

 

and THIS is not in trinitycore "manual" Installation guide https://trinitycore.atlassian.net/wiki/display/tc/Server+Setup

there is : " The IP in the Config.wtf file should be exactly the same as the IP address you entered in the realmlist table above. (Example: SET portal "localhost") "

anyway thank you very much one more time :)

Share this post


Link to post
Share on other sites

Ever since I've switched from WoDCore to trintiy I can't log in to the client.

It keeps throwing me the error as said in the title. Any ideas?

Share this post


Link to post
Share on other sites

I was just dealing with this myself.

1) I reviewed the forums and found that the I had copied the Wow.exe and Wow-64.exe to linux, run the connection_patcher, ignoring the missing issues.  End result, couldn't connect.

so... I created a Windows share with my copy of Wow and all its files... (sometimes I want to play real Wow).  I mounted that windows share to a mount point in linux.

I changed directory to the mount point so that Wow.exe was in my current working directory.

I then ran the connection_patcher from deep in the build directory that I used to build the Linux version of the server.

this is the command I used:

/storage/wow/tc6/TrinityCore/build/src/tools/connection_patcher/connection_patcher Wow.exe

I'm now currently in my server.  The bold part should be the same on your system.

Share this post


Link to post
Share on other sites
52 minutes ago, Banned said:

I was just dealing with this myself.

1) I reviewed the forums and found that the I had copied the Wow.exe and Wow-64.exe to linux, run the connection_patcher, ignoring the missing issues.  End result, couldn't connect.

so... I created a Windows share with my copy of Wow and all its files... (sometimes I want to play real Wow).  I mounted that windows share to a mount point in linux.

I changed directory to the mount point so that Wow.exe was in my current working directory.

I then ran the connection_patcher from deep in the build directory that I used to build the Linux version of the server.

this is the command I used:

/storage/wow/tc6/TrinityCore/build/src/tools/connection_patcher/connection_patcher Wow.exe

I'm now currently in my server.  The bold part should be the same on your system.

IT's all good :) I fixed it by adding the bnet and worldserver executables to the firewall.

Then it gave me another BLZ5190 error which I fixed by re-doing the patcher and getting the tc_bundle txt file or whatever.

Share this post


Link to post
Share on other sites

Thank you Shauren for the fix - I gave up after 2 weeks of frustration with other viewers' suggestions which did not solve my problem.  I do appreciate all responses, however, in that some of the suggestions did help me to clean up some database discrepancies.  Anyway, after substituting 127.0.0.1 in the wtf file, lo and behold, magic coalesced into success and I am one very happy 75 year old camper.

Share this post


Link to post
Share on other sites

I'm having to log on to the server console provides protocol mismatch. (Screenshot attached)
P.S.

I used by clients 6.2.3 instead of 6.2.4, for the reason that he could not find it. If possible, could you share the source for a client.

I hope for you.

Trinity_Auth.jpg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By vehementis
      Hello TrinityCore Community,
      I am actually trying to setup a server using the master branch by building it from Core.
      I am developer and experienced with setting up servers and other software.
      Now I'm looking into setting up a wow Server to get some experience with it.
      I followed the Guide in the Wiki to set up the master branch on Windows (normally I'm working on Linux but using my Gaming PC for this right now).
      I got it running so far that the bnetserver is starting up fine as well as the worldserver. As soon as I try to connect from game to bnetserver I get this message "You have been disconnected. (BLZ51901023)".
      Here the important part of my bnetserver.conf
      Thats the bnet.log
      That's the content of my auth.realmlist table
      If i use PuTTY to connect to IP 127.0.0.1 on Port 8085 tahts what i get
      So I think there shouldn't be a Server side Problem.
      Most likely there is a Problem With my Client. Client-side I Changed the WTF/Config.wtf
       
×