Jump to content
TrinityCore

Compile or cmake problems


Joy
 Share

Recommended Posts

  • Replies 2.9k
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Posted Images

I'm using Linux Mint (which is based on Ubuntu 16.04) and I'm having some build issues that seem to be related to a conflict between mariadb and mysql-server.

 

If I install libmariadb-dev first then libmysqlclient-dev, libmysqlclient-dev overwrites libmysqlclient20 and I end up with this error during build:

make[2]: *** No rule to make target '/usr/lib/x86_64-linux-gnu/libmariadb.so', needed by 'src/server/database/libdatabase.so'.  Stop.

 

On the other hand if I install libmysqlclient-dev first then libmariadb-dev, libmariadb-dev overwrites libmysqlclient20 and I end up with this error:

/home/trinity/TrinityCore/src/server/database/Database/MySQLConnection.cpp:506:14: error: ‘CR_INVALID_CONN_HANDLE’ was not declared in this scope

 

So either it complains that it can't find libmariadb.so, or if I install libmariadb-dev, it can't resolve a mySQL error. In the requirements it only lists libmariadb-dev for debian 9.0, and only libmysqlclient-dev for ubuntu 16.04, but it complains about libmariadb.so. How do I resolve this conflict?

Link to comment
Share on other sites

20 hours ago, aspen said:

If I install libmariadb-dev first then libmysqlclient-dev, libmysqlclient-dev overwrites libmysqlclient20 and I end up with this error during build:

make[2]: *** No rule to make target '/usr/lib/x86_64-linux-gnu/libmariadb.so', needed by 'src/server/database/libdatabase.so'.  Stop.

You don't need mariadb (for your version of linux OS). I'm only using mysql. Your cmake config is still viewing marialib.
Just blow away the build directory, remove mariadb, load only mysql and start over from cmake, then build.

apt-get install libmysqlclient-dev mysql-server

  • Upvote 1
Link to comment
Share on other sites

2 hours ago, CDawg said:

You don't need mariadb (for your version of linux OS). I'm only using mysql. Your cmake config is still viewing marialib.
Just blow away the build directory, remove mariadb, load only mysql and start over from cmake, then build.

apt-get install libmysqlclient-dev mysql-server

I ran into this issue after upgrading from Debian 8 to 9. I believe it was updated to mariadb as part of the upgrade, but i may have removed something by mistake, can't remember. Installing mysql-server through apt-get didn't fix it.

In synaptic, i installed default-libmysqlclient-dev to get it going again.

Link to comment
Share on other sites

6 hours ago, skipperheartbeat said:

In synaptic, i installed default-libmysqlclient-dev to get it going again.

Did you get it working?
I had the same issue testing out mariadb and loading the libraries, I was furious that it overwrote my tables, libraries, data, etc.. (I thought it would install parallel and read my db so that I could test performance over true mysql server).

I just completely uninstalled any trace of it. If you need to backup data, do a mysqldump first.

https://askubuntu.com/questions/806107/remove-mariadb-mysql-databases

  • Upvote 1
Link to comment
Share on other sites

7 hours ago, CDawg said:

Did you get it working?
I had the same issue testing out mariadb and loading the libraries, I was furious that it overwrote my tables, libraries, data, etc.. (I thought it would install parallel and read my db so that I could test performance over true mysql server).

I just completely uninstalled any trace of it. If you need to backup data, do a mysqldump first.

https://askubuntu.com/questions/806107/remove-mariadb-mysql-databases

I haven't got to the point where i've ran the server as i'm trying to get a Master branch set up using only a laptop and USB hard drive :)

Tables look fine though, doesn't look corrupt. I will need to update the installed 3.3.5 that was already installed before the Debian upgrade. Will give it a go some time today and let you know how i get on.

MariaDB [(none)]> use world
Reading table information for completion of table and column names
You can turn off this feature to get a quicker startup with -A

Database changed
MariaDB [world]> show tables;
+-----------------------------------+
| Tables_in_world                   |
+-----------------------------------+
| access_requirement                |
| achievement_criteria_data         |
| achievement_dbc                   |
| achievement_reward                |
| achievement_reward_locale         |
| areatrigger_involvedrelation      |
| areatrigger_scripts               |
| areatrigger_tavern                |
| areatrigger_teleport              |
| battleground_template             |
| battlemaster_entry                |
| broadcast_text                    |
| broadcast_text_locale             |
| command                           |
| conditions                        |
| creature                          |
| creature_addon                    |
| creature_classlevelstats          |
| creature_equip_template           |
| creature_formations               |
| creature_loot_template            |
| creature_model_info               |
| creature_onkill_reputation        |
| creature_questender               |
| creature_questitem                |
| creature_queststarter             |
| creature_summon_groups            |
| creature_template                 |
| creature_template_addon           |
| creature_template_locale          |
| creature_text                     |
| creature_text_locale              |
| disables                          |
| disenchant_loot_template          |
| event_scripts                     |
| exploration_basexp                |
| fishing_loot_template             |
| game_event                        |
| game_event_arena_seasons          |
| game_event_battleground_holiday   |
| game_event_condition              |
| game_event_creature               |
| game_event_creature_quest         |
| game_event_gameobject             |
| game_event_gameobject_quest       |
| game_event_model_equip            |
| game_event_npc_vendor             |
| game_event_npcflag                |
| game_event_pool                   |
| game_event_prerequisite           |
| game_event_quest_condition        |
| game_event_seasonal_questrelation |
| game_tele                         |
| game_weather                      |
| gameobject                        |
| gameobject_addon                  |
| gameobject_loot_template          |
| gameobject_questender             |
| gameobject_questitem              |
| gameobject_queststarter           |
| gameobject_template               |
| gameobject_template_addon         |
| gameobject_template_locale        |
| gossip_menu                       |
| gossip_menu_option                |
| gossip_menu_option_locale         |
| graveyard_zone                    |
| instance_encounters               |
| instance_template                 |
| item_enchantment_template         |
| item_loot_template                |
| item_set_names                    |
| item_set_names_locale             |
| item_template                     |
| item_template_locale              |
| lfg_dungeon_rewards               |
| lfg_dungeon_template              |
| linked_respawn                    |
| mail_level_reward                 |
| mail_loot_template                |
| milling_loot_template             |
| npc_spellclick_spells             |
| npc_text                          |
| npc_text_locale                   |
| npc_trainer                       |
| npc_vendor                        |
| outdoorpvp_template               |
| page_text                         |
| page_text_locale                  |
| pet_levelstats                    |
| pet_name_generation               |
| pickpocketing_loot_template       |
| player_classlevelstats            |
| player_factionchange_achievement  |
| player_factionchange_items        |
| player_factionchange_quests       |
| player_factionchange_reputations  |
| player_factionchange_spells       |
| player_factionchange_titles       |
| player_levelstats                 |
| player_xp_for_level               |
| playercreateinfo                  |
| playercreateinfo_action           |
| playercreateinfo_cast_spell       |
| playercreateinfo_item             |
| playercreateinfo_skills           |
| playercreateinfo_spell_custom     |
| points_of_interest                |
| points_of_interest_locale         |
| pool_creature                     |
| pool_gameobject                   |
| pool_pool                         |
| pool_quest                        |
| pool_template                     |
| prospecting_loot_template         |
| quest_details                     |
| quest_mail_sender                 |
| quest_offer_reward                |
| quest_poi                         |
| quest_poi_points                  |
| quest_request_items               |
| quest_template                    |
| quest_template_addon              |
| quest_template_locale             |
| reference_loot_template           |
| reputation_reward_rate            |
| reputation_spillover_template     |
| script_spline_chain_meta          |
| script_spline_chain_waypoints     |
| script_waypoint                   |
| skill_discovery_template          |
| skill_extra_item_template         |
| skill_fishing_base_level          |
| skill_perfect_item_template       |
| skinning_loot_template            |
| smart_scripts                     |
| spell_area                        |
| spell_bonus_data                  |
| spell_custom_attr                 |
| spell_dbc                         |
| spell_enchant_proc_data           |
| spell_group                       |
| spell_group_stack_rules           |
| spell_learn_spell                 |
| spell_linked_spell                |
| spell_loot_template               |
| spell_pet_auras                   |
| spell_proc                        |
| spell_ranks                       |
| spell_required                    |
| spell_script_names                |
| spell_scripts                     |
| spell_target_position             |
| spell_threat                      |
| spelldifficulty_dbc               |
| transports                        |
| trinity_string                    |
| updates                           |
| updates_include                   |
| vehicle_accessory                 |
| vehicle_template_accessory        |
| version                           |
| warden_checks                     |
| waypoint_data                     |
| waypoint_scripts                  |
| waypoints                         |
+-----------------------------------+
166 rows in set (0.00 sec)

MariaDB [world]>

 

Link to comment
Share on other sites

Updated and its working fine. Logged into game and all seems good. Can't comment on any improvement over previous version though. Maybe you were just unlucky with the corruption CDawg

 

TrinityCore rev. 9c1a426202ba 2017-07-14 06:50:41 +0200 (3.3.5 branch) (Unix, Release, Static) (authserver)
<Ctrl-C> to stop.

 ______                       __
/\__  _\       __          __/\ \__
\/_/\ \/ _ __ /\_\    ___ /\_\ \, _\  __  __
   \ \ \/\`'__\/\ \ /' _ `\/\ \ \ \/ /\ \/\ \
    \ \ \ \ \/ \ \ \/\ \/\ \ \ \ \ \_\ \ \_\ \
     \ \_\ \_\  \ \_\ \_\ \_\ \_\ \__\\/`____ \
      \/_/\/_/   \/_/\/_/\/_/\/_/\/__/ `/___/> \
                                 C O R E  /\___/
http://TrinityCore.org \/__/

Using configuration file /home/dave/server/etc/authserver.conf.
Using SSL version: OpenSSL 1.0.2l  25 May 2017 (library: OpenSSL 1.0.2l  25 May 2017)
Using Boost version: 1.62.0
Automatic database updates are disabled for all databases!
Opening DatabasePool 'auth'. Asynchronous connections: 1, synchronous connections: 1.
MySQL client library: 10.1.23-MariaDB
MySQL server ver: 10.1.23-MariaDB-9+deb9u1
Connected to MySQL database at 127.0.0.1
MySQL client library: 10.1.23-MariaDB
MySQL server ver: 10.1.23-MariaDB-9+deb9u1
Connected to MySQL database at 127.0.0.1
DatabasePool 'auth' opened successfully. 2 total connections running.
Started auth database connection pool.
Added realm "Trinity" at 192.168.0.22:8085.

 

Link to comment
Share on other sites

  • 2 weeks later...

pls read here; https://community.trinitycore.org/topic/120-compile-or-cmake-problems/?do=findComment&comment=82954

because of; 

1 hour ago, Aokromes said:

 -DACE_LIBRARY=/home/XXX/ACE_wrappers/lib/libACE.so ACE? update your core, you are using a extremely outdated core or 3rd party project unsuported here.

this was a mistake by me; i don't use ACE and i had the error bevor i was playing around with that.

Edited by inconnu
Link to comment
Share on other sites

#define _HASH                      "1de89579c75f"
 #define _DATE                      "2017-07-23 18:01:42 +0200"
 #define _BRANCH                    "3.3.5"

hi, i'm running in this error "src/server/authserver/CMakeFiles/authserver.dir/build.make:186: recipe for target 'src/server/authserver/authserver' failed". hopefully, someone could help... i'm at the end of my latin :)

Description:    Ubuntu 16.04.2 LTS
 

g++  (4:5.3.1-1ubuntu1).
gcc (4:5.3.1-1ubuntu1).
libbz2-dev (1.0.6-8).
libncurses5-dev (6.0+20160213-1ubuntu1).
libreadline-dev (6.3-8ubuntu2).
make (4.1-6).
libboost-all-dev  (1.58.0.1ubuntu1).
p7zip  (9.20.1~dfsg.1-4.2).
cmake (3.5.1-1ubuntu3).
git (1:2.7.4-0ubuntu1.1).
libmysqlclient-dev (5.7.19-0ubuntu0.16.04.1).
mysql-server (5.7.19-0ubuntu0.16.04.1).
openssl 1.0.1l

 

cmake conf;

cmake ../ -DCMAKE_INSTALL_PREFIX=/home/XXX/server -DTOOLS=1 -DOPENSSL_CRYPTO_LIBRARIES=/home/XXX/usr/local/lib -DOPENSSL_INCLUDE_DIR=/home/XXX/usr/local/include -DOPENSSL_LIBRARIES=/home/XXX/usr/local/lib -DOPENSSL_ROOT_DIR=/home/XXX/usr/local/openssl -DOPENSSL_SSL_LIBRARIES=/home/XXX/usr/local/lib

 

~/TrinityCore/build$ make 

Scanning dependencies of target authserver
[ 39%] Building CXX object src/server/authserver/CMakeFiles/authserver.dir/Main.cpp.o
[ 39%] Building CXX object src/server/authserver/CMakeFiles/authserver.dir/Server/AuthSession.cpp.o
[ 39%] Building CXX object src/server/authserver/CMakeFiles/authserver.dir/Authentication/TOTP.cpp.o
[ 39%] Building CXX object src/server/authserver/CMakeFiles/authserver.dir/Authentication/AuthCodes.cpp.o
[ 39%] Linking CXX executable authserver
src/server/authserver/CMakeFiles/authserver.dir/build.make:186: recipe for target 'src/server/authserver/authserver' failed
CMakeFiles/Makefile2:1464: recipe for target 'src/server/authserver/CMakeFiles/authserver.dir/all' failed
Makefile:127: recipe for target 'all' failed

-----

BigNumber.cpp:(.text+0x50): undefined reference to `BN_set_word'
../../common/libcommon.a(BigNumber.cpp.o): In function `BigNumber::~BigNumber()':
BigNumber.cpp:(.text+0x64): undefined reference to `BN_free'
../../common/libcommon.a(BigNumber.cpp.o): In function `BigNumber::SetDword(unsigned int)':
BigNumber.cpp:(.text+0x76): undefined reference to `BN_set_word'
../../common/libcommon.a(BigNumber.cpp.o): In function `BigNumber::SetQword(unsigned long)':
BigNumber.cpp:(.text+0xb6): undefined reference to `BN_add_word'
../../common/libcommon.a(BigNumber.cpp.o): In function `BigNumber::SetHexStr(char const*)':
BigNumber.cpp:(.text+0x131): undefined reference to `BN_hex2bn'
../../common/libcommon.a(BigNumber.cpp.o): In function `BigNumber::SetRand(int)':
BigNumber.cpp:(.text+0x14b): undefined reference to `BN_rand'
collect2: error: ld returned 1 exit status
src/server/authserver/CMakeFiles/authserver.dir/build.make:186: recipe for target 'src/server/authserver/authserver' failed
make[2]: *** [src/server/authserver/authserver] Error 1
CMakeFiles/Makefile2:1464: recipe for target 'src/server/authserver/CMakeFiles/authserver.dir/all' failed
make[1]: *** [src/server/authserver/CMakeFiles/authserver.dir/all] Error 2
Makefile:127: recipe for target 'all' failed
make: *** [all] Error 2

 

Edited by inconnu
Link to comment
Share on other sites

I have an interesting issue where authserver and worldserver load without any errors. When I login to my account, there is no problem. But when I create a character I get stuck at Creating Character. When I try to login again, it gets stuck at Connected. If I try to login with an existing character, it will get at the loading screen(fully loaded). Then I wouldn't be able to login to my account unless I restart worldserver. I used CMAKE and recompiled several times and still the same.

The error started occurring after creating a custom script. I deleted it and removed it from CustomScriptLoader and from the project itself too. Then I recompiled several times.

PS: my worldserver.conf is just fine. I even replaced it with another one.

I suppose worldserver freezes after the first login attempt I do on every start. What should I do?


Another thing that recently started occurring was:

I started getting over 1500 warnings on every compile stating '*=' conversion from float to uint32. Possible loss of data.

All warnings are of the same type. I get no errors.

 

 

Edited by Achylles
My issue got resolved and another one came up.
Link to comment
Share on other sites

  • 2 weeks later...

Hi there,

i am trying to compile the current 3.3.5 Branch on Linux.
 

Manjaro KDE Rolling Release -> up to Date

gcc (7.1.1-4)
make (4.2.1-2)
boost (1.64.0-4)
cmake (3.8.2-1)
git (2.13.4-1)
mariadb (10.1.25-1)
openssl (1.1.0.f-1.1) / openssl-1.0 (1.0.2.l-1)

 

I am following the installation guide from the Trinity Core Page....

after running cmake i get the following:

-- Detected 64-bit platform
-- UNIX: Using default configuration directory
-- UNIX: Using default library directory
-- UNIX: Configuring uninstall target
-- UNIX: Created uninstall target
-- UNIX: Detected compiler: /usr/bin/cc
-- GCC: Enabled c++11 support
-- GCC: Enabled C99 support
-- GCC: SFMT enabled, SSE2 flags forced
-- Using mysql-config: /usr/bin/mysql_config
-- Found MySQL library: /usr/lib/libmysqlclient.so
-- Found MySQL headers: /usr/include/mysql
-- Found MySQL executable: /usr/bin/mysql
-- Found git binary : /usr/bin/git

* TrinityCore revision   : d09de6425ca7 2017-08-12 21:10:22 +0200 (3.3.5 branch)
* TrinityCore buildtype  : Release

* Install core to        : /home/dark574/Server
* Install libraries to   : /home/dark574/Server/lib
* Install configs to     : /home/dark574/Server/etc

* Build world/auth       : Yes (default)
* Build with scripts     : Yes (static)
* Build map/vmap tools   : Yes (default)
* Build core w/PCH       : Yes (default)
* Build scripts w/PCH    : Yes (default)
* Show compile-warnings  : No  (default)
* Use coreside debug     : No  (default)
* Show source tree       : Yes (hierarchical)
* Use GIT revision hash  : Yes (default)

-- Boost version: 1.64.0
-- Found the following Boost libraries:
--   system
--   filesystem
--   thread
--   program_options
--   iostreams
--   regex
-- Found OpenSSL library: /usr/lib/libssl.so;/usr/lib/openssl-1.0
-- Found OpenSSL headers: /usr/include/openssl-1.0
-- Found Readline library: /usr/lib/libreadline.so
-- Include dir is: /usr/include

* Script configuration (static):
    |
    +- worldserver
    |   +- Commands
    |   +- Custom
    |   +- EasternKingdoms
    |   +- Events
    |   +- Kalimdor
    |   +- Northrend
    |   +- OutdoorPvP
    |   +- Outland
    |   +- Pet
    |   +- Spells
    |   +- World
    |

-- Configuring done

 

To run CMake succesfully, I used the following command, since CMake found openssl 1.1:

cmake ../ -DCMAKE_INSTALL_PREFIX=/home/dark574/Server -DOPENSSL_LIBRARIES=/usr/lib/openssl-1.0 -DOPENSSL_INCLUDE_DIR=/usr/include/openssl-1.0

 

Configuration worked. After running 'make' I get error at 39% :/

[ 38%] Building CXX object src/server/game/CMakeFiles/game.dir/Weather/Weather.cpp.o
[ 38%] Building CXX object src/server/game/CMakeFiles/game.dir/Weather/WeatherMgr.cpp.o
[ 38%] Building CXX object src/server/game/CMakeFiles/game.dir/World/World.cpp.o
[ 38%] Linking CXX static library libgame.a
[ 38%] Built target game
Scanning dependencies of target authPCH.cpp_dephelp
[ 38%] Building CXX object src/server/authserver/CMakeFiles/authPCH.cpp_dephelp.dir/PrecompiledHeaders/authPCH.cpp.o
[ 39%] Linking CXX shared module libauthPCH.cpp_dephelp.so
[ 39%] Built target authPCH.cpp_dephelp
Scanning dependencies of target generate_authPCH.cpp
[ 39%] Generating authPCH.h.gch
[ 39%] Built target generate_authPCH.cpp
Scanning dependencies of target authserver
[ 39%] Building CXX object src/server/authserver/CMakeFiles/authserver.dir/Main.cpp.o
[ 39%] Building CXX object src/server/authserver/CMakeFiles/authserver.dir/Authentication/AuthCodes.cpp.o
[ 39%] Building CXX object src/server/authserver/CMakeFiles/authserver.dir/Authentication/TOTP.cpp.o
[ 39%] Building CXX object src/server/authserver/CMakeFiles/authserver.dir/Server/AuthSession.cpp.o
[ 39%] Linking CXX executable authserver
/usr/bin/ld: ../../common/libcommon.a(BigNumber.cpp.o): undefined reference to symbol '[email protected]@OPENSSL_1_1_0'
/usr/lib/libcrypto.so.1.1: error adding symbols: DSO missing from command line
collect2: Fehler: ld gab 1 als Ende-Status zurück
make[2]: *** [src/server/authserver/CMakeFiles/authserver.dir/build.make:189: src/server/authserver/authserver] Fehler 1
make[1]: *** [CMakeFiles/Makefile2:1465: src/server/authserver/CMakeFiles/authserver.dir/all] Fehler 2
make: *** [Makefile:130: all] Fehler 2

 

Anyone who can help me? :/

Link to comment
Share on other sites

i know that openssl 1.0x is needed

 

thats why i told cmake to use it

cmake ../ -DCMAKE_INSTALL_PREFIX=/home/dark574/Server -DOPENSSL_LIBRARIES=/usr/lib/openssl-1.0 -DOPENSSL_INCLUDE_DIR=/usr/include/openssl-1.0

 

but i dont understand why it still uses the wrong libs... i used the correct path to the 1.0 openssl libs

Maybe its a trivial problem but i am relatively new to Linux, so sorry coming forth with a stupid error

 

Link to comment
Share on other sites

33 minutes ago, Dark574 said:

i know that openssl 1.0x is needed

 

thats why i told cmake to use it

cmake ../ -DCMAKE_INSTALL_PREFIX=/home/dark574/Server -DOPENSSL_LIBRARIES=/usr/lib/openssl-1.0 -DOPENSSL_INCLUDE_DIR=/usr/include/openssl-1.0

 

but i dont understand why it still uses the wrong libs... i used the correct path to the 1.0 openssl libs

Maybe its a trivial problem but i am relatively new to Linux, so sorry coming forth with a stupid error

 

you need more parameters.

Link to comment
Share on other sites

hello guys,i met a problem in linux core complie:

ubuntu 16.04  trinity version is 3.3.5

i follow the guild to the CMAKE step,and it's done.

then i make,it,it will stuck at 18% every time 

i dont understand how did this happen,missing some lib? please help me.

$ cmake ../ -DCMAKE_INSTALL_PREFIX=/home/trinity/server
-- The C compiler identification is GNU 5.4.0
-- The CXX compiler identification is GNU 5.4.0
-- Check for working C compiler: /usr/bin/cc
-- Check for working C compiler: /usr/bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Detecting C compile features
-- Detecting C compile features - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Detecting CXX compile features
-- Detecting CXX compile features - done
-- Detected 64-bit platform
-- UNIX: Using default configuration directory
-- UNIX: Using default library directory
-- UNIX: Configuring uninstall target
-- UNIX: Created uninstall target
-- UNIX: Detected compiler: /usr/bin/cc
-- GCC: Enabled c++11 support
-- GCC: Enabled C99 support
-- GCC: SFMT enabled, SSE2 flags forced
-- Using mysql-config: /usr/bin/mysql_config
-- Found MySQL library: /usr/lib/x86_64-linux-gnu/libmysqlclient.so
-- Found MySQL headers: /usr/include/mysql
-- Found MySQL executable: /usr/bin/mysql
-- Found git binary : /usr/bin/git
 

 

 

[ 17%] Built target shared
Scanning dependencies of target gamePCH.cpp_dephelp
[ 17%] Building CXX object src/server/game/CMakeFiles/gamePCH.cpp_dephelp.dir/PrecompiledHeaders/gamePCH.cpp.o
[ 18%] Linking CXX shared module libgamePCH.cpp_dephelp.so
[ 18%] Built target gamePCH.cpp_dephelp
Scanning dependencies of target generate_gamePCH.cpp
[ 18%] Generating gamePCH.h.gch
[ 18%] Built target generate_gamePCH.cpp
Scanning dependencies of target game
[ 18%] Building CXX object src/server/game/CMakeFiles/game.dir/World/World.cpp.o

c++: internal compiler error: Segmentation fault (program cc1plus)
Please submit a full bug report,
with preprocessed source if appropriate.
See <file:///usr/share/doc/gcc-5/README.Bugs> for instructions.
src/server/game/CMakeFiles/game.dir/build.make:62: recipe for target 'src/server/game/CMakeFiles/game.dir/World/World.cpp.o' failed
make[2]: *** [src/server/game/CMakeFiles/game.dir/World/World.cpp.o] Error 4
CMakeFiles/Makefile2:1330: recipe for target 'src/server/game/CMakeFiles/game.dir/all' failed
make[1]: *** [src/server/game/CMakeFiles/game.dir/all] Error 2
Makefile:127: recipe for target 'all' failed
make: *** [all] Error 2
$  

 


 

 

Edited by cloudfox
Link to comment
Share on other sites

4 hours ago, cloudfox said:

but my vps is 1core 1Gram,i use "make" can only got one core,would "make -j 1" make any diffrent?

Yes, it should. If not, then you will need to dedicate more RAM to your vps. That is extremely low even for testing 3.3.5a.

Link to comment
Share on other sites

I have a lot of warnings "Unknown compiler version - please run the configure tests and report the results" in VS log. I'm not sure but I think it's since the last VS update and wasn't before. However it compiles without errors. (CMake is also without errors)

After a Google search I think it something with Boost libs. But I already use the latest stable 1.64 version. The VS is version 15.3.1.

Somebody else also have this warnings ? Are they new ?

 

 

Link to comment
Share on other sites

5 hours ago, Magnuss said:

I have a lot of warnings "Unknown compiler version - please run the configure tests and report the results" in VS log. I'm not sure but I think it's since the last VS update and wasn't before. However it compiles without errors. (CMake is also without errors)

After a Google search I think it something with Boost libs. But I already use the latest stable 1.64 version. The VS is version 15.3.1.

Somebody else also have this warnings ? Are they new ?

 

 

no official support for vs 15.3.1 yet.

Link to comment
Share on other sites

  • Aokromes changed the title to Compile or cmake problems
  • Aokromes pinned this topic

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...