Jump to content
TrinityCore
Apple

"unknown column" "missing table" "duplicate column" error / sql problems / SQLDriverLogFile < answer on 1st post of 1st page

Recommended Posts

8 hours ago, Maximus311 said:

Hello,
I followed the detailed guide (https://trinitycore.atlassian.net/wiki/spaces/tc/overview?mode=global) to compile and install my server.

It works but I have multiple database errors (see DBErrors.log).

Is this normal or am I doing something wrong?

I am in master branch and my client is in version 8.0.1.28153

Thank you in advance for your help.

DBErrors.zip 142.13 kB · 1 download

db errors aint database instalation failure, known bugs, ignore.

Share this post


Link to post
Share on other sites

I am really sorry to have to ask, but here goes.

Ubuntu 17.10 x64.  Fresh clone of the 3.3.5 branch.  I've let the worldserver create its own world database from scratch, and this is what it tells me:

TrinityCore rev. bc1f456125c1 2018-11-14 22:57:06 +0100 (3.3.5 branch) (Unix, RelWithDebInfo, Static) (worldserver-daemon)
Using SSL version: OpenSSL 1.0.2g  1 Mar 2016 (library: OpenSSL 1.0.2g  1 Mar 2016)
Using Boost version: 1.62.0


Updating Auth database...
>> Auth database is up-to-date! Containing 2 new and 42 archived updates.
Updating Character database...
>> Character database is up-to-date! Containing 1 new and 31 archived updates.
Updating World database...
>> World database is up-to-date! Containing 32 new and 4037 archived updates.
In mysql_stmt_prepare() id: 55, sql: "SELECT entry, difficulty_entry_1, difficulty_entry_2, difficulty_entry_3, KillCredit1, KillCredit2, modelid1, modelid2, modelid3, modelid4, name, subname, IconName, gossip_menu_id, minlevel, maxlevel, exp, faction, npcflag, speed_walk, speed_run, scale, `rank`, dmgschool, BaseAttackTime, RangeAttackTime, BaseVariance, RangeVariance, unit_class, unit_flags, unit_flags2, dynamicflags, family, trainer_type, trainer_spell, trainer_class, trainer_race, type, type_flags, lootid, pickpocketloot, skinloot, resistance1, resistance2, resistance3, resistance4, resistance5, resistance6, spell1, spell2, spell3, spell4, spell5, spell6, spell7, spell8, PetSpellDataId, VehicleId, mingold, maxgold, AIName, MovementType, ctm.Ground, ctm.Swim, ctm.Flight, ctm.Rooted, HoverHeight, HealthModifier, ManaModifier, ArmorModifier, DamageModifier, ExperienceModifier, RacialLeader, movementId, RegenHealth, mechanic_immune_mask, spell_school_immune_mask, flags_extra, ScriptName FROM creature_template ct LEFT JOIN creature_template_movement ctm ON ct.entry = ctm.CreatureId WHERE entry = ?"
Unknown column 'trainer_type' in 'field list'
Could not prepare statements of the World database, see log for details.

Now, the funny thing is, if I don't put a TDB_full_world file in the bin directory, it grumbles about how it explicitly wants a 'TDB_full_world_335.64_2018_02_19.sql' file.  If I give it this file, which I am under the impression is a little outdated, I get the error above.  There is a newer TDB_full_world file, TDB_full_world_335.19041_2019_04_15.sql.  Which if I put in the bin directory, is ignored.  In my TrinityCore directory, the revision_data.h.in.cmake file references this newer sql file.  I'm not sure why a freshly compiled worldserver would ask for this older sql file.  (Manually applying this newer sql file, and all the updates thereafter, also doesn't work.  but I know it's best to let the worldserver process do the updating, so manually doesn't really count.)

What's the dumb thing I'm missing, making me look especially dumb?
 

Share this post


Link to post
Share on other sites
9 hours ago, Vanclaive said:

I am really sorry to have to ask, but here goes.

Ubuntu 17.10 x64.  Fresh clone of the 3.3.5 branch.  I've let the worldserver create its own world database from scratch, and this is what it tells me:

TrinityCore rev. bc1f456125c1 2018-11-14 22:57:06 +0100 (3.3.5 branch) (Unix, RelWithDebInfo, Static) (worldserver-daemon)
Using SSL version: OpenSSL 1.0.2g  1 Mar 2016 (library: OpenSSL 1.0.2g  1 Mar 2016)
Using Boost version: 1.62.0


Updating Auth database...
>> Auth database is up-to-date! Containing 2 new and 42 archived updates.
Updating Character database...
>> Character database is up-to-date! Containing 1 new and 31 archived updates.
Updating World database...
>> World database is up-to-date! Containing 32 new and 4037 archived updates.
In mysql_stmt_prepare() id: 55, sql: "SELECT entry, difficulty_entry_1, difficulty_entry_2, difficulty_entry_3, KillCredit1, KillCredit2, modelid1, modelid2, modelid3, modelid4, name, subname, IconName, gossip_menu_id, minlevel, maxlevel, exp, faction, npcflag, speed_walk, speed_run, scale, `rank`, dmgschool, BaseAttackTime, RangeAttackTime, BaseVariance, RangeVariance, unit_class, unit_flags, unit_flags2, dynamicflags, family, trainer_type, trainer_spell, trainer_class, trainer_race, type, type_flags, lootid, pickpocketloot, skinloot, resistance1, resistance2, resistance3, resistance4, resistance5, resistance6, spell1, spell2, spell3, spell4, spell5, spell6, spell7, spell8, PetSpellDataId, VehicleId, mingold, maxgold, AIName, MovementType, ctm.Ground, ctm.Swim, ctm.Flight, ctm.Rooted, HoverHeight, HealthModifier, ManaModifier, ArmorModifier, DamageModifier, ExperienceModifier, RacialLeader, movementId, RegenHealth, mechanic_immune_mask, spell_school_immune_mask, flags_extra, ScriptName FROM creature_template ct LEFT JOIN creature_template_movement ctm ON ct.entry = ctm.CreatureId WHERE entry = ?"
Unknown column 'trainer_type' in 'field list'
Could not prepare statements of the World database, see log for details.

Now, the funny thing is, if I don't put a TDB_full_world file in the bin directory, it grumbles about how it explicitly wants a 'TDB_full_world_335.64_2018_02_19.sql' file.  If I give it this file, which I am under the impression is a little outdated, I get the error above.  There is a newer TDB_full_world file, TDB_full_world_335.19041_2019_04_15.sql.  Which if I put in the bin directory, is ignored.  In my TrinityCore directory, the revision_data.h.in.cmake file references this newer sql file.  I'm not sure why a freshly compiled worldserver would ask for this older sql file.  (Manually applying this newer sql file, and all the updates thereafter, also doesn't work.  but I know it's best to let the worldserver process do the updating, so manually doesn't really count.)

What's the dumb thing I'm missing, making me look especially dumb?
 

you are trying to use one outdated core ( 2018-11-14 22:57:06) with one to new database: TDB_full_world_335. 2019 04 1 _2019_04_15.sq

Share this post


Link to post
Share on other sites

When I run the worldserver

It shows 

--------------------

Opening DatabasePool 'realmd'. Asynchronous connections: 1, synchronous connections: 1.

DatabasePool Login NOT opened. 

--------------------

 

Share this post


Link to post
Share on other sites

Getting a missing field error on spell_area table when first run of worldserver to build world database.  Below is my Server.log  I've looked at the database after the worldserver.exe closes and there is no flags field in the spell_area table.  Have downloaded most recent database and cloned most recent git.  DBErrors.log is empty.

 

TrinityCore rev. ada4e431ae77 2019-10-05 20:40:17 +0200 (HEAD branch) (Win64, RelWithDebInfo, Dynamic) (worldserver-daemon)
<Ctrl-C> to stop.

 ______                       __
/\__  _\       __          __/\ \__
\/_/\ \/ _ __ /\_\    ___ /\_\ \, _\  __  __
   \ \ \/\`'__\/\ \ /' _ `\/\ \ \ \/ /\ \/\ \
    \ \ \ \ \/ \ \ \/\ \/\ \ \ \ \ \_\ \ \_\ \
     \ \_\ \_\  \ \_\ \_\ \_\ \_\ \__\\/`____ \
      \/_/\/_/   \/_/\/_/\/_/\/_/\/__/ `/___/> \
                                 C O R E  /\___/
http://TrinityCore.org \/__/

Using configuration file C:/projects/trinitycore/worldserver.conf.
Using SSL version: OpenSSL 1.0.2s  28 May 2019 (library: OpenSSL 1.0.2s  28 May 2019)
Using Boost version: 1.67.0
Database Auth is empty, auto populating it...
>> Applying 'C:/projects/trinitycore/sql/base/auth_database.sql'...
>> Done!
Database Character is empty, auto populating it...
>> Applying 'C:/projects/trinitycore/sql/base/characters_database.sql'...
>> Done!
Database World is empty, auto populating it...
>> Applying 'TDB_full_world_335.19091_2019_09_15.sql'...
>> Done!
Updating Auth database...
>> Auth database is up-to-date! Containing 21 new and 115 archived updates.
Updating Character database...
>> Character database is up-to-date! Containing 12 new and 77 archived updates.
Updating World database...
DBUpdater: Given update include directory "C:/projects/trinitycore/sql/old/3.3.5a/world" does not exist, skipped!
>> Applying update "2019_06_20_02_world_2017_01_06_01_world.sql" 'D469B1D'...
>> Applying update "2019_06_20_03_world_2017_01_07_01_world.sql" '676F8B9'...
ERROR 1054 (42S22) at line 3: Unknown column 'flags' in 'field list'


Applying of file 'C:/projects/trinitycore/sql/updates/world/master/2019_06_20_03_world_2017_01_07_01_world.sql' to database 'world' failed! If you are a user, please pull the latest revision from the repository. Also make sure you have not applied any of the databases with your sql client. You cannot use auto-update system and import sql files from TrinityCore repository with your sql client. If you are a developer, please fix your sql query.
Could not update the World database, see log for details.

Edited by steihl

Share this post


Link to post
Share on other sites
On 10/7/2019 at 12:54 AM, steihl said:

Getting a missing field error on spell_area table when first run of worldserver to build world database.  Below is my Server.log  I've looked at the database after the worldserver.exe closes and there is no flags field in the spell_area table.  Have downloaded most recent database and cloned most recent git.  DBErrors.log is empty.

 

TrinityCore rev. ada4e431ae77 2019-10-05 20:40:17 +0200 (HEAD branch) (Win64, RelWithDebInfo, Dynamic) (worldserver-daemon)
<Ctrl-C> to stop.

 ______                       __
/\__  _\       __          __/\ \__
\/_/\ \/ _ __ /\_\    ___ /\_\ \, _\  __  __
   \ \ \/\`'__\/\ \ /' _ `\/\ \ \ \/ /\ \/\ \
    \ \ \ \ \/ \ \ \/\ \/\ \ \ \ \ \_\ \ \_\ \
     \ \_\ \_\  \ \_\ \_\ \_\ \_\ \__\\/`____ \
      \/_/\/_/   \/_/\/_/\/_/\/_/\/__/ `/___/> \
                                 C O R E  /\___/
http://TrinityCore.org \/__/

Using configuration file C:/projects/trinitycore/worldserver.conf.
Using SSL version: OpenSSL 1.0.2s  28 May 2019 (library: OpenSSL 1.0.2s  28 May 2019)
Using Boost version: 1.67.0
Database Auth is empty, auto populating it...
>> Applying 'C:/projects/trinitycore/sql/base/auth_database.sql'...
>> Done!
Database Character is empty, auto populating it...
>> Applying 'C:/projects/trinitycore/sql/base/characters_database.sql'...
>> Done!
Database World is empty, auto populating it...
>> Applying 'TDB_full_world_335.19091_2019_09_15.sql'...
>> Done!
Updating Auth database...
>> Auth database is up-to-date! Containing 21 new and 115 archived updates.
Updating Character database...
>> Character database is up-to-date! Containing 12 new and 77 archived updates.
Updating World database...
DBUpdater: Given update include directory "C:/projects/trinitycore/sql/old/3.3.5a/world" does not exist, skipped!
>> Applying update "2019_06_20_02_world_2017_01_06_01_world.sql" 'D469B1D'...
>> Applying update "2019_06_20_03_world_2017_01_07_01_world.sql" '676F8B9'...
ERROR 1054 (42S22) at line 3: Unknown column 'flags' in 'field list'


Applying of file 'C:/projects/trinitycore/sql/updates/world/master/2019_06_20_03_world_2017_01_07_01_world.sql' to database 'world' failed! If you are a user, please pull the latest revision from the repository. Also make sure you have not applied any of the databases with your sql client. You cannot use auto-update system and import sql files from TrinityCore repository with your sql client. If you are a developer, please fix your sql query.
Could not update the World database, see log for details.

you have a broken git repository mixing 3.3.5a and master branches, i suggest you to delete the repo and clone 3.3.5a branch selecting it from dropdown.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Hydra_Btforce
      Just finished download & compile fresh trinitycore 4.3.4  From : https://gitlab.com/trinitycore/TrinityCore_434/tree/4.3.4
       
      Creating World database from : https://github.com/TrinityCoreLegacy/TrinityCore/releases
      Downloading the lasted one & create new database named World
      Navigate to my repo applying sql/updates/world/4.3.4
      Trying to apply all updates but an error occurred while applying updates
      And if i don't apply all updates the world is totally bugged and items/creature are missing.
       
      Please help
    • By 939h
      Hi,

      The chat channel Lookup for group is not available when a player isn't in a city. I tried to modify the worldserver.conf file with:
      #
      #    Channel.RestrictedLfg
      #        Description: Restrict LookupForGroup channel to characters registered in the LFG tool.
      #        Default:     1 - (Enabled, Allow join to channel only if registered in LFG)
      #                     0 - (Disabled, Allow join to channel in any time)
      Channel.RestrictedLfg = 0

      I restarted the server but it didn't help.

      Thanks
    • By Probie_Wan_Kenobi
      I believe everything I have done up to this point has been correct. When I go to launch worldserver.exe a console window opens up for a second and closes right away and nothing else seems to have happened. I skipped a head a little in the instructions to see what is left and step 5 seems skippable since I am running this only for this computer and step 6 has me launch to a log in screen which I can not get to. I tried going to the faq but the page was not loading properly so I am forced to post here.
    • By Cantte
      Well ... today I was about to compile the trinity core version for WoW 4.3.4 of this repository "https://gitlab.com/trinitycore/TrinityCore_434". Download them and when you use the cmake, I generate the solution correctly. When I began to compile this went well until I got to the last step, when I was 90% practically.
      This was the error:
      Main.obj: error LNK2019: external symbol SSLeay_version unresolved referred to in the function "public: void __cdecl <lambda_4a2d53ce610f18dba0b4b4d6532c13a7> :: operator () (void) const" (?? R <lambda_4a2d53ce610f18dba0b4b4d6532c13a7> @@ QEBAXXZ)
      25> scripts.lib (cs_server.obj): error LNK2001: external symbol SSLeay_version unresolved
      25> gsoap.lib (stdsoap2.obj): error LNK2019: unresolved sk_num external symbol referenced in the tcp_connect function
      25> gsoap.lib (stdsoap2.obj): error LNK2019: unresolved sk_value external symbol referenced in the tcp_connect function
      25> gsoap.lib (stdsoap2.obj): error LNK2019: unresolved sk_pop_free external symbol referenced in the tcp_connect function
      25> gsoap.lib (stdsoap2.obj): error LNK2019: outer symbol OPENSSL_add_all_algorithms_noconf unresolved referenced in the soap_ssl_init function
      25> gsoap.lib (stdsoap2.obj): error LNK2019: external symbol SSL_load_error_strings unresolved referenced in the soap_ssl_init function
      25> gsoap.lib (stdsoap2.obj): error LNK2019: unresolved external SSLv23_method symbol referenced in the ssl_auth_init function
      25> gsoap.lib (stdsoap2.obj): error LNK2019: external symbol SSL_library_init unresolved referenced in the soap_ssl_init function
      25> gsoap.lib (stdsoap2.obj): error LNK2019: external symbol SSL_state unresolved referenced in the tcp_connect function
      25> common.lib (OpenSSLCrypto.obj): error LNK2019: external symbol CRYPTO_num_locks unresolved referred to in the function "void __cdecl OpenSSLCrypto :: threadsCleanup (void)" (? ThreadsCleanup @ OpenSSLCrypto @@ YAXXZ)
      25> common.lib (OpenSSLCrypto.obj): error LNK2019: external symbol CRYPTO_set_locking_callback unresolved referred to in the function "void __cdecl OpenSSLCrypto :: threadsCleanup (void)" (? ThreadsCleanup @ OpenSSLCrypto @@ YAXXZ)
      25> common.lib (OpenSSLCrypto.obj): error LNK2019: external symbol CRYPTO_THREADID_set_numeric unresolved referred to in the function "void __cdecl threadIdCallback (struct crypto_threadid_st *)" (? ThreadIdCallback @@ YAXPEAUcrypto_threadid_st @@@ Z)
      25> common.lib (OpenSSLCrypto.obj): error LNK2019: external symbol CRYPTO_THREADID_set_callback unresolved referenced in the function "void __cdecl OpenSSLCrypto :: threadsCleanup (void)" (? ThreadsCleanup @ OpenSSLCrypto @@ YAXXZ)
      25> common.lib (ARC4.obj): error LNK2019: external symbol EVP_CIPHER_CTX_init unresolved referred to in the function "public: __cdecl ARC4 :: ARC4 (unsigned int)" (?? 0ARC4 @@ QEAA @ I @ Z)
      25> common.lib (HmacHash.obj): error LNK2019: unresolved HMAC_CTX_init external symbol referenced in the "struct hmac_ctx_st * __cdecl HMAC_CTX_new (void)" function (? HMAC_CTX_new @@ YAPEAUhmac_ctx_st @@ XZ)
      25> common.lib (HmacHash.obj): error LNK2019: unresolved HMAC_CTX_cleanup external symbol referenced in the "void __cdecl HMAC_CTX_free (struct hmac_ctx_st *)" function (? HMAC_CTX_free @@ YAXPEAUhmac_ctx_st @@@ Z)
      25> E: \ Server-Wow \ TrinityCore_434-4.3.4 \ Build \ bin \ RelWithDebInfo \ worldserver.exe: fatal error LNK1120: 16 external unresolved
      25> Compilation of the "worldserver.vcxproj" project completed - ERROR.
      26> ------ Compile operation started: project: ALL_BUILD, configuration: RelWithDebInfo x64 ------
      26> Building Custom Rule E: /Server-Wow/TrinityCore_434-4.3.4/CMakeLists.txt
      26> CMake does not need to re-run because E: /Server-Wow/TrinityCore_434-4.3.4/Build/CMakeFiles/generate.stamp is up-to-date.
      ========== Compile: 23 correct, 3 incorrect, 0 updated, 0 omitted ==========
       
      And this is the original error in Spanish (since I use the compiler in Spanish)
       
      Main.obj : error LNK2019: símbolo externo SSLeay_version sin resolver al que se hace referencia en la función "public: void __cdecl <lambda_4a2d53ce610f18dba0b4b4d6532c13a7>::operator()(void)const " (??R<lambda_4a2d53ce610f18dba0b4b4d6532c13a7>@@QEBAXXZ)
      25>scripts.lib(cs_server.obj) : error LNK2001: símbolo externo SSLeay_version sin resolver
      25>gsoap.lib(stdsoap2.obj) : error LNK2019: símbolo externo sk_num sin resolver al que se hace referencia en la función tcp_connect
      25>gsoap.lib(stdsoap2.obj) : error LNK2019: símbolo externo sk_value sin resolver al que se hace referencia en la función tcp_connect
      25>gsoap.lib(stdsoap2.obj) : error LNK2019: símbolo externo sk_pop_free sin resolver al que se hace referencia en la función tcp_connect
      25>gsoap.lib(stdsoap2.obj) : error LNK2019: símbolo externo OPENSSL_add_all_algorithms_noconf sin resolver al que se hace referencia en la función soap_ssl_init
      25>gsoap.lib(stdsoap2.obj) : error LNK2019: símbolo externo SSL_load_error_strings sin resolver al que se hace referencia en la función soap_ssl_init
      25>gsoap.lib(stdsoap2.obj) : error LNK2019: símbolo externo SSLv23_method sin resolver al que se hace referencia en la función ssl_auth_init
      25>gsoap.lib(stdsoap2.obj) : error LNK2019: símbolo externo SSL_library_init sin resolver al que se hace referencia en la función soap_ssl_init
      25>gsoap.lib(stdsoap2.obj) : error LNK2019: símbolo externo SSL_state sin resolver al que se hace referencia en la función tcp_connect
      25>common.lib(OpenSSLCrypto.obj) : error LNK2019: símbolo externo CRYPTO_num_locks sin resolver al que se hace referencia en la función "void __cdecl OpenSSLCrypto::threadsCleanup(void)" ([email protected]@@YAXXZ)
      25>common.lib(OpenSSLCrypto.obj) : error LNK2019: símbolo externo CRYPTO_set_locking_callback sin resolver al que se hace referencia en la función "void __cdecl OpenSSLCrypto::threadsCleanup(void)" ([email protected]@@YAXXZ)
      25>common.lib(OpenSSLCrypto.obj) : error LNK2019: símbolo externo CRYPTO_THREADID_set_numeric sin resolver al que se hace referencia en la función "void __cdecl threadIdCallback(struct crypto_threadid_st *)" ([email protected]@[email protected]@@Z)
      25>common.lib(OpenSSLCrypto.obj) : error LNK2019: símbolo externo CRYPTO_THREADID_set_callback sin resolver al que se hace referencia en la función "void __cdecl OpenSSLCrypto::threadsCleanup(void)" ([email protected]@@YAXXZ)
      25>common.lib(ARC4.obj) : error LNK2019: símbolo externo EVP_CIPHER_CTX_init sin resolver al que se hace referencia en la función "public: __cdecl ARC4::ARC4(unsigned int)" ([email protected]@[email protected]@Z)
      25>common.lib(HmacHash.obj) : error LNK2019: símbolo externo HMAC_CTX_init sin resolver al que se hace referencia en la función "struct hmac_ctx_st * __cdecl HMAC_CTX_new(void)" ([email protected]@[email protected]@XZ)
      25>common.lib(HmacHash.obj) : error LNK2019: símbolo externo HMAC_CTX_cleanup sin resolver al que se hace referencia en la función "void __cdecl HMAC_CTX_free(struct hmac_ctx_st *)" ([email protected]@[email protected]@@Z)
      25>E:\Server-Wow\TrinityCore_434-4.3.4\Build\bin\RelWithDebInfo\worldserver.exe : fatal error LNK1120: 16 externos sin resolver
      25>Compilación del proyecto "worldserver.vcxproj" terminada -- ERROR.
      26>------ Operación Compilar iniciada: proyecto: ALL_BUILD, configuración: RelWithDebInfo x64 ------
      26>Building Custom Rule E:/Server-Wow/TrinityCore_434-4.3.4/CMakeLists.txt
      26>CMake does not need to re-run because E:/Server-Wow/TrinityCore_434-4.3.4/Build/CMakeFiles/generate.stamp is up-to-date.
      ========== Compilar: 23 correctos, 3 incorrectos, 0 actualizados, 0 omitidos ==========
       
       
      Thanks.
    • By Fyury
      When I run "worldserver.exe" it just crashes and I get this:
      TrinityCore rev. 084da48ba15a 2018-05-26 18:48:09 +0200 (master branch) (Win64, RelWithDebInfo, Static) (worldserver-daemon)
      <Ctrl-C> to stop.
       ______                       __
      /\__  _\       __          __/\ \__
      \/_/\ \/ _ __ /\_\    ___ /\_\ \, _\  __  __
         \ \ \/\`'__\/\ \ /' _ `\/\ \ \ \/ /\ \/\ \
          \ \ \ \ \/ \ \ \/\ \/\ \ \ \ \ \_\ \ \_\ \
           \ \_\ \_\  \ \_\ \_\ \_\ \_\ \__\\/`____ \
            \/_/\/_/   \/_/\/_/\/_/\/_/\/__/ `/___/> \
                                       C O R E  /\___/
      http://TrinityCore.org                    \/__/
      Using configuration file C:/WoW-Server/bin/RelWithDebInfo/worldserver.conf.
      Using SSL version: OpenSSL 1.0.1e 11 Feb 2013 (library: OpenSSL 1.0.1e 11 Feb 2013)
      Using Boost version: 1.65.1
      Updating Auth database...
      >> Auth database is up-to-date! Containing 6 new and 115 archived updates.
      Updating Character database...
      >> Character database is up-to-date! Containing 3 new and 77 archived updates.
      Updating World database...
      >> World database is up-to-date! Containing 193 new and 2262 archived updates.
      Updating Hotfixes database...
      >> Hotfixes database is up-to-date! Containing 18 new and 130 archived updates.
      Realm running as realm ID 1
      Using World DB: TDB 735.00
      Using enUS DBC Locale
      Will clear `logs` table of entries older than 1209600 seconds every 10 minutes.
      Using DataDir ./
      WORLD: MMap data directory is: ./mmaps
      VMap support included. LineOfSight: 1, getHeight: 1, indoorCheck: 1
      VMap data directory is: ./vmaps
      Missing name Guild.SaveInterval in config file C:/WoW-Server/bin/RelWithDebInfo/worldserver.conf, add "Guild.SaveInterval = 15" to this file
      Initialize PlayerDump...
      >> Initialized 370 PlayerDump ColumnDefinitions in 551 ms.
      Loading Trinity strings...
      >> Loaded 965 trinity strings in 32 ms
      Initialize data stores...
      Some required *.db2 files (2 from 230) not found or not compatible:
      ItemSearchName.db2
      WorldSafeLocs.db2
       
       
      ItemSearName.db2 & WorldSafeLocs.db2 dont exist but how can I get them
      When I start "mapextractor.exe" this happens:
       
      Unable to open file DBFilesClient\ItemSearchName.db2 in the archive for locale enUS: FILE_NOT_FOUND
      Unable to open file DBFilesClient\Unittest.db2 in the archive for locale enUS: FILE_NOT_FOUND
      Unable to open file DBFilesClient\WorldSafeLocs.db2 in the archive for locale enUS: FILE_NOT_FOUND
       
×
×
  • Create New...