Jump to content
TrinityCore
Apple

"unknown column" "missing table" "duplicate column" error / sql problems / SQLDriverLogFile < answer on 1st post of 1st page

Recommended Posts

-- EDIT BY Aokromes --

If you get "unknown column" "missing table" "Duplicate column" errors:

use mysql --default-character-set=utf8 to avoid import failures because timeout/mysql gone away/etc

1) Clone desired branch.

2) Import sql/create/create_mysql.sql

3) start core

4) leave core to update databases.

Our Wiki: http://collab.kpsn.org/display/tc/TrinityCore+Home

Share this post


Link to post
Share on other sites

Check if you have accurate data in the quest_poi and quest_poi_points table. (TDB data is the only accurate data).

If that doesn't cut it, attach a debugger to it and post a dump in the tracker.

Share this post


Link to post
Share on other sites

Okay I ''designed'' my quest_poi_points table to same which it is in the TrinityCore wiki.

Now I get error:

Loading Quest POI

SQL: SELECT questId, id, x, y FROM quest_poi_points ORDER BY questId DESC, idx

ERROR: [1054] Unknown column 'idx' in 'order clause'

Unhandled MySQL errno 1054. Unexpected behaviour possible

and then comes classic ''Worldserver has stopped to respond''.

Edited by Apple

Share this post


Link to post
Share on other sites

--- Canned message start

It appears the issue in the original post was solved, so this thread shall be closed. Should you encounter any other difficulties, please open a new thread.

--- Canned message end ---

Share this post


Link to post
Share on other sites

run "tc/sql/update/10828_characters_character_queststatus.sql "

tips "[Err] 1054 - Unknown column 'rewarded' in 'where clause'

[Err] INSERT INTO character_queststatus_rewarded SELECT guid, quest FROM character_queststatus WHERE rewarded = 1;

[Err] 1054 - Unknown column 'rewarded' in 'where clause'

[Err] DELETE FROM character_queststatus WHERE rewarded = 1;

[Err] 1091 - Can't DROP 'rewarded'; check that column/key exists

[Err] ALTER TABLE character_queststatus DROP COLUMN rewarded;

[Msg] Finished - Unsuccessfully"

Impact on the entire database it?

Share this post


Link to post
Share on other sites

I finally got a recent version of the core to compile and install on a mac, but now I need to apply SQL updates to my databases. Can someone remind me how to tell which sql updates I need to apply from the git source?

Thanks for the help!

Share this post


Link to post
Share on other sites

If you bothered looking you would have found this on the wiki.

http://www.trinitycore.org/w/How-to:Mac#Installing_The_Trinity_Databases

Share this post


Link to post
Share on other sites

How do I tell what version of the "characters" database I am on? My world database updated fine from 10818 to 10925, but when I run the script "10828_characters_character_queststatus.sql", I get the following error: "ERROR 1054 (42S22) at line 8: Unknown column 'rewarded' in 'where clause'"

Share this post


Link to post
Share on other sites

If you created a new character and auth DB, you need NO UPDATES at all.

gotcha, that makes sense. When I wipe everything and install fresh, everything starts up great and I can create a new account and login.

The problem however, is that I still have my old character and auth DB, which I would like to preserve. Unfortunately, I wasn't very diligent about keeping track of my versions, and now TC does not start.

Is there an easy way to figure out which version my characters and auth DB are on, so I can apply the necessary patches to get things working again?

Thanks!

Share this post


Link to post
Share on other sites

check your old server.log files to see what the last revision you ran was?, or, look in auth DB for the uptime table, it should have the last revision you ran in it.

Share this post


Link to post
Share on other sites

Hey anyone know how I can get this thing up and running? heh, I keep getting this error:

[ERROR]: In mysql_stmt_prepare() id: 0, sql: "DELETE FROM pool_quest_save WHERE pool_id = ?"

[ERROR]: Table 'characters.pool_quest_save' doesn't exist

~DatabaseWorkerPool for ''.

~DatabaseWorkerPool for 'characters'.

~DatabaseWorkerPool for 'world'.

When launching the ./worldserver

using the most up-to-date version of TDB. Does anyone have an idea what's going on?

Trying on a x64 bit install of Ubuntu 10.10.

Edited by Noaru

Share this post


Link to post
Share on other sites

You sure you applied all the updates from the trinitycore

Well I used the most current fresh install. I had looked everywhere in the error logs, inc the DB Errors, and nothing. That error shows up in the server.

Share this post


Link to post
Share on other sites

Simply run this query in the characters database:

DROP TABLE IF EXISTS `pool_quest_save`;

CREATE TABLE `pool_quest_save` (

  `pool_id` int(10) unsigned NOT NULL DEFAULT '0',

  `quest_id` int(10) unsigned NOT NULL DEFAULT '0',

  PRIMARY KEY (`pool_id`,`quest_id`)

) ENGINE=InnoDB DEFAULT CHARSET=utf8;

Which we can find in the 3.3.5 sql updates folder; found it in 10 seconds ^^

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By reyne
      Hey there!

      I've followed a few threads here about map extraction, and am still having issues. Originally, I was having the issue described here.
      After following the advice given in that thread (creating characters of both BC races and running around for a bit), I am no longer getting that error, however now I get the following error while trying to extract maps:

      `Error loading World\Maps\Expansion01\Expansion01_42_6.adt`

      This repeats for every line in Expansion01, and then the extractor crashes.

      I'm not sure where else to go from here.

      Thanks for your help

      Edit: I've created an 85 on an i85 server and flown all around Outland now, same issue.
    • By Uee
      I recently found the Trinity Cataclsym Preservation Project and thought I will try it out.
      I am already running 3.3.5a and Master - both server run great
      Pulled 4.3.4 down using Git and built it same way as others:
      boost_1_73_0 cmake 3.17.2 Mysql 5.7.30 VS Community 2019 Built fine - no issue. Used 'Extractor.bat' to run all the map extractors - worked great!
      Noticed there was extra file 'connection_patcher.exe`, ran that - worked great! Now have "wow_patched" and use this to launch client
      MySQL runs in standalone mode, -initialize, added base sql files, imported, auth and character sql files
      Configured both the .conf files and passwords, IPs etc are all in place.
      Note: When loading the exe and built conf file, bnetserver complain about these items missing, so I add them:
      Updates.AutoSetup = 1 Updates.EnableDatabases = 0 LoginDatabase.SynchThreads = 1 Load up Mysql - loads fine
      Load up bnetserver and appears to load ok - last few lines look like this:
      Connected to MySQL database at 127.0.0.1
      DatabasePool 'auth' opened successfully. 2 total connections running.
      Started auth database connection pool.
      Listening on connections from worldservers on port 1118...
      Load up worldserver and it adds the FULL world and hotfixes, then applied all updates (confirmed archived in SQL) - last few lines look like this:
      Calculate next monthly quest reset time...
      Calculate random battleground reset time...
      Calculate guild limitation(s) reset time...
      Calculate next currency reset time...
      World initialized in 0 minutes 13 seconds
      TrinityCore rev. d0c7bbab40bc 2020-05-06 00:01:21 +0200 (master branch) (Win64, RelWithDebInfo, Static) (worldserver-daemon) ready...
       
      There are no db errors in logs.
      Config.wtf contain portal, realmlist as remote server and patchlist as localhost.
      When I try to connecting using "[email protected]" and password I get immediately disconnected.
      What I did noticed different is that the bnetserver doesnt add "Added realm "Battle for Azeroth" at 192.168.10.213:8085." (From my Master log) 
      3.3.5a also have this line as last line in authserver - but 4.3.4 is not giving me this one.
      Realmlist table is accurate with right information.
      Anyone know why bnetserver is not starting me realm?
       
    • By Deer_Hunter
      Hello all,
      I just updated from the latest Git 
      Trinity Core REV. ac6baa547376 + 2020-02-21  3.3.5 Branch.
      I'm getting this error after crash.
      Problem signature:
        Problem Event Name:    APPCRASH
        Application Name:    worldserver.exe
        Application Version:    0.0.0.0
        Application Timestamp:    5e50a462
        Fault Module Name:    StackHash_f12f
        Fault Module Version:    6.3.9600.19629
        Fault Module Timestamp:    5e2fdc0d
        Exception Code:    c0000374
        Exception Offset:    PCH_9E_FROM_ntdll+0x0000000000090D0A
        OS Version:    6.3.9600.2.0.0.272.7
        Locale ID:    1033
        Additional Information 1:    f12f
        Additional Information 2:    f12f0934d3e965f73c68e60f20f2cd40
        Additional Information 3:    7595
        Additional Information 4:    7595e4d8d703db9dcd3d2f6ea540e357
      the exception code says its a Heap error,  I'm not sure how to troubleshoot this.
      Thanks
    • By Hydra_Btforce
      Just finished download & compile fresh trinitycore 4.3.4  From : https://gitlab.com/trinitycore/TrinityCore_434/tree/4.3.4
       
      Creating World database from : https://github.com/TrinityCoreLegacy/TrinityCore/releases
      Downloading the lasted one & create new database named World
      Navigate to my repo applying sql/updates/world/4.3.4
      Trying to apply all updates but an error occurred while applying updates
      And if i don't apply all updates the world is totally bugged and items/creature are missing.
       
      Please help
    • By 939h
      Hi,

      The chat channel Lookup for group is not available when a player isn't in a city. I tried to modify the worldserver.conf file with:
      #
      #    Channel.RestrictedLfg
      #        Description: Restrict LookupForGroup channel to characters registered in the LFG tool.
      #        Default:     1 - (Enabled, Allow join to channel only if registered in LFG)
      #                     0 - (Disabled, Allow join to channel in any time)
      Channel.RestrictedLfg = 0

      I restarted the server but it didn't help.

      Thanks
×
×
  • Create New...