Jump to content

"unknown column" "missing table" "duplicate column" error / sql problems / SQLDriverLogFile < answer on 1st post of 1st page


Recommended Posts

Hey sorry,

I'm using Web-wow, the name of my dbs are auth, characters and world.

Here is the SQL code

* Unstuck character


3 => "UPDATE ".$config_data[$id.'-2'][0].'.'.TBL_CHARACTERS." INNER JOIN ".$config_data[$id.'-2'][0].".character_homebind

ON ".TBL_CHARACTERS.".guid = character_homebind.guid AND  ".TBL_CHARACTERS.".guid = '".$param1."'

SET  ".TBL_CHARACTERS.".position_X = character_homebind.position_x,

".TBL_CHARACTERS.".position_Y = character_homebind.position_y,

".TBL_CHARACTERS.".position_z = character_homebind.position_z",


Link to comment
Share on other sites

I'd stop focusing on the unstucker (stupid name) script, and, start checking to be sure the auth (also known as realm) DB is set up properly in the configs, etc. as that is where the username field comes in... in the accounts table.

I agree, but i checked my auth database and everything seems to be fine, I mean i am not having any in-game problems with accounts or anything and i see the username field in auth > colums > username, varchar (32) and i see all the user names and everything.

I just don't understand because this has always worked for me in the past until recently it stopped working, and nobody else reported this problem and i even tried starting with a fresh website and everything and it still didn't work >.<

I wish there was just some other Unstucker script that is simple like Select the character from a drop down list and click "Unstuck" so that i could implement it to my site, but i fail at PHP and everyone else who attempts that fails because they are never secure..

Link to comment
Share on other sites


I'm going to post everything i know about the problem right now, I had the exact same problem (error message) with my teleporter module whenever i would try and teleport to Dalaran, I fixed that by going into the PHP script and the coordinates for Dalaran had commas instead of periods, so i replaced that and now it works fine, but i can't find such an easy fix for the Unstucker..

Here is the whole Unstucker script...


global $user,$db,$form,$lang,$config,$Html;


* This part of website is executed before any output is given

* so every post data is processed here then using Header(Location:)

* we simply call normal site and display errors



* Access premission:


if(!$user->logged_in){ if (!isset($proccess)) echo "<a href='./?page=loginout'>".$lang['Login']."</a>"; return; }


* MODULE SELF INSTALLATION (none for this module):


/*if (!isset($proccess))








if(isset($proccess) && $proccess == TRUE){


* Processes the user submitted login form, if errors

* are found, the user is redirected to correct the information,

* if not, the user is effectively logged in to the system.

* If user is logged in, he will be logged out and redirected to

* index.php page.


function Process(){

global $user, $form, $config,$db,$lang;

$charinfo = preg_replace( "/[^0-9-]/", "", $_POST['character'] );

$charinfo = explode("-", $charinfo );



/* Get character info */

$db_realm = connect_realm($realmid);

$char_info0 = $db_realm->query( $user->CoreSQL(1 ,$charguid, $realmid ) ) or die ($db->error('error_msg'));

$char_info = $db_realm->fetch_array( $char_info0 );


//echo  $user->CoreSQL( 3 ,$char_info['guid'], $realmid  );exit;

$tel_db = $db_realm->query( $user->CoreSQL( 3 .$char_info['guid'], $realmid  ) ) or die ($db->error('error_msg'));

if ($tel_db) {

$_SESSION['notice'] ="<center><a href='./?page=wwc-unstucker'>".$lang['OK']."</a></center>"; return;


else $_SESSION['notice'] ="<center>Failed!<br><br><a href='./?page=wwc-unstucker'>".$lang['OK']."</a></center>";


if (isset($_POST['unstuck'])){

/* Initialize process */



/* Reinitilaze 'form' proccess with latest session data */





<!-- This element is important, must be at beginning of module output, dont change it, except module name -->

<div class="post_body_title"><?php echo $lang['Unstucker']; ?></div>



* Notification


if (isset($_SESSION['notice'])){

echo $_SESSION['notice'];





<center><form method="post">



?>&nbsp;&nbsp;<input name="unstuck" type="submit" value="<?php echo $lang['OK']; ?>" /></form><br />


and this is what i believe to be the SQL that will be executed.. Found it in a seperate file, Trinity.php

$sqls = array(


* Select username and userids:

*  param1 = username;


0 => 'SELECT id,username FROM '.TBL_ACCOUNT.' WHERE username LIKE "%'.$db->escape($param1).'%"',


* Select character info (donation and vote shops, teleporter):

*  param1 = realm_id (0->); param2 = char_guid;


1 => 'SELECT name,guid,race,class,gender,level,money FROM '.$config_data[$id.'-2'][0].'.'.TBL_CHARACTERS.' WHERE guid="'.$param1.'" AND account="'.$user->userinfo['guid'].'" LIMIT 1',


* Teleport character


2 => 'UPDATE '.$config_data[$id.'-2'][0].'.'.TBL_CHARACTERS.' SET position_x="'.$param3.'", position_y="'.$param4.'", position_z="'.$param5.'", map="'.$param1.'", money="'.$param6.'" WHERE guid="'.$param7.'"',


* Unstuck character


3 => 'UPDATE '.$config_data[$id.'-2'][0].'.'.TBL_CHARACTERS." INNER JOIN ".$config_data[$id.'-2'][0].".character_homebind

ON ".TBL_CHARACTERS.".guid = character_homebind.guid AND  ".TBL_CHARACTERS.".guid = '".$param1."'

SET  ".TBL_CHARACTERS.".position_X = character_homebind.position_x,

".TBL_CHARACTERS.".position_Y = character_homebind.position_y,

".TBL_CHARACTERS.".position_z = character_homebind.position_z",


* Expansion change, 0 to 3


4 => "UPDATE ".TBL_ACCOUNT." SET expansion='".$param2."' WHERE id='".$param1."'",


return $sqls[$id];


Link to comment
Share on other sites

Well, I'm using Web wow... so its all set up in the Configuration so its connecting to my DB

ok... i see that i have to do a sketch!

PHP Basic 101:


$variable = '0'; //The value of the $variable is 0.

$variable = mysql_query("SELECT id FROM account WHERE username = 'test'"); //The value of variable is the id from test.


TBL_ACCOUNT get his variable somewhere... i just want to know where and that code!

  • Upvote 1
Link to comment
Share on other sites

hum... unless the engine_logon_db variable doesn't point to your auth DB i don't see why it throws that error!

The thing is that i had the exact same problem with the Character teleporter and it gave the same error when i would try teleporting my character to Dalaran, so i took a look at the script and this is what i found:


case 9:

$map = "530";

$x = "-1863.03";

$y = "4998.05";

$z = "-21.1847";

$place = "Shattrath";



case 10:

$map = "571";

$x = "5804,62";

$y = "619,803";

$z = "649";

$place = "Dalaran";


as you can see the teleporting coordinates for Dalaran have a , in between them instead of a . - so i replaced the , with dots and then it worked perfectly fine and didnt give me that error...

Anyways, i dont want to bother you too much ^^ but thanks for helpign me now :)

Link to comment
Share on other sites

But that doesn't explain the

Unknown column 'username' in 'where clause
It doesn't explain it... but it still fixes the problem for the teleporter script, but i cant find anything wrong with this...=/ I bet that the error
Unknown column 'username' in 'where clause

is just something stupid in the sites script.. but has nothing to do with the username column.. because changing , to . fixed the problem on the teleporter module.. but i cant see where i can make the same changes to fix this problem...

Link to comment
Share on other sites

Hi everyone,

I get a problem with an update for the World Trinity DB, the update is 2011_04_28_01_world_creature_equip_template

Here is the content of the update

ALTER TABLE `creature_equip_template`


CHANGE `equipentry1` `itemEntry1` MEDIUMINT(8) UNSIGNED DEFAULT '0' NOT NULL,

CHANGE `equipentry2` `itemEntry2` MEDIUMINT(8) UNSIGNED DEFAULT '0' NOT NULL,

CHANGE `equipentry3` `itemEntry3` MEDIUMINT(8) UNSIGNED DEFAULT '0' NOT NULL,


ADD INDEX(newEntry),


UPDATE `creature_template` ct, `creature_equip_template` cet

SET ct.`equipment_id` = cet.`newEntry`

WHERE ct.`equipment_id` = cet.`entry`;

UPDATE `game_event_model_equip` geme, `creature_equip_template` cet

SET geme.`equipment_id` = cet.`newEntry`

WHERE geme.`equipment_id` = cet.`entry`;

UPDATE `creature` c, `creature_equip_template` cet

SET c.`equipment_id` = cet.`newEntry`

WHERE c.`equipment_id` = cet.`entry`;

UPDATE `creature_equip_template` SET `entry` = `newEntry`;

ALTER TABLE `creature_equip_template`


DROP COLUMN `newEntry`;
So when I try to apply it to my World DB i get this error :
Line no.:8

Error Code: 1054 - Unknown column 'equipentry1' in 'creature_equip_template'

I have a fresh copy of the latest Trinity DB (335.11.39) and my core is in the last revision.

So have I made something wrong with the updates or stuff like that ?

Thanks for your future answers

Link to comment
Share on other sites

I just checked again and I don't missed any update. I also emptied my World DB and applied the updates again and I got the same error

something you did wrong...

I just did a fresh load of the World Database with all SQL updates and i didn't get that error!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By xgamerninjax
      Hello all, first time posting here and it's really got me scratching my head.
      I've compiled everything on my own computer, and then transferred everything to a host computer so the server can stay live. The server was running fine for a month or so and then suddenly it just crashes when it hits "Loading C++ scripts", exiting saying "caught signal 22"
      I tried setting up the host computer from scratch and transferred everything over fresh and it's still happening for some reason. (Note, I can run the server perfectly on my personal pc where I compiled it.)
      Any help would be greatly appreciated, thanks!
      3d7e3a40e2b3+_worldserver.exe_[1-4_15-19-45].dmp 3d7e3a40e2b3+_worldserver.exe_[1-4_15-19-45].txt
    • By Rochet2
      A lot of people have asked how to debug so I made this short guide on how to set up debugging.
      This guide only tells you how to actually set up debugging in TrinityCore on Windows and Linux.
      This will not explain the basics of debugging. You can google those or play around with the debugger to learn.
      Here are a few videos that explain how to actually debug after setting debugging up on visual studio: https://youtu.be/0ebzPwixrJA and linux: https://www.youtube.com/watch?v=sCtY--xRUyI

      This guide contains multiple guides. Each list of bullet points is it's own guide.
      Make sure you can run the server normally before trying to debug.

      On Windows before anything you should check these
      - Before debugging or making crashlogs etc. with Visual Studio you must compile the core in "Debug" instead of "Release". You can select this in "Build>Configuration Manager" or at the top of Visual Studio window http://i.imgur.com/5oHd59j.png
      - You also need to move the new pdb files generate by compiling in debug mode on Visual Studio from the compile output folder (bin) to your server folder - these files contain information needed for debugging.
      - It is assumed that Solution Explorer is open. Open it by selecting "View>Solution Explorer" in Visual Studio http://i.imgur.com/hkW6Gk0.png
      -- You may want to click on the Home icon to reset the view on Solution Explorer http://i.imgur.com/N8UPwDh.png
      - You can place breakpoints in Visual Studio editor by right clicking a line of code and selecting "Breakpoint>Insert Breakpoint" http://i.imgur.com/L2TxBVG.png
      - At the top of the window you should see controls for stepping and continuing when you have started to debug.
      - Here is a video showing the basic Visual Studio functionality https://www.youtube.com/watch?v=Ijdk4z8-2OI
      Fastest way to debug on windows. This is the easiest way to start up debugging a script.
      - Start the authserver and worldserver normally
      - Open TrinityCore.sln in Visual Studio. This is what you usually open when you want to compile the core
      - In Visual Studio at the top select "Debug>Attach to process...>worldserver.exe" and click "Attach" http://i.imgur.com/jDEI2Hq.png
      - You are now debugging
      The second slower way of debugging on windows. This is useful for debugging something that occurs in the startup of the server.
      - Open TrinityCore.sln in Visual Studio. This is what you usually open when you want to compile the core
      - In solution explorer right click on worldserver and select "Set as StartUp Project" http://i.imgur.com/wvMzeRA.png
      - In solution explorer right click on worldserver and select "Properties" http://i.imgur.com/rTNEF9O.png
      -- In Properties you should go to "Configuration Properties>Debugging" and edit "Working Directory" to point to the server folder. For me this is the default compile folder so I use "$(OutDir)" http://i.imgur.com/aRI29fB.png
      - Start the authserver normally
      - Start the worldserver by selecting "Debug>Start Debugging". The server will start with debugging attached from the beginning http://i.imgur.com/cg1KJNw.png
      - You are now debugging
      Crashlogs on windows. Once you have a way to reproduce a crash you can get a crashlog that can help you resolve it.
      - After compiling the core in "Debug" instead of "Release" start up the worldserver and authserver
      - Reproduce the crash you have
      - In the server folder there is now a folder called Crashes that contains txt and dmp files. http://i.imgur.com/9eQIdql.png
      - You can open the txt files in text editors http://i.imgur.com/EH6R17E.png
      -- At the top of a txt file there is some information about your system and below it there is the Call Stack and below that there are Variables of each part of the call stack
      -- The Call Stack will tell you at the top what was the last function call before crashing and what function calls led to that function call.
      -- Next to the function names there is the file that the function is defined in and the line number the code was executing in that function.
      -- In the Variables section you can inspect variables that were present at each function call.
      -- Based on this information you are often able to see what crashed or get a better view of what you need to inspect more in your code.
      - The dmp file can be opened in Visual Studio
      -- Open TrinityCore.sln in Visual Studio. This is what you usually open when you want to compile the core
      -- Drag and drop the dmp file to Visual Studio
      -- In the window that opens click to "Debug with Native Only" http://i.imgur.com/OgyU2kM.png
      -- In the window popup click "Break" http://i.imgur.com/4jDzqRn.png
      -- You are now in a state like you would have hit a break point in the code or a crash while debugging. You can inspect the call stack and the variables.
      Edit and continue on windows. When debugging this allows you to change the code and without restarting the server apply those changes so they actually work ingame.
      - Open TrinityCore.sln in Visual Studio. This is what you usually open when you want to compile the core
      - In solution explorer right click on worldserver and select "Properties" http://i.imgur.com/rTNEF9O.png
      -- In Properties select "Configuration Properties>Linker>General" and set "Enable Incremental Linking" to "Yes". http://i.imgur.com/caQqwN5.png
      -- In Properties select "Configuration Properties>Linker>Advanced" and set "Image Has Safe Exception Handlers" to "No". http://i.imgur.com/FYzN8Ks.png
      -- In Properties select "Configuration Properties>C/C++>General" and set "Debug Information Format" to "Program Database for Edit And Continue". http://i.imgur.com/pxQ6I8N.png
      - At the top of the window select "Tools>Options". In the Options select "Debugging>General" and in there select "Enable Edit and Continue", "Enable Native Edit and Continue" and "Require source files to exactly match the original version".
      - Compile the server for the changes to take effect.
      - Set up "The second slower way of debugging" (I did not test edit and continue on other configurations)
      - Start the authserver normally
      - Start the worldserver by selecting "Debug>Start Debugging".
      - Try edit a cpp file a little and save it.
      - At top of Visual Studio window select "Debug>Apply Code Changes" and wait until the changes are applied. Warning: it can take considerable amount of time for the changes to be applied. http://i.imgur.com/77pb58E.png
      - If you have issues, be sure to check the error messages in Output. You can view it by selecting "View>Output" http://i.imgur.com/4cIznW9.png
      - This guide was written based on https://msdn.microsoft.com/en-us/library/esaeyddf.aspx and https://blogs.msdn.microsoft.com/vcblog/2015/07/22/c-edit-and-continue-in-visual-studio-2015/
      First we need to compile the server in debug mode.
      - Compile the server with the cmake flag -DCMAKE_BUILD_TYPE=Debug

      Debugging on linux. You can debug on linux by using GDB.
      - Here is a good video about it: https://www.youtube.com/watch?v=sCtY--xRUyI
      - Basically you
      -- Start the authserver
      -- Start the worldserver by using "gdb ./worldserver"
      -- Enter breakpoints by using break command on gdb
      -- Use the run command on gdb to start the server
      -- You are now debugging
      - You may also be interested in using VScode or some other more visual debuggers. https://www.youtube.com/watch?v=B0xTgyCwsAo
      Crashlogs on linux. Once you have a way to reproduce a crash you can get a crashlog that can help you resolve it.
      - Take crashreport.gdb from /contrib/debugger from source folder and place it to your server folder
      - Start the authserver
      - Start the worldserver by using "gdb -x crashreport.gdb ./worldserver"
      - Reproduce your crash
      - There should be a backtrace.log in your server folder that contains information about the crash like the callstack and variables in each function call in the call stack
      - This guide was written based on https://github.com/TrinityCore/TrinityCore/blob/master/contrib/debugger/README
      Running valgrind on linux. This helps you find memory errors like invalid reads and writes and memory leaks.
      - Here is a good video about it: https://www.youtube.com/watch?v=fvTsFjDuag8
      - Basically you
      -- Start the authserver
      -- Start the worldserver by using "valgrind ./worldserver"
      -- Run your code that you want to analyze and close the server
      -- The console or an output log should contain the valgrind log
    • By reyne
      Hey there!

      I've followed a few threads here about map extraction, and am still having issues. Originally, I was having the issue described here.
      After following the advice given in that thread (creating characters of both BC races and running around for a bit), I am no longer getting that error, however now I get the following error while trying to extract maps:

      `Error loading World\Maps\Expansion01\Expansion01_42_6.adt`

      This repeats for every line in Expansion01, and then the extractor crashes.

      I'm not sure where else to go from here.

      Thanks for your help

      Edit: I've created an 85 on an i85 server and flown all around Outland now, same issue.
    • By Uee
      I recently found the Trinity Cataclsym Preservation Project and thought I will try it out.
      I am already running 3.3.5a and Master - both server run great
      Pulled 4.3.4 down using Git and built it same way as others:
      boost_1_73_0 cmake 3.17.2 Mysql 5.7.30 VS Community 2019 Built fine - no issue. Used 'Extractor.bat' to run all the map extractors - worked great!
      Noticed there was extra file 'connection_patcher.exe`, ran that - worked great! Now have "wow_patched" and use this to launch client
      MySQL runs in standalone mode, -initialize, added base sql files, imported, auth and character sql files
      Configured both the .conf files and passwords, IPs etc are all in place.
      Note: When loading the exe and built conf file, bnetserver complain about these items missing, so I add them:
      Updates.AutoSetup = 1 Updates.EnableDatabases = 0 LoginDatabase.SynchThreads = 1 Load up Mysql - loads fine
      Load up bnetserver and appears to load ok - last few lines look like this:
      Connected to MySQL database at
      DatabasePool 'auth' opened successfully. 2 total connections running.
      Started auth database connection pool.
      Listening on connections from worldservers on port 1118...
      Load up worldserver and it adds the FULL world and hotfixes, then applied all updates (confirmed archived in SQL) - last few lines look like this:
      Calculate next monthly quest reset time...
      Calculate random battleground reset time...
      Calculate guild limitation(s) reset time...
      Calculate next currency reset time...
      World initialized in 0 minutes 13 seconds
      TrinityCore rev. d0c7bbab40bc 2020-05-06 00:01:21 +0200 (master branch) (Win64, RelWithDebInfo, Static) (worldserver-daemon) ready...
      There are no db errors in logs.
      Config.wtf contain portal, realmlist as remote server and patchlist as localhost.
      When I try to connecting using "[email protected]" and password I get immediately disconnected.
      What I did noticed different is that the bnetserver doesnt add "Added realm "Battle for Azeroth" at" (From my Master log) 
      3.3.5a also have this line as last line in authserver - but 4.3.4 is not giving me this one.
      Realmlist table is accurate with right information.
      Anyone know why bnetserver is not starting me realm?
    • By Deer_Hunter
      Hello all,
      I just updated from the latest Git 
      Trinity Core REV. ac6baa547376 + 2020-02-21  3.3.5 Branch.
      I'm getting this error after crash.
      Problem signature:
        Problem Event Name:    APPCRASH
        Application Name:    worldserver.exe
        Application Version:
        Application Timestamp:    5e50a462
        Fault Module Name:    StackHash_f12f
        Fault Module Version:    6.3.9600.19629
        Fault Module Timestamp:    5e2fdc0d
        Exception Code:    c0000374
        Exception Offset:    PCH_9E_FROM_ntdll+0x0000000000090D0A
        OS Version:    6.3.9600.
        Locale ID:    1033
        Additional Information 1:    f12f
        Additional Information 2:    f12f0934d3e965f73c68e60f20f2cd40
        Additional Information 3:    7595
        Additional Information 4:    7595e4d8d703db9dcd3d2f6ea540e357
      the exception code says its a Heap error,  I'm not sure how to troubleshoot this.
  • Create New...