Jump to content
TrinityCore

Stuck at connected / infinite loop / login issues / battle.net


CFGhost
 Share

Recommended Posts

Greetings friends,

 

I come to you with an unfortunate problem. But first, some info

 

 

Server:

Ubuntu Server 12.04

TrinityCore rev. 96c50c424c8f 2014-02-11 15:14:02 +0100 (master branch) (Unix, Release)

TDB 335.52

 

The symptom is being stuck on Retrieving Character List.

Realmlist table is correctly set to the external IP.

 

to troubleshoot I have tried making a fresh build and fresh DB install, and then updating to latest revision and trying a fresh build and fresh DB install there. I have tried running the server as a local server and tunneling ports 3724 and 8085 to connect instead locally through my server. Most of the solutions I can find online are for Windows and are related to forwarding of ports or setting this realmlist table but the ports are listening and reachable and the realmlist is set properly.

 

I dunno what to do now.

Link to comment
Share on other sites

Can anyone confirm that a fresh linux build works okay?

I updated my windows build to the same revision as the linux one, and although there was apparently a missing SQL update file (to create auth.rbac_default_permissions) it works fine. Another symptom I noticed was that on linux, the .acc set gmlevel command gives the "You set GMlevel of x to y" output it does not create an entry in the account_access table whereas on windows it does.

Link to comment
Share on other sites

learn to fucking search.

 

 

I know it sounds hard, but, it really isn't.

 

More indications of hostility, intentional or not. Not even you were perfect when you began everything in your life. I bet you fell a lot when you started to walk (we all do). Same goes for riding a bike, writing, spelling, and even using search boxes. Did you really have 100% perfect search use the very first time you ever used a search box? I bet not. Lighten up. Don't be so aggressive towards people that aren't as computer literate as you and I seem to be. Have you ever needed to point me to the search box? I do still have one problem, though. I reflect (and almost always amplify) the type of feedback I get. Lately, and I assume there's some personal problem causing it, you have been showing more and more attitude. The community isn't your enemy. New members are simply not going to know as much as you know about this project. I know I have a lot to learn still, but I try every search I can think of before I ask for assistance. I'm not Joe Average, though.

Link to comment
Share on other sites

  • 7 months later...
  • 2 weeks later...

Hi Everyone,

 

First, sry for my bad english i'm french and i try to have a nice english so i rarely use translator.

 

Here is the problem :

 

I use No-IP and MySQL 5.1 ( SQLYog for edit my Database ).

My server correctly run in local, so lot of my friend come at my home can play in my server and edit Database with their computers.

 

I actually try to put my server on the Web but only the distant access for DB Work, i mean, if my friend try to connect at my Database from their home, it's work.

 

But when my friend try to connect at my server from their home, he's stuck at the choice of the realm. And if selected the realm and click OK, after 5 second he are not connected and my friend are again in the "realm" choice.

So maybe someone can help me about that ?
 
Don"t hesitate if you need more informations !

 

PS : If my english are too bad just say to me and i use a translator.

See you !

Link to comment
Share on other sites

  • 6 months later...

Hello guys,

I'm new in waters of Trinity Core, but that's not the point :) Recently I tried to run WoW server on my second machine, it's rig with CentOS 7 system on it.

 

I didn't have a single problem until I managed to run server and start the whole thing up.

 

So, here's explanation.

- I have two computers connected by LAN. Windows computer shares Internet connection via LAN for Unix. IP of unix is 192.168.137.137.

 

- World server works fine, it's up, created 1st account with common commands.

- Auth server is up, I edited realmlist table with name of server and IP above.

 

Screenshot - http://i.imgur.com/UTwUwvW.png

 

The thing is I cannot connect with WoW.exe client to that Unix rig. I already set realmlist to IP of Unix, but it seems like something block my connection. I can't access Webmin too by using browser and IP on Windows computer.

 

Do you have any idea what's wrong?

- IPV4 settings on Windows for Internet connection share?

- /etc/hosts ?

- Something else?

- Isn't Unix suppose to have all ports open by default?

 

I'm not in rush, when you have some time to spare, help me please solve this issue.

 

Thank you!

Edited by Nazzgull
Link to comment
Share on other sites

Okay, I've managed to login now :) But only if I disable Firewall on CentOS 7.

 

Do you know what ports I need to leave open?

sudo systemctl disable firewalld
sudo systemctl stop firewalld

I think it's not a wise choice.

Edited by Nazzgull
Link to comment
Share on other sites

  • 4 weeks later...

Salutations,

 

While I am new to this particular community, I am by no means new to running servers.  I am a veteran systems, storage, and network engineer for a website that many in this community likely know well.  For some time before attempting to run a TrinityCore server I operated a MaNGOS 1.12 WoW server.

 

I recently attempted to compile and host a Trinity server running 3.3.5a and came to encounter the problem in this thread:

 

I read through all 10 pages of responses but never did I see a definitive answer to why clients outside my network could not connect to a realm.  When I used MaNGOS as my server back-end, the solution was in fact as simple as updating the Auth.Realmlist table with the FQDN of my server in the ‘address’ field.  What had been, in MaNGOS, a relatively simple step then, turned into 4-5 hours of troubleshooting with TrinityCore.  I have finally come upon an answer, and in it I offer a suggestion to the dev team –

 

Based on my testing, I discovered that Trinity appears to handle DNS resolution of the Realm server-side.  Utilizing a series of packet captures in Wireshark, I came to the understanding that if you provide a FDQN in the address field of the Realm.Realmlist table, the Trinity Auth server will perform the name resolution prior to communication with the client.  What is passed to the client is the pre-resolved IP address that the Trinity server itself discovered / resolved.  Here is a breakdown:

 

  • For each realm ID, server does nslookup on ‘address’ value and assigns it to a variable. 
    • Example:   RealmIP_ID1 = nslookup (Auth.realmlist.address_id1)
  • Client connects to Auth server for authentication.
  • Auth server responds with RealmIP_idx (once for each realm ID found in the DB)

 

The trouble with this approach of course, is that it causes a split horizon DNS problem for clients attempting to access a Trinity server that has done a resolution to an IP address that is unreachable by the client.  This likely explains why so many users have been running into problems when connecting to a Trinity server on this thread.  My perimeter gateway firewall had been setup to override my external FQDN server hostname in DNS with the internal IP, which caused the TC Auth server to resolve and send an RFC 1918 address to clients on the internet – something that obviously will not work.

 

What I would suggest is updating the server-side code to pass the FQDN as it was entered in the address table so the client can perform its own name resolution of the FQDN.   E.g. host-record.domain.com:8085 instead of resolved_IP_Addr:8085

 

Let me know if you have any questions.

 

Regards,

 

-ElGuapo

Edited by elguapo
Link to comment
Share on other sites

  • 2 weeks later...

I have some problem.

I have router, and server have only local IP, but all traffic rout from router to server.

If i set binding to 0.0.0.0 in authserver.conf i can connect only from LAN machines.

If i try set external IP i have error in console:

TrinityCore rev. 1a7a9619d87e+ 2015-06-13 00:56:24 +0200 (3.3.5 branch) (Unix, Release) (authserver)
<Ctrl-C> to stop.

Using configuration file ../etc/authserver.conf.
Using SSL version: OpenSSL 1.0.1f 6 Jan 2014 (library: OpenSSL 1.0.1f 6 Jan 2014)
Using Boost version: 1.54.0
Daemon PID: 19114

Opening DatabasePool 'auth'. Asynchronous connections: 1, synchronous connections: 1.
MySQL client library: 5.5.43
MySQL server ver: 5.5.43-0ubuntu0.14.04.1 
Connected to MySQL database at 127.0.0.1
MySQL client library: 5.5.43
MySQL server ver: 5.5.43-0ubuntu0.14.04.1 
Connected to MySQL database at 127.0.0.1
DatabasePool 'auth' opened successfully. 2 total connections running.
Started auth database connection pool.
Updating Realm List...
Added realm "Шторм [x1]" at 188.168.24.29:8085.
Exception caught in SocketMgr.StartNetwork (188.168.24.29:3724): bind: Cannot assign requested address

Ports 8085, 8086, 1119 and 3724 opened.

1 year ago it work fine with binding to 0.0.0.0 but after update from git and rebuilding it fail :(

  • Upvote 1
Link to comment
Share on other sites

  • 5 weeks later...

I got it fixed now i changed the gamebuild in the realm list when I shouldn't have.

​I have no idea how many times we have to say it but do not change that gamebuild unless you know what you are doing.

You are not the first nor the last one doing that tho.

 

P.S Sorry for the mini rant, just tired of people doing the same mistakes and then wondering why stuff doesn't work 

  • Upvote 1
Link to comment
Share on other sites

This was my first time ever compiling , after reading through the forum I didn't find anything about my first error so I stupidly tried suggestions then I went back a second time and manage to find the info and changed the gamebuild back. I completely understand the rant some people don't even bother to read they just go in and start messing with things then demand help.

  • Upvote 1
Link to comment
Share on other sites

  • 4 weeks later...

It may be due to many many reasons:

  • Check your router/firewall, if the ports are redirected to correct machine (or redirected at all). This is very common amongs wifi routers with default config from ISPs.
  • Check your database realmlist if it has the public IP address, example, 80.24.24.24 (not my IP, invented just for the example) instead of 192.168.0.x. Check you IP here
  • Check your worldserver config, specially the part which says, listen, either set it to 0.0.0.0 for it to listen on all addresses, or put the public

Your issue seems caused by the last 2 points, as you can connect to auth already.

Link to comment
Share on other sites

It may be due to many many reasons:

  • Check your router/firewall, if the ports are redirected to correct machine (or redirected at all). This is very common amongs wifi routers with default config from ISPs.
  • Check your database realmlist if it has the public IP address, example, 80.24.24.24 (not my IP, invented just for the example) instead of 192.168.0.x. Check you IP here
  • Check your worldserver config, specially the part which says, listen, either set it to 0.0.0.0 for it to listen on all addresses, or put the public

Your issue seems caused by the last 2 points, as you can connect to auth already.

​Now it got stuck on Success! and then I was thrown to the realms list and got stuck on Logging in to game server again. I tried the last two points.

 

Link to comment
Share on other sites

If it stucks in success, means that worldserver is not getting connected to, are you using windows? if so, check windows firewall, sometimes the window to allow it to connect to the internet is missed and you have to manually enable it.

It may also mean, that you forgot to redirect the world port to the computer, as it is not getting connected, so try point 1 also, or configure your NAT firewall accordingly

Link to comment
Share on other sites

  • 3 weeks later...

Hi,

I have a problem with trinity core (6.x branch).

I compiled the server on a machine, which host the game server.

On this machine, when i tried to connect to the game server with my Wow 6.2 Client, no problem, all is running, i can play to the game.

When i try on my remote machine, i can't connect to the server (104 error).

What i have done :

  • Changing the IP address in the realmlist table of the auth database (server public IP address, fixed).
  • Changing the IP address in the WTF config file (WTF\config.wtf, SET portal "SERVERIP").
  • Wow.exe, and Wow-64.exe patch, with connection_patcher, after a first launch of the client to connect to official server.
  • Client download on my remote machine.

So I have the same client on my server and on my remote machine.

On the server, all is fine, On my remote machine, i can't connect and i got a 104 error when i try.

In the log files, i see that the game client try to connect to the correct IP address, witch is my server public IP address.

I openned my firewall ports, i also tried to deactivate it...

Somebody have a solution for me?

 

I sait that I only copy the game folder (folder that contains Wow.exe and Wow-64.exe), I don't know if the problem comes from that, I didn't have this problem with wow 3.3.5a, and I had done the same way.

 

Thanks for your help :)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...