Jump to content
TrinityCore
Munga

Dbc, Maps, mmaps, Vmaps problems

Recommended Posts

Sind Sie mit den richtigen Verzeichnisbaum?

 


Correct *.map files not found in path 'data/maps' or *.vmtree/*.vmtile files in 'data/vmaps'. Please place *.map/*.vmtree/*.vmtile files in appropriate directories or correct the DataDir value in the worldserver.conf file.

 

Grüße.

Mortos.

Share this post


Link to post
Share on other sites

Du hast entweder den Pfad in der Config nicht korrekt eingestellt oder aber die Maps von einem falschen Clienten gezogen. Beachte, dass der Master Branch mit 3.3.5a arbeitet und die Maps, VMaps und MMaps entsprechend von diesem erstellt werden müssen.

Share this post


Link to post
Share on other sites

VMaps und MMaps entsprechend von diesem erstellt werden müssen.

Auch mit Ihrem eigenen, zusammengestellt Tools (CMake).

 

Grüße.

Mortos.

Share this post


Link to post
Share on other sites

Ich habe alles nach der Anleitung für Linux gemacht und mit den compilierten tools alle maps gezogen. An der config habe ich für die maps ichts geändert.

Share this post


Link to post
Share on other sites

Hi,

erstmal sorry, für die verspätete antwort, aber ich war im Urlaub und konnte da nicht direkt schauen.

 

Server.log: 

Using SSL version: OpenSSL 1.0.1e 11 Feb 2013 (library: OpenSSL 1.0.1e 11 Feb 2013)
Using Boost version: 1.49.0
Realm running as realm ID 1
Using World DB: TDB 335.54
Will clear `logs` table of entries older than 1209600 seconds every 10 minutes.
Using DataDir ./data/
WORLD: MMap data directory is: ./data/mmaps
VMap support included. LineOfSight: 1, getHeight: 1, indoorCheck: 1
VMap data directory is: ./data/vmaps
Map file './data/maps/0004331.map': does not exist!
Correct *.map files not found in path './data/maps' or *.vmtree/*.vmtile files in './data/vmaps'. Please place *.map/*.vmtree/*.vmtile files in appropriate directories or correct the DataDir value in the worldserver.conf file.

Die Maps wurden mit der WoW Clientnummer: 12340 entpackt und über dewn linux benutzer, der auch die rechte für das starten des servers hat.

Share this post


Link to post
Share on other sites

da steht es doch das der path nicht stimt zu deinen maps

Passe in der Confing den Path 'DataDir' an

So steht es bei dir wahrscheinlich in der Confing und da liegt der Fehler

DataDir = "./data" 

so siet es bei mir aus

 

DataDir="/home/trinity/server/Lk/data"

siehst du den Fehler

Share this post


Link to post
Share on other sites

Das war mir schon bewusst und ich habe das auch gemacht. Aber das Problem habe ich auch bereits gelöst. Habe die DBC und Maps nochmals extrahiert und kopiert, jetzt geht es, ich muss nur nochmal die VMaps und MMaps extrahieren.

Share this post


Link to post
Share on other sites

Well, i have some problem with mapextractor (i have the latest version of everything). it shows me this:

lYa99g.png

 

In addition, to this problem, i have problem in vmapextractor too:

8cjduX.png

 

Haven't found anything similar.

Anyone have a solution?

 

btw, i have windows 7 ultimate 64 bit.

Edited by R-MaX

Share this post


Link to post
Share on other sites

Well, i have some problem with mapextractor (i have the latest version of everything). it shows me this:

lYa99g.png

 

In addition, to this problem, i have problem in vmapextractor too:

8cjduX.png

 

Haven't found anything similar.

Anyone have a solution?

 

btw, i have windows 7 ultimate 64 bit.

 

That happens with incomplete 4.3.4 versions.

Share this post


Link to post
Share on other sites

Just thought I would add that I successfully extracted everything (3.3.5a) under Debian yesterday, and that mmaps only took 4 1/4 hours this time. :)

Share this post


Link to post
Share on other sites

Just thought I would add that I successfully extracted everything (3.3.5a) under Debian yesterday, and that mmaps only took 4 1/4 hours this time. :)

Wow, and I thought my gaming rig is ancient, few days ago it did mmaps in 2,5 hours for 335a.

434 took me about 3,5 hours, probably for the new areas?

Share this post


Link to post
Share on other sites

Wow, and I thought my gaming rig is ancient, few days ago it did mmaps in 2,5 hours for 335a.

434 took me about 3,5 hours, probably for the new areas?

Gaming rig? That was on my server.

Share this post


Link to post
Share on other sites

Just thought I would add that I successfully extracted everything (3.3.5a) under Debian yesterday, and that mmaps only took 4 1/4 hours this time. :)

 

Wow, and I thought my gaming rig is ancient, few days ago it did mmaps in 2,5 hours for 335a.

434 took me about 3,5 hours, probably for the new areas?

 

Last year I dusted off an old Dell Dimension 2400 so I could extract maps on it while I played some LotRO and it took over 24 hours for the mmaps to finish.

 

Needless to say I won't be doing that anytime soon.

Share this post


Link to post
Share on other sites

Last year I dusted off an old Dell Dimension 2400 so I could extract maps on it while I played some LotRO and it took over 24 hours for the mmaps to finish.

 

Needless to say I won't be doing that anytime soon.

There are some really good optimizations on the mmaps.exe, a few months ago it took me about 5h for 3.3.5a and now only 2,5h on an old Core2Quad Q9550.

Share this post


Link to post
Share on other sites

 

vmapcrash_zps460c55a8.png

 

map extraction TC 4.3.4  

 

i ran mapextractor.exe fine  then made the bat file   with the following 

 

vmap4extractor.exe

md vmaps

vmap4assembler.exe Buildings vmaps

pause
 

Ran file goto below and clashed  

 

Extracting Worldwmotransportstransport_zeppelintransport_zeppelin.wmo
Extracting WorldwmotransportsWMO_elevatorsAbyssal_Jellyfish_Elevator_transpo
rt.wmo
Extracting WorldwmotransportsWMO_elevatorsND_Ship_UD_BG_Transport.wmo
 
E:World of Warcraft - Cataclysm>md vmaps
 
E:World of Warcraft - Cataclysm>vmap4assembler.exe Buildings vmaps
using Buildings as source directory and writing output to vmaps
Could not read dir_bin file!
exit with errors
 
E:World of Warcraft - Cataclysm>pause
Press any key to continue . . .
 
 
error_zpsaf884e2b.png

 

 

I've got the same problem but under linux.

 /server/bin/vmap4assembler Buildings/ vmaps/
using Buildings/ as source directory and writing output to vmaps/
Could not read dir_bin file!
exit with errors

Does anybody now how to solve it?

Edited by tima2000

Share this post


Link to post
Share on other sites

Hello all,

 

I've been searching all over. There are more topics to this question, but I cannot find a solution.

 

When I run the .bat file it extracts loads of .wmo files. Until it gets stuck at

"Extracting WorldwmotransportsWMO_elevatorsND_Ship_UD_BG_Transport.wmo"

 

I've asked on #trinity IRC. They say it's because my client is incomplete. I've downloaded the 4.3.4 WoW client from the Molten WoW torrent. indeed when I log on into a server of theirs, my game says it's still downloading at 63%

It takes 5 hours to get 1 % and when I enter a new area, it goes back to 49%

 

I've searched all over and downloaded multiple clients. Some were even just virusses and such.

Do I have to keep looking? Or is something else wrong?

 

Maybe someone has a a link I could use to get 100% 4.3.4

 

 

 

I'm using:

Windows 7 64bit

VS2013 64bit

CMake 2.8.12.2

HeidiSQL 8.3.0.4694

Git Extensions

I've been using this Tut: http://collab.kpsn.org/display/tc/Win+4.3.4

Edit: Using WoW enGB 4.3.4

 

Hopefully this is enough info.

Thanks

Edited by WoMBaTToS

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By roweqharoji
      Hi guys, this is my first post for help. I think this may be a really noob problem, but I just can't...... Sorry first if there's any mistakes.
      I tried to host 4.3.4 from https://gitlab.com/trinitycore/TrinityCore_434, but with no luck I keep recieving error like The `spell_proc` table entry for spellIdXXX has Attribute PROC_ATTR_REQ_SPELLMOD, but spell has no spell mods. Proc will not be triggered. Detailed log is attached below.
      I have host 3.3.5 without error, but when it comes to 4.3.4, I just can't figure out how to solve this situation. I've tried searching for similar problem, but they said it's client side issue. like this https://gitlab.com/trinitycore/TrinityCore_434/issues/165. I tried download different client data such as wowmortal, atlantiss, mangos wowregeneration...and other two client. But no luck with those...
      If anyone can show me any hint, I would really appreciate
      DBErrors.log
    • By omgdior
      Hello user!  Help me please. How to extract the client DBC, Maps, VMaps & VMaps. I for some reason after 3.3.5 can not understand what to do in the new version. I hope for you.
    • By JourneyJay
      So far, it appears to be irrelevant, since extraction continued, and I'm assuming the client will load. If not, I'll update this post.
       
      Map Extractor fails to find a series of files, but continues onward. A jpeg is linked via google drive below.
      https://drive.google.com/file/d/0By4quSN6E7RvTFhvdjZSS3JSZjQ/view

    • By hashimoff
      Hi Everybody I have problem with map extractors.
      When I run mapextractor.exe and vmapextractor.exe I got this error
      d:\Program Files\World of Warcraft>mapextractor.exe Map & DBC Extractor (vmaps too) =================== error opening casc storage 'd:/Program Files\World of Warcraft\Data': FILE_NOT_FOUND Can anyone Help ME?
    • By leandrod
      Hello guys , good night . I'm new here and I have a problem to extract the maps and vmaps and other game files version 3.3.5a , as created the server in a virtual machine and do not have much room to pass the entire game to the folder on Linux and why I need to do this process on windows and then move the files , but can not find the software to extract the files in windows . Someone would have these updated extractors to pass me ?
×
×
  • Create New...