Sign in to follow this  
Followers 0
petartri

realmlist table
TrinityCore 4.3.4.15595

100 posts in this topic

We do not have a 4.3.4 branch.

0

Share this post


Link to post
Share on other sites

I believe this is the latest TrinityCore 4.3.4 branch before it was dropped:

https://github.com/Nickelangelo/TrinityCore/tree/4.3.4

You can find latest DB that was released:

https://github.com/Nickelangelo/TrinityCore/releases/tag/TDB434.09

 

I just found out this:

https://github.com/TrinityCoreLegacy/TrinityCore/commits/4.3.4

Edited by Exodius
added Legacy link
2

Share this post


Link to post
Share on other sites
8 hours ago, Exodius said:

I believe this is the latest TrinityCore 4.3.4 branch before it was dropped:

https://github.com/Nickelangelo/TrinityCore/tree/4.3.4

You can find latest DB that was released:

https://github.com/Nickelangelo/TrinityCore/releases/tag/TDB434.09

 

I just found out this:

https://github.com/TrinityCoreLegacy/TrinityCore/commits/4.3.4

Thanks really.

But did you test that DB and source your own?

0

Share this post


Link to post
Share on other sites
2 minutes ago, mahdishahidi said:

Thanks really.

But did you test that DB and source your own?

I did while I was working on things... It worked normally. Nowadays, I have no times for anything. That's why I even stopped submitting fixes for active branches. RL is a bitch.

I'd like to thank @Aokromes, @Killyana and everyone else that are keeping Legacy repo "up to date" by backporting things pushed to active (supported) branches.

1

Share this post


Link to post
Share on other sites

Hi to all developers of Trinity Core and thanks for making possible the WoW open source servers. I have two questions regarding 4.3.4. First, which are the advances in https://github.com/TrinityCoreLegacy/TrinityCore ? if you need help with that, we can help you (if interested please PM for details). Second, do you share my outrage about the other teams that make 4.3.4 and 5.4.8 repacks based on your core and DB and even give you credit ??? WowSource, by example

0

Share this post


Link to post
Share on other sites
2 hours ago, Nay said:

I'm not sure if you noticed that the repo you linked is named TrinityCoreLegacy/TrinityCore.

Check https://trinitycore.atlassian.net/wiki/display/tc/Installation+Guide#InstallationGuide-DevelopmentState for the supported version/branches.

I ask because I see activity en that repo, I'm curious and I cannot acces to https://trinitycore.atlassian.net/ since some days ago

0

Share this post


Link to post
Share on other sites

Hello there,

Is there any problem with the last rev. of the trinitycore legacy for patch 4.3.4? it is breaking when start loading the Objects, is this a known problem?

I will send the log so you can see where it stops, it literely break the pc, everything stops everytime i try to load at the same place, my 3.3.5 its working fine.

Thanks in advance.

Server.log

0

Share this post


Link to post
Share on other sites

TrinityCore does not mantain an active 4.3.4 branch. Stick with 3.3.5 or 6.x.

-1

Share this post


Link to post
Share on other sites

To me it looks like a database issue
It looks like the table it calls after >> Loaded 19670 gameobject_template_locale strings in 1906 ms
is what is causing your crash
Sorry I dont work with 4.3.4 so I dont have a log for 4.3.4 to point you in the right direction

Please enable your Dberror logging and launch core... it will point the issue out to you if it is db related and if the 4.3.4 has a solid dberror logging system
I hope this has helped you 
Good luck KyanagaCloud

0

Share this post


Link to post
Share on other sites

Hello,

I have problem with Characters DB, I can't update it because of an error 1091.

Screenshot : https://ctrlv.cz/tROn

Do you have any idea how to do it?

Thank you for your answers !

0

Share this post


Link to post
Share on other sites

I download a TDB (4.3.4-11) from here https://github.com/TrinityCoreLegacy/TrinityCore/releases

I compile de code from here https://github.com/TrinityCoreLegacy/TrinityCore.git

I extract maps,vmaps,mmaps and all things that i need to run my server and all its ok. But when a log in to my server the spells and any description relating to spells attributes appears with this sign (?????? 3% ?????)

Please help me .

Im going to upload a picture later..

0

Share this post


Link to post
Share on other sites
On 6/11/2016 at 10:39 AM, Nay said:

TrinityCore does not mantain an active 4.3.4 branch. Stick with 3.3.5 or 6.x.

 

0

Share this post


Link to post
Share on other sites

I know that but aokromes make a fork and work on it everyday and make updates periodicaly.

I update the pictures righ now .

pd : The worgen town is partiality empty and the quests does not work.

WoWScrnShot_072816_130525.jpg

WoWScrnShot_072816_130539.jpg

WoWScrnShot_072816_130545.jpg

WoWScrnShot_072816_130550.jpg

WoWScrnShot_072816_130620.jpg

WoWScrnShot_072816_130644.jpg

WoWScrnShot_072816_130653.jpg

0

Share this post


Link to post
Share on other sites

Worgen Zone isn'w works. On this must be fixed the quests and the spawns.

I think your client is broken, the text from spells etc. is from client and not from server, so your client can't load right the data to show.

0

Share this post


Link to post
Share on other sites

thxs,

Any sql to update for worgen and  goblin zones to work similar like blizz??

0

Share this post


Link to post
Share on other sites

Hello there,

I've recently tried to start a local TrinityCore Cataclysm (4.3.4) server. Unfortunately I've run into some problems. First of all I am quite confused about which core and which TDB to use. When I tried to start the server for the first time I used this core and this TDB (the TDB_full_world_434.14_2016_11_06.rar one). It went quite well. I imported the databases manually and when I started the worldserver.exe it failed to update the world DB. I re-imported the DB and disabled automatic updates in configs and the server started. But now when I wanted to try modifying an item I could not because in my item_template there were only 207 rows. Only 207 items. I checked the TDB.sql and it really did not have the item I wanted to modify. Now did anything the items change (the last time I started a server was like 4 years ago, the 3.3.5 branch) in Cataclysm TC? How do I modify them then. Oh and I could add them, lookup them and use them. They were not missing in the server.

Then I tried to start the server on my notebook, different machine, and I tried using the same TDB but different core (the Source Code.zip below the TDB). Again there were problems with updating (characters and world now), I let the worldserver.exe create, populate and update the databases as the wiki howto mentions. I also copied my mmaps, vmaps, ... from my PC and pasted them to this new server but then there was an error saying that the worldserver.exe could not find \vmaps\000.vmtree. But it is there.

So my questions are which core and which TDB should I use so there are no problems with updating etc. and how do I modify items which I can't find in the item_template.

Thank you.

0

Share this post


Link to post
Share on other sites

I'm using the currently passing 4.3.4 build

 

Hey!

I don't even know where to start, because everything is just totally screwed up.

First, worldserver was crashing because it tried to update the sql tables using files for 335->434 sql conversion (I've no idea why they were even present in the source). I just deleted those files and all seemed ok (except for the fact that it still updates some sql tables every time I run it)

Then, I found out that the locales_creature table is basically absent from the database. Weirdly, some npcs have names in English and some - in Russian (when I see them in game). Also, texts in books are unreadable because they appear as random letters/signs.

Now I just noticed that the item_template table only contains 207 records (I noticed that because I was going to edit an item in Truice, but it couldn't find it). Most bizzarely, the game client and worldserver.exe can still somehow access all items (lookup, add, etc.), including those not present in the item_template table.

Please, help me before I go totally insane

 

P.S. An additional problem for those of you who enjoy this: I'm trying to extract vmaps from my 4.3.4 client, and it seems to be working fine (with an occasional err=2), but in the end I get this: 

7a4qe12USFo.jpg

Then the program closes and my vmaps folder is empty.

Edited by Смердокрыл
0

Share this post


Link to post
Share on other sites

Hello, I need help with the realmlist table in my mysql database. I am using the legacy 4.3.4 Trinitycore which I compiled through the trinitycore guide. I browsed the wiki for information about the realmlist table, when I noticed that this wiki was really outdated. Could anyone help me out about this?

So what I am asking for is this, what is the region table? I wan't my server's region to be in Europe, as I suspects it's currently in USA or something similar. It's currently set on 2

Untitled.png

0

Share this post


Link to post
Share on other sites

Anyone else getting problems with the 4.3.4 branch since the updates with the newest commit where it will let you join into the world but other times it won't this was fine until the updates from 5 days ago.  Sometimes it works and others it don't and when I restart server it does then picks times not to work again.  Everything was fine until updates.

0

Share this post


Link to post
Share on other sites

I have two different things going on the server one is when I add a npc with mana the mana is not showing up on the npc but the mana field is being taken up not sure what is going on.  The other problem is when I get on the server it sometimes gets really bad lag on the 4.3.4 branch but other servers I have joined seem to work fine for me, wasn't sure if something in the server is doing this or not.  And the last problem I am getting with 7.2.0 branch is incompatible realmd is what it is saying when I select the realm list, not sure how to fix this.  Thanks for any help on this matter.

0

Share this post


Link to post
Share on other sites

The mana is due to the unit_class in the database make sure you have it on the correct class that you are wanting to make the npc have mana.  For the lag it is due to the server opcodes not being complete on some things that need to be updated also due to the server not being complete also.

0

Share this post


Link to post
Share on other sites

Mana is working now.  The last thing is the lag in the server I am getting.

0

Share this post


Link to post
Share on other sites

This is due to some opcodes not working properly which is trying to load at times, which also there are some things not complete with the server when it comes to loading certain pieces of the server.  This is why you are having problems with lag sometimes because you say it is not doing this problem with a different server, because you will also see a older server or newer one that has been running for a while with no updates to the commit it is running smoother because of the changes to the core in 4.3.4

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.