Jump to content
TrinityCore
Munga

Dbc, Maps, mmaps, Vmaps problems

Recommended Posts

Hello id like some advice is this error "File 'temp_gameobject_models' seems to be corrupted" something to be worryed about ?

Yeah thats normal, the file is read correctly but it seems to make 1 more read past the end of the file, showing that error, nothing to worry about tho

  • Upvote 1

Share this post


Link to post
Share on other sites

My WoW Client is on my windows desktop, and the size of it is really big, and it would take time for me to upload it to my server, i'm just wondering what are the needed files to compile Dbc, Maps, Vmaps instead of uploading the entire client.

Thank you!

Share this post


Link to post
Share on other sites

My WoW Client is on my windows desktop, and the size of it is really big, and it would take time for me to upload it to my server, i'm just wondering what are the needed files to compile Dbc, Maps, Vmaps instead of uploading the entire client.

Thank you!

Ok, so you are getting it wrong hehe, don't worry, I'll explain. (although you should read http://www.trinitycore.info/)

You DON'T have to upload the WoW client. You just have to upload Vmaps, Maps, DBCs. To answer your question about what are the needed files... well, if you compiled the core (and followed http://www.trinitycore.info/ instructions) you'd end up with a few tools (three ".exe" files in windows, don't know what extension are they in other OSs) named:

vmap4assembler.exe

vmap4extractor.exe

mapextractor.exe

THIS 3 files are the "needed files" for compiling dbc, maps and vmaps. (you do not upload these)

Now, you go and read "Extracting DBC/Maps/VMaps" (click on it) section from the wiki.

If you read carefully you'll see that you will end up with 4 new folders, DBCs, Vmaps, Maps and Buildings. You CAN delete the "buildings" folder. The other 3 (maps, vmaps and dbcs) ARE THE ONES YOU HAVE TO UPLOAD to your server.

To make that clear: After you use the tools for extracting the files, you ONLY UPLOAD THOSE NEW FOLDERS. And remember, you have to upload them in the same directory as your authserver and worldserver programs are.

I hope you understand now.

If you need more help, or if you manage to do it succesfuly, please tell me.

Good luck.

Delro

P.S.: If english is not your main language or if you don't know it very well, I recommend you to go to the localized sub-forums (http://www.trinityco...m/29-languages/) and post your problem in your native language. The guys over there might be able to help you better.

Share this post


Link to post
Share on other sites

Hi!

I have 3.3.5a and 4.3.2 installed on my pc, and i need to extract the vmaps,maps and dbc files, but when i run the extractor, i get a lot of error...

Extracting World\Wmo\Cataclysm\Firelands\Lavaboss_Platform\Firelands_Lavaboss_Platform_Destruction.wmo

No such file.

Couldn't open RootWmo!!!

Extracting World\Wmo\Northrend\Buildings\Nocollision_Destruct.wmo

No such file.

Couldn't open RootWmo!!!

Extracting World\Wmo\Northrend\Buildings\Human\Nd_Alliancegunship_Dragonsoul.wmo

No such file.

Couldn't open RootWmo!!!

Done!


Extract V4.00 2012_02. Work complete. No errors.


D:\World of Warcraft>vmap4assembler.exe Buildings vmaps

using Buildings as source directory and writing output to vmaps

Could not read dir_bin file!

exit with errors


Any idea?

Thanks in advance and greetings from Hungary!

Share this post


Link to post
Share on other sites

I run everything on Debian linux, and idk how to port the vmap_assembler so it runs on windows, anyone has a windows version they can upload for me? I need to redo the vmaps :)

Thanks in advance.

Share this post


Link to post
Share on other sites

Maybe other people dont have the ability to provide you a compiled exe

Share this post


Link to post
Share on other sites

You can cross-compile with MinGW. I started to cross-compile the vmap tools like that from my Debian machine to Windows but hit some issues with CMake I didn't feel like sorting through to fix a problem that wasn't mine (aka I don't care / need to run vmap on Windows...It was just a fun experiment). MinGW doesn't support -rdynamic option but CMake (for this project? in general? IDK, haven't looked at CMake much) enforces it during the build-tests and fails out.

Share this post


Link to post
Share on other sites

Dont know if this will make it a bit easier

Paste this inside a text file:

@echo off

vmap4extractor.exe -l -d Data

md vmaps

vmap4assembler.exe Buildings vmaps

pause

Rename the new text file to makevmaps4_simple.bat Paste this inside another new text file
@echo off

echo Wrong one dumbie!!!

pause

Rename the text file to make_vmaps3_simple.bat

Share this post


Link to post
Share on other sites

another related question... i got this:

Extracting GameObject models...Extracting WorldWmoBandFinal_Stage.wmo

No such file.

Couldn't open RootWmo!!!

Done!

Extract V4.00 2012_02. Work complete. No errors.

at the end of the extractor work.

is this a fault on my system, or someone else got this?

Share this post


Link to post
Share on other sites

another related question... i got this:

at the end of the extractor work.

is this a fault on my system, or someone else got this?

Other people, myself included, have also got that error for that WMO.

I looked through the MPQs and it in fact doesn't exist. It can be ignored.

Share this post


Link to post
Share on other sites

Hiya,

I am having trouble with extracting and assembling my vmaps.

It's pretty much the same as the error below:

http://www.trinityco...lem-with-vmaps/

OS: Windows 7 64bit

Client: WoW 3.3.5a

Compiler used to make the binaries: Visual C++ 2008 Express 32bit, no compile errors

I have administrator privileges, I do indeed see the binaries making the folders in my World of Warcraft folder, and sometimes it adds 1 wmo file in the Buildings directory, so there must be no issue with admin privileges.

I haven't got any registry keys assigned to WoW. It was taken off my old hard drive when I formatted and upgraded the OS.

I also have a 4.0.6a client in another folder, but I doubt that is an issue, it also was taken off my old HD.

Yes, the extractor/assembler are in my D:\World of Warcraft\ folder, which is 3.3.5a

Map extractor works fine.

I have used the batch file from the wiki and the following batch file:

vmap4extractor.exe -d Data

md vmaps

vmap4assembler.exe Buildings vmaps  

pause
This is the output:
D:\World of Warcraft>vmap4extractor.exe -d Data

Extract V4.00 2012_02. Beginning work ....


Game path: Data/

Found locale 'enUS'


Adding data files from locale directories.

Scanning patch levels from data directory.

Scanning patch levels from locale directories.

Locale: enUS


Opening Data/enUS/locale-enUS.MPQ

Opening Data/enUS/expansion-locale-enUS.MPQ

Opening Data/enUS/lichking-locale-enUS.MPQ

Opening Data/common.MPQ

Opening Data/common-2.MPQ

Opening Data/expansion.MPQ

Opening Data/lichking.MPQ

Opening Data/patch.MPQ

Opening Data/patch-2.MPQ

Opening Data/patch-3.MPQ

Opening Data/enUS/patch-enUS.MPQ

Opening Data/enUS/patch-enUS-2.MPQ

Opening Data/enUS/patch-enUS-3.MPQ

Read LiquidType.dbc file...Done! (26 LiqTypes loaded)

Extracting World\wmo\Dungeon\Azjol_Lowercity\Azjol_Lowercity.wmo


D:\World of Warcraft>md vmaps


D:\World of Warcraft>vmap4assembler.exe Buildings vmaps

using Buildings as source directory and writing output to vmaps

Could not read dir_bin file!

exit with errors


D:\World of Warcraft>pause

Press any key to continue . . .

From what I gather from this error, the map extractor is ending prematurely, and I have no idea why that is. The last time I had used the extractors was when TrinityCore was hosted on BitBucket, and on a 32bit windows xp OS. Is it because it's 32bit it's giving me this error?

I also attempted trying a different emulator vmap extractor, of course not to use for tc2, but just for testing sake, and it also provided the same error. I have searched for this error, and most results came back with a wrong client version, so I don't know what's going on. I'll try later today to use the binaries on my other PC which also has win 7 64bit

Any help would be appreciated.

Thanks

Share this post


Link to post
Share on other sites

I did a clean WoW install a few days ago, clean Trinity build, install and patched to 3.3.5a. Ran WoW a couple times and then extracted vmaps according to the wiki and go no errors. That probably doesn't help you but I can say it worked for me.

You could double check to make sure you don't have old extracted data sitting in your WoW folder from before since you copied your old WoW folder.

Share this post


Link to post
Share on other sites

Open a command prompt and point it to the path where the BAT file is. Run the BAT file from the command prompt (instead of double-clicking it). This will allow you to see the errors that are generated because the window won't close when the extractor craps out.

If the errors don't make sense to you, post them here.

Share this post


Link to post
Share on other sites

I did a clean WoW install a few days ago, clean Trinity build, install and patched to 3.3.5a. Ran WoW a couple times and then extracted vmaps according to the wiki and go no errors. That probably doesn't help you but I can say it worked for me.

You could double check to make sure you don't have old extracted data sitting in your WoW folder from before since you copied your old WoW folder.

Hiya, thanks for the input. I have already tried deleting Buildings/vmaps/maps folders, but it doesn't seem to solve anything.

Open a command prompt and point it to the path where the BAT file is. Run the BAT file from the command prompt (instead of double-clicking it). This will allow you to see the errors that are generated because the window won't close when the extractor craps out.

If the errors don't make sense to you, post them here.

It seems to produce the same error - I have also ran the vmap4extractor.exe by command prompt, but the most it can make is just a folder and 1 wmo file in it.

uhmy.png

I also found by repeatedly opening the vmap4extractor.exe, most of the time it produces a random wmo file, ranging from 0 kb file size, up to 600kbs

Edited by James

Share this post


Link to post
Share on other sites

You mentioned in your OP that you have both wow 3.3.5a and 4.x, did you run "wow.exe" from the 3.3.5a before using the extractors?

When you run wow.exe from any version it overwrites registry entries that the extractors use so if you've played the 4.x client recently, run the 3.3.5a client and close it (you don't need to actually log in), then immediately run the extractors.

Share this post


Link to post
Share on other sites

You mentioned in your OP that you have both wow 3.3.5a and 4.x, did you run "wow.exe" from the 3.3.5a before using the extractors?

When you run wow.exe from any version it overwrites registry entries that the extractors use so if you've played the 4.x client recently, run the 3.3.5a client and close it (you don't need to actually log in), then immediately run the extractors.

Yes, I have recently run the 3.3.5a client build 12340 and have closed it multiple times. I haven't ran the 4.x client in a while.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By omgdior
      Hello user!  Help me please. How to extract the client DBC, Maps, VMaps & VMaps. I for some reason after 3.3.5 can not understand what to do in the new version. I hope for you.
    • By JourneyJay
      So far, it appears to be irrelevant, since extraction continued, and I'm assuming the client will load. If not, I'll update this post.
       
      Map Extractor fails to find a series of files, but continues onward. A jpeg is linked via google drive below.
      https://drive.google.com/file/d/0By4quSN6E7RvTFhvdjZSS3JSZjQ/view

    • By hashimoff
      Hi Everybody I have problem with map extractors.
      When I run mapextractor.exe and vmapextractor.exe I got this error
      d:\Program Files\World of Warcraft>mapextractor.exe Map & DBC Extractor (vmaps too) =================== error opening casc storage 'd:/Program Files\World of Warcraft\Data': FILE_NOT_FOUND Can anyone Help ME?
    • By leandrod
      Hello guys , good night . I'm new here and I have a problem to extract the maps and vmaps and other game files version 3.3.5a , as created the server in a virtual machine and do not have much room to pass the entire game to the folder on Linux and why I need to do this process on windows and then move the files , but can not find the software to extract the files in windows . Someone would have these updated extractors to pass me ?
×