Jump to content
TrinityCore

Dbc, Maps, mmaps, Vmaps problems


Munga
 Share

Recommended Posts

Hello !

I have extract dbc/db2, maps, vmaps and when I run the command "vmap4assembler.exe Buildings vmaps", I have an error with the common.dll and the libeay32.dll so I put the files in the WoW folder and I restart vmap4assembler.exe and I have this error : "The application was unable to start correctly (0xc000007b). Click OK to close the application."

[SOLVED] : I pasted the OpenSSL 32bits dll and not the OpenSLL 64bits dll
 

Link to comment
Share on other sites

Hi guys, I have searched around and cant seem to find an answer to this question, so I need to ask it

I have the 7.0.3 client, the 6.x branch and everything has worked fine in compiling and getting setup to point of map extraction.

Currently I have run the extractor, and selected 4 for extract all. My issue is with the BattlePetEffectProperties.db2 file. Its currently at 64gb and still going. Is this normal? I remember doing map extractions ages ago and it never took this long, so far its been over a day :(

 

Sorry SOLVED now. Cant use the extractor bat, had to run individual bat files instead

 

Edited by freekyjason
SOLVED
Link to comment
Share on other sites

  • 2 weeks later...
  • 1 month later...
On 09.09.2016 at 8:59 PM, brokentechnology said:

EDIT:

I am an idiot. You need to run the following:

./mapextractor 

- Works perfect! Issue resolved for me. 

I am having a trouble extracting the contents on OS X. It seems to be default to a directory I did not define:

error opening casc storage '/Users/Steven/Data' locale enUS: FILE_NOT_FOUND

error opening casc storage '/Users/Steven/Data' locale koKR: FILE_NOT_FOUND

error opening casc storage '/Users/Steven/Data' locale frFR: FILE_NOT_FOUND

error opening casc storage '/Users/Steven/Data' locale deDE: FILE_NOT_FOUND

error opening casc storage '/Users/Steven/Data' locale zhCN: FILE_NOT_FOUND

error opening casc storage '/Users/Steven/Data' locale zhTW: FILE_NOT_FOUND

error opening casc storage '/Users/Steven/Data' locale esES: FILE_NOT_FOUND

error opening casc storage '/Users/Steven/Data' locale esMX: FILE_NOT_FOUND

error opening casc storage '/Users/Steven/Data' locale ruRU: FILE_NOT_FOUND

error opening casc storage '/Users/Steven/Data' locale ptBR: FILE_NOT_FOUND

error opening casc storage '/Users/Steven/Data' locale itIT: FILE_NOT_FOUND

 

However, I am indeed running it from the .app directory: 

 

 

Stevens-MacBook-Pro:World of Warcraft Steven$ open /Applications/World\ of\ Warcraft/mapextractor 

Stevens-MacBook-Pro:World of Warcraft Steven$ ls -l

total 16936

drwxrwxr-x  4 Steven  admin      136 Sep  9 13:55 Cache

drwxrwxrwx  6 Steven  admin      204 Sep  9 12:49 Data

drwxrwxr-x  3 Steven  admin      102 Sep  9 13:56 Interface

-rwxrwxrwx  1 Steven  admin        4 Sep  9 01:56 Launcher.db

drwxrwxr-x  9 Steven  admin      306 Sep  9 13:56 Logs

drwxrwxr-x  4 Steven  admin      136 Sep  9 13:56 WTF

-rwxrwxrwx  1 Steven  admin       32 Sep  9 13:55 WoW.mfil

drwxrwxrwx  3 Steven  admin      102 Sep  8 22:48 World of Warcraft Launcher.app

drwxrwxrwx  3 Steven  admin      102 Sep  8 22:48 World of Warcraft.app

-rwxr-xr-x  1 Steven  staff   765488 Sep  9 02:26 mapextractor

-rwxr-xr-x  1 Steven  staff  4698900 Sep  9 02:26 mmaps_generator

-rwxr-xr-x  1 Steven  staff  2438468 Sep  9 02:26 vmap4assembler

-rwxr-xr-x  1 Steven  staff   750756 Sep  9 02:26 vmap4extractor

Not sure why it wants to look under my name and /Data. I guess I could copy it there if it really wants it there. 

Hello, brokentechnology

Did you solve this issue? Can you help me with it? 

Client 7.1.0 (??????), then use mapextractor on it system reports this:

 

SRAMXU~H01.PNG

Link to comment
Share on other sites


http://TrinityCore.org

Extract V4.03 2015_05. Beginning work ....

error opening casc storage 'D:/wow\Data' locale enUS: FILE_NOT_FOUND
error opening casc storage 'D:/wow\Data' locale koKR: FILE_NOT_FOUND
error opening casc storage 'D:/wow\Data' locale frFR: FILE_NOT_FOUND
error opening casc storage 'D:/wow\Data' locale deDE: FILE_NOT_FOUND
error opening casc storage 'D:/wow\Data' locale zhCN: FILE_NOT_FOUND
error opening casc storage 'D:/wow\Data' locale zhTW: FILE_NOT_FOUND
error opening casc storage 'D:/wow\Data' locale esES: FILE_NOT_FOUND
error opening casc storage 'D:/wow\Data' locale esMX: FILE_NOT_FOUND
error opening casc storage 'D:/wow\Data' locale ruRU: FILE_NOT_FOUND
error opening casc storage 'D:/wow\Data' locale ptBR: FILE_NOT_FOUND
error opening casc storage 'D:/wow\Data' locale itIT: FILE_NOT_FOUND
FATAL ERROR: No locales defined, unable to continue.

D:\wow>

I try running the extractor.bat but it can not find the file mapextractor,  when there in the same folder

I to am having this same trouble running windows 10 pro. I tried to open a ticket, but i guess that was wrong. I  did what is says on the page for window users

https://trinitycore.atlassian.net/wiki/display/tc/Windows+Server+Setup

But i see others have this error too... but i dont see how it was fixed  i seen one ran ./mapextractor.exe  fixed it for him but not me

I know its something to do with parameters i think

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

 

Ok I got it to work after messing and messing and trying new things. And i seen no one posted any fix on what they did, So here is what worked for me. I deleted my Config.wt file.. re ran wow again once... then after that.. it worked ok for me :D

Edited by madmax765
Link to comment
Share on other sites

Thank you very much, AokromesMay I ask you a few question?

Then, how to determine which version of the client need for the last revision of trinity? I have downloaded two version of client: 7.1.0 (22908) and 7.1.0 (23222), running the mapextractor in this wow clients binary location, but extractor send message "No locales detected".

Interesting that in releases community give only one legion`s TDB 703.00 (not TDB 710.00) at this moment, does this mean that master branch need is 7.0.3 (22594) version of the client now to use of extractors from last revision

Edited by triturus
Link to comment
Share on other sites

Keyled:

On 28.07.2016 at 11:52 PM, Aokromes said:

we don't share client files.

Yeah, this is little problematic. May somebody linked in PM non-broken and full official 7.0.3 client for extracts? Find and download three torrents with 7.0.3 (22423), 7.0.3 (22594) and one of them is 7.0.3 (undefined) was downloded, but it was broken and not repaired from battle.net (launcher), launcher analyze and forcibly auto-update this to last revision of client 7.1.0 (23222). It's sad for me, because I have slow internet.

Edited by triturus
Link to comment
Share on other sites

16 minutes ago, triturus said:

Keyled:

Yeah, this is little problematic. May somebody linked in PM non-broken and full official 7.0.3 client for extracts? Find and download three torrents with 7.0.3 (22423), 7.0.3 (22594) and one of them is 7.0.3 (undefined) was downloded, but it was broken and not repaired from battle.net (launcher), launcher analyze and forcibly auto-update this to last revision of client 7.1.0 (23222). It's sad for me, because I have slow internet.

you don't need client 7.0.3. 

 

  • Upvote 1
Link to comment
Share on other sites

Hello! The auto-update feature is awesome! Much less time to update TC now!

Getting the following error when I try to start 3.3.5a worldserver on linux after updating on 30/12 (authserver started fine):

VMap file '/home/trinity-lk/server/data/vmaps/000.vmtree' does not exist
Please place VMAP-files (*.vmtree and *.vmtile) in the vmap-directory (/home/trinity-lk/server/data/vmaps/), or correct the DataDir setting in your worldserver.conf file.

But when I run an ls in that directory, I see the 000.vmtree file in there. Should I just re-extract the vmaps, or is this a different issue?

Update: Re-extracting the vmaps did the trick!

Edited by shadedmagus
Solution found
Link to comment
Share on other sites

On 12/31/2016 at 8:34 AM, shadedmagus said:

Hello! The auto-update feature is awesome! Much less time to update TC now!

Getting the following error when I try to start 3.3.5a worldserver on linux after updating on 30/12 (authserver started fine):

VMap file '/home/trinity-lk/server/data/vmaps/000.vmtree' does not exist
Please place VMAP-files (*.vmtree and *.vmtile) in the vmap-directory (/home/trinity-lk/server/data/vmaps/), or correct the DataDir setting in your worldserver.conf file.

But when I run an ls in that directory, I see the 000.vmtree file in there. Should I just re-extract the vmaps, or is this a different issue?

Update: Re-extracting the vmaps did the trick!

After re-extracting the maps, there is a new version applied to the vmtree. There should be a message that says 'wrong version', rather than the map file display that does not exist.

Anyhow, looks like you got the message :)

Link to comment
Share on other sites

  • 2 weeks later...
On 1/3/2017 at 2:11 AM, Slartibartfat said:

Hi!

 

I wanted to extract the dcb, maps and vmaps on Mac OS X but there isn't any guide for that in the wiki. I tried to adapt the guide for Linux but I have been unsuccessful. Has anyone been successful in extracting them on mac and is it possible to have a detaile guide for it?

thanks 

What was unsuccessful? Missing binary extractors on your mac?

I've extracted the client files on Linux. In fact Iv'e done just about everything purely without any Windows support. It can be done.

I just need to know what was the issue you were having?

Link to comment
Share on other sites

I have a few questions,

1º Where could i download full wow client without updating and patches for Legion?

2º How to know my trinity core compiled version?

3ºI have tools compiled and it works!

4º In realmlist table I have a field which it is called "gamebuild" it s initialized to 23222

5º If there is anyone who have dbc,vmaps,mmaps, etc. to download , he or she will help me a lot

 

This is the content of my Server txt file after running world,

 

TrinityCore rev. 940c52222249 2017-01-11 02:14:23 +0100 (master branch) (Win64, Debug, Static) (worldserver-daemon)
<Ctrl-C> to stop.

 ______                       __
/\__  _\       __          __/\ \__
\/_/\ \/ _ __ /\_\    ___ /\_\ \, _\  __  __
   \ \ \/\`'__\/\ \ /' _ `\/\ \ \ \/ /\ \/\ \
    \ \ \ \ \/ \ \ \/\ \/\ \ \ \ \ \_\ \ \_\ \
     \ \_\ \_\  \ \_\ \_\ \_\ \_\ \__\\/`____ \
      \/_/\/_/   \/_/\/_/\/_/\/_/\/__/ `/___/> \
                                 C O R E  /\___/
http://TrinityCore.org                    \/__/

Using configuration file C:/Trinity_Build_Legion_7.1/worldserver.conf.
Using SSL version: OpenSSL 1.0.1u  22 Sep 2016 (library: OpenSSL 1.0.1u  22 Sep 2016)
Using Boost version: 1.60.0
Updating Auth database...
>> Auth database is up-to-date! Containing 9 new and 82 archived updates.
Updating Character database...
>> Character database is up-to-date! Containing 5 new and 58 archived updates.
Updating World database...
>> World database is up-to-date! Containing 95 new and 1368 archived updates.
Updating Hotfixes database...
>> Hotfixes database is up-to-date! Containing 7 new and 90 archived updates.
Realm running as realm ID 1
Using World DB: Unknown world database.
Using enUS DBC Locale
Missing name MonsterSight in config file C:/Trinity_Build_Legion_7.1/worldserver.conf, add "MonsterSight = 50.000000" to this file
Missing name GuarderSight in config file C:/Trinity_Build_Legion_7.1/worldserver.conf, add "GuarderSight = 50.000000" to this file
Will clear `logs` table of entries older than 1209600 seconds every 10 minutes.
Using DataDir C:/Trinity_Build_Legion_7.1/
WORLD: MMap data directory is: C:/Trinity_Build_Legion_7.1/mmaps
VMap support included. LineOfSight: 1, getHeight: 1, indoorCheck: 1
VMap data directory is: C:/Trinity_Build_Legion_7.1/vmaps
Missing name Guild.SaveInterval in config file C:/Trinity_Build_Legion_7.1/worldserver.conf, add "Guild.SaveInterval = 15" to this file
Missing name Guild.UndeletableLevel in config file C:/Trinity_Build_Legion_7.1/worldserver.conf, add "Guild.UndeletableLevel = 4" to this file
VMap file 'C:/Trinity_Build_Legion_7.1/vmaps/0000.vmtree' does not exist
Please place VMAP-files (*.vmtree and *.vmtile) in the vmap-directory (C:/Trinity_Build_Legion_7.1/vmaps/), or correct the DataDir setting in your worldserver.conf file.
Unable to load critical files - server shutting down !!!
 

0000.vmtree exist in the folder....

Furthermore, 

here is the btnserver file,

 

TrinityCore rev. 940c52222249 2017-01-11 02:14:23 +0100 (master branch) (Win64, Debug, Static) (bnetserver)
<Ctrl-C> to stop.

 ______                       __
/\__  _\       __          __/\ \__
\/_/\ \/ _ __ /\_\    ___ /\_\ \, _\  __  __
   \ \ \/\`'__\/\ \ /' _ `\/\ \ \ \/ /\ \/\ \
    \ \ \ \ \/ \ \ \/\ \/\ \ \ \ \ \_\ \ \_\ \
     \ \_\ \_\  \ \_\ \_\ \_\ \_\ \__\\/`____ \
      \/_/\/_/   \/_/\/_/\/_/\/_/\/__/ `/___/> \
                                 C O R E  /\___/
http://TrinityCore.org                    \/__/

Using configuration file C:/Trinity_Build_Legion_7.1/bnetserver.conf.
Using SSL version: OpenSSL 1.0.1u  22 Sep 2016 (library: OpenSSL 1.0.1u  22 Sep 2016)
Using Boost version: 1.60.0
Automatic database updates are disabled for all databases!
Opening DatabasePool 'auth'. Asynchronous connections: 1, synchronous connections: 1.
MySQL client library: 5.5.54
MySQL server ver: 5.5.54 
Connected to MySQL database at 127.0.0.1
MySQL client library: 5.5.54
MySQL server ver: 5.5.54 
Connected to MySQL database at 127.0.0.1
DatabasePool 'auth' opened successfully. 2 total connections running.
Started auth database connection pool.
Login service bound to http://0.0.0.0:8081
Added realm "Trinity" at 127.0.0.1:8085.
 

works successfully!!!

 I hope you could give me a hand.

Cheers!

Edited by akeendev
Link to comment
Share on other sites

7 hours ago, akeendev said:

 

I have a few questions,

1º Where could i download full wow client without updating and patches for Legion?

2º How to know my trinity core compiled version?

3ºI have tools compiled and it works!

4º In realmlist table I have a field which it is called "gamebuild" it s initialized to 23222

5º If there is anyone who have dbc,vmaps,mmaps, etc. to download , he or she will help me a lot

 

This is the content of my Server txt file after running world,

 

TrinityCore rev. 940c52222249 2017-01-11 02:14:23 +0100 (master branch) (Win64, Debug, Static) (worldserver-daemon)
<Ctrl-C> to stop.

 

To answer:

2. should answer your own question. with the console text that you pasted. (hence the TrinityCore rev.)

5. Do NOT download seperate dbc,vmaps,mmaps. Compile the tools and extract them yourself.

From what it appears in your text dump, you got a successful server compile or binary and compile the tools (from what you answered in number 3) Then extract them yourself. or you will get an error with an invalid vmtree version.

Link to comment
Share on other sites

9 hours ago, CDawg said:

To answer:

2. should answer your own question. with the console text that you pasted. (hence the TrinityCore rev.)

5. Do NOT download seperate dbc,vmaps,mmaps. Compile the tools and extract them yourself.

From what it appears in your text dump, you got a successful server compile or binary and compile the tools (from what you answered in number 3) Then extract them yourself. or you will get an error with an invalid vmtree version.

Yes I compiled the tools.

Where to download the official wow client at this version?

This is my main problem lol.

Link to comment
Share on other sites

Hi, I am having this problem, and I am starting to think it might be a bug, but I am not sure, the thing is, I am getting that the file does not exist, but I am 10000% sure it is there, I even specified the path in DataDir of the root folder (where worldserver is), I was able to run this long ago, and I am using exactly the same map files that I used by then and that worked just fine but for some reason, on this release, they just don't...

EDIT: Still NOT working, but tried to extract all maps again, exactly same issue remains.

Screenshot_1.png
 

TrinityCore rev. 55c3eb66d7d6 2017-01-13 17:07:03 -0300 (3.3.5 branch) (Win64, Release, Static) (worldserver-daemon)
<Ctrl-C> to stop.

 ______                       __
/\__  _\       __          __/\ \__
\/_/\ \/ _ __ /\_\    ___ /\_\ \, _\  __  __
   \ \ \/\`'__\/\ \ /' _ `\/\ \ \ \/ /\ \/\ \
    \ \ \ \ \/ \ \ \/\ \/\ \ \ \ \ \_\ \ \_\ \
     \ \_\ \_\  \ \_\ \_\ \_\ \_\ \__\\/`____ \
      \/_/\/_/   \/_/\/_/\/_/\/_/\/__/ `/___/> \
                                 C O R E  /\___/
http://TrinityCore.org                    \/__/

Using configuration file D:/World Of Warcraft TrinityCore/worldserver.conf.
Using SSL version: OpenSSL 1.0.2j  26 Sep 2016 (library: OpenSSL 1.0.2h  3 May 2016)
Using Boost version: 1.59.0
Updating Auth database...
>> Auth database is up-to-date! Containing 3 new and 14 archived updates.
Updating Character database...
>> Character database is up-to-date! Containing 2 new and 17 archived updates.
Updating World database...
>> World database is up-to-date! Containing 297 new and 1800 archived updates.
Realm running as realm ID 1
Using World DB: Unknown world database.
Missing name MonsterSight in config file D:/World Of Warcraft TrinityCore/worldserver.conf, add "MonsterSight = 50.000000" to this file
Will clear `logs` table of entries older than 1209600 seconds every 10 minutes.
Using DataDir D:/World Of Warcraft TrinityCore/
WORLD: MMap data directory is: D:/World Of Warcraft TrinityCore/mmaps
VMap support included. LineOfSight: 1, getHeight: 1, indoorCheck: 1
VMap data directory is: D:/World Of Warcraft TrinityCore/vmaps
VMap file 'D:/World Of Warcraft TrinityCore/vmaps/000.vmtree' does not exist
Please place VMAP-files (*.vmtree and *.vmtile) in the vmap-directory (D:/World Of Warcraft TrinityCore/vmaps/), or correct the DataDir setting in your worldserver.conf file.
Unable to load critical files - server shutting down !!!

Edited by [email protected]
Link to comment
Share on other sites

Had the same issue when versions were bumped on TC. DB changes cause fresh extracts to be required. I had just done a fresh extract not 24 hours before TC DB changed, so it baffled me too. But your symptoms are identical to mine. File was there but it was asking for it again. Fresh commit pull/mmaps and vmaps extraction and recompiling fixed it.

Long story short.... start from square 1.

  • Upvote 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.


  • Similar Content

    • By WalkerSh
      Friends,
      I am going through a big problem.
      all maps in "BFa" are completely empty. (without "mobs", without "Npc's".
      how can I enable world missions and all the content in "BFa".  ??????????????????????
      I looked everywhere on this subject, but I was unsuccessful.
      I apologize, I am a beginner in the projects.

      ====================================================================
      I am currently using this project. 8.3.0 (33369)
      http://www.ac-web.org/forums/showthread.php?237071-World
       
      updated to 8.3.7 (35662)
      https://mega.nz/file/0dpmla4Q#4tKwrc-G9uhyxCkJozNwZp8Pr0ArgZmwO-ay7OCMvGw
      Source project
      https://github.com/TrinityCore/TrinityCore

      ====================================================================
      My WorldServ.conf
      #    Expansion
      #        Description: Allow server to use content from expansions. Checks for expansion-related
      #                     map files, client compatibility and class/race character creation.
      #        Default:     7 - (Expansion 7)
      #                     6 - (Expansion 6)
      #                     5 - (Expansion 5)
      #                     4 - (Expansion 4)
      #                     3 - (Expansion 3)
      #                     2 - (Expansion 2)
      #                     1 - (Expansion 1)
      #                     0 - (Disabled, Ignore and disable expansion content (maps, races, classes)
      Expansion = 8
      #
    • By reyne
      Hey there!

      I've followed a few threads here about map extraction, and am still having issues. Originally, I was having the issue described here.
      After following the advice given in that thread (creating characters of both BC races and running around for a bit), I am no longer getting that error, however now I get the following error while trying to extract maps:

      `Error loading World\Maps\Expansion01\Expansion01_42_6.adt`

      This repeats for every line in Expansion01, and then the extractor crashes.

      I'm not sure where else to go from here.

      Thanks for your help

      Edit: I've created an 85 on an i85 server and flown all around Outland now, same issue.
    • By Ithylis
      =====[ English ]=====
      Hello,
      First of all I'm sorry if my english is not good, it's the use of Mr Google translation
      That's after years I restart in a WoW private server.
      I thank everyone who gives their time to help TrinityCore evolve.
      I appeal to the community because I can not find the dbc-cameras-vmaps-maps-mmaps-gt files of master 8.2.0.31478.
      I have the official version of the game in 8.2.5 and going through Arctium I do not have the data to extract all that, or else I get it wrong.
      Would anyone be kind enough to share all these extracted files please?
      Thank you very much and have a good day / night
      Regards,
      Ithylis
      =====[ Français ]=====
      Bonjour,

      Avant tout je suis désolé si mon anglais n'est pas bon, c'est l'utilisation de Monsieur Google traduction

      Voilà après des années je me relance dans un serveur privé WoW.
      Je remercie tout ceux qui donnent de leur temps pour faire évoluer TrinityCore.
      Je fais appel à la communauté, car je n'arrive pas à trouver les fichiers dbc-cameras-vmaps-maps-mmaps-gt de la version master 8.2.0.31478.
      J'ai la version officielle du jeu en 8.2.5 et en passant par Arctium je n'ai pas les données pour extraire tout cela, ou alors je m'y prends mal.

      Est-ce que quelqu'un aurait la bonté de partager tous ces fichiers extraits s'il vous plait ?

      Merci beaucoup et bonne journée/nuit
      Cordialement,
      Ithylis
    • By roweqharoji
      Hi guys, this is my first post for help. I think this may be a really noob problem, but I just can't...... Sorry first if there's any mistakes.
      I tried to host 4.3.4 from https://gitlab.com/trinitycore/TrinityCore_434, but with no luck I keep recieving error like The `spell_proc` table entry for spellIdXXX has Attribute PROC_ATTR_REQ_SPELLMOD, but spell has no spell mods. Proc will not be triggered. Detailed log is attached below.
      I have host 3.3.5 without error, but when it comes to 4.3.4, I just can't figure out how to solve this situation. I've tried searching for similar problem, but they said it's client side issue. like this https://gitlab.com/trinitycore/TrinityCore_434/issues/165. I tried download different client data such as wowmortal, atlantiss, mangos wowregeneration...and other two client. But no luck with those...
      If anyone can show me any hint, I would really appreciate
      DBErrors.log
    • By omgdior
      Hello user!  Help me please. How to extract the client DBC, Maps, VMaps & VMaps. I for some reason after 3.3.5 can not understand what to do in the new version. I hope for you.
×
×
  • Create New...