Jump to content
TrinityCore
Munga

Dbc, Maps, mmaps, Vmaps problems

Recommended Posts

Hi, i tried to make my first little 3.3.5a server, i compiled trinity but when i start the server i get:

VMap file '../data/vmaps/000.vmtree' couldn't be loaded
This is because the version of the VMap file and the version of this module are different, please re-extract the maps with the tools compiled with this module.
Unable to load critical files - server shutting down !!!
 

i think the problem is that i downloaded the vmaps from a forum instead of extracting it.

any help is appreciated,

thanks.

Share this post


Link to post
Share on other sites

like error say " This is because the version of the VMap file and the version of this module are different, please re-extract the maps with the tools compiled with this module. "

Share this post


Link to post
Share on other sites

This is why I love when they do client updates I knew something like this would happen I should of stayed with 7.2.0 now master is really fucked up, but I know it will get fix like it always does :)

  • Upvote 1

Share this post


Link to post
Share on other sites

The only fucked up thing is your configuration/installation

7.2.5 works exactly the same as 7.2.0 did (assuming you updated everything properly)

Share this post


Link to post
Share on other sites

Actually i got the same error and others,what i did  was deleted my cache folder this time. i then went and login to retail and swap to a few toons, logout and redid extraction. All extraction extracted as it should be with no errors. My worldserver core starts OK now.

Share this post


Link to post
Share on other sites

Well then tell me how they can be so fucked up if I redid everything from start, the only thing I didn't do was vmaps and mmaps but everything else is from the start and is fresh. The error sounds like it is coming from the dbc files but I did those fresh too so not sure if you say core from master is running great then there really is a problem somewhere not sure where. I am reinstalling the client too just to cover everything this time as well.

I can ensure you I did everything properly this isn't my first time doing this. I agree though I cannot find anything code wise that this would be. I'm doing vmaps and mmaps now just to make sure everything is done from fresh build. I wonder is there a way to rebuild the gt folder in wow because it sounds like that is where the error is coming from since it is not from the dbc files, I am going to try and re-scan the client for changes or to force changes made to it.

  • Upvote 1

Share this post


Link to post
Share on other sites

Here is mine, core is working and i attach the gt folder zipped .

 

TrinityCore rev. cf5aa01be7ee+ 2017-06-18 22:17:48 +0200 (master branch) (Win64, Release, Static) (worldserver-daemon)
<Ctrl-C> to stop.

 ______                       __
/\__  _\       __          __/\ \__
\/_/\ \/ _ __ /\_\    ___ /\_\ \, _\  __  __
   \ \ \/\`'__\/\ \ /' _ `\/\ \ \ \/ /\ \/\ \
    \ \ \ \ \/ \ \ \/\ \/\ \ \ \ \ \_\ \ \_\ \
     \ \_\ \_\  \ \_\ \_\ \_\ \_\ \__\\/`____ \
      \/_/\/_/   \/_/\/_/\/_/\/_/\/__/ `/___/> \
                                 C O R E  /\___/
http://TrinityCore.org                    \/__/

Using configuration file C:/TCSPLegion/worldserver.conf.
Using SSL version: OpenSSL 1.0.2j  26 Sep 2016 (library: OpenSSL 1.0.2j  26 Sep 2016)
Using Boost version: 1.63.0
Process priority class set to HIGH
Opening DatabasePool 'tdb_auth'. Asynchronous connections: 1, synchronous connections: 1.
DatabasePool 'tdb_auth' opened successfully. 2 total connections running.
Opening DatabasePool 'tdb_characters'. Asynchronous connections: 1, synchronous connections: 2.
DatabasePool 'tdb_characters' opened successfully. 3 total connections running.
Opening DatabasePool 'xworld'. Asynchronous connections: 2, synchronous connections: 2.
DatabasePool 'xworld' opened successfully. 4 total connections running.
Opening DatabasePool 'xhotfixes'. Asynchronous connections: 1, synchronous connections: 1.
DatabasePool 'xhotfixes' opened successfully. 2 total connections running.
Updating Auth database...
>> Auth database is up-to-date! Containing 6 new and 97 archived updates.
Updating Character database...
>> Character database is up-to-date! Containing 5 new and 67 archived updates.
Updating World database...
>> World database is up-to-date! Containing 83 new and 1910 archived updates.
Updating Hotfixes database...
>> Hotfixes database is up-to-date! Containing 6 new and 104 archived updates.
Realm running as realm ID 1
Using World DB: TDB 720.00
Added realm "Trinity" at 127.0.0.1:8085.
Using enUS DBC Locale
BaseMapLoadAllGrids enabled, but GridUnload also enabled. GridUnload must be disabled to enable base map pre-loading. Base map pre-loading disabled
Missing name MonsterSight in config file C:/TCSPLegion/worldserver.conf, add "MonsterSight = 50.000000" to this file
Will clear `logs` table of entries older than 600 seconds every 2 minutes.
Using DataDir f:\legiondata/
WORLD: MMap data directory is: f:\legiondata/mmaps
VMap support included. LineOfSight: 1, getHeight: 1, indoorCheck: 0
VMap data directory is: f:\legiondata/vmaps
Missing name Guild.SaveInterval in config file C:/TCSPLegion/worldserver.conf, add "Guild.SaveInterval = 15" to this file
Loading Trinity strings...
>> Loaded 1065 trinity strings in 2 ms
Initialize data stores...
>> Initialized 213 DB2 data stores in 4088 ms
Loading hotfix info...
>> Loaded 0 hotfix info entries.
Closing down DatabasePool 'xhotfixes'.
Asynchronous connections on DatabasePool 'xhotfixes' terminated. Proceeding with synchronous connections.
All connections on DatabasePool 'xhotfixes' closed.
>> Loading Cinematic Camera files
>> Loaded 34 cinematic waypoint sets in 4 ms
>> Initialized 27 GameTables in 8 ms
Loading SpellInfo store..

gt.7z

  • Upvote 1

Share this post


Link to post
Share on other sites

Thank you so much that is what it was the gt folder everything works great now. You saved the day!!! YEAH!!!!!!!! not sure how the gt folder got screwed up but thank you.

  • Upvote 1

Share this post


Link to post
Share on other sites

Hello!

I tried to extract the mmaps vmap etc... but no one seems to work under windows 10 for now, I got some error message (and maps folder isn't created, even if I create it there is nothing on it the message keep to say "maps folder doesn't exist or is empty)

On the previous core I haven't got any problem

Share this post


Link to post
Share on other sites

Labaouici,

I am on Windows 7, after running just the mapextractor.exe I can see the errors. Are you receiving the same ones? I just compiled the core yesterday and also haven't been able to extract.

 

My Error:

error opening casc storage 'D:/WowLK\Data' locale enUS
Error opening casc storage 'D:/WowLK\Data': FILE_NOT_FOUND

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By roweqharoji
      Hi guys, this is my first post for help. I think this may be a really noob problem, but I just can't...... Sorry first if there's any mistakes.
      I tried to host 4.3.4 from https://gitlab.com/trinitycore/TrinityCore_434, but with no luck I keep recieving error like The `spell_proc` table entry for spellIdXXX has Attribute PROC_ATTR_REQ_SPELLMOD, but spell has no spell mods. Proc will not be triggered. Detailed log is attached below.
      I have host 3.3.5 without error, but when it comes to 4.3.4, I just can't figure out how to solve this situation. I've tried searching for similar problem, but they said it's client side issue. like this https://gitlab.com/trinitycore/TrinityCore_434/issues/165. I tried download different client data such as wowmortal, atlantiss, mangos wowregeneration...and other two client. But no luck with those...
      If anyone can show me any hint, I would really appreciate
      DBErrors.log
    • By omgdior
      Hello user!  Help me please. How to extract the client DBC, Maps, VMaps & VMaps. I for some reason after 3.3.5 can not understand what to do in the new version. I hope for you.
    • By JourneyJay
      So far, it appears to be irrelevant, since extraction continued, and I'm assuming the client will load. If not, I'll update this post.
       
      Map Extractor fails to find a series of files, but continues onward. A jpeg is linked via google drive below.
      https://drive.google.com/file/d/0By4quSN6E7RvTFhvdjZSS3JSZjQ/view

    • By hashimoff
      Hi Everybody I have problem with map extractors.
      When I run mapextractor.exe and vmapextractor.exe I got this error
      d:\Program Files\World of Warcraft>mapextractor.exe Map & DBC Extractor (vmaps too) =================== error opening casc storage 'd:/Program Files\World of Warcraft\Data': FILE_NOT_FOUND Can anyone Help ME?
    • By leandrod
      Hello guys , good night . I'm new here and I have a problem to extract the maps and vmaps and other game files version 3.3.5a , as created the server in a virtual machine and do not have much room to pass the entire game to the folder on Linux and why I need to do this process on windows and then move the files , but can not find the software to extract the files in windows . Someone would have these updated extractors to pass me ?
×
×
  • Create New...