Jump to content

[SOLVED]Table `command` contains a non-existing command '<command name>', skipped.


Recommended Posts

--- Canned message start --- It appears the issue in the original post was solved, so this thread shall be closed. Should you encounter any other difficulties, please open a new thread. --- Canned message end ---

Link to comment
Share on other sites

I had a server crash and so am reinstalling my TrinityCore server on which I run both 3.3.5a and 6.x. I've done this a few times before successfully so while not an expert I'm not new to it either. I've got 3.3.5a working entirely again from scratch but though I can get 6.x setup, compiled and started ok my console commands do not work so I cannot among other things, create an account.

I am using:

Linux: Debian 8.3.0
TrinityCore: commit from April 25, 2016 Commit: 926c1ac9a064780241f0a22fd6cab45d10e16f89
MySQL: Ver 14.14 Distrib 5.5.47, for debian-linux-gnu (x86_64) using readline 6.3
GCC: (Debian 4.9.2-10) 4.9.2
CMake: version 3.0.2
OpenSSL: 1.0.1k 8 Jan 2015

I do not believe this to be a compilation or dependency issue, because the core starts up, the extractor work correctly, the DB installs without warnings or errors and as suggested below, if I checkout the 6.03 tag and compile that instead everything works fine.

This is a brand new install (DBs entirely empty) with an automatic DB setup from downloaded TDB 6.04 (TDB_full_6.04_2016_04_11.7z) plus automatic updates on core startup to current required SQL/DB revisions.

The core starts up but when I try to execute any CLI/console commands, the first time I issue one (anything at all; account, help, etc) I get the following spewed output. 

TC> account

Table `command` contains a non-existing command 'deserter', skipped.
Table `command` contains a non-existing command 'deserter', skipped.
Table `command` contains a non-existing command 'list', skipped.
Table `command` contains a non-existing command 'account', skipped.
Table `command` contains a non-existing command 'arena', skipped.
Table `command` contains a non-existing command 'reload', skipped.
Table `command` contains a non-existing command 'account', skipped.
Table `command` contains a non-existing command 'account', skipped.
Table `command` contains a non-existing command 'ahbot', skipped.
Table `command` contains a non-existing command 'ahbot', skipped.
Table `command` contains a non-existing command 'guild', skipped.
Table `command` contains a non-existing command 'instance', skipped.
Table `command` contains a non-existing command 'instance', skipped.
Table `command` contains a non-existing command 'go', skipped.
Table `command` contains a non-existing command 'debug', skipped.
Table `command` contains a non-existing command 'debug', skipped.

After the first attempt at a command, any subsequent command just gives me;

TC> account
TC>There is no such command

I've also tried from the milestone/tag release for 6.04 (TDB 6.04 - 2016/04/11 - a1f59c9d8d9351bd4373e1e4355eee09369c589f) and a bunch of other commits between that one and the one above over the last several days always with the same issue.

Then I tried a fresh install of the milestone/tag release for 6.03 (TDB 6.03 - 2015/11/08 - 271390753d63ea34e498e45f5e00a758f6997fbc). Same sort of installation procedure; fresh pull, compile, drop all the DBs and install them fresh from the 6.03 release of TDB with auto-population and updates on startup. This works fine, and my console commands work as expected.

After I had that working I did a new pull to the origin master head revision and updated everything to TrinityCore rev. 926c1ac9a064 again (so back up to TDB 6.04 plus updates) and again the problems started and no commands work.

I'm surprised I can't find anything on the forum or the google about this for searches such as "Table contains a non-existing command" so I have to expect this is something specific to me, but like I said, I've tried a bunch of times with the same effect. Any pointers or suggestions appreciated.


Edited by lozman
Link to comment
Share on other sites

1 hour ago, Aokromes said:

delete build directory and compile again.

Ok, I deleted the build directory and recreated it. reran CMAKE, recompiled and installed. I still get the same issue.  I dropped my entire databases and had them repopulate again but still the same.

I can just blitz the entire installation folders, re-pull/clone the repo and start entirely fresh if you think that should make a difference, but I did that right at the start when I set the new server up, so I'm confused :/

Link to comment
Share on other sites

17 hours ago, Nay said:

What's the value of the variable SCRIPTS in CMake?

Thank you, Nay, this pointed me in the correct direction to solve the (silly) issue.

Over the previous times I've built TC I've kept notes, snippets of code, commands, SQL, etc, that I used to make it easier in the future. Seems that the cmake command I had saved had an option specified (CSCRIPTS=1) that presumably was correct (or at least not problematic) at one point for one of the versions in the past (as I said interestingly when I tried rolling back to tag TDB 6.03 everything worked fine) but not for the current build. I noticed on checking the documentation carefully again that this is now a default option (defaulting to CSCRIPTS="static") and so I removed the incorrect parameter from my command line.

Everything is now built and working as expected.

Thank you, both, for replying.




Edited by lozman
Link to comment
Share on other sites

  • 1 month later...



I am  having the same problem only using macOS I have recompiled several times and it  still does not work.  When I use the default for Cscripts I get an ld error.  If I use Cscripts=0 it compiles but then there are no CLI commands, I must be missing something please help.



Link to comment
Share on other sites

The last message  I get when it fails is the following:


0  0x103fcb99e  __assert_rtn + 144
1  0x104002207  archive::File<x86_64>::makeObjectFileForMember(archive::File<x86_64>::Entry const*) const + 1131
2  0x104001866  archive::File<x86_64>::justInTimeforEachAtom(char const*, ld::File::AtomHandler&) const + 112
3  0x104015b25  ld::tool::InputFiles::searchLibraries(char const*, bool, bool, bool, ld::File::AtomHandler&) const + 265
4  0x10401d763  ld::tool::Resolver::resolveUndefines() + 165
5  0x10401fdeb  ld::tool::Resolver::resolve() + 75
6  0x103fcc7a7  main + 940
7  0x7fff8e5cc5ad  start + 1
A linker snapshot was created at:
ld: Assertion failed: (memberIndex != 0), function makeObjectFileForMember, file /Library/Caches/com.apple.xbs/Sources/ld64/ld64-264.3.102/src/ld/parsers/archive_file.cpp, line 355.
clang: error: linker command failed with exit code 1 (use -v to see invocation)


The following build commands failed:
    Ld /Users/daverober4/WOW_Stuff/Trinity/build/src/server/worldserver/Debug/worldserver normal x86_64
(1 failure)


Link to comment
Share on other sites

If I use this command for building my xcodebuild project it fails with the above error for ld Assertion Failed.


cmake $TRINITY/repo -G "Xcode" -DMYSQL_ADD_INCLUDE_PATH=/usr/local/Cellar/mysql/5.7.12//include -DMYSQL_LIBRARY=/usr/local/Cellar/mysql/5.7.12/lib/libmysqlclient.dylib -DREADLINE_INCLUDE_DIR=/usr/local/Cellar/readline/6.3.8/include -DREADLINE_LIBRARY=/usr/local/Cellar/readline/6.3.8/lib/libreadline.dylib -DBOOST_INCLUDEDIR=/usr/local/Cellar/boost/1.60.0_2/include -DBOOST_LIBRARYDIR=/usr/local/Cellar/boost/1.60.0_2/lib -DOPENSSL_SSL_LIBRARIES=/usr/local/Cellar/openssl/1.0.2h_1/lib/libssl.dylib -DOPENSSL_CRYPTO_LIBRARIES=/usr/local/Cellar/openssl/1.0.2h_1/lib/libcrypto.dylib -DOPENSSL_INCLUDE_DIR=/usr/local/Cellar/openssl/1.0.2h_1/include -DCMAKE_INSTALL_PREFIX=$TRINITY -DWITH_WARNINGS=1 -DTOOLS=1


However if I add -DSCRIPTS=0 at the end it builds fine but then the TC commands do not work.  I used homebrew to install the dependencies not sure what I might be doing wrong.  I can bring up the database, along with the worldserver,  I also patched the client but I can't create accounts to log in.   Any help would be greatly appreciated.


Link to comment
Share on other sites

I have tried that several times.. and when I compile with no SCRIPTS option it fails with the ld assertion error.  

I have even wiped everything out and downloaded everything again just to be sure I had what I needed to get this compiled.  

Edited by annarober
added more information
Link to comment
Share on other sites

  • 2 weeks later...
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Frik24
      Hello TrinityCore members,

      I wanted to mess around with 6.2.4a build 21742,
      I've downloaded/compiled the trinitycore TrinityCore-6.2.4-21742 from github

      I've got connection_patcher.exe among other files in my release build

      I've got client with same patch TrinityCore-6.2.4-21742

      I patched the client(all successful) with patcher i've got from compiling source.

      When i run WoW_Patched.exe i get error message https://imgur.com/a/ZZQI3J9
      can anyone help me i'd appreciate it a lot!
    • By darki73
      So i guess it is pretty obvious about what am i going to ask =)
      Problem is, previousle we could just sha1 username and password separated by colon and here is the sha_pass_hash.
      The problem i am facing right now, is that according to https://github.com/TrinityCore/TrinityCore/blob/86b98686a95e23247ecb774fb23ecd5b8d94b97b/src/server/game/Accounts/BattlenetAccountMgr.cpp#L177 Trinity now uses SHA256, so the hashes do not match anymore. The thing is, password length in database is 40 symbols (exactly as many as in sha1 hash), but sha256 hash length is 64 characters long. I am confused...
      I've tried to recreate whole "Cryptography" thing on PHP but, guess what, failed.
      Can somebody explain me how the password is generated nowadays?
      Thank you for your attention. 
    • By HolyNitzan
      Hey Guys,
      I'm  using the last build of TrinityCore for WoD, currently using latest TDB release, I noticed that there are no spawns in Draenor, I would like to konw how could I solve it? is the TDB not populated with Draenor mobs/npc spawns?
    • By Shinzon
      I have searched all over the forums and can't find anything that exactly matches this. 
      I can connect fine to the server using my windows client, but when I try to connect using my mac client it immediately bounces back stating "You have been disconnected from the server". 
      I have the correct IP address in the config.wtf (And realmlist in the DB) but still can't connect. 
      I of course can't apply the connection patcher, because the EXE isn't mac compatible. 
      Is there something else I need to do to connect with mac?
      Here is my connection.log if it helps (NOTE that the ".logon.battle.net" I can't get rid of... there is no where config.wtf that has that).
      3/14 13:10:21.966  Login program=WoW platform=Mc64 locale=enUS 3/14 13:10:22.097  Component WoW.Mc64.20886 3/14 13:10:22.097  Component WoW.base.20726 3/14 13:10:22.099  Battle.net is Component Bnet.Mc64.37165 3/14 13:10:22.099  LOGIN: state: LOGIN_STATE_CONNECTING result: LOGIN_OK  3/14 13:10:22.145  Failed to resolve “”.logon.battle.net 3/14 13:10:22.145  LOGIN: state: LOGIN_STATE_FAILED result: DISCONNECTED  3/14 13:10:22.145  Login program=WoW platform=Mc64 locale=enUS 3/14 13:10:22.145  Component WoW.Mc64.20886 3/14 13:10:22.145  Component WoW.base.20726 3/14 13:10:22.154  Battle.net is Component Bnet.Mc64.37165 3/14 13:10:23.298  Client Disconnect due to reason:8 3/14 13:12:54.053  LOGIN: state: LOGIN_STATE_CONNECTING result: LOGIN_OK  3/14 13:12:54.073  Failed to resolve “”.logon.battle.net 3/14 13:12:54.151  LOGIN: state: LOGIN_STATE_FAILED result: DISCONNECTED  3/14 13:12:54.151  Login program=WoW platform=Mc64 locale=enUS 3/14 13:12:54.173  Component WoW.Mc64.20886 3/14 13:12:54.173  Component WoW.base.20726 3/14 13:12:54.308  Battle.net is Component Bnet.Mc64.37165 3/14 13:12:54.309  Client Disconnect due to reason:8  
    • By Ewe Loon
      I followed the instructions  ( i think )
      compile went OK (i think, didn't see any errors)
      downloaded the database and copied the file as required
      got to the point where the instructions say to run worldserver
      I cd'd to the folder /server/bin and typed "worldserver" and got the message 
      worldserver: command not found
      so i typed dir and it appears to be there
      here is a copy of the terminal showing commands and results
      [email protected]:~/server/bin$ worldserver
      worldserver: command not found
      [email protected]:~/server/bin$ dir
      authserver    mmaps_generator                vmap4assembler  worldserver
      mapextractor  TDB_full_world_335.61_2016_04_11.sql  vmap4extractor
      anyone have any idea why it wont run
  • Create New...