Jump to content
TrinityCore

"unknown column" "missing table" "duplicate column" error / sql problems / SQLDriverLogFile < answer on 1st post of 1st page


Apple
 Share

Recommended Posts

@Nay: I Compiled the core again and the problem was solved (thanks) but I faced new error in running worldserver.exe ,I think it is related to the problem

 

 

[1054] Unknown column 'quest_repeatable_rate' in 'field list'

Your database structure is not up to date. Please make sure you've executed all queries in the sql/updates folders.
Link to comment
Share on other sites

Hello i get this error when opening worldserver.

 

Using configuration file worldserver.conf.
Using SSL version: OpenSSL 1.0.0d 8 Feb 2011 (library: OpenSSL 1.0.0d 8 Feb 2011)
Using ACE version: 6.1.4
TrinityCore rev. unknown 1970-01-01 00:00:00 +0000 (Archived branch) (Win64, Release) (worldserver-daemon)
<Ctrl-C> to stop.
 
 ______                       __
/__  _       __          __/ __
/_/ / _ __ /_    ___ /_ , _  __  __
    /`'__/ /' _ `/ / / /
    / / / _ _
      _ _   _ _ _ _ __/`____
      /_//_/   /_//_//_//_//__/ `/___/>
                                 C O R E  /___/
http://TrinityCore.org                    /__/
 
In mysql_stmt_prepare() id: 55, sql: "SELECT name, permission, help FROM command"
Unknown column 'permission' in 'field list'
DatabasePool world NOT opened. There were errors opening the MySQL connections. Check your SQLDriverLogFile for specific errors.
Cannot connect to world database 127.0.0.1;3306;76454;5674;world
 
I need help i have tried to figgure out all day and i guess its somethign with sql?
Link to comment
Share on other sites

--- Canned message start ---

Read http://www.trinitycore.org/f/topic/1518-trouble-with-your-trinity-install-readme-1st-faqs/

Also please Look in upper right hand corner of the forum, there is a button labeled search field, feel free to search for your issues first before posting, most questions like this one have already been answered.

If you still cannot find the answers you seek feel free to make a post and tell us the steps you took to resolve this issue and we will do our best to help you.

--- Canned message end ---

Link to comment
Share on other sites

Hey guys just 2 warn you even jeutie couldnt find the problem to my issue on ac-web

okay this is a copy from my post on ac-web

 

hey guys well here is the story me and my friend are trying to create a server on patch 4.3.4 well im trying to sort all of this stuff out he doesn't have a clue about making cores so im trying to do it over teamviewer and i did all the updates fine and everything i even checked on a guide after here is a link to that guide that i was checking on : http://collab.kpsn.org/display/tc/How-To_Win+4.3.4

after i run the mysql and auth server no error

but when i run the worldserver shuts down straight away in the blink of a eye and this error

is shown in the server.txt document that pops up after the error is done in my bin release folder

Using configuration file worldserver.conf.
Using SSL version: OpenSSL 1.0.1e 11 Feb 2013 (library: OpenSSL 1.0.1e 11 Feb 2013)
Using ACE version: 6.1.4
TrinityCore rev. 6c8d0e5405a4 2013-08-31 21:52:15 +0200 (4.3.4 branch) (Win32, Release) (worldserver-daemon)
<Ctrl-C> to stop.

______ __
/__ _ __ __/ __
/_/ / _ __ /_ ___ /_ , _ __ __
/`'__/ /' _ `/ / / /
/ / / _ _
_ _ _ _ _ _ __/`____
/_//_/ /_//_//_//_//__/ `/___/>
C O R E /___/
http://TrinityCore.org /__/

In mysql_stmt_prepare() id: 55, sql: "SELECT name, permission, help FROM command"
Unknown column 'permission' in 'field list'
DatabasePool world NOT opened. There were errors opening the MySQL connections. Check your SQLDriverLogFile for specific errors.
Cannot connect to world database 127.0.0.1;3306;root;ascent;world


Plz can someone awnser asap would rly appreciate it as we rly wanna get this uptoday ALSO I HAVE LOOKED EVERYWHERE NO PLACE ON THE INTERNET HAS THE AWNSER TO THIS QUESTION SHOCKING HUH DEFEATS THE LAWS OF ETHICS !! BLOWN YOUR MIND !!

Link to comment
Share on other sites

--- Canned message start ---

Read http://www.trinitycore.org/f/topic/1518-trouble-with-your-trinity-install-readme-1st-faqs/

Also please Look in upper right hand corner of the forum, there is a button labeled search field, feel free to search for your issues first before posting, most questions like this one have already been answered.

If you still cannot find the answers you seek feel free to make a post and tell us the steps you took to resolve this issue and we will do our best to help you.

--- Canned message end ---

Link to comment
Share on other sites

getting there errors tonight from 2013_09_02_04_world_command.sql to 2013_09_02_18_world_command.sql

 

Error occured at:2013-09-02 22:46:20
Line no.:24
Error Code: 1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ')' at line 1
 
 
 
Query:
UPDATE `command` SET `permission` = @id+18 WHERE `name` = 'disable remove vmap')
 
Error occured at:2013-09-02 22:47:43
Line no.:24
Error Code: 1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ')' at line 1
 
 
 
Query:
UPDATE `command` SET `permission` = @id+9 WHERE `name` = 'go zonexy')
 
Error occured at:2013-09-02 22:48:07
Line no.:15
Error Code: 1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ')' at line 1
 
 
 
Query:
UPDATE `command` SET `permission` = @id+12 WHERE `name` = 'gobject turn')
 
Error occured at:2013-09-02 22:49:20
Line no.:18
Error Code: 1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ')' at line 1
 
 
 
Query:
UPDATE `command` SET `permission` = @id+12 WHERE `name` = 'gobject turn')
 
Error occured at:2013-09-02 22:50:35
Line no.:18
Error Code: 1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ')' at line 1
 
 
 
Query:
UPDATE `command` SET `permission` = @id+12 WHERE `name` = 'gobject turn')
 
Error occured at:2013-09-02 22:50:37
Line no.:18
Error Code: 1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ')' at line 1
 
 
 
Link to comment
Share on other sites

 
Query:
UPDATE `command` SET `permission` = @id+6 WHERE `name` = 'guild rename')
 
Error occured at:2013-09-02 23:50:37
Line no.:18
Error Code: 1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ')' at line 1
 
 
2013_09_02_09_world_command.sql
Edited by iceyman
Link to comment
Share on other sites

Hello, before someone starts to say, "you have to update your database with the latest updates!", let me explain the situation.

  • Ubuntu 13.04 Server
  • TrinityCore rev. 6514e21b7cd8 2013-09-03 21:03:09 +0200 (4.3.4 branch) (Unix, Release)
  • TDB 434.05
  • MySql version - 5.5.32-0ubuntu0.13.04.1

     

Server.log
 
So, i imported the TDB 434.05 sql file to the world database, and applied the updates from git  (TrinityCore_4.3.4_DB_Alpha/updates/) that were more recent than May.

 

Am i missing some important database update ?

Edited by ArcM
Link to comment
Share on other sites

--- Canned message start ---

Read http://www.trinitycore.org/f/topic/1518-trouble-with-your-trinity-install-readme-1st-faqs/

Also please Look in upper right hand corner of the forum, there is a button labeled search field, feel free to search for your issues first before posting, most questions like this one have already been answered.

If you still cannot find the answers you seek feel free to make a post and tell us the steps you took to resolve this issue and we will do our best to help you.

--- Canned message end ---

Link to comment
Share on other sites

  • 2 weeks later...

error with authserver :

TrinityCore rev. bd8d0cfbce9a 2013-09-12 16:42:22 +0100 (master branch) (Win32, Release) (authserver)
<Ctrl-C> to stop.

Using configuration file authserver.conf.
OpenSSL 1.0.1e 11 Feb 2013 (Library: OpenSSL 1.0.0b 16 Nov 2010)
Opening DatabasePool 'auth'. Asynchronous connections: 1, synchronous connections: 1.
MySQL client library: 5.5.9
MySQL server ver: 5.5.9-log 
Connected to MySQL database at 127.0.0.1
In mysql_stmt_prepare() id: 43, sql: "UPDATE account SET reg_mail = ? WHERE id = ?"
Unknown column 'reg_mail' in 'field list'
MySQL client library: 5.5.9
MySQL server ver: 5.5.9-log 
Connected to MySQL database at 127.0.0.1
In mysql_stmt_prepare() id: 34, sql: "INSERT INTO account(username, sha_pass_hash, reg_mail, email, joindate) VALUES(?, ?, ?, ?, NOW())"
Unknown column 'reg_mail' in 'field list'
In mysql_stmt_prepare() id: 59, sql: "SELECT a.username, aa.gmlevel, a.email, a.reg_mail, a.last_ip, DATE_FORMAT(a.last_login, '%Y-%m-%d %T'), a.mutetime, a.mutereason, a.muteby, a.failed_logins, a.locked, a.OS FROM account a LEFT JOIN account_access aa ON (a.id = aa.id AND (aa.RealmID = ? OR aa.RealmID = -1)) WHERE a.id = ?"
Unknown column 'a.reg_mail' in 'field list'
DatabasePool auth NOT opened. There were errors opening the MySQL connections. Check your SQLDriverLogFile for specific errors.
Cannot connect to database

Error with worldserver :

Using configuration file worldserver.conf.
Using SSL version: OpenSSL 1.0.1e 11 Feb 2013 (library: OpenSSL 1.0.0b 16 Nov 2010)
Using ACE version: 6.1.4
TrinityCore rev. bd8d0cfbce9a 2013-09-12 16:42:22 +0100 (master branch) (Win32, Release) (worldserver-daemon)
<Ctrl-C> to stop.

 ______                       __
/__  _       __          __/ __
/_/ / _ __ /_    ___ /_ , _  __  __
     /`'__/  /' _ `/   / / / 
        /   / /     _  _ 
      _ _   _ _ _ _ __/`____ 
      /_//_/   /_//_//_//_//__/ `/___/> 
                                 C O R E  /___/
http://TrinityCore.org                    /__/

In mysql_stmt_prepare() id: 43, sql: "UPDATE account SET reg_mail = ? WHERE id = ?"
Unknown column 'reg_mail' in 'field list'
In mysql_stmt_prepare() id: 34, sql: "INSERT INTO account(username, sha_pass_hash, reg_mail, email, joindate) VALUES(?, ?, ?, ?, NOW())"
Unknown column 'reg_mail' in 'field list'
In mysql_stmt_prepare() id: 59, sql: "SELECT a.username, aa.gmlevel, a.email, a.reg_mail, a.last_ip, DATE_FORMAT(a.last_login, '%Y-%m-%d %T'), a.mutetime, a.mutereason, a.muteby, a.failed_logins, a.locked, a.OS FROM account a LEFT JOIN account_access aa ON (a.id = aa.id AND (aa.RealmID = ? OR aa.RealmID = -1)) WHERE a.id = ?"
Unknown column 'a.reg_mail' in 'field list'
DatabasePool auth NOT opened. There were errors opening the MySQL connections. Check your SQLDriverLogFile for specific errors.
Cannot connect to login database 127.0.0.1;3306;root;ascent;auth

if you can add me on skype and help please do so  my names dylan.hf

or post here thanks

Link to comment
Share on other sites

When I open worldserver.exe, after opening authserver without any problem I get this 

 

Using configuration file worldserver.conf.
Using SSL version: OpenSSL 1.0.0c 2 Dec 2010 (library: OpenSSL 1.0.1c 10 May 2012)
Using ACE version: 6.1.4
TrinityCore rev. unknown 1970-01-01 00:00:00 +0000 (Archived branch) (Win32, Release) (worldserver-daemon)
<Ctrl-C> to stop.

 ______                       __
/__  _       __          __/ __
/_/ / _ __ /_    ___ /_ , _  __  __
     /`'__/  /' _ `/   / / / 
        /   / /     _  _ 
      _ _   _ _ _ _ __/`____ 
      /_//_/   /_//_//_//_//__/ `/___/> 
                                 C O R E  /___/
http://TrinityCore.org                    /__/

In mysql_stmt_prepare() id: 55, sql: "SELECT name, permission, help FROM command"
Unknown column 'permission' in 'field list'
In mysql_stmt_prepare() id: 56, sql: "SELECT difficulty_entry_1, difficulty_entry_2, difficulty_entry_3, KillCredit1, KillCredit2, modelid1, modelid2, modelid3, modelid4, name, subname, IconName, gossip_menu_id, minlevel, maxlevel, exp, faction_A, faction_H, npcflag, speed_walk, speed_run, scale, rank, mindmg, maxdmg, dmgschool, attackpower, dmg_multiplier, baseattacktime, rangeattacktime, unit_class, unit_flags, unit_flags2, dynamicflags, family, trainer_type, trainer_spell, trainer_class, trainer_race, minrangedmg, maxrangedmg, rangedattackpower, type, type_flags, lootid, pickpocketloot, skinloot, resistance1, resistance2, resistance3, resistance4, resistance5, resistance6, spell1, spell2, spell3, spell4, spell5, spell6, spell7, spell8, PetSpellDataId, VehicleId, mingold, maxgold, AIName, MovementType, InhabitType, HoverHeight, Health_mod, Mana_mod, Armor_mod, RacialLeader, questItem1, questItem2, questItem3, questItem4, questItem5, questItem6, movementId, RegenHealth, mechanic_immune_mask, flags_extra, ScriptName FROM creature_template WHERE entry = ?"
Unknown column 'unit_flags2' in 'field list'
DatabasePool world NOT opened. There were errors opening the MySQL connections. Check your SQLDriverLogFile for specific errors.
Cannot connect to world database localhost;3306;root;****;world
I have compiled the core.

 

 

 

 

 

 

Link to comment
Share on other sites

--- Canned message start ---

Read http://www.trinitycore.org/f/topic/1518-trouble-with-your-trinity-install-readme-1st-faqs/

Also please Look in upper right hand corner of the forum, there is a button labeled search field, feel free to search for your issues first before posting, most questions like this one have already been answered.

If you still cannot find the answers you seek feel free to make a post and tell us the steps you took to resolve this issue and we will do our best to help you.

--- Canned message end ---

Link to comment
Share on other sites

--- Canned message start ---

Read http://www.trinitycore.org/f/topic/1518-trouble-with-your-trinity-install-readme-1st-faqs/

Also please Look in upper right hand corner of the forum, there is a button labeled search field, feel free to search for your issues first before posting, most questions like this one have already been answered.

If you still cannot find the answers you seek feel free to make a post and tell us the steps you took to resolve this issue and we will do our best to help you.

--- Canned message end ---

Link to comment
Share on other sites

Hello,

I've been trying to get Trinity Core 4.3.4 running today. I've spent like 5 hours trying to figure it out what is the problem. I will post here the steps i followed.

1) Pulled the git from 4.3.4 branch, runned CMake and got it compiled via Visual Studio 2010.

2) Cloned the 4.3.4 DB Repository and downloaded the last full db compilation (TDB_full_434.05_2013_07_17).

3) Created the databases by executing create_mysql.sql, auth_database.sql and characters_database.sql. 

4) Updated characters database . Only had to run this query 2013_07_19_00_characters_corpse.sql .

5) Runned merge_windows.bat and updated my world database , by executing the sql generated (world_update.sql).

6) Edited the config files accordingly.

7) Moved libmysql and the other 2 openssl libraries into the release folder.

8) Started authserver.exe .

9) Started worldserver.exe .

MENTION : Had no errors till now. I also added DBC/Maps/VMaps in the release folder.

 

Got this error on worldserver :

 

In mysql_stmt_prepare() id: 55, sql: "SELECT name, permission, help FROM command"

Unknown column 'permission' in 'field list'

DatabasePool world NOT opened. There were errors opening the MySQL connections.

Check your SQLDriverLogFile for specific errors

Cannot connect to world database 127.0.0.1;3306;xxxxx;xxxxx;world

 

I've tried everything, even renaming the security column to permission and still got some database related errors. 

 

Am I doing something wrong ?

 

L.E. I want to mention that i use mysql 5.5.27 and i use the libmysql.dll library provided by CMake.

Edited by punkyy2408
Link to comment
Share on other sites

--- Canned message start ---

Read http://www.trinitycore.org/f/topic/1518-trouble-with-your-trinity-install-readme-1st-faqs/

Also please Look in upper right hand corner of the forum, there is a button labeled search field, feel free to search for your issues first before posting, most questions like this one have already been answered.

If you still cannot find the answers you seek feel free to make a post and tell us the steps you took to resolve this issue and we will do our best to help you.

--- Canned message end ---

Link to comment
Share on other sites

I would have loved to make my entrance into a website like this with a share, but I'm running into a very big issue right now.

 

When I tried to run worldserver.exe I get this error:

Using configuration file worldserver.conf.
Using SSL version: OpenSSL 1.0.1e 11 Feb 2013 (library: OpenSSL 1.0.1e 11 Feb 2013)
Using ACE version: 6.1.4
TrinityCore rev. 4498ac0062d5+ 2013-09-22 18:40:47 +0200 (master branch) (Win32, Release) (worldserver-daemon)
<Ctrl-C> to stop.



In mysql_stmt_prepare() id: 55, sql: "SELECT name, permission, help FROM command"
Unknown column 'permission' in 'field list'
In mysql_stmt_prepare() id: 56, sql: "SELECT difficulty_entry_1, difficulty_entry_2, difficulty_entry_3, KillCredit1, KillCredit2, modelid1, modelid2, modelid3, modelid4, name, subname, IconName, gossip_menu_id, minlevel, maxlevel, exp, faction_A, faction_H, npcflag, speed_walk, speed_run, scale, rank, mindmg, maxdmg, dmgschool, attackpower, dmg_multiplier, baseattacktime, rangeattacktime, unit_class, unit_flags, unit_flags2, dynamicflags, family, trainer_type, trainer_spell, trainer_class, trainer_race, minrangedmg, maxrangedmg, rangedattackpower, type, type_flags, lootid, pickpocketloot, skinloot, resistance1, resistance2, resistance3, resistance4, resistance5, resistance6, spell1, spell2, spell3, spell4, spell5, spell6, spell7, spell8, PetSpellDataId, VehicleId, mingold, maxgold, AIName, MovementType, InhabitType, HoverHeight, Health_mod, Mana_mod, Armor_mod, RacialLeader, questItem1, questItem2, questItem3, questItem4, questItem5, questItem6, movementId, RegenHealth, mechanic_immune_mask, flags_extra, ScriptName FROM creature_template WHERE entry = ?"
Unknown column 'unit_flags2' in 'field list'
DatabasePool world NOT opened. There were errors opening the MySQL connections. Check your SQLDriverLogFile for specific errors.
Cannot connect to world database 127.0.0.1;3306;root;ascent;world

 

I have researched this on the forum, and no luck. I've tried adding all of the updates via a merged SQL but I have not wanted to do them one by one. ~130 seems like quite a bit to me.

I also noted the TDB Download (Full) I've downloaded is pretty out dated: http://www.trinitycore.org/f/files/file/5-tdb-full-updates/

 

I do realize it has all the updates available upon compile... but damn, it's a bunch.

 

 

I am presented with these errors whilst trying to add the updates via a merged SQL on a world database added from the download link I provided:

http://pastebin.com/KMDs1t6q

 

 

I do thank you for all your support, and I'd like to thank the entire Trinity team!

 

I hope I can get this resolved, thank you.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.


  • Similar Content

    • By xgamerninjax
      Hello all, first time posting here and it's really got me scratching my head.
      I've compiled everything on my own computer, and then transferred everything to a host computer so the server can stay live. The server was running fine for a month or so and then suddenly it just crashes when it hits "Loading C++ scripts", exiting saying "caught signal 22"
      I tried setting up the host computer from scratch and transferred everything over fresh and it's still happening for some reason. (Note, I can run the server perfectly on my personal pc where I compiled it.)
      Any help would be greatly appreciated, thanks!
      3d7e3a40e2b3+_worldserver.exe_[1-4_15-19-45].dmp 3d7e3a40e2b3+_worldserver.exe_[1-4_15-19-45].txt
    • By Rochet2
      A lot of people have asked how to debug so I made this short guide on how to set up debugging.
      This guide only tells you how to actually set up debugging in TrinityCore on Windows and Linux.
      This will not explain the basics of debugging. You can google those or play around with the debugger to learn.
      Here are a few videos that explain how to actually debug after setting debugging up on visual studio: https://youtu.be/0ebzPwixrJA and linux: https://www.youtube.com/watch?v=sCtY--xRUyI

      This guide contains multiple guides. Each list of bullet points is it's own guide.
      Make sure you can run the server normally before trying to debug.

      Windows:
      On Windows before anything you should check these
      - Before debugging or making crashlogs etc. with Visual Studio you must compile the core in "Debug" instead of "Release". You can select this in "Build>Configuration Manager" or at the top of Visual Studio window http://i.imgur.com/5oHd59j.png
      - You also need to move the new pdb files generate by compiling in debug mode on Visual Studio from the compile output folder (bin) to your server folder - these files contain information needed for debugging.
      - It is assumed that Solution Explorer is open. Open it by selecting "View>Solution Explorer" in Visual Studio http://i.imgur.com/hkW6Gk0.png
      -- You may want to click on the Home icon to reset the view on Solution Explorer http://i.imgur.com/N8UPwDh.png
      - You can place breakpoints in Visual Studio editor by right clicking a line of code and selecting "Breakpoint>Insert Breakpoint" http://i.imgur.com/L2TxBVG.png
      - At the top of the window you should see controls for stepping and continuing when you have started to debug.
      - Here is a video showing the basic Visual Studio functionality https://www.youtube.com/watch?v=Ijdk4z8-2OI
      Fastest way to debug on windows. This is the easiest way to start up debugging a script.
      - Start the authserver and worldserver normally
      - Open TrinityCore.sln in Visual Studio. This is what you usually open when you want to compile the core
      - In Visual Studio at the top select "Debug>Attach to process...>worldserver.exe" and click "Attach" http://i.imgur.com/jDEI2Hq.png
      - You are now debugging
       
      The second slower way of debugging on windows. This is useful for debugging something that occurs in the startup of the server.
      - Open TrinityCore.sln in Visual Studio. This is what you usually open when you want to compile the core
      - In solution explorer right click on worldserver and select "Set as StartUp Project" http://i.imgur.com/wvMzeRA.png
      - In solution explorer right click on worldserver and select "Properties" http://i.imgur.com/rTNEF9O.png
      -- In Properties you should go to "Configuration Properties>Debugging" and edit "Working Directory" to point to the server folder. For me this is the default compile folder so I use "$(OutDir)" http://i.imgur.com/aRI29fB.png
      - Start the authserver normally
      - Start the worldserver by selecting "Debug>Start Debugging". The server will start with debugging attached from the beginning http://i.imgur.com/cg1KJNw.png
      - You are now debugging
      Crashlogs on windows. Once you have a way to reproduce a crash you can get a crashlog that can help you resolve it.
      - After compiling the core in "Debug" instead of "Release" start up the worldserver and authserver
      - Reproduce the crash you have
      - In the server folder there is now a folder called Crashes that contains txt and dmp files. http://i.imgur.com/9eQIdql.png
      - You can open the txt files in text editors http://i.imgur.com/EH6R17E.png
      -- At the top of a txt file there is some information about your system and below it there is the Call Stack and below that there are Variables of each part of the call stack
      -- The Call Stack will tell you at the top what was the last function call before crashing and what function calls led to that function call.
      -- Next to the function names there is the file that the function is defined in and the line number the code was executing in that function.
      -- In the Variables section you can inspect variables that were present at each function call.
      -- Based on this information you are often able to see what crashed or get a better view of what you need to inspect more in your code.
      - The dmp file can be opened in Visual Studio
      -- Open TrinityCore.sln in Visual Studio. This is what you usually open when you want to compile the core
      -- Drag and drop the dmp file to Visual Studio
      -- In the window that opens click to "Debug with Native Only" http://i.imgur.com/OgyU2kM.png
      -- In the window popup click "Break" http://i.imgur.com/4jDzqRn.png
      -- You are now in a state like you would have hit a break point in the code or a crash while debugging. You can inspect the call stack and the variables.
      Edit and continue on windows. When debugging this allows you to change the code and without restarting the server apply those changes so they actually work ingame.
      - Open TrinityCore.sln in Visual Studio. This is what you usually open when you want to compile the core
      - In solution explorer right click on worldserver and select "Properties" http://i.imgur.com/rTNEF9O.png
      -- In Properties select "Configuration Properties>Linker>General" and set "Enable Incremental Linking" to "Yes". http://i.imgur.com/caQqwN5.png
      -- In Properties select "Configuration Properties>Linker>Advanced" and set "Image Has Safe Exception Handlers" to "No". http://i.imgur.com/FYzN8Ks.png
      -- In Properties select "Configuration Properties>C/C++>General" and set "Debug Information Format" to "Program Database for Edit And Continue". http://i.imgur.com/pxQ6I8N.png
      - At the top of the window select "Tools>Options". In the Options select "Debugging>General" and in there select "Enable Edit and Continue", "Enable Native Edit and Continue" and "Require source files to exactly match the original version".
      - Compile the server for the changes to take effect.
      - Set up "The second slower way of debugging" (I did not test edit and continue on other configurations)
      - Start the authserver normally
      - Start the worldserver by selecting "Debug>Start Debugging".
      - Try edit a cpp file a little and save it.
      - At top of Visual Studio window select "Debug>Apply Code Changes" and wait until the changes are applied. Warning: it can take considerable amount of time for the changes to be applied. http://i.imgur.com/77pb58E.png
      - If you have issues, be sure to check the error messages in Output. You can view it by selecting "View>Output" http://i.imgur.com/4cIznW9.png
      - This guide was written based on https://msdn.microsoft.com/en-us/library/esaeyddf.aspx and https://blogs.msdn.microsoft.com/vcblog/2015/07/22/c-edit-and-continue-in-visual-studio-2015/
      Linux:
      First we need to compile the server in debug mode.
      - Compile the server with the cmake flag -DCMAKE_BUILD_TYPE=Debug

      Debugging on linux. You can debug on linux by using GDB.
      - Here is a good video about it: https://www.youtube.com/watch?v=sCtY--xRUyI
      - Basically you
      -- Start the authserver
      -- Start the worldserver by using "gdb ./worldserver"
      -- Enter breakpoints by using break command on gdb
      -- Use the run command on gdb to start the server
      -- You are now debugging
      - You may also be interested in using VScode or some other more visual debuggers. https://www.youtube.com/watch?v=B0xTgyCwsAo
      Crashlogs on linux. Once you have a way to reproduce a crash you can get a crashlog that can help you resolve it.
      - Take crashreport.gdb from /contrib/debugger from source folder and place it to your server folder
      - Start the authserver
      - Start the worldserver by using "gdb -x crashreport.gdb ./worldserver"
      - Reproduce your crash
      - There should be a backtrace.log in your server folder that contains information about the crash like the callstack and variables in each function call in the call stack
      - This guide was written based on https://github.com/TrinityCore/TrinityCore/blob/master/contrib/debugger/README
      Running valgrind on linux. This helps you find memory errors like invalid reads and writes and memory leaks.
      - Here is a good video about it: https://www.youtube.com/watch?v=fvTsFjDuag8
      - Basically you
      -- Start the authserver
      -- Start the worldserver by using "valgrind ./worldserver"
      -- Run your code that you want to analyze and close the server
      -- The console or an output log should contain the valgrind log
    • By reyne
      Hey there!

      I've followed a few threads here about map extraction, and am still having issues. Originally, I was having the issue described here.
      After following the advice given in that thread (creating characters of both BC races and running around for a bit), I am no longer getting that error, however now I get the following error while trying to extract maps:

      `Error loading World\Maps\Expansion01\Expansion01_42_6.adt`

      This repeats for every line in Expansion01, and then the extractor crashes.

      I'm not sure where else to go from here.

      Thanks for your help

      Edit: I've created an 85 on an i85 server and flown all around Outland now, same issue.
    • By Uee
      I recently found the Trinity Cataclsym Preservation Project and thought I will try it out.
      I am already running 3.3.5a and Master - both server run great
      Pulled 4.3.4 down using Git and built it same way as others:
      boost_1_73_0 cmake 3.17.2 Mysql 5.7.30 VS Community 2019 Built fine - no issue. Used 'Extractor.bat' to run all the map extractors - worked great!
      Noticed there was extra file 'connection_patcher.exe`, ran that - worked great! Now have "wow_patched" and use this to launch client
      MySQL runs in standalone mode, -initialize, added base sql files, imported, auth and character sql files
      Configured both the .conf files and passwords, IPs etc are all in place.
      Note: When loading the exe and built conf file, bnetserver complain about these items missing, so I add them:
      Updates.AutoSetup = 1 Updates.EnableDatabases = 0 LoginDatabase.SynchThreads = 1 Load up Mysql - loads fine
      Load up bnetserver and appears to load ok - last few lines look like this:
      Connected to MySQL database at 127.0.0.1
      DatabasePool 'auth' opened successfully. 2 total connections running.
      Started auth database connection pool.
      Listening on connections from worldservers on port 1118...
      Load up worldserver and it adds the FULL world and hotfixes, then applied all updates (confirmed archived in SQL) - last few lines look like this:
      Calculate next monthly quest reset time...
      Calculate random battleground reset time...
      Calculate guild limitation(s) reset time...
      Calculate next currency reset time...
      World initialized in 0 minutes 13 seconds
      TrinityCore rev. d0c7bbab40bc 2020-05-06 00:01:21 +0200 (master branch) (Win64, RelWithDebInfo, Static) (worldserver-daemon) ready...
       
      There are no db errors in logs.
      Config.wtf contain portal, realmlist as remote server and patchlist as localhost.
      When I try to connecting using "[email protected]" and password I get immediately disconnected.
      What I did noticed different is that the bnetserver doesnt add "Added realm "Battle for Azeroth" at 192.168.10.213:8085." (From my Master log) 
      3.3.5a also have this line as last line in authserver - but 4.3.4 is not giving me this one.
      Realmlist table is accurate with right information.
      Anyone know why bnetserver is not starting me realm?
       
    • By Deer_Hunter
      Hello all,
      I just updated from the latest Git 
      Trinity Core REV. ac6baa547376 + 2020-02-21  3.3.5 Branch.
      I'm getting this error after crash.
      Problem signature:
        Problem Event Name:    APPCRASH
        Application Name:    worldserver.exe
        Application Version:    0.0.0.0
        Application Timestamp:    5e50a462
        Fault Module Name:    StackHash_f12f
        Fault Module Version:    6.3.9600.19629
        Fault Module Timestamp:    5e2fdc0d
        Exception Code:    c0000374
        Exception Offset:    PCH_9E_FROM_ntdll+0x0000000000090D0A
        OS Version:    6.3.9600.2.0.0.272.7
        Locale ID:    1033
        Additional Information 1:    f12f
        Additional Information 2:    f12f0934d3e965f73c68e60f20f2cd40
        Additional Information 3:    7595
        Additional Information 4:    7595e4d8d703db9dcd3d2f6ea540e357
      the exception code says its a Heap error,  I'm not sure how to troubleshoot this.
      Thanks
×
×
  • Create New...