Jump to content

"unknown column" "missing table" "duplicate column" error / sql problems / SQLDriverLogFile < answer on 1st post of 1st page


Recommended Posts

I have the exact same problem (and I confirm, the thread linked doesn't have the answer).

I pulled the core, db and downloaded the world file yesterday.

I followed the tutorial (with quite some difficulty).

The auth server starts but I get the same error as OP when starting the world server. What to do ?


Edit :

System : Windows 7 64 bits

Core version : I don't know where to find that, pulled yesterday.

DB version : I don't know where to find that, pulled yesterday.

World file : TDB_full_434.05_2013_07_17.sql


I have updated the world db once only.

Edited by bj51
Link to comment
Share on other sites

Hi there

I'm a newbie, trying to compile my first core after playing on repacks for a while.


For starters :

Win 7 64,

latest 4.3.4 core and db (pulled on the 22)



I followed the tutorial on http://collab.kpsn.org/display/tc/How-To_Win+4.3.4 to try and set up the server (with quite some difficulty, this is my first time doing a bunch of stuff here).

All programs used are at least the same version as the one needed.


At the end, I have the following error starting the world server :

In mysql_stmt_prepare() id: 55, sql: "SELECT name, permission, help FROM command"
Unknown column 'permission' in 'field list'

From the possible reasons I read from the FAQ, I can't find the one responsible.

I dropped the world dB and recreated It, being careful not to apply the same update twice, but the problem is persistant. And since I'm a newbie, I'm quite lost.


What to do, please ?


PS : please don't send me that pedantic bot who links you to the FAQ...

Link to comment
Share on other sites

with quite some difficulty, this is my first time doing a bunch of stuff here


Highly recommend you do not start your use of TC with the 434 branch. The 434 branch is not for inexperienced users and inherently comes with its own set of difficulties which TC expects you to be capable of figuring out on your own, thus 434 is generally not supported (as in, we don't address issues with this branch because of the previous reason).


Your database does not reflect the required structure necessary for the revision of core you are using. This could be one of several reasons:


  1. 434 is not synced with the master repo, in which case some changes are not yet reflected, making it impossible to run 434 using the most recent commit. In this case, you should determine the last revision at which 434 TDB was released, and then compile using that revision. You can then safely start the core without issues (keeping in mind that you need not apply updates, you only need TDB[434])
  2. you incorrectly applied 434 DB updates. Follow the guide verbatim and this will not happen


TC provides a very clear disclaimer on the 434 guides.


"The database and the core are alpha, early development, and are only meant to be used for development purposes".

4.3.4 is still in development! Do not expect this to be a fully functioning, production server. I don't believe it is even in Alpha stages yet. Use for fun, or for helping the project.


Please bear this in mind, and expect things to go wrong.

Link to comment
Share on other sites

I was doing my monthly update to the latest version of the core, and was surprised to see errors thrown in importing the updates from /sql/updates/auth

Table 'auth.rbac_group_roles' doesn't exist
Table 'auth.rbac_role_permissions' doesn't exist

I attempted a variety of troubleshooting methods, including manually adding the tables, to no avail. I eventually decided to start the server to see if it threw any errors, it didn't, so I logged in, and discovered all of the gm commands were disabled. I went to the worldserver console and reset my account level, it said it completed successfully, but after reologing in, commands still didn't work.

I tried manually setting my gmlevel in the database. Nope.

I dumped the whole auth database, rebuilt it from the base, re-applied all the updates. It still threw the missing table errors, and I still couldn't set the account level.

I've been running Trinity for over a year wuithout even the slightest issue before, I haven't the slightest clue wha I may have done wrong this time.

Edited by Ness199X
Link to comment
Share on other sites

If you're getting those as a result of a DB update, it's because they have already been removed (i.e., you're applying updates incorrectly). Those tables, along with a handful of others, were removed. RBAC was essentially condensed to 4 tables. Take a look at the documentation for more info.


As far as your GM commands are concerned, you need to add the appropriate accounts to rbac_account_permissions (specifically, for admin access, your account and permission 196, 197 for GM, 198 for mod, etc). Alternatively you can use the .rbac account grant console command. [.rbac account grant acctid 196]


Then take a look at your rbac_linked_permissions to see what each of those roles (permissions with other permissions assigned to them) has. To see all the "default" roles, just filter this table with keyword "role".

Link to comment
Share on other sites

I dumped the whole auth database, rebuilt it from the base, re-applied all the updates.


This is wrong. If you dumped the auth database, and rebuilt it using source/sql/base, you do *not* need to apply updates. 


Check rbac_linked_permissions and see what permissions are linked to permission 196. Also make sure your account is listed as "level 3" in trinity.account_access.

Link to comment
Share on other sites



Why "level 4"? When you do "help account set gmlevel" it says the range is 0 to 3.


Yeah...I meant 3.



we shouldn't be using any number levels at all, since RBAC is supposed to get rid of that clumsy system.


I agree, but not yet anyway, not while the core still relies on it. See "rbac_default_permissions" which defines the rbac_permissions based on access level.

Link to comment
Share on other sites



i used the last rev from the TrinityCore 3.3.5a.

I have compiled the TrinityCore on my Linux Debian server.

All okay.

Then i insert the "auth"-database in my mysql. ("TrinityCore/sql/base/auth_database.sql")

When i am insert the updates from "TrinityCore/sql/updates/auth" show me this error:

mysql> . 2013_08_25_00_auth.sql
ERROR 1060 (42S21): Duplicate column name 'token_key'
mysql> . 2013_08_30_00_auth_misc.sql
Query OK, 7 rows affected (0.00 sec)

Query OK, 17 rows affected (0.01 sec)
Records: 17  Duplicates: 0  Warnings: 0

ERROR 1146 (42S02): Table 'auth.rbac_role_permissions' doesn't exist
ERROR 1146 (42S02): Table 'auth.rbac_role_permissions' doesn't exist

Who can i download the new correct auth-database whith RBAC?


Sry my english is not so good

Greetings from Germany!

Link to comment
Share on other sites

hello good I explained what happened to me after compiling and other
when configuring the server as usual e echo ago but now when I try to open the WorldServer me the following error jumps.
In mysql_stmt_prepare () id: 53, sql: "SELECT name, permission, help FROM command"
Unknown column 'permission' in 'field list'
how could I fix it?
pardon my English

Good because the servant does not initiate me if I put well the information. The following thing is said. I put trinity not to put my information
In mysql_stmt_prepare() id: 53, sql: "SELECT name, permission, help FROM command"
Unknown column 'permission' in 'field list'
DatabasePool world NOT opened. There were errors opening the MySQL connections. Check your SQLDriverLogFile for specific errors.
Cannot connect to world database trinity;3306;root;trinity;world


Link to comment
Share on other sites

--- Canned message start ---

Read http://www.trinitycore.org/f/topic/1518-trouble-with-your-trinity-install-readme-1st-faqs/

Also please Look in upper right hand corner of the forum, there is a button labeled search field, feel free to search for your issues first before posting, most questions like this one have already been answered.

If you still cannot find the answers you seek feel free to make a post and tell us the steps you took to resolve this issue and we will do our best to help you.

--- Canned message end ---

Link to comment
Share on other sites

I am having this very same problem.


I tried everything.


Just even download the whole core/db again and did a clean install.


Is any update with world db has to do with that error?


The only comands I can use right now are .gm on/off, mod speed and levelup. Besides that I cant use anything.


Can anyone PLEASE do a step by step to add an account to have all commands or any command?


Really appreciate. Trying this since yesterday, I read everything and did many searchs, but I cant figure this out :(



EDIT: Whoever is getting that same error, mine was solved after I updated my command table. Freaking thing :(

Edited by PhoenixSong
Link to comment
Share on other sites

we are wizards and we can read mind of poster and know the warning.

Where can I get the logs from to see the warning?

Hmm I tried importing characters_database with sqlyog instead and no errors appeared, this could be a heidisql problem then?

Edited by zeukin
Link to comment
Share on other sites

Where can I get the logs from to see the warning?

Hmm I tried importing characters_database with sqlyog instead and no errors appeared, this could be a heidisql problem then?


Adding to what Guybrush stated... Iv'e always imported from command line. I've been told otherwise (no idea why), but I have NEVER had a problem.

Link to comment
Share on other sites

Hello everyone.


I'm having some trouble with in game commands for RBAC.


--To answer the basic questions--


I have a self-compile made today.

I have updated the world database

I have not updated character or auth database.

I have created accounts and given them security through console.

(.account create test test1 | .account set gmlevel test 3 -1)

The auth database is set up correctly with all four RBAC tables, and the linked permissions are set properly. 


Players: No commands, unable to access BGs/Arenas/Etc.
Moderator: ^

Gamemaster: ^^

Administrator: ^^^


Not sure what else I could do. I've been looking around the forums for a few hours trying to figure out how to fix this.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By xgamerninjax
      Hello all, first time posting here and it's really got me scratching my head.
      I've compiled everything on my own computer, and then transferred everything to a host computer so the server can stay live. The server was running fine for a month or so and then suddenly it just crashes when it hits "Loading C++ scripts", exiting saying "caught signal 22"
      I tried setting up the host computer from scratch and transferred everything over fresh and it's still happening for some reason. (Note, I can run the server perfectly on my personal pc where I compiled it.)
      Any help would be greatly appreciated, thanks!
      3d7e3a40e2b3+_worldserver.exe_[1-4_15-19-45].dmp 3d7e3a40e2b3+_worldserver.exe_[1-4_15-19-45].txt
    • By Rochet2
      A lot of people have asked how to debug so I made this short guide on how to set up debugging.
      This guide only tells you how to actually set up debugging in TrinityCore on Windows and Linux.
      This will not explain the basics of debugging. You can google those or play around with the debugger to learn.
      Here are a few videos that explain how to actually debug after setting debugging up on visual studio: https://youtu.be/0ebzPwixrJA and linux: https://www.youtube.com/watch?v=sCtY--xRUyI

      This guide contains multiple guides. Each list of bullet points is it's own guide.
      Make sure you can run the server normally before trying to debug.

      On Windows before anything you should check these
      - Before debugging or making crashlogs etc. with Visual Studio you must compile the core in "Debug" instead of "Release". You can select this in "Build>Configuration Manager" or at the top of Visual Studio window http://i.imgur.com/5oHd59j.png
      - You also need to move the new pdb files generate by compiling in debug mode on Visual Studio from the compile output folder (bin) to your server folder - these files contain information needed for debugging.
      - It is assumed that Solution Explorer is open. Open it by selecting "View>Solution Explorer" in Visual Studio http://i.imgur.com/hkW6Gk0.png
      -- You may want to click on the Home icon to reset the view on Solution Explorer http://i.imgur.com/N8UPwDh.png
      - You can place breakpoints in Visual Studio editor by right clicking a line of code and selecting "Breakpoint>Insert Breakpoint" http://i.imgur.com/L2TxBVG.png
      - At the top of the window you should see controls for stepping and continuing when you have started to debug.
      - Here is a video showing the basic Visual Studio functionality https://www.youtube.com/watch?v=Ijdk4z8-2OI
      Fastest way to debug on windows. This is the easiest way to start up debugging a script.
      - Start the authserver and worldserver normally
      - Open TrinityCore.sln in Visual Studio. This is what you usually open when you want to compile the core
      - In Visual Studio at the top select "Debug>Attach to process...>worldserver.exe" and click "Attach" http://i.imgur.com/jDEI2Hq.png
      - You are now debugging
      The second slower way of debugging on windows. This is useful for debugging something that occurs in the startup of the server.
      - Open TrinityCore.sln in Visual Studio. This is what you usually open when you want to compile the core
      - In solution explorer right click on worldserver and select "Set as StartUp Project" http://i.imgur.com/wvMzeRA.png
      - In solution explorer right click on worldserver and select "Properties" http://i.imgur.com/rTNEF9O.png
      -- In Properties you should go to "Configuration Properties>Debugging" and edit "Working Directory" to point to the server folder. For me this is the default compile folder so I use "$(OutDir)" http://i.imgur.com/aRI29fB.png
      - Start the authserver normally
      - Start the worldserver by selecting "Debug>Start Debugging". The server will start with debugging attached from the beginning http://i.imgur.com/cg1KJNw.png
      - You are now debugging
      Crashlogs on windows. Once you have a way to reproduce a crash you can get a crashlog that can help you resolve it.
      - After compiling the core in "Debug" instead of "Release" start up the worldserver and authserver
      - Reproduce the crash you have
      - In the server folder there is now a folder called Crashes that contains txt and dmp files. http://i.imgur.com/9eQIdql.png
      - You can open the txt files in text editors http://i.imgur.com/EH6R17E.png
      -- At the top of a txt file there is some information about your system and below it there is the Call Stack and below that there are Variables of each part of the call stack
      -- The Call Stack will tell you at the top what was the last function call before crashing and what function calls led to that function call.
      -- Next to the function names there is the file that the function is defined in and the line number the code was executing in that function.
      -- In the Variables section you can inspect variables that were present at each function call.
      -- Based on this information you are often able to see what crashed or get a better view of what you need to inspect more in your code.
      - The dmp file can be opened in Visual Studio
      -- Open TrinityCore.sln in Visual Studio. This is what you usually open when you want to compile the core
      -- Drag and drop the dmp file to Visual Studio
      -- In the window that opens click to "Debug with Native Only" http://i.imgur.com/OgyU2kM.png
      -- In the window popup click "Break" http://i.imgur.com/4jDzqRn.png
      -- You are now in a state like you would have hit a break point in the code or a crash while debugging. You can inspect the call stack and the variables.
      Edit and continue on windows. When debugging this allows you to change the code and without restarting the server apply those changes so they actually work ingame.
      - Open TrinityCore.sln in Visual Studio. This is what you usually open when you want to compile the core
      - In solution explorer right click on worldserver and select "Properties" http://i.imgur.com/rTNEF9O.png
      -- In Properties select "Configuration Properties>Linker>General" and set "Enable Incremental Linking" to "Yes". http://i.imgur.com/caQqwN5.png
      -- In Properties select "Configuration Properties>Linker>Advanced" and set "Image Has Safe Exception Handlers" to "No". http://i.imgur.com/FYzN8Ks.png
      -- In Properties select "Configuration Properties>C/C++>General" and set "Debug Information Format" to "Program Database for Edit And Continue". http://i.imgur.com/pxQ6I8N.png
      - At the top of the window select "Tools>Options". In the Options select "Debugging>General" and in there select "Enable Edit and Continue", "Enable Native Edit and Continue" and "Require source files to exactly match the original version".
      - Compile the server for the changes to take effect.
      - Set up "The second slower way of debugging" (I did not test edit and continue on other configurations)
      - Start the authserver normally
      - Start the worldserver by selecting "Debug>Start Debugging".
      - Try edit a cpp file a little and save it.
      - At top of Visual Studio window select "Debug>Apply Code Changes" and wait until the changes are applied. Warning: it can take considerable amount of time for the changes to be applied. http://i.imgur.com/77pb58E.png
      - If you have issues, be sure to check the error messages in Output. You can view it by selecting "View>Output" http://i.imgur.com/4cIznW9.png
      - This guide was written based on https://msdn.microsoft.com/en-us/library/esaeyddf.aspx and https://blogs.msdn.microsoft.com/vcblog/2015/07/22/c-edit-and-continue-in-visual-studio-2015/
      First we need to compile the server in debug mode.
      - Compile the server with the cmake flag -DCMAKE_BUILD_TYPE=Debug

      Debugging on linux. You can debug on linux by using GDB.
      - Here is a good video about it: https://www.youtube.com/watch?v=sCtY--xRUyI
      - Basically you
      -- Start the authserver
      -- Start the worldserver by using "gdb ./worldserver"
      -- Enter breakpoints by using break command on gdb
      -- Use the run command on gdb to start the server
      -- You are now debugging
      - You may also be interested in using VScode or some other more visual debuggers. https://www.youtube.com/watch?v=B0xTgyCwsAo
      Crashlogs on linux. Once you have a way to reproduce a crash you can get a crashlog that can help you resolve it.
      - Take crashreport.gdb from /contrib/debugger from source folder and place it to your server folder
      - Start the authserver
      - Start the worldserver by using "gdb -x crashreport.gdb ./worldserver"
      - Reproduce your crash
      - There should be a backtrace.log in your server folder that contains information about the crash like the callstack and variables in each function call in the call stack
      - This guide was written based on https://github.com/TrinityCore/TrinityCore/blob/master/contrib/debugger/README
      Running valgrind on linux. This helps you find memory errors like invalid reads and writes and memory leaks.
      - Here is a good video about it: https://www.youtube.com/watch?v=fvTsFjDuag8
      - Basically you
      -- Start the authserver
      -- Start the worldserver by using "valgrind ./worldserver"
      -- Run your code that you want to analyze and close the server
      -- The console or an output log should contain the valgrind log
    • By reyne
      Hey there!

      I've followed a few threads here about map extraction, and am still having issues. Originally, I was having the issue described here.
      After following the advice given in that thread (creating characters of both BC races and running around for a bit), I am no longer getting that error, however now I get the following error while trying to extract maps:

      `Error loading World\Maps\Expansion01\Expansion01_42_6.adt`

      This repeats for every line in Expansion01, and then the extractor crashes.

      I'm not sure where else to go from here.

      Thanks for your help

      Edit: I've created an 85 on an i85 server and flown all around Outland now, same issue.
    • By Uee
      I recently found the Trinity Cataclsym Preservation Project and thought I will try it out.
      I am already running 3.3.5a and Master - both server run great
      Pulled 4.3.4 down using Git and built it same way as others:
      boost_1_73_0 cmake 3.17.2 Mysql 5.7.30 VS Community 2019 Built fine - no issue. Used 'Extractor.bat' to run all the map extractors - worked great!
      Noticed there was extra file 'connection_patcher.exe`, ran that - worked great! Now have "wow_patched" and use this to launch client
      MySQL runs in standalone mode, -initialize, added base sql files, imported, auth and character sql files
      Configured both the .conf files and passwords, IPs etc are all in place.
      Note: When loading the exe and built conf file, bnetserver complain about these items missing, so I add them:
      Updates.AutoSetup = 1 Updates.EnableDatabases = 0 LoginDatabase.SynchThreads = 1 Load up Mysql - loads fine
      Load up bnetserver and appears to load ok - last few lines look like this:
      Connected to MySQL database at
      DatabasePool 'auth' opened successfully. 2 total connections running.
      Started auth database connection pool.
      Listening on connections from worldservers on port 1118...
      Load up worldserver and it adds the FULL world and hotfixes, then applied all updates (confirmed archived in SQL) - last few lines look like this:
      Calculate next monthly quest reset time...
      Calculate random battleground reset time...
      Calculate guild limitation(s) reset time...
      Calculate next currency reset time...
      World initialized in 0 minutes 13 seconds
      TrinityCore rev. d0c7bbab40bc 2020-05-06 00:01:21 +0200 (master branch) (Win64, RelWithDebInfo, Static) (worldserver-daemon) ready...
      There are no db errors in logs.
      Config.wtf contain portal, realmlist as remote server and patchlist as localhost.
      When I try to connecting using "[email protected]" and password I get immediately disconnected.
      What I did noticed different is that the bnetserver doesnt add "Added realm "Battle for Azeroth" at" (From my Master log) 
      3.3.5a also have this line as last line in authserver - but 4.3.4 is not giving me this one.
      Realmlist table is accurate with right information.
      Anyone know why bnetserver is not starting me realm?
    • By Deer_Hunter
      Hello all,
      I just updated from the latest Git 
      Trinity Core REV. ac6baa547376 + 2020-02-21  3.3.5 Branch.
      I'm getting this error after crash.
      Problem signature:
        Problem Event Name:    APPCRASH
        Application Name:    worldserver.exe
        Application Version:
        Application Timestamp:    5e50a462
        Fault Module Name:    StackHash_f12f
        Fault Module Version:    6.3.9600.19629
        Fault Module Timestamp:    5e2fdc0d
        Exception Code:    c0000374
        Exception Offset:    PCH_9E_FROM_ntdll+0x0000000000090D0A
        OS Version:    6.3.9600.
        Locale ID:    1033
        Additional Information 1:    f12f
        Additional Information 2:    f12f0934d3e965f73c68e60f20f2cd40
        Additional Information 3:    7595
        Additional Information 4:    7595e4d8d703db9dcd3d2f6ea540e357
      the exception code says its a Heap error,  I'm not sure how to troubleshoot this.
  • Create New...