Jump to content

6.x - a few issues/questions


Recommended Posts


I can not connect to my server 6.

I am using 5 so it is ok for the port (and the new one)

I have 


5/14 19:25:53.053  LOGIN: state: LOGIN_STATE_CONNECTING result: LOGIN_OK 

5/14 19:25:53.084  Connecting to
5/14 19:25:53.287  LOGIN: state: LOGIN_STATE_FAILED result: LOGIN_FAILED 
5/14 19:25:53.303  Disconnected from
5/14 19:25:53.334  Client initiated Disconnect from
5/14 19:25:53.365  Client initiated Disconnect from
5/14 19:25:53.397  LOGIN: state: LOGIN_STATE_FAILED result: LOGIN_FAILED 
5/14 19:25:53.412  Login program=WoW platform=Wn64 locale=frFR
5/14 19:25:53.443  Component WoW.Wn64.19865
5/14 19:25:53.475  Component WoW.base.19793
5/14 19:25:53.506  Battle.net is Component Bnet.Wn64.37165
5/14 19:29:24.074  LOGIN: state: LOGIN_STATE_CONNECTING result: LOGIN_OK 
5/14 19:29:24.152  Connecting to
5/14 19:29:24.433  LOGIN: state: LOGIN_STATE_FAILED result: LOGIN_FAILED 
5/14 19:29:24.465  Disconnected from
5/14 19:29:24.512  Client initiated Disconnect from
5/14 19:29:24.543  Client initiated Disconnect from
5/14 19:29:24.574  LOGIN: state: LOGIN_STATE_FAILED result: LOGIN_FAILED 
5/14 19:29:24.605  Login program=WoW platform=Wn64 locale=frFR
5/14 19:29:24.637  Component WoW.Wn64.19865
5/14 19:29:24.668  Component WoW.base.19793
5/14 19:29:24.746  Battle.net is Component Bnet.Wn64.37165

I take a look at other post , and double check my components are ok (I have build a clean version to test)


I have no clues what to check or where to look 

I have created several accounts to test, but no way.

Is their some extra securities (rbac ?) above the user ?


I have no trace of my logs, on incorrect password on the server file


thanks in advance.


Can someone share an example of its tables ?

Link to comment
Share on other sites

  • 1 month later...

Greetings all,

I just have a few questions about the current state of 6.x to make sure I'm doing things right and don't open needless issues.


Here's what I've done:

  • Compiled latest rev (812fa65c613e as of today) using Debian 7.0 x64 and Windows 7 x64
  • Created dbc, maps, vmaps, and mmaps on both
  • Imported latest TDB and all of the world/hotfix updates in the /sql/updates folder
  • Used correct client to connect to both, and experienced same issues

Here's what I'm experiencing:



  • Innkeepers dialogue options (open shop, bind location) do not work at times.  Closing and reopening dialog a couple of times generally fixes.
  • Clicking to sort bags greys out all items in them until I relog

One other thing of note is the console is spammed with a whole lot of errors on server load, mostly related to spells it appears.  This is just on load, and not the opcode spam.


I do realize that this is a very early phase for the 6.x branch, and I mainly compiled and setup just to see what does/doesn't work.  I don't have any development experience, but hoping I can at least file some bug reports to expose issues that do exist.  I just want to make sure my setup is functioning "as intended" for the current state of the project before opening tickets on the issue tracker that are only issues because I did something wrong!  I'm happy to provide any addition information needed.  Thanks!

Edited by jududdar
I didn't do my homework fully.
  • Upvote 1
Link to comment
Share on other sites

Okay, thanks!  I guess I'll just start playing through and reporting things I see (provided there's not already something on the tracker for it).  Although I'm not really proficient with programming or SQL skills, I'd like to contribute whatever I can, even if it's just play time.

  • Upvote 1
Link to comment
Share on other sites

  • 2 weeks later...

You can't downgrade your client. You can grab a 6.1.2 executable somewhere and play with it (thanks to blizzard streaming system) but you won't be able to extract dbc/maps/vmaps because your client will be incomplete.

6.2.0 20216 works with last commit. It's not fully working but it works. Check github

Link to comment
Share on other sites

Update : Resolved issue by building new system and reinstalling all tools, one by one carefully. :).

thanks to trinity-team for a great system. now extracting..lets hope....



i would appreciate any help. First time compile. Using centos 7 using git pull 10 minutes ago. (* TrinityCore revision   : 9a9706cc5f02 2015-07-12 05:05:49 +0200 (6.x branch))

I might have maybe overlooked something ?

cmake passes. then when running make i get the following error :

[  7%] Building CXX object dep/cppformat/CMakeFiles/format.dir/posix.cc.o
In file included from /root/builds/TrinityCore/dep/cppformat/posix.cc:33:0:
/root/builds/TrinityCore/dep/cppformat/posix.cc: In member function ‘fmt::LongLong fmt::File::size() const’:
/root/builds/TrinityCore/dep/cppformat/posix.h:74:70: error: ‘static_assert’ was not declared in this scope
 # define FMT_STATIC_ASSERT(cond, message) static_assert(cond, message)
/root/builds/TrinityCore/dep/cppformat/posix.cc:162:3: note: in expansion of macro ‘FMT_STATIC_ASSERT’
   FMT_STATIC_ASSERT(sizeof(fmt::LongLong) >= sizeof(file_stat.st_size),
dep/cppformat/CMakeFiles/format.dir/build.make:77: recipe for target 'dep/cppformat/CMakeFiles/format.dir/posix.cc.o' failed
make[2]: *** [dep/cppformat/CMakeFiles/format.dir/posix.cc.o] Error 1
CMakeFiles/Makefile2:357: recipe for target 'dep/cppformat/CMakeFiles/format.dir/all' failed
make[1]: *** [dep/cppformat/CMakeFiles/format.dir/all] Error 2
Makefile:116: recipe for target 'all' failed
make: *** [all] Error 2

Can anyone point me out how to correct/fix ? Apologies if i forgot a library, would appreciate the help.






Edited by ravensnow
update with revision
Link to comment
Share on other sites

Hello everybody.

i donwload your trinitycore 6.x and compile it fololowing the wiki instructions,

but when i tray to run worlserver.exe  it give me 


TrinityCore rev. unknown 1970-01-01 00:00:00 +0000 (Archived branch) (Win32, Release) (worldserver-daemon)
<Ctrl-C> to stop.
 ______                       __
/\__  _\       __          __/\ \__
\/_/\ \/ _ __ /\_\    ___ /\_\ \, _\  __  __
   \ \ \/\`'__\/\ \ /' _ `\/\ \ \ \/ /\ \/\ \
    \ \ \ \ \/ \ \ \/\ \/\ \ \ \ \ \_\ \ \_\ \
     \ \_\ \_\  \ \_\ \_\ \_\ \_\ \__\\/`____ \
      \/_/\/_/   \/_/\/_/\/_/\/_/\/__/ `/___/> \
                                 C O R E  /\___/
http://TrinityCore.org                   \/__/
Using configuration file worldserver.conf.
Using SSL version: OpenSSL 1.0.1o 12 Jun 2015 (library: OpenSSL 1.0.1o 12 Jun 2015)
Using Boost version: 1.57.0
Automatic database updates are disabled for all databases!
Realm running as realm ID 1 region 2 battlegroup 1
Using World DB: Unknown world database.
Using enUS DBC Locale
Will clear `logs` table of entries older than 1209600 seconds every 10 minutes.
Using DataDir ./
WORLD: MMap data directory is: ./mmaps
VMap support included. LineOfSight: 1, getHeight: 1, indoorCheck: 1
VMap data directory is: ./vmaps
Loading Trinity strings...
>> Loaded 4 trinity strings in 1 ms
Initialize data stores...
Some required *.dbc files (2 from 85) not found or not compatible:
./dbc/Difficulty.dbc exists, and has 13 field(s) (expected 14). Extracted file might be from wrong client version or a database-update has been forgotten.
./dbc/LfgDungeons.dbc exists, and has 29 field(s) (expected 30). Extracted file might be from wrong client version or a database-update has been forgotten.
and me mmapextractor.exe dont found well becouse i have the small 6.1.2 client.
I dont know if i have first modify someone in the core for admit 6.1.2 or what i can do to resolve this error.
can you help me?
thanks for your work!!!!
Edited by gontzal
Link to comment
Share on other sites

--- Canned message start --- Trinity does not support repacks. Please learn to compile and configure the source yourself, you will learn more and may even find that the error doesnt exist in vanilla TC. Please refer to the author of the repack for your questions if you continue to use said repack. --- Canned message end ---

Link to comment
Share on other sites

I would like to try the 6.x branch, but I am concerned of one thing.

Currently I am playing on retail, and also I have an active 3.3.5 server to test, is there any problem to have both retail and TC installed in the same computer? Or does it modify battlenet somehow so I could get banned frol retail? 

I'd appreciate help in this matter, as this is a blockstopper :) 

Link to comment
Share on other sites

 is there any problem to have both retail and TC installed in the same computer?

There shouldn't be any problem. I used both retail and TC in the same computer, using the patched binary to access to TrinityCore and the original one to access to retail. I had just to change the SET portal value in Config.WTF each time I had to switch.

  • Upvote 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Frik24
      Hello TrinityCore members,

      I wanted to mess around with 6.2.4a build 21742,
      I've downloaded/compiled the trinitycore TrinityCore-6.2.4-21742 from github

      I've got connection_patcher.exe among other files in my release build

      I've got client with same patch TrinityCore-6.2.4-21742

      I patched the client(all successful) with patcher i've got from compiling source.

      When i run WoW_Patched.exe i get error message https://imgur.com/a/ZZQI3J9
      can anyone help me i'd appreciate it a lot!
    • By darki73
      So i guess it is pretty obvious about what am i going to ask =)
      Problem is, previousle we could just sha1 username and password separated by colon and here is the sha_pass_hash.
      The problem i am facing right now, is that according to https://github.com/TrinityCore/TrinityCore/blob/86b98686a95e23247ecb774fb23ecd5b8d94b97b/src/server/game/Accounts/BattlenetAccountMgr.cpp#L177 Trinity now uses SHA256, so the hashes do not match anymore. The thing is, password length in database is 40 symbols (exactly as many as in sha1 hash), but sha256 hash length is 64 characters long. I am confused...
      I've tried to recreate whole "Cryptography" thing on PHP but, guess what, failed.
      Can somebody explain me how the password is generated nowadays?
      Thank you for your attention. 
    • By HolyNitzan
      Hey Guys,
      I'm  using the last build of TrinityCore for WoD, currently using latest TDB release, I noticed that there are no spawns in Draenor, I would like to konw how could I solve it? is the TDB not populated with Draenor mobs/npc spawns?
    • By Shinzon
      I have searched all over the forums and can't find anything that exactly matches this. 
      I can connect fine to the server using my windows client, but when I try to connect using my mac client it immediately bounces back stating "You have been disconnected from the server". 
      I have the correct IP address in the config.wtf (And realmlist in the DB) but still can't connect. 
      I of course can't apply the connection patcher, because the EXE isn't mac compatible. 
      Is there something else I need to do to connect with mac?
      Here is my connection.log if it helps (NOTE that the ".logon.battle.net" I can't get rid of... there is no where config.wtf that has that).
      3/14 13:10:21.966  Login program=WoW platform=Mc64 locale=enUS 3/14 13:10:22.097  Component WoW.Mc64.20886 3/14 13:10:22.097  Component WoW.base.20726 3/14 13:10:22.099  Battle.net is Component Bnet.Mc64.37165 3/14 13:10:22.099  LOGIN: state: LOGIN_STATE_CONNECTING result: LOGIN_OK  3/14 13:10:22.145  Failed to resolve “”.logon.battle.net 3/14 13:10:22.145  LOGIN: state: LOGIN_STATE_FAILED result: DISCONNECTED  3/14 13:10:22.145  Login program=WoW platform=Mc64 locale=enUS 3/14 13:10:22.145  Component WoW.Mc64.20886 3/14 13:10:22.145  Component WoW.base.20726 3/14 13:10:22.154  Battle.net is Component Bnet.Mc64.37165 3/14 13:10:23.298  Client Disconnect due to reason:8 3/14 13:12:54.053  LOGIN: state: LOGIN_STATE_CONNECTING result: LOGIN_OK  3/14 13:12:54.073  Failed to resolve “”.logon.battle.net 3/14 13:12:54.151  LOGIN: state: LOGIN_STATE_FAILED result: DISCONNECTED  3/14 13:12:54.151  Login program=WoW platform=Mc64 locale=enUS 3/14 13:12:54.173  Component WoW.Mc64.20886 3/14 13:12:54.173  Component WoW.base.20726 3/14 13:12:54.308  Battle.net is Component Bnet.Mc64.37165 3/14 13:12:54.309  Client Disconnect due to reason:8  
    • By FreddyLIE
      (sorry for bad english)
      i was trying out the 6.X Core and there was no Spawns in Dreanor.
      So i want to Sniff them from Live and add them my Self. If i manage to get it to work i will share my Work.
      I need some help.
      Im complete new to sniffing/parsing. And the last time i was setting up a Privatserver is some years ago.
      Some month ago i made my degree in Software dev. so i got "some" C# & SQL knowledge.
      Im compiling the Core and Parser myself.

      My sniffing attemps
      I was walking around in Dreanor/Gorgrond for testing to get some spawns.
      I got a 2MB .pkt Package and try to parse the creatures and i got some data out that looks not correct to me.

      - The names of the creatures not working, looks like some utf-8 problem.
      - The data dont look correct, and dont match the TDB tables. for example:
      [...] modelid1=32784, modelid2=117440512, name='�', rank=1852130080, family=1851877746, type=1866932324 [...]

      The parsed SQL is producing errors like this:
      Out of range value for column 'modelid2' at row 1
      Out of range value for column 'rank' at row 1
      Out of range value for column 'family' at row 1

      Can you help me getting this to work?

      See attachments.
      - FreddyLIE
  • Create New...