Jump to content
TrinityCore

Stuck at connected / infinite loop / login issues / battle.net


CFGhost
 Share

Recommended Posts

  • 2 weeks later...
  • 1 month later...

1. i modified my DB to have thoses entry's on my linux server.

mysql> select * from realmlist;
+----+--------------+---------------+--------------+-----------------+------+------+------+----------+----------------------+------------+-----------+--------+-------------+
| id | name         | address       | localAddress | localSubnetMask | port | icon | flag | timezone | allowedSecurityLevel | population | gamebuild | Region | Battlegroup |
+----+--------------+---------------+--------------+-----------------+------+------+------+----------+----------------------+------------+-----------+--------+-------------+
|  1 | WoW-SERVER1 |<MY EXTERNAL IP> | 127.0.0.1    | 255.255.255.0   | 8085 |    0 |    0 |        1 |                    0 |          0 |     25996 |      2 |           1 |
+----+--------------+---------------+--------------+-----------------+------+------+------+----------+----------------------+------------+-----------+--------+-------------+
1 row in set (0.00 sec)

2. I compiled the Core Tools on my Windows machine and used the connection patcher on my Wow64.exe and got the Wow64-patched.exe
3. modified the  . / WTF/config.wtf   file portal field from 
         portal="EN-US"    to    portal="<MY EXTERNAL IP>"             <-- Same as in the DB 

4. I port fowarded Both port 8085 and 8086 on my Modem to point to the linux server. ( shoudl not be a concern for me to log in from within my own network, but did for further testing)

5. started my bnetserver and worldserver

but i still get error : BLZ51914001 when trying to log in with the account i made in the world console. ( i double checked that its present in the MySql DB).

My Modem does not support IP mirroring so i cannot call my own External IP from within the network. 
shoudl i change the config.wtf portal for my own machine to the internal IP of the server and  add in the DB under the localAddress field the internal IP address of the server ?

Link to comment
Share on other sites

4 hours ago, Ronin825 said:

1. i modified my DB to have thoses entry's on my linux server.

mysql> select * from realmlist;
+----+--------------+---------------+--------------+-----------------+------+------+------+----------+----------------------+------------+-----------+--------+-------------+
| id | name         | address       | localAddress | localSubnetMask | port | icon | flag | timezone | allowedSecurityLevel | population | gamebuild | Region | Battlegroup |
+----+--------------+---------------+--------------+-----------------+------+------+------+----------+----------------------+------------+-----------+--------+-------------+
|  1 | WoW-SERVER1 |<MY EXTERNAL IP> | 127.0.0.1    | 255.255.255.0   | 8085 |    0 |    0 |        1 |                    0 |          0 |     25996 |      2 |           1 |
+----+--------------+---------------+--------------+-----------------+------+------+------+----------+----------------------+------------+-----------+--------+-------------+
1 row in set (0.00 sec)

2. I compiled the Core Tools on my Windows machine and used the connection patcher on my Wow64.exe and got the Wow64-patched.exe
3. modified the  . / WTF/config.wtf   file portal field from 
         portal="EN-US"    to    portal="<MY EXTERNAL IP>"             <-- Same as in the DB 

4. I port fowarded Both port 8085 and 8086 on my Modem to point to the linux server. ( shoudl not be a concern for me to log in from within my own network, but did for further testing)

5. started my bnetserver and worldserver

but i still get error : BLZ51914001 when trying to log in with the account i made in the world console. ( i double checked that its present in the MySql DB).

My Modem does not support IP mirroring so i cannot call my own External IP from within the network. 
shoudl i change the config.wtf portal for my own machine to the internal IP of the server and  add in the DB under the localAddress field the internal IP address of the server ?

use dns instead external ip and edit hosts for your lan ip to the dns.

Link to comment
Share on other sites

12 hours ago, Aokromes said:

use dns instead external ip and edit hosts for your lan ip to the dns.

i already run a minecraft server using my IP, and i have a system to share the IP and i have had no problem so far with it.
inside the network, the server has a static IP.

Just for testing i reset everything to simply LAN values (192.168.X.X) and i still cant connect to the server.

- i changed the Mysql realmlist entry address to the LAN IP address

-restarted both server's (bnet and world)

-re-run the connection patcher on the WoW64.exe

-double and triple checked the ports are open on the server and modem.

still cant connect from within the network.

Edit : 
Also i noticed i was editing the config.wtf file present in my original C:\World of Warcrfaft\WTF folder   and that there one config.wtf folder present in the build file, is that the one i shoudl have been editing before using connection patcher or is it there only for backup purposes ? because its almost empty and has no value under portal.

Also i am currently at school to become I.T. and also a decent C++ programmer but this is putting me to shame and making me feel like an idiot, i woudl like to understand the structure of how the DB, the bnet server and world server use the realmlist / config file to communicate. Because i am confused has to how the bnet server and DB need my external IP from within the network, shoudnt they only need the internal one and only the config file of the client outside the network need it to route itself to my server ? Shoudnt i be able to address the internal IP of the server with my client sitting in the network and be able to connect to it ?

edit 2:

It just occurred to me. Do i need to have the maps,vmaps,mmaps,gt.cameras,dbc files extracted in the client folder on my windows machine or only on the server side ?

i looked in the documentation for the Database auth.realmlist and the LocalAddress field has no definition. Shoudl it always stay on 127.0.0.1 or shoudl i put this field to my server internal address so it can accept lan connection ?

Edited by Ronin825
Link to comment
Share on other sites

Right now my set up has this structure and theses settings :

(Modem)  IP :     Internal  interface : 192.168.2.1

                                  External interface : 70.X.X.X

                   Port Fowarded 8085 ---> 8085

                                                   8086 -->  8086

(LINUX Ubuntu 17.10 Server) IP : 192.168.2.55
               - bnetServer : created realm 1 at  70.X.X.X : 8085

                                           login service bound to http://0.0.0.0:8081

               - WorldServer : does seem to have a lot of load errors, error log file is enormous. dont know if thats normal atm, but seems to be executing normally, account commands and lookup works perfectly.
               - Mysql server : auth.realmlist value :    address : 70.X.X.X             localAddress : 127.0.0.1  ( im assuming this is for the auth server to find the sql db or something)

(Windows 10 Client Machine) IP : 192.168.2.38
                - WoW64-patched.exe ( made with connectionPatcher.exe, compile on this machine, does not have vmaps, or maps etc.)

                  - config.wtf file   portal value : i tried both 192.168.2.55 and the 70.X.X.X    (both dont work and i get blz51914001   or blz51910002   error)

(Friend Windows 10 Client ) IP : External

                   - With same config (wow64-patched.exe with connection patcher) as my machine. config.wtf file is set to my 70.X.X.X IP of course.

i nmaped my network from the outside and the inside, port all seem to be proprely open and fowarded, firewall on linux box allows traffic.
What am i missing ?

Edited by Ronin825
Link to comment
Share on other sites

On 3/1/2018 at 2:39 PM, skipperheartbeat said:

I could be wrong but on Master i believe you also need to forward port 3724 to your server as well.

i have 4 fowarded 1119,8081,8085,8086.

but locally i shoudnt have to, especially since im directly addressing it by its LAN address and not hostname or or through url. Ports are open and listening on the machine and i still cant login

UPDATE :

Fixed the issue by changing the Mysql value in auth.realmlist.LocalAddress to my 192.168.2.55
even tho the tutorial say's not to change it. Might wanna change that. By reading the documentation i figured out that the values in the Mysql Db are the values sent back after a person has been authenticated by the bnet server.

Edited by Ronin825
Link to comment
Share on other sites

  • 4 weeks later...

Core version: Master, 7.3.5.26124 (I believe, sorry I am not sure how to check the version)

Hi guys, first time trying to setup my private server here, so please excuse me if this is a newb question =P

I have followed the instructions from https://trinitycore.atlassian.net/wiki/spaces/tc/overview?mode=global

all the way up to #7. ClientSetup,  where I created the Wow_Patched.exe.

 

I launched the Wow_Patched.exe, got into the Wow log-in screen and typed the user name create in step 6, which is [email protected], test.

 

Then I got this error message:

"Unable to connect. Please try again later. If the
  problem persists, please contact technical support at:[http://us.blizzard.com/support/[email protected]=2316]
(BLZ51901001)
"

 

Can somebody please please help?


 

I mean...it feels like just one more step to go.... =P

 

Thanks!

 

Update:

Issue fixed using this method from ROnin's post:

3. modified the  . / WTF/config.wtf   file portal field from 
         portal="EN-US"    to    portal="<MY EXTERNAL IP>"             <-- Same as in the DB 

Edited by Jack_TrinityCore
Link to comment
Share on other sites

  • 4 weeks later...

Hia all,

Im having problems connecting to my trinity core server, i have no repacks as i exctacted it all myself.

I have tried everything i can think of to get this working.

Internal ip: 192.168.0.6

External: 2.125.80.xxx

Dns: xxx.servegame.com

I have updated my auth table realmlist and in the address colum i have tried my external, dns and 127.0.0.1, i have done the same with my realmlist.wtf

When i try to connect it just says connecting and then error, when i have it set to 127.0.0.1 in realmlist and in auth it shows me my relm but is stuck in a relm loop.

Link to comment
Share on other sites

  • 4 weeks later...

Hi, 

First, thank you for the TrinityCore that i use for many years, and sorry for my poor english.

I never had problems to use it before.

But , i have now one that made me crazy.

I have the latest master compiled on linux 7.3.5 (26365) working fine on centos.

I can connect to the server with my windows 10 computer, but i can not connect  with my other  windows 7 computer.

i have on this windows 7 computer  --- you have been disconnected -- BLZ51901021 

Next i try my client with a second windows 7 laptop from a friend in my home , and i can connect   to the server with his computer. 

I have checked all, no firewall problems , ports problems, or network issues. or account issues ...

What is the problem ? Windows7 is up to date , is something missing ?

any ideas ??

Thank you

 

 

Edited by elixcyr
Link to comment
Share on other sites

Hi all, Im trying to debug issues opening TrinityCore to the public internet.

Currently everything works via LAN (using the IP supplied by my router 192.x.x.x), but not when using my external ip: wtfismyip.com/text

I have tried using my hostname that resolves to that IP as well as the IP directly. I have ports: 8081, 8085, 8086, and 3724 open for both UDP/TCP.

 

The error I am seeing is the "Unable to connect" from my patched WoW client. Any ideas on what might be wrong, or how I could better debug this?

Link to comment
Share on other sites

Hello

I'm coming back here because I'm trying to mount my server again. I tried a lot of things since the last time

Config

OS : Ubuntu 17.10 artful (x86-64) (CORE & DB on it)

TrinityCore : 3.3.5a Branch

Worldconf & authconf

  • Try with : default
  • Try with : bind IP 192.168.1.78 (my local IP)

Database

realmlist.address : mynoip.ddns.net

realmlist.localAddress

  • Try with : 192.168.1.78
  • Try with : 127.0.0.1

Rooter

  • Try with : Firewall middle security + 3724 & 8085 NAT/PAT
  • Try with : Firewall low security + 3724 & 8085 NAT/PAT
  • Try with : Firewall low security + 3724 & 8085 NAT/PAT + DMZ on my server

Hosts file

127.0.0.1 localhost

127.0.1.1 my_server_name

192.168.1.78 mynoip.ddns.net

Realmlist client : set realmlist mynoip.ddns.net

Firewall : ufw status return Disable

 

Result on LAN client : Connected and play

Result on WAN client : stay on realm list, show my realm online but i can't join it

 

Test when distant client try to connect : 

netstat -tape

  • mynoip:3724 to 0.0.0.0 LISTEN
  • mynoip:3724 to client_ip:random_port ETABLISHED
  • mynoip:8085 to 0.0.0.0 LISTEN
  • No more with 8085 port

Conclusion

Do you have any ideas on the cause of this problem because I am exhausted ?

Thank you in advance !

Edited by Velyss
Link to comment
Share on other sites

I haven't checked your config in detail but just some hints:

  1. In auth and world config must be BindIP = "0.0.0.0" to grant the servers are listening on all IPs (Local, LAN, WAN)
  2. In the auth Database table realmlist: localAdress 127.0.0.1 is fine but address should be your public WAN IP.
  3. Router: Depending on your model you may have to set security rules AND forwarding the ports. Means: allow traffic and forward it to your computer.

Hope it helps a little bit.

Link to comment
Share on other sites

Hello

1 & 2 . I tried it before swaping :

  • 0.0.0.0 to mynoip.ddns.net in conf file
  • 127.0.0.1 to 192.168.1.78 

But i put the default file so now 0.0.0.0 in two files.

2. I switched localAddress : 127.0.0.1 to "80.my.wan.ip"

3.That works for 3724 port, why will not it work for 8085 port. I have the same configuration for both. :/

After all the changes : It still doesn't work, always the same problem.

I am disappointed. :/

 

Edited by Vell
Link to comment
Share on other sites

5 hours ago, Vell said:

Hello

1 & 2 . I tried it before swaping :

  • 0.0.0.0 to mynoip.ddns.net in conf file
  • 127.0.0.1 to 192.168.1.78 

But i put the default file so now 0.0.0.0 in two files.

2. I switched localAddress : 127.0.0.1 to "80.my.wan.ip"

3.That works for 3724 port, why will not it work for 8085 port. I have the same configuration for both. :/

After all the changes : It still doesn't work, always the same problem.

I am disappointed. :/

 

 

Link to comment
Share on other sites

Well. My you could help me if i screen ALL.

ROOTER DHCP : 1527446024-dhcp.jpg

ROOTER : NAT/PAT : 1527446025-nat.jpg

DATABASE Struct realmlist : 1527446026-dbstruct.jpg

DATABASE Content realmlist : 1527446027-db1.jpg

My hosts file (etc/hosts) :

127.0.0.1           localhost

127.0.1.1          my_pc_name-UBUNTU

192.168.1.78  *******.ddns.net

Realmlist : Try with :

set realmlist ******.ddns.net

and with :

set host *******.ddns.net

LAN OK but not ext for BOTH.

Test :

- LAN ping : OK

- EXT ping : OK

- Check port : OK for both
- LAN client : OK

- WAN clien : Ok for auth but still stuck on realm

Link to comment
Share on other sites

On 26.5.2018 at 9:12 AM, Magnuss said:

In the auth Database table realmlist: localAdress 127.0.0.1 is fine but address should be your public WAN IP.

https://trinitycore.atlassian.net/wiki/spaces/tc/pages/2130016/realmlist#realmlist-address

As far as I know address must be a numeric IP address not a domain name. The core doesn't resolve name and isn't updating dynamic IPs.

Means you have to update the IP manually whenever it changes. Somebody correct me if I'm wrong.

Link to comment
Share on other sites

38 minutes ago, Magnuss said:

https://trinitycore.atlassian.net/wiki/spaces/tc/pages/2130016/realmlist#realmlist-address

As far as I know address must be a numeric IP address not a domain name. The core doesn't resolve name and isn't updating dynamic IPs.

Means you have to update the IP manually whenever it changes. Somebody correct me if I'm wrong.

nope, for lan+wan it must be dns like it's pointed on the thread i linked.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...