Jump to content
TrinityCore

Stuck at connected / infinite loop / login issues / battle.net


CFGhost
 Share

Recommended Posts

8 hours ago, Magnuss said:

127.0.0.1 for localAdress works well mostly.

But is your public IP a static IP? Some provider in some countries change this on a daily schedule.

Does your server PC has a static IP ?

And did you forward both ports to your server ? (As SarcNBit asked?)

Check your ports: https://www.yougetsignal.com/tools/open-ports/
(ATM they are closed for your given IP)

- My public IP is not static, but i changed it when i load the server ;

- Same for server PC ;

EDIT*////- Yes i forward 8085 and 3724 on my router but https://www.yougetsignal.com/tools/open-ports/ say my port are closed (with the server open and the server down ...), for the firewall, im just disabled him when i load the server.////EDIT*

8 hours ago, Daniel25 said:

Well...this is a spanish video-tutorial but maybe it can help you: trinity public server

By the way, I remember that old versions as 3.3.5 used differents ports but I'm not sure if it has changed and trinity 3.3.5 use the same ports than legion now... Check your server configs for knowing it...

I follow the instruction of the video, except for the dns. And i can't modify "host" in C:/Windows32/ ...

 

I don't know why that's not working :( 

 

*EDIT : For the port with https://www.yougetsignal.com/tools/open-ports/, that's good now : http://prntscr.com/hlo44e / http://prntscr.com/hlo49i.

Edited by Keonys
Link to comment
Share on other sites

Double post for an other question, sorry for that,

If I take hamachi while I have less than 5 friends comming on the server, but after that, if I have more than 5 friends and I want to take a little dedicated server, I'm going to have the same problem than i have now to put my server online ?

Sorry for my english and thanks for your help ^^

Link to comment
Share on other sites

2 hours ago, Keonys said:

Double post for an other question, sorry for that,

If I take hamachi while I have less than 5 friends comming on the server, but after that, if I have more than 5 friends and I want to take a little dedicated server, I'm going to have the same problem than i have now to put my server online ?

Sorry for my english and thanks for your help ^^

For modify host file you have to uncheck "read only" in the file propierties... If you dont modify the host file, server will be never online...

I think that you can use hamachi for more than 5 people....

Link to comment
Share on other sites

36 minutes ago, Daniel25 said:

For modify host file you have to uncheck "read only" in the file propierties... If you dont modify the host file, server will be never online...

I think that you can use hamachi for more than 5 people....

Ok so in the host file, i have to write what ? Because i use an ip address, not a dns address.

Here http://prntscr.com/hlqi4d:)

And for hamachi, we can't be connected by more than 5 people no ? :o

Link to comment
Share on other sites

The host file you need only to change if you use a dynamic dns server like https://www.noip.com/

(I don't know if this service works for Trinity core.)

First change on your server PC network setting so that you have a static IP and forward your ports to this IP afterwards.

With a dynamic public IP you have to inform your friends about this IP every time it changes and they have to change the IP in the realmlist. (Or you use a ddns service).
Additional you have to change the IP every time in the auth database realmlist and restart the server.

In both config files (auth + world) there must be this (should be the default value):

BindIP = "0.0.0.0"

 

 

 

  • Upvote 1
Link to comment
Share on other sites

8 hours ago, Magnuss said:

The host file you need only to change if you use a dynamic dns server like https://www.noip.com/

(I don't know if this service works for Trinity core.)

First change on your server PC network setting so that you have a static IP and forward your ports to this IP afterwards.

With a dynamic public IP you have to inform your friends about this IP every time it changes and they have to change the IP in the realmlist. (Or you use a ddns service).
Additional you have to change the IP every time in the auth database realmlist and restart the server.

In both config files (auth + world) there must be this (should be the default value):

BindIP = "0.0.0.0"

 

 

 

Ok so,

I don't take a dns (and i don't touch the host file ^^) ;

now my ip is static and my ports are forwared on the router and on the firewall ;

Im going to inform my friends about the ip changement, np ;

Yes, i change my ip on the database every time, like the realmlist on my wow client ;

BindIP was at "0.0.0.0" all the time.

Annnnnnnd that's not working ^^'

http://prntscr.com/hm57h7

http://prntscr.com/hm57tn (in french, sorry)

Idk why it's not workiiiiiing :'(

EDIT : Im going to put some other screen if you want to see what i have :

http://prntscr.com/hm5av9

http://prntscr.com/hm5b40

http://prntscr.com/hm5cgw

http://prntscr.com/hm5cxp

Edited by Keonys
Link to comment
Share on other sites

Hey, I'm stuck.  I've port forwarded and all, but I cannot connect to my server from an external IP.  Made sure to use the patcher and all.  Got the right version I think since local connects work.  Master branch. 

When I connect, I get to the realm list, but when I pick trinity, I get disconnected with this error:

WOW51900328

Maybe I'm bad at reading but I couldn't find much on google.

 

Edit: Disregard that I am a noob.

 

To the people who are experiencing this in the future: When they say "edit the database with HeidiSQL" make sure you click the data tab near the top, cause the default value tab isn't how you do it and no matter how many times you restart, default values isn't going to take hold..

Edited by LinaNoob
Link to comment
Share on other sites

@keonys

Your screenshoots looks well so far. But in the morning a port check to this given IP told me they are closed. Don't know if your IP has already changed again or your server was down.

May you want to send a screenshot of your router settings. But at the moment I can't say anymore.

A possible way to check your network connection including port is using Telnet. If you have a Telnet client start it like that:
telnet [IP] [Port]

f.ex.: telnet 192.168.0.140 8085  to test a local connection
or: telnet 176.164.12.14 8085 to test your public ip

If your network is working the server will send some not human readable cryptic signs (about 30 signs) back to you. Press enter and in the TC world console appears a network error message like this: client [IP] sent malformed packet.

Before you must configure your world.conf and enable Logger.network.

Link to comment
Share on other sites

2 hours ago, Keonys said:

@Magnuss

I found the error, i have a 4g box and i think is just not working on this 4g box !

I test to put my server online on a simple box and that's working, so hamachi was the best option to stay on my 4g box and play with friends, thx for your help bro :)

if you use 3g/4g very likely you are under a NAT / CGNAT so external connections never can reach your lan without external tools.

Link to comment
Share on other sites

Hello there! 

I am kinda a noob, to do portforwarding and need some help with it.

I have installed 3.3.5 wow server on my pc, then I have portforwarding this ports: 80, 8085, 3306, 7878, 3443, 8050 and they all is TCP/UDP.

but I dont really, know what I should change in worldserver.conf and auth.conf?

I have made an A-record that is point at my external ip.

but what more should I do?

Link to comment
Share on other sites

NEVER EVER forward 3306!
I'm not sure why you have 3443 and 8050 unless.

Whatever you have your authserver and worldserver ports configured in your confs is all that you need to portforward (open to public).
I'm assuming you have http and soap turned on. if not, then you just need to close 80 and 7878.

Close the ports you dont need. I don't see 3724 open (auth server port).

If you want, you can private message me your address, if you want me to test it. Again, for security purposes, dont open ports you dont need, especially 3306 mysql is extremely easy to hack into.

Link to comment
Share on other sites

  • 3 weeks later...

Hi, First, I do not speak English very well, excuse me for that.

Problem => Client stuck on : "Authentification"

 

Config

OS : Ubuntu 17.10 artful (x86-64) (CORE & DB on it)

TrinityCore : 3.3.5a branch

Worldconf & authconf : default

realmlist.address : ***.ddns.net (test ping on address, it works)

realmlist.localAddress : 127.0.0.1

Opened port on my rooter (NAT/PAT) : 3724 & 8085 (tested and work)

hosts : 

127.0.0.1    localhost

127.0.1.1    *PCNAME*

*MY_EXTERNAL_IP*    ***.ddns.net

Firewall : "sudo ufw status" return : Disable

Realmlist client :  set realmlist ***.ddns.net

 

I do not know what I forgot, if you could help me :/

Precision : When i put a LAN IP in realmlist address, all works but i want that my friends could connect too. :/

 

Thanks in advance

Edited by Vel
Link to comment
Share on other sites

5 hours ago, Vel said:

Hi, First, I do not speak English very well, excuse me for that.

Problem => Client stuck on : "Authentification"

 

Config

OS : Ubuntu 17.10 artful (x86-64) (CORE & DB on it)

TrinityCore : 3.3.5a branch

Worldconf & authconf : default

realmlist.address : ***.ddns.net (test ping on address, it works)

realmlist.localAddress : 127.0.0.1

Opened port on my rooter (NAT/PAT) : 3724 & 8085 (tested and work)

hosts : 

127.0.0.1    localhost

127.0.1.1    *PCNAME*

*MY_EXTERNAL_IP*    ***.ddns.net

Firewall : "sudo ufw status" return : Disable

Realmlist client :  set realmlist ***.ddns.net

 

I do not know what I forgot, if you could help me :/

Precision : When i put a LAN IP in realmlist address, all works but i want that my friends could connect too. :/

 

Thanks in advance

you must set *MY_EXTERNAL_IP*    ***.ddns.net to your lan ip.

Link to comment
Share on other sites

First, thank you for trying to help me. ^^

I tried to put in my 'hosts' file:

192.168.1.**    ***.ddns.net

Same issue, my client stuck on  "Authentification" :/

 

Others ideas ? :S

 

EDIT : It works with LAN realmlist but not DNS realmlist. :/

Edited by Vel
Link to comment
Share on other sites

7 hours ago, Vel said:

First, thank you for trying to help me. ^^

I tried to put in my 'hosts' file:

192.168.1.**    ***.ddns.net

Same issue, my client stuck on  "Authentification" :/

 

Others ideas ? :S

 

EDIT : It works with LAN realmlist but not DNS realmlist. :/

Are you sure you are changing address and not default? (look the posts before your 1st post)

Link to comment
Share on other sites

For 3724 port : https://www.noelshack.com/2018-02-1-1515425990-3724p.jpg

For 8085 port : https://www.noelshack.com/2018-02-1-1515425991-8085p.jpg

For ping : https://www.noelshack.com/2018-02-1-1515426225-ping.jpg

External ping : https://www.noelshack.com/2018-02-1-1515439576-ext-ping.jpg

 

I used : ping ***.ddns.net

It found me my real external IP.

 

Port router to my Server : https://www.noelshack.com/2018-02-1-1515430679-port.jpg (doubt about that)

Edited by Vel
Link to comment
Share on other sites

28 minutes ago, skipperheartbeat said:

The destination IP on your router would be going to one host .. so the mask would be 255.255.255.255

The source i would say is any IP address, but failing that it would be you public IP obtained from whatsmyip.org. with the mask 255.255.255.255

Ok, i have this : https://www.noelshack.com/2018-02-2-1515495670-port.jpg

But Always stuck on "Authentification" on my client LAN :/

 

Client screen of my friend : https://image.noelshack.com/fichiers/2018/02/2/1515496534-wowscrnshot-010918-121053.jpg

"connection to the game server" in english

 

Again thank you for helping me :s

Edited by Vel
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...