Jump to content
TrinityCore
Apple

"unknown column" "missing table" "duplicate column" error / sql problems / SQLDriverLogFile < answer on 1st post of 1st page

Recommended Posts

When I try to do this

Final Steps

You can type commands inside the worldserver program, similar to a command prompt.

  • Type: account create <user> <pass>
    • Example: account create test test
  • Type: account set gmlevel <user> 3 -1
    • Example: account set gmlevel test 3 -1
      • DO !NEVER! create an account directly into your database unless you are ABSOLUTELY SURE that you know what and how to do!
  • The "3" is the GM account level (higher numbers = more access), and the "-1" is the realm ID that stands for "all realms".
    • Tip: Open the world database in your database management tool and find the command table. This table shows a full list of GM commands, their descriptions, and the security (GM level) needed to use them. You will not find a more accurate list of current GM commands anywhere else (assuming you keep your database up-to-date). The security level for a given command identifies that THAT GM level can use the command, along with all GM levels above it. For example, if a command has a security of 2, all accounts with a GM level of 2, 3, and 4 will be able to use it.
  • Minimize your authserver and worldserver and run WoW (never run WoW using the Launcher unless you edited the realmlist.wtf's patchlist option above).
  • Log in using the user/pass you just created (test/test).
  • The Trinity realm should be selectable. Log in, create a character, and you're all done!

 

I get this error.

 

Table `command` have not existed command '.rbac', skip.
Table `command` have not existed command '.rbac', skip.
Table `command` have not existed command '.rbac', skip.
Table `command` have not existed command '.rbac', skip.
Table `command` have not existed command '.rbac', skip.
Table `command` have unexpected subcommand 'groups' in command 'rbac list groups', skip.
Table `command` have unexpected subcommand 'roles' in command 'rbac list roles', skip.
Table `command` have unexpected subcommand 'permissions' in command 'rbac list permissions', skip.

Share this post


Link to post
Share on other sites

What makes you think you must apply sql/updates/auth files when wiki have wrote don't do it?

(BTW, it's a serious question, i am looking to know why people tries to apply those files)

 

Yup, don't apply the updates and you won't get the error...

Share this post


Link to post
Share on other sites

Ok so I trashed the auth and used the file in the create folder to create a new auth then went into the base and applied the files for auth from there. I am now getting this error still but it does allow me to create an account and make it a gm.  If any one could plz help me get rid of this error I would appresheat it very much.

 

Table `command` have not existed command '.rbac', skip.
Table `command` have not existed command '.rbac', skip.
Table `command` have not existed command '.rbac', skip.
Table `command` have not existed command '.rbac', skip.
Table `command` have not existed command '.rbac', skip.
Table `command` have unexpected subcommand 'groups' in command 'rbac list groups', skip.
Table `command` have unexpected subcommand 'roles' in command 'rbac list roles', skip.
Table `command` have unexpected subcommand 'permissions' in command 'rbac list permissions', skip.

Share this post


Link to post
Share on other sites

So I got the sql file TDB_full_335.52_2013_07_17 and when I go into phpmyadmin and import it. It will say 

SQL query:
--
-- Table structure for table `access_requirement`
--
DROP TABLE IF EXISTS `access_requirement` ;

MySQL said: 
#1046 - No database selected 

I am using mysql 5.5.35

 

I've tried installing the databases separate by using the base sql files that comes with trinitycore but it is missing the world sql. 

 

Can anyone help me?

Edited by kavex

Share this post


Link to post
Share on other sites

Ok so I imported the TDB_full_335.52_2013_07_17.sql via the terminal into a database called wow

 

mysql -u root -p wow </home/root/server/sql/db.sql

 

When I run ./worldserver

Using configuration file /home/root/server/etc/worldserver.conf.
Using SSL version: OpenSSL 1.0.1 14 Mar 2012 (library: OpenSSL 1.0.1 14 Mar 2012)
Using ACE version: 6.0.3
TrinityCore rev. dcfbe53552b0 2013-12-14 20:22:39 -0330 (master branch) (Unix, Release) (worldserver-daemon)
<Ctrl-C> to stop.


 ______                       __
/__  _       __          __/ __
/_/ / _ __ /_    ___ /_ , _  __  __
     /`'__/  /' _ `/   / / / 
        /   / /     _  _ 
      _ _   _ _ _ _ __/`____ 
      /_//_/   /_//_//_//_//__/ `/___/> 
                                 C O R E  /___/
http://TrinityCore.org                    /__/


In mysql_stmt_prepare() id: 53, sql: "SELECT name, permission, help FROM command"
Unknown column 'permission' in 'field list'
DatabasePool wow NOT opened. There were errors opening the MySQL connections. Check your SQLDriverLogFile for specific errors.
Cannot connect to world database 127.0.0.1;3306;xxxxxx;xxxxxx;wow
when I run ./authserver
 
I fixed this issue by making a datebase from the base sql file
I'm a bit confused what I did wrong
 
worldserver.conf
LoginDatabaseInfo     = "127.0.0.1;3306;xxxxx;xxxxx;auth"
WorldDatabaseInfo     = "127.0.0.1;3306;xxxxx;xxxxx;wow"
CharacterDatabaseInfo = "127.0.0.1;3306;xxxxx;xxxxx;characters"

authserver.conf

LoginDatabaseInfo = "127.0.0.1;3306;xxxxx;xxxxx;auth"
Edited by kavex

Share this post


Link to post
Share on other sites

There should be 3 different databases: auth, characters, and world. The database you were importing is specifically the world database. Obviously, with the conf file allowing that to be set, you can call it something other than world, but the other 2 databases need to be created separately with the appropriate sql files from the source tree (see /sql/create, /sql/base, and /sql/updates).

Share this post


Link to post
Share on other sites
Kylroi, on 15 Dec 2013 - 3:04 PM, said:
There should be 3 different databases: auth, characters, and world. The database you were importing is specifically the world database. Obviously, with the conf file allowing that to be set, you can call it something other than world, but the other 2 databases need to be created separately with the appropriate sql files from the source tree (see /sql/create, /sql/base, and /sql/updates).
 

 

 

 
I figured that out after awhile
 

 

Ok I was reading this http://www.trinitycore.org/f/topic/1518-trouble-with-your-trinity-install-readme-1st-faqs/?p=42704

 

If I install TDB_full_335.52_2013_07_17.sql do I have to install the updates as well?

 

I looked in the update folder for the world and there is like a million of them? Do I do them all?

Edited by kavex

Share this post


Link to post
Share on other sites

If you pulled the latest code, you will want to run all the updates for the database. I believe there are scripts (for Linux) to combine the many updates into a single file, if that will help.

Share this post


Link to post
Share on other sites

OS: Windows Server 2008 Web
Trinity rev:  2bda5330d091+ 2013-12-10 09:09:16 -0600 (master branch) (Win32, Release) (worldserver-daemon)
TDB rev : TDB 335.52
 
// Player saving

PrepareStatement(CHAR_INS_CHARACTER, "INSERT INTO characters (guid, account, name, race, class, gender, level, xp, money, playerBytes, playerBytes2, playerFlags, "

"map, instance_id, instance_mode_mask, position_x, position_y, position_z, orientation, trans_x, trans_y, trans_z, trans_o, transguid, "

"taximask, cinematic, "

"totaltime, leveltime, rest_bonus, logout_time, is_logout_resting, resettalents_cost, resettalents_time, "

"extra_flags, stable_slots, at_login, zone, "

"death_expire_time, taxi_path, arenaPoints, totalHonorPoints, todayHonorPoints, yesterdayHonorPoints, totalKills, "

"todayKills, yesterdayKills, chosenTitle, knownCurrencies, watchedFaction, drunk, health, power1, power2, power3, "

"power4, power5, power6, power7, latency, speccount, activespec, exploredZones, equipmentCache, ammoId, knownTitles, actionBars, grantableLevels) VALUES "

"(?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?)", CONNECTION_ASYNC);

this is how that part works
take something from here
I have a problem with my mysql on a new host I bought running on Windows Server 2008 (on which everything was fine). The default databases which come with the installation are 0 bytes. They have data in them, but every one of them shows as 0 bytes in Heidisql.

I am running a game server, and upon creating a new character, I get an error :

[ERROR]: [1265] Data truncated for column 'x' at row 1 Unhandled MySQL errno 1265. Unexpected behaviour possible.

I tried contacting my host because I think that the problem is probably from their end, but they do not help with administering customer's dedicated servers.

What I did when I moved is that I backed up each database with Sqlyog, and executed them via the new how without any problem. I have a database which is over 1 Gib in size, and when I view it via Heidisql it just shows as 0 bytes.

I tried reinstalling mysql several times using different options, but that didn't help. I edited my.ini, with options I found upon googling, but those didn't help either. I tried manually editing mysql root user permissions, but that didn't do the trick.

Could someone point me in the right direction?

and this
I have installed a fresh MYSQL 32x and 64x as well, it seems that I don't have some kind of perimission. I use an application which requires its own mysql database.

The default(mysql, information_schema databases are showing as 0 byte, despite the fact that they have data in it. I exported my own databases from my old dedicated server, the data appears, but the main database is showing as 0 byte. I'm using latest version of mysql downloaded fromhttp://dev.mysql.com/downloads/windows/installer/

I searched google, and what I've found is to change from Innodb to myisam, but that didn't help either. I did not have any problems on my other dedicated server from which I moved from. Please take a look at this, because it's causing me a headache, and I cannot figure out what could the problem be.

Hope some of you guys can help me. :S

Edited by ButtlerKid

Share this post


Link to post
Share on other sites

ok ok I just want to make sure i'm doing this correct

 

1. Import TrinityCore-TrinityCore-f1a82a5/sql/create/create_mysql.sql

2. Import TrinityCore-TrinityCore-f1a82a5/sql/base/auth_database.sql to the auth database 

3. Import TrinityCore-TrinityCore-f1a82a5/sql/base/characters_database.sql to the characters database 

4. Import TDB_full_335.52_2013_07_17.sql to the world database 

 

5. Install the updates from TrinityCore-TrinityCore-e90a7f8/sqlupdates to their databases one at a time?

 

I'm guessing since I'm using TDB_full_335.52_2013_07_17.sql for my world I don't need to install the update only that comes with it

 

Link to a DB installer for linux   installer

Edited by kavex

Share this post


Link to post
Share on other sites

When I run serverworld.exe,some wrong happened.

 

Server.log

 

DatabasePool world NOT opened. There were errors opening the MySQL connections. Check your SQLDriverLogFile for specific errors.
Cannot connect to world database 127.0.0.1;3306;root;123123;world
 
 
 

DBErrors.log

 

 In mysql_stmt_prepare() id: 53, sql: "SELECT name, permission, help FROM command"
Unknown column 'permission' in 'field list'
In mysql_stmt_prepare() id: 54, sql: "SELECT difficulty_entry_1, difficulty_entry_2, difficulty_entry_3, KillCredit1, KillCredit2, modelid1, modelid2, modelid3, modelid4, name, subname, IconName, gossip_menu_id, minlevel, maxlevel, exp, faction_A, faction_H, npcflag, speed_walk, speed_run, scale, rank, mindmg, maxdmg, dmgschool, attackpower, dmg_multiplier, baseattacktime, rangeattacktime, unit_class, unit_flags, unit_flags2, dynamicflags, family, trainer_type, trainer_spell, trainer_class, trainer_race, minrangedmg, maxrangedmg, rangedattackpower, type, type_flags, lootid, pickpocketloot, skinloot, resistance1, resistance2, resistance3, resistance4, resistance5, resistance6, spell1, spell2, spell3, spell4, spell5, spell6, spell7, spell8, PetSpellDataId, VehicleId, mingold, maxgold, AIName, MovementType, InhabitType, HoverHeight, Health_mod, Mana_mod, Armor_mod, RacialLeader, questItem1, questItem2, questItem3, questItem4, questItem5, questItem6, movementId, RegenHealth, mechanic_immune_mask, flags_extra, ScriptName FROM creature_template WHERE entry = ?"
Unknown column 'trainer_spell' in 'field list' 
 
Can you help me?THXLOT
 

Share this post


Link to post
Share on other sites
Cannot connect to world database 127.0.0.1;3306;root;123123;world

This line tells everything. Check your SQL settings.

 

And if you don't run a repack the exe is called worldserver.exe

Share this post


Link to post
Share on other sites

--- Canned message start ---

Read http://www.trinitycore.org/f/topic/1518-trouble-with-your-trinity-install-readme-1st-faqs/

Also please Look in upper right hand corner of the forum, there is a button labeled search field, feel free to search for your issues first before posting, most questions like this one have already been answered.

If you still cannot find the answers you seek feel free to make a post and tell us the steps you took to resolve this issue and we will do our best to help you.

--- Canned message end ---

Share this post


Link to post
Share on other sites

I am trying to setup Trinity for the first time. According to the Wiki I have to:

 

  • Use the Sql from the create folder to set up the databases: Check
  • Use the Sql from the base folder to set up the character and auth tables: Check
  • Use the Sql from the TDB_full folder to set up the world tables: Check
  • Use the Sql from the update folders to update various data: Not Checked

I can't use the updates from the TDB folder. It complains about missing columns or tables.

So I check out the update folders from the trinity source folders and there are updates there too. So the next logical step for me would be to execute those in order right?

 

I tried that as well and I still get errors.

In auth I am missing the rbac_roles and rbac_groups tables. But I can't find SQL that would add these.

 

What am I doing wrong in this procesS? The wiki is not very clear on this or I have downloaded the wrong SQL files :/

Share this post


Link to post
Share on other sites

Ok guys,

I feel like a noob for asking this, but for some reason i can't get the gm commands to work ingame on my gm account.

I'm helpless for some reason, in the console everything works fine but in game it says 'There is no such subcommand'.

 

I cloned a new tc, downloaded the TDB_full_335.52_2013_07_17 world database.

I used auth & characters in "sqlbase" to setup those 2 databases.

I updated every database with all the updates till rev: 6402fa02ac4a4f1d731ed0b6d744328527e2a857 (23/12/2013)

 

I start it up, no errors, i do "account create name pass" & account set gmlevel 2 3 -1 (in auth -> account -> i see ID=2 and then the username i made). in account_access it does say id=2 gmlevel=3 realmid=-1. So that is set.

 

As far that rbac goes i got 4 tables in auth, "rbac_account_permissions, rbac_default_permissions, rbac_linked_permissions and rbac_permissions.

 

Then we i am ingame i see and i go to console press pinfo -> i see

Account: username (id: 2), gmlevel: 3 and some other stuff, player name (guid: 1)

 

But when i do ".help" it does nothing,

when i do ".account" it says Incorrect syntax -> and when i do ".account help" i get There is no such subcommand.

 

Can anyone point me my fatal flaw?

 

Thanks in advance

Edited by V0gelz

Share this post


Link to post
Share on other sites

I am missing these aswell.. I can't even get gm working at the moment. (Worst thing is, i got it working few months ago and now with a fresh clone it fails).

Share this post


Link to post
Share on other sites

It would seem that sql/updates/auth/2013_09_29_00_auth_misc.sql saw the removal of rbac_roles and rbac_groups from the database. As such, any updates that are trying to change those tables can be removed. If you look at the end of the file I just mentioned, you will see 7 tables being removed because of being obsolete (the core, at that point, doesn't use them).

Share this post


Link to post
Share on other sites

Sure you missed this text:

Important

Icon

IF THIS IS YOUR FIRST TIME INSTALLING TrinityCore DON'T apply any *.sql file on sqlupdatesauth or sqlupdatescharacters. Continue with SETTING UP THE SERVER.

Share this post


Link to post
Share on other sites

Important

Icon

IF THIS IS YOUR FIRST TIME INSTALLING TrinityCore DON'T apply any *.sql file on sqlupdatesauth or sqlupdatescharacters. Continue with SETTING UP THE SERVER.

Share this post


Link to post
Share on other sites

Sure you missed this text:

Important

Icon

IF THIS IS YOUR FIRST TIME INSTALLING TrinityCore DON'T apply any *.sql file on sqlupdatesauth or sqlupdatescharacters. Continue with SETTING UP THE SERVER.

Thanks for the advice, works now, However can you explain what we should do to make it work with the updates?

Share this post


Link to post
Share on other sites

Hello,

 

I'm setting up the TrinityCore 3.3.5 for the first time.

I'm using Debian 7 and MySQL 5.6.15.

 

According to this topic I need to change the sql_mode when using 5.6. But when I'm using SELECT @@GLOBAL.sql_mode; to determine which modes are set, only STRICT_TRANS_TABLES and NO_ENGINE_SUBSTITION is listed. The ONLY_FULL_GROUP_BY flag mentioned by Machiavelli is not listed.

 

So I thought everything is fine and I ran the create and base .sql files. So now, auth and character db is up to date. But when I want to execute TDB_full_335.52_2013_07_17.sql to create the world db (db itself already created) then I receive the following error:

DELIMITER ;;
/*!50003 CREATE*/ /*!50003 PROCEDURE `sp_dev_reguid_alter_tables`()
BEGIN

            CREATE TABLE `creature_temp` (
  `guid` INT(10) UNSIGNED NOT NULL AUTO_INCREMENT COMMENT 'Global Unique Identifier',
  `id` MEDIUMINT(8) UNSIGNED NOT NULL DEFAULT '0' COMMENT 'Creature Identifier',
  `map` SMALLINT(5) UNSIGNED NOT NULL DEFAULT '0' COMMENT 'Map Identifier',
  `spawnMask` TINYINT(3) UNSIGNED NOT NULL DEFAULT '1',
  `phaseMask` SMALLINT(5) UNSIGNED NOT NULL DEFAULT '1',
  `modelid` MEDIUMINT(8) UNSIGNED NOT NULL DEFAULT '0',
  `equipment_id` MEDIUMINT(9) NOT NULL DEFAULT '0',
  `position_x` FLOAT NOT NULL DEFAULT '0',
  `position_y` FLOAT NOT NULL DEFAULT '0',
  `position_z` FLOAT NOT NULL DEFAULT '0',
  `orientation` FLOAT NOT NULL DEFAULT '0',
  `spawntimesecs` INT(10) UNSIGNED NOT NULL DEFAULT '120',
  `spawndist` FLOAT NOT NULL DEFAULT '5',
  `currentwaypoint` MEDIUMINT(8) UNSIGNED NOT NULL DEFAULT '0',
  `curhealth` INT(10) UNSIGNED NOT NULL DEFAULT[...]



#1064 - You have an error in your SQL syntax; check the manual that corresponds to yo-- ur MySQL server version for the right syntax to use near 'CREATE*/ /*!50003 PROCEDURE `sp_dev_reguid_alter_tables`()
BEGIN
' at line 1 

What is this error caused by? Still wrong sql_mode although the flag isn't listed?

 

And another short question: If this import works fine, do I have to run every single .sql update file since 335.52 in /sql/updates/world until it's up to date?

 

 

Thanks in advance!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Hydra_Btforce
      Just finished download & compile fresh trinitycore 4.3.4  From : https://gitlab.com/trinitycore/TrinityCore_434/tree/4.3.4
       
      Creating World database from : https://github.com/TrinityCoreLegacy/TrinityCore/releases
      Downloading the lasted one & create new database named World
      Navigate to my repo applying sql/updates/world/4.3.4
      Trying to apply all updates but an error occurred while applying updates
      And if i don't apply all updates the world is totally bugged and items/creature are missing.
       
      Please help
    • By 939h
      Hi,

      The chat channel Lookup for group is not available when a player isn't in a city. I tried to modify the worldserver.conf file with:
      #
      #    Channel.RestrictedLfg
      #        Description: Restrict LookupForGroup channel to characters registered in the LFG tool.
      #        Default:     1 - (Enabled, Allow join to channel only if registered in LFG)
      #                     0 - (Disabled, Allow join to channel in any time)
      Channel.RestrictedLfg = 0

      I restarted the server but it didn't help.

      Thanks
    • By Probie_Wan_Kenobi
      I believe everything I have done up to this point has been correct. When I go to launch worldserver.exe a console window opens up for a second and closes right away and nothing else seems to have happened. I skipped a head a little in the instructions to see what is left and step 5 seems skippable since I am running this only for this computer and step 6 has me launch to a log in screen which I can not get to. I tried going to the faq but the page was not loading properly so I am forced to post here.
    • By Cantte
      Well ... today I was about to compile the trinity core version for WoW 4.3.4 of this repository "https://gitlab.com/trinitycore/TrinityCore_434". Download them and when you use the cmake, I generate the solution correctly. When I began to compile this went well until I got to the last step, when I was 90% practically.
      This was the error:
      Main.obj: error LNK2019: external symbol SSLeay_version unresolved referred to in the function "public: void __cdecl <lambda_4a2d53ce610f18dba0b4b4d6532c13a7> :: operator () (void) const" (?? R <lambda_4a2d53ce610f18dba0b4b4d6532c13a7> @@ QEBAXXZ)
      25> scripts.lib (cs_server.obj): error LNK2001: external symbol SSLeay_version unresolved
      25> gsoap.lib (stdsoap2.obj): error LNK2019: unresolved sk_num external symbol referenced in the tcp_connect function
      25> gsoap.lib (stdsoap2.obj): error LNK2019: unresolved sk_value external symbol referenced in the tcp_connect function
      25> gsoap.lib (stdsoap2.obj): error LNK2019: unresolved sk_pop_free external symbol referenced in the tcp_connect function
      25> gsoap.lib (stdsoap2.obj): error LNK2019: outer symbol OPENSSL_add_all_algorithms_noconf unresolved referenced in the soap_ssl_init function
      25> gsoap.lib (stdsoap2.obj): error LNK2019: external symbol SSL_load_error_strings unresolved referenced in the soap_ssl_init function
      25> gsoap.lib (stdsoap2.obj): error LNK2019: unresolved external SSLv23_method symbol referenced in the ssl_auth_init function
      25> gsoap.lib (stdsoap2.obj): error LNK2019: external symbol SSL_library_init unresolved referenced in the soap_ssl_init function
      25> gsoap.lib (stdsoap2.obj): error LNK2019: external symbol SSL_state unresolved referenced in the tcp_connect function
      25> common.lib (OpenSSLCrypto.obj): error LNK2019: external symbol CRYPTO_num_locks unresolved referred to in the function "void __cdecl OpenSSLCrypto :: threadsCleanup (void)" (? ThreadsCleanup @ OpenSSLCrypto @@ YAXXZ)
      25> common.lib (OpenSSLCrypto.obj): error LNK2019: external symbol CRYPTO_set_locking_callback unresolved referred to in the function "void __cdecl OpenSSLCrypto :: threadsCleanup (void)" (? ThreadsCleanup @ OpenSSLCrypto @@ YAXXZ)
      25> common.lib (OpenSSLCrypto.obj): error LNK2019: external symbol CRYPTO_THREADID_set_numeric unresolved referred to in the function "void __cdecl threadIdCallback (struct crypto_threadid_st *)" (? ThreadIdCallback @@ YAXPEAUcrypto_threadid_st @@@ Z)
      25> common.lib (OpenSSLCrypto.obj): error LNK2019: external symbol CRYPTO_THREADID_set_callback unresolved referenced in the function "void __cdecl OpenSSLCrypto :: threadsCleanup (void)" (? ThreadsCleanup @ OpenSSLCrypto @@ YAXXZ)
      25> common.lib (ARC4.obj): error LNK2019: external symbol EVP_CIPHER_CTX_init unresolved referred to in the function "public: __cdecl ARC4 :: ARC4 (unsigned int)" (?? 0ARC4 @@ QEAA @ I @ Z)
      25> common.lib (HmacHash.obj): error LNK2019: unresolved HMAC_CTX_init external symbol referenced in the "struct hmac_ctx_st * __cdecl HMAC_CTX_new (void)" function (? HMAC_CTX_new @@ YAPEAUhmac_ctx_st @@ XZ)
      25> common.lib (HmacHash.obj): error LNK2019: unresolved HMAC_CTX_cleanup external symbol referenced in the "void __cdecl HMAC_CTX_free (struct hmac_ctx_st *)" function (? HMAC_CTX_free @@ YAXPEAUhmac_ctx_st @@@ Z)
      25> E: \ Server-Wow \ TrinityCore_434-4.3.4 \ Build \ bin \ RelWithDebInfo \ worldserver.exe: fatal error LNK1120: 16 external unresolved
      25> Compilation of the "worldserver.vcxproj" project completed - ERROR.
      26> ------ Compile operation started: project: ALL_BUILD, configuration: RelWithDebInfo x64 ------
      26> Building Custom Rule E: /Server-Wow/TrinityCore_434-4.3.4/CMakeLists.txt
      26> CMake does not need to re-run because E: /Server-Wow/TrinityCore_434-4.3.4/Build/CMakeFiles/generate.stamp is up-to-date.
      ========== Compile: 23 correct, 3 incorrect, 0 updated, 0 omitted ==========
       
      And this is the original error in Spanish (since I use the compiler in Spanish)
       
      Main.obj : error LNK2019: símbolo externo SSLeay_version sin resolver al que se hace referencia en la función "public: void __cdecl <lambda_4a2d53ce610f18dba0b4b4d6532c13a7>::operator()(void)const " (??R<lambda_4a2d53ce610f18dba0b4b4d6532c13a7>@@QEBAXXZ)
      25>scripts.lib(cs_server.obj) : error LNK2001: símbolo externo SSLeay_version sin resolver
      25>gsoap.lib(stdsoap2.obj) : error LNK2019: símbolo externo sk_num sin resolver al que se hace referencia en la función tcp_connect
      25>gsoap.lib(stdsoap2.obj) : error LNK2019: símbolo externo sk_value sin resolver al que se hace referencia en la función tcp_connect
      25>gsoap.lib(stdsoap2.obj) : error LNK2019: símbolo externo sk_pop_free sin resolver al que se hace referencia en la función tcp_connect
      25>gsoap.lib(stdsoap2.obj) : error LNK2019: símbolo externo OPENSSL_add_all_algorithms_noconf sin resolver al que se hace referencia en la función soap_ssl_init
      25>gsoap.lib(stdsoap2.obj) : error LNK2019: símbolo externo SSL_load_error_strings sin resolver al que se hace referencia en la función soap_ssl_init
      25>gsoap.lib(stdsoap2.obj) : error LNK2019: símbolo externo SSLv23_method sin resolver al que se hace referencia en la función ssl_auth_init
      25>gsoap.lib(stdsoap2.obj) : error LNK2019: símbolo externo SSL_library_init sin resolver al que se hace referencia en la función soap_ssl_init
      25>gsoap.lib(stdsoap2.obj) : error LNK2019: símbolo externo SSL_state sin resolver al que se hace referencia en la función tcp_connect
      25>common.lib(OpenSSLCrypto.obj) : error LNK2019: símbolo externo CRYPTO_num_locks sin resolver al que se hace referencia en la función "void __cdecl OpenSSLCrypto::threadsCleanup(void)" ([email protected]@@YAXXZ)
      25>common.lib(OpenSSLCrypto.obj) : error LNK2019: símbolo externo CRYPTO_set_locking_callback sin resolver al que se hace referencia en la función "void __cdecl OpenSSLCrypto::threadsCleanup(void)" ([email protected]@@YAXXZ)
      25>common.lib(OpenSSLCrypto.obj) : error LNK2019: símbolo externo CRYPTO_THREADID_set_numeric sin resolver al que se hace referencia en la función "void __cdecl threadIdCallback(struct crypto_threadid_st *)" ([email protected]@[email protected]@@Z)
      25>common.lib(OpenSSLCrypto.obj) : error LNK2019: símbolo externo CRYPTO_THREADID_set_callback sin resolver al que se hace referencia en la función "void __cdecl OpenSSLCrypto::threadsCleanup(void)" ([email protected]@@YAXXZ)
      25>common.lib(ARC4.obj) : error LNK2019: símbolo externo EVP_CIPHER_CTX_init sin resolver al que se hace referencia en la función "public: __cdecl ARC4::ARC4(unsigned int)" ([email protected]@[email protected]@Z)
      25>common.lib(HmacHash.obj) : error LNK2019: símbolo externo HMAC_CTX_init sin resolver al que se hace referencia en la función "struct hmac_ctx_st * __cdecl HMAC_CTX_new(void)" ([email protected]@[email protected]@XZ)
      25>common.lib(HmacHash.obj) : error LNK2019: símbolo externo HMAC_CTX_cleanup sin resolver al que se hace referencia en la función "void __cdecl HMAC_CTX_free(struct hmac_ctx_st *)" ([email protected]@[email protected]@@Z)
      25>E:\Server-Wow\TrinityCore_434-4.3.4\Build\bin\RelWithDebInfo\worldserver.exe : fatal error LNK1120: 16 externos sin resolver
      25>Compilación del proyecto "worldserver.vcxproj" terminada -- ERROR.
      26>------ Operación Compilar iniciada: proyecto: ALL_BUILD, configuración: RelWithDebInfo x64 ------
      26>Building Custom Rule E:/Server-Wow/TrinityCore_434-4.3.4/CMakeLists.txt
      26>CMake does not need to re-run because E:/Server-Wow/TrinityCore_434-4.3.4/Build/CMakeFiles/generate.stamp is up-to-date.
      ========== Compilar: 23 correctos, 3 incorrectos, 0 actualizados, 0 omitidos ==========
       
       
      Thanks.
    • By Fyury
      When I run "worldserver.exe" it just crashes and I get this:
      TrinityCore rev. 084da48ba15a 2018-05-26 18:48:09 +0200 (master branch) (Win64, RelWithDebInfo, Static) (worldserver-daemon)
      <Ctrl-C> to stop.
       ______                       __
      /\__  _\       __          __/\ \__
      \/_/\ \/ _ __ /\_\    ___ /\_\ \, _\  __  __
         \ \ \/\`'__\/\ \ /' _ `\/\ \ \ \/ /\ \/\ \
          \ \ \ \ \/ \ \ \/\ \/\ \ \ \ \ \_\ \ \_\ \
           \ \_\ \_\  \ \_\ \_\ \_\ \_\ \__\\/`____ \
            \/_/\/_/   \/_/\/_/\/_/\/_/\/__/ `/___/> \
                                       C O R E  /\___/
      http://TrinityCore.org                    \/__/
      Using configuration file C:/WoW-Server/bin/RelWithDebInfo/worldserver.conf.
      Using SSL version: OpenSSL 1.0.1e 11 Feb 2013 (library: OpenSSL 1.0.1e 11 Feb 2013)
      Using Boost version: 1.65.1
      Updating Auth database...
      >> Auth database is up-to-date! Containing 6 new and 115 archived updates.
      Updating Character database...
      >> Character database is up-to-date! Containing 3 new and 77 archived updates.
      Updating World database...
      >> World database is up-to-date! Containing 193 new and 2262 archived updates.
      Updating Hotfixes database...
      >> Hotfixes database is up-to-date! Containing 18 new and 130 archived updates.
      Realm running as realm ID 1
      Using World DB: TDB 735.00
      Using enUS DBC Locale
      Will clear `logs` table of entries older than 1209600 seconds every 10 minutes.
      Using DataDir ./
      WORLD: MMap data directory is: ./mmaps
      VMap support included. LineOfSight: 1, getHeight: 1, indoorCheck: 1
      VMap data directory is: ./vmaps
      Missing name Guild.SaveInterval in config file C:/WoW-Server/bin/RelWithDebInfo/worldserver.conf, add "Guild.SaveInterval = 15" to this file
      Initialize PlayerDump...
      >> Initialized 370 PlayerDump ColumnDefinitions in 551 ms.
      Loading Trinity strings...
      >> Loaded 965 trinity strings in 32 ms
      Initialize data stores...
      Some required *.db2 files (2 from 230) not found or not compatible:
      ItemSearchName.db2
      WorldSafeLocs.db2
       
       
      ItemSearName.db2 & WorldSafeLocs.db2 dont exist but how can I get them
      When I start "mapextractor.exe" this happens:
       
      Unable to open file DBFilesClient\ItemSearchName.db2 in the archive for locale enUS: FILE_NOT_FOUND
      Unable to open file DBFilesClient\Unittest.db2 in the archive for locale enUS: FILE_NOT_FOUND
      Unable to open file DBFilesClient\WorldSafeLocs.db2 in the archive for locale enUS: FILE_NOT_FOUND
       
×
×
  • Create New...